antiX-19.2 (Hannie Schaft) with 4.19 kernels available

Since some users have reported issues with our default iso files running the 4.9 kernel (better suited for older hardware), we have made available full and base versions (SysVinit and runit) 64 bit architecture only to our users.

kernel is 4.19.100

Everything else is the same as our default antiX-19.2 isos.

For full details, have a look

here

Download from here

antiX-19.2 based on debian sid isos available

These iso files are based on Debian sid and come as core or net version using svsVinit or runit.

The following flavours for both 32 and 64 bit architecture are available.

antiX-core (c400MB) sysVinit and runit versions – no X, but should support most wireless.
Core versions also include elogind and dbus-x11.

antiX-net (c180MB) sysVinit and runit versions – no X. Just enough to get you connected (wired only) and ready to build.

The 32 bit version uses a non-pae kernel.

These iso files are for experienced users of antiX or Debian.

* Based on Debian sid
* runit or sysVinit as init
* eudev (3.2.9) instead of systemd-udev
* Customised 5.5.0 kernel with fbcondecor splash
* antiX remaster and persistence tools
* live-kernel-updater
* cli-aptiX – a cli package installer
* antiX-cli-cc – cli control centre
* live-usb-maker
* basic cli installler
* no UEFI install option
* no encryption option

Download isos from the sid or runit-sid folder

Enjoy!

antiX-19.2 (Hannie Schaft) bug-fix/upgrade isos available

All new isos are bug-fix/upgrades/improvements of antiX-19 sysvinit series.

BONUS: We now offer versions running the runit init system as well.

No need to download if using antiX-19(.x).

NOTE: All base versions are antiX-19.2.1 since I re-uploaded the iso files because there was an issue with connman wifi connection. Apologies to those who downloaded antiX-19.2 base versions.

antiX-19.2 (Hannie Schaft) is based on Debian Buster and is fully systemd-free.

As usual we offer the following systemd-free flavours for both 32 and 64 bit architecture, running sysvinit or runit.

antiX-full (c1.1GB) – 4 windows managers – IceWM (default), fluxbox, jwm and herbstluftwm plus full libreoffice suite.

antiX-base (c700MB so fits on a cd) – 4 windows managers – IceWM (default), fluxbox, jwm and herbstluftwm.

antiX-core (c350MB) – no X, cli-installer without UEFI support nor encryption, but should support most wireless.

antiX-net (c140MB)- no X, cli-installer without UEFI support nor encryption. Just enough to get you connected (wired) and ready to build.

The 32 bit version uses a non-pae kernel.

Changes:

* We believe we have fixed the issue when running (g)ufw firewall
* apt-notifier included and enabled on full versions for those who prefer update notifications
* Tray icon manager for IceWM
* Improved and updated localisation
* Improved cli-installer – more ‘safety’ checks added
* nosystemd repo added to antix.list sources
* Debian buster-backports repository enabled
* mps-youtube includes fix for apt_key bug
* A newer 4.9.212 kernel
* firefox-esr (68.6.0esr)
* libreoffice 6.4.1
* IceWM upgraded to latest upstream version (1.6.5)
* fluxbox upgraded to 1.3.7
* mtpaint upgraded to version 3.49
* runit backported from Debian sid
* links(2) cli browser to latest upstream version (2.20.2)
* eudev (3.2.9) instead of systemd-udev
* elogind upgrade to 243.7
* consolekit2 available
* ceni network manager included, but connman is default on full and base
* latest cherrytree (0.3.9) hierarchical note taking application
* various upstream Debian security upgrades

See here for full list of what’s included on antiX-19 series.

Enjoy!

anticapitalista, 28 March 2020, Thessaloniki

buster-backports repo enabled

Latest update of apt-antix includes buster-backports.list which is enabled.
By default, only apps that have already been installed from this repo will get updates, which for antiX-19 and 19.1 is none.
If users install latest libreoffice via the package installer, it will download the version from buster-backports and any future updates from buster-backports automatically when upgrading.
If users are concerned about the inclusion of buster-backports.list, just delete it from /etc/apt/sources.list.d

mps-youtube bug and fix

mps-youtube is giving errors about apt_key.

Short-term fix is to do the following.

1. delete ~/.config/mps-youtube/cache_py*
2. Open mps-youtube and type

set api_key AIzaSyApOW6Ur8oRM_1OACkkhxnNrbtv0e4qfaM

3. quit mps-youtube
4. Start mps-youtube

VirtualBox upgrades

VirtualBox in antiX-19 Main will be upgraded to version 6.1.2 tomorrow, 2/6/2020. There have been a number of bugfixes and improvements since the current version, and the current version will not build its modules on the new 5.4+ version kernels so this update is necessary,

VirtualBox users need to know that any Saved or Paused VMs will not open after a VirtualBox version update. Here are your options to avoid trouble:

1) Shutdown the OS in any VMs you have before you upgrade.
or
2) Lock your current VirtualBox version so it won’t upgrade.

sudo apt-mark hold virtualbox*

If you also do updates with Synaptic you will need to lock the virtualbox packages there as well since it ignores apt-mark hold and apt-get ignores Synaptic’s package locks.

If you have already upgraded you have two options to repair.

A) If the saved state of the VM is not important to you, you can use the Discard Saved State… option in the settings for that VM and it should start up.
B) If the saved state is important you can reinstall your old Virtualbox packages from /var/cache/apt/archives, then follow 1) or 2) above.

New kernels available

Latest secure kernels available in the repos for 32 (pae and non-pae) and 64 bit architecture.

5.5.0 (antiX-17, antiX-19, testing and sid)
4.19.100 (antiX-17, antiX-19, testing and sid)
4.9.212 (antiX-17, antiX-19, testing and sid)
4.4.212 (antiX-16, antiX-17, antiX-19)

Note: The 5.5.0 kernel will not build broadcom-sta wifi, nvidia drivers or virtualbox drivers (yet).

(g)ufw and default 4.9 kernel – fix

Running with default antiX-19 series, running sudo ufw enable gives an error.
Previously, we suggested upgrading to a 4.19 or later kernel.

However, it may not be necessary. Instead just switch to using legacy iptables.

# update-alternatives --set iptables /usr/sbin/iptables-legacy
# update-alternatives --set ip6tables /usr/sbin/ip6tables-legacy