Видеокарта NVIDIA Corporation NV28 [GeForce4 Ti 4200 AGP 8x]

Forum Forums Official Releases antiX-17 “Heather Heyer, Helen Keller” Видеокарта NVIDIA Corporation NV28 [GeForce4 Ti 4200 AGP 8x]

  • This topic has 6 replies, 3 voices, and was last updated Sep 6-8:06 am by Xecure.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #38696
    Member
    arkady

    Здравствуйте!
    Видеокарта NVIDIA Corporation NV28 [GeForce4 Ti 4200 AGP 8x]
    Не могу выставить частоту ЭЛТ-монитора: нужно 85 Гц, а “в наличии” – только 60 Гц.

    “Мой” драйвер, кажется, 96.43.хх series – legasy driver, на сайте производителя я его нашел.
    https://www.nvidia.com/en-us/geforce/drivers/
    https://www.nvidia.com/en-us/drivers/results/48996/
    Как его ставить и как прописывать?

    Пробовал “через” : cvt 1024 768 85 и т.д.
    “На выбор” появляется требуемая частота (монитор переходит на неё), но при этом сдвигается на 1 сантиметр влево (появляется черная полоса). Картинку можно выставить по центру настройками монитора после этого.
    В данном случае у меня возникает вопрос: какие настройки надо изменить, чтобы после запуска можно было выбрать нужную частоту.

    Спасибо!

    #38759
    Moderator
    BobC
    Helpful
    Up
    0
    :D

    Maybe this will help:

    https://www.antixforum.com/forums/topic/video-better-in-v16-than-in-v17/

    The important part is in the next to last post on that thread. Quoted here:

    Well, it took awhile but I finally got this problem solved. As it turns out I did not have to change the kernel or compile an old driver to work. All I had to do was use some “cheat codes” on the boot line from the live DVD and add to a blacklist file in /etc/modprobe.d/.

    Here’s what I did to get antiX-17 installed on this old Pentium-III:

    After booting with the Live DVD I changed the F7 video selection to “default”. Then I typed in the cheat codes “xorg=nouveau” and “bp=b9” then hit enter to continue the boot.

    A bash shell came up and I entered “modprobe nouveau”, enter, then used “Ctrl-d” to continue the boot.

    Eventually the Live desktop came on screen. I checked the inxi, lsmod, and xorg. All looked good and setup for nouveau.

    Ran the installer and then robooted. After booting the X system did not start. I came to a text login. I logged in and then checked inxi and lsmod. Nouveau was loading but so was the nvidiafb and rivafb modules. I was reminded by a forum member that sometimes the nvidiafb module has to be blacklisted for nouveau to work. So I added “blacklist nvidiafb” and “blacklist rivafb” to the blacklist files in /etc/modprobe.d/. Rebooted.

    After reboot the X desktop came up. I logged in and then took another look at inxi, lsmod and xorg.log. It all looked properly setup for nouveau.

    the cheat codes “xorg=nouveau” and “bp=b9” were the key for me. Then adding to the blacklist at /etc/modprobe.d/.

    You will probably have to do something similar, but with the drivers for your video card. The modern kernel no longer supports your card. But it can be used by force feeding the correct driver. In my case blacklisting the nvidiafb and rivafb drivers and adding the nouveau driver worked for my card.

    Don’t worry about using the command line. It is the most efficient way to tell antiX what to do. And there is no GUI version of this process in antiX.

    Seaken64

    #38763
    Member
    Xecure
    Helpful
    Up
    0
    :D

    I used the translator for your post. Please do the same if you cannot understand something from my answer.

    First, you need to tell us what your current running driver is:
    inxi -Gxxx
    If not running nouveau, follow BobC’s answer above. Mainly testing
    xorg=nouveau nouveau.modeset=1
    as boot parameters (we can explain if you need it, just ask), but first let us know your graphic drivers with the inxi -Gxxx command.

    Пробовал “через” : cvt 1024 768 85 и т.д.
    “На выбор” появляется требуемая частота (монитор переходит на неё), но при этом сдвигается на 1 сантиметр влево (появляется черная полоса). Картинку можно выставить по центру настройками монитора после этого.
    В данном случае у меня возникает вопрос: какие настройки надо изменить, чтобы после запуска можно было выбрать нужную частоту.

    How do you set it? using arandr? using xrandr? Please explain with more detail. If you are able to set it manually as you describe, maybe you could save those settings and load them at startup. We can discuss this once we know for sure that you are running nouveau driver.

    #38767
    Moderator
    BobC
    Helpful
    Up
    0
    :D

    I got your question to translate. I’m sorry, the link in my post didn’t provide a way to run 1024 x 768 at 85 hz.

    I wonder if someone else had that problem…

    https://forums.linuxmint.com/viewtopic.php?t=245783

    That person also had an old nVidia card that needed to run at 1024×768 at 85 khz.

    Linux Mint is a cousin of antiX, so that answer might work, since antiX has the same tools.

    #38774
    Member
    Xecure
    Helpful
    Up
    0
    :D

    More info is needed
    inxi -Gxxx
    Execute this command in terminal and paste the output in a new reply.

    #41139
    Member
    arkady
    Helpful
    Up
    0
    :D

    Здравствуйте!
    Кроме NVIDIA Corporation NV28 [GeForce4 Ti 4200 AGP 8x] перепробовал:
    NVIDIA NV17 [GeForce4 MX 440] driver: nouveau v
    NVIDIA NV34 [GeForce FX 5500] driver: nouveau v
    NVIDIA NV44A [GeForce 6200] vendor: Gigabyte driver: nouveau v:
    AMD RV280 [Radeon 9200 SE] vendor: PC Partner Limited driver: radeon
    NVIDIA NV5 [Riva TNT2 Model 64 / Model 64 Pro] vendor: ASUSTeK AGP-V3800M
    ВСЕ (кроме NV28) “подхватили” необходимые разрешение и частоту (1024×768~85Hz). При этом две из них были “откровенно поломаны” – двоение, цвета расплывались и т.п.
    Возможно, разгадка кроется где-то тут:
    https://nouveau.freedesktop.org/wiki/CodeNames/
    https://nouveau.freedesktop.org/wiki/FeatureMatrix/
    Спасибо за внимание!

    #41188
    Member
    Xecure
    Helpful
    Up
    0
    :D

    It could be an xorg issue (newer xserver-xorg packages no longer support certain old nvidia cards, as reported by other forum users). Maybe antiX16 could pick it up properly (as it brings an older xorg-nouveau version), but it is no longer supported, unfortunately.
    As you figured how to change it for antiX17 through command line in your first post, you could add the commands into a script and launch it at startup (though you would have to re-calibrate the screen if you change cards, I think).

    Thanks for reporting the cards that worked for you. Hopefully it will help others too.

    Regards.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.