17.3 Core can not view files in folder

Forum Forums Official Releases antiX-17 “Heather Heyer” 17.3 Core can not view files in folder

This topic contains 14 replies, has 5 voices, and was last updated by accoustic Jan 22-5:49 pm.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #15054
    Member
    Avatar
    accoustic

    Hi All,
    For some odd reason my original post got deleted. Here i’m again and looking for help.
    My Removable usb drive is xfat and i’m trying to access the files but it said “empty folder”

    I also see empty folder for other format as well except FAT16

    Any suggestion or idea?

    Thx
    Ben

    • This topic was modified 7 months, 2 weeks ago by accoustic.
    #15056
    Member
    Avatar
    delix02

    sorry, guess my “suggestions” are much too basic for you

    • This reply was modified 7 months, 2 weeks ago by delix02.
    #15077
    Member
    Avatar
    skidoo

    delix02, I also started a reply earlier, then backed out without posting.
    Title mentions CORE. I’m not using core & wonder where “empty folder” would be displayed? “mc” file manager?
    The CORE version may not have an exfat filesystem handler pre-installed, or the OP may be wrestling with file permissions, or mount options (I think your post mentioned these)… but the OP just doesn’t contain enough info

    #15086
    Member
    Avatar
    accoustic

    Thx for helping with this issue.
    I have installed the following
    Exfat-utils
    Exfat-fuse
    But still no luck. I can see the mount point at /media however when I open it it’s empty.
    I also tested 17.3 full work perfectly.

    Thx
    B

    #15090
    Member
    Avatar
    skidoo

    From the list of packages installed in base + full (not core) base-AND-full/package.list I recognize these 2 as being related to mounting:
    udisks2
    udevil

    #15159
    Member
    Avatar
    accoustic

    Thx, I just install the udisk2 and udevil but problem still exist. So is something else.

    #15163
    Member
    Avatar
    skidoo

    sudo apt update
    sudo apt-get install exfat-utils exfat-fuse
    (i didn’t check — these may already be pre-installed in core version)

    Where are you seeing “empty folder” ~~ the output of “ls” command? Something displayed by “mc” midnight commander file manager?

    #15180
    Member
    Avatar
    accoustic

    Those extfat package had been install from the get go.
    I’m not seeing files in /mount and I use MC, but I’m seeing at /run
    Also I checked the permission all are 40755 root.

    • This reply was modified 7 months, 1 week ago by accoustic.
    #15184
    Member
    Avatar
    skidoo

    “Core” edition is intended for experts. I’m not expert enough to attempt using “Core”. Are you an expert? Asking because I’ve never heard of a valid reason to poke around in the “/run” directory… and although I’m familiar with “/media” and “/mnt”, I’ve never encountered a directory named “/mount” (mentioned in your post) pathed at top level of the root filesystem.

    Tested: using mc, if I descend into the /media tree and attmept to F3 “view” any of my attached (but currently unmounted) drives, yes the contents are “empty” ~~ but that’s the expected result.

    Look here: https://miqu.me/blog/2015/01/14/tip-exfat-hdd-with-raspberry-pi/
    ignore that they’re discussing RPi & understand that you are probably required to ID the drive and manually mount it (choosing the mountpoint) before its content will be visible via mc file manager.

    #16617
    Member
    Avatar
    accoustic

    I would like to give an update on the progress to getting this work. Thank @skidoo for the link on pi. I was able to get some idea.
    Turn out it actually need to insert the mount command to actually mount the device.
    I’m not sure if the boot keyword for “auto mount” is working or not. if development have time to check please do. but for now its working.

    Once again, Thank you for all the response and help.

    B

    #16620
    Member
    Avatar
    skidoo

    It’s good to hear you’ve made some progress.
    Before asking the devs to investigate “is working or not”, let’s confirm that you have read about and have attempted to use appropriate the boot option(s)

    edit:
    The following is only applicable during antiX live and/or antiX frugal boot sessions.

    .

    • This reply was modified 7 months ago by skidoo.
    #16671
    Member
    Avatar
    accoustic

    Thanks again for the info.
    My automount was selected from F4 at Gurb Menu, There isn’t a submenu for automount=all or automount=usb.
    Do i need to add this flag at the custom line along with automount enable in F4

    #16683
    Moderator
    masinick
    masinick

    “Core” edition is intended for experts. I’m not expert enough to attempt using “Core”. Are you an expert? Asking because I’ve never heard of a valid reason to poke around in the “/run” directory… and although I’m familiar with “/media” and “/mnt”, I’ve never encountered a directory named “/mount” (mentioned in your post) pathed at top level of the root filesystem.

    Tested: using mc, if I descend into the /media tree and attmept to F3 “view” any of my attached (but currently unmounted) drives, yes the contents are “empty” ~~ but that’s the expected result.

    Look here: https://miqu.me/blog/2015/01/14/tip-exfat-hdd-with-raspberry-pi/
    ignore that they’re discussing RPi & understand that you are probably required to ID the drive and manually mount it (choosing the mountpoint) before its content will be visible via mc file manager.

    I have installed Core myself many times, though I’m not regularly using it anymore. There are a lot of things that I don’t know by memory, but when issues arise, I do have the resources, the background, the understanding of what I read, and the intensity to chase after issues. I also have to say that I seldom look into directories like /run or /proc, though if I do, I can research and figure out whatever I may need in order to understand and utilize whatever information I happen to find.

    In spite of that, there are countless things I’ve never seen. Distributions or builds that require such knowledge are indeed best left for those who are willing to do most research on their own, and when questions or comments are raised, they are shared only after performing extensive personal research.

    The regular antiX distributions, especially “Full” and the versions that can run directly from USB do NOT require this kind of background, but when you are creating essentially your own creative work from the absolute minimal resources in antiX Core, it’s helpful to be self driven as much as possible. There are those of us willing to help, but we also need the help of one another and the people who are asking questions. Most of us have a lot of other activities we manage and our work with antiX is usually 100% volunteer as time permits. We’re glad to help, but appreciate consideration of our time, abilities, and efforts – thank you to all who contribute.

    Brian Masinick

    #16684
    Forum Admin
    BitJam
    BitJam

    Thanks again for the info.
    My automount was selected from F4 at Gurb Menu, There isn’t a submenu for automount=all or automount=usb.
    Do i need to add this flag at the custom line along with automount enable in F4

    We are now using 2 different forms of automounting, a GUI based one for base and full and our home-brew cli based one for core. I will look into how you can control it from the cli and from the bootloader but for now, just try:mount /media/<DIRECTORY> or sudo mount /media/<DIRECTORY>

    • This reply was modified 7 months ago by BitJam.

    Context is worth 80 IQ points -- Alan Kay

    #17215
    Member
    Avatar
    accoustic

    Thanks for the info. Yes, that is what i’m currently doing. mount /media/<DIRECTORY>

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.