4.20.0-antix.1 kernel

Forum Forums Official Releases antiX-17 “Heather Heyer” 4.20.0-antix.1 kernel

This topic contains 3 replies, has 2 voices, and was last updated by caprea Jan 23-7:30 am.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #15015
    Member
    caprea
    caprea

    I tried the 4.20.0-antix.1-amd64-smp kernel.
    The kernel will not build against any nvidia-driver available from repos or ddm-mx.
    I could get it to build on my main system with the very latest from official nvidia-side,though.

    The 4.19.10-antix.1-amd64-smp builds fine against all drivers, even the nvidia-legacy on my old laptop.

    At this time only the 4.20.0-antix.1 is in the package-installer as a recent kernel.Suggestion would be to keep the 4.19.10-antix.1 in the package-installer,too, because it builds fine against broadcam-sta,ndiswrapper, virtualbox-guest and nvidia.

    Otherwise the 4.20.0-antix.1 runs very nicely and I sure will keep it on my main system.

    #17230
    Member
    Avatar
    russellb23

    Nice to know that you’ve made nvidia working for you. I am having trouble installing nvidia-driver and not able to set up optimus through bumblebee. Could you guide me to get nvidia working? What are the steps that you’ve followed?

    I am encountering the following error:

    
    sudo apt-get install nvidia-driver
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     nvidia-driver : Depends: nvidia-driver-libs (= 390.87-2~bpo9+1~mx17+2) but it is not going to be installed or
                              nvidia-driver-libs-nonglvnd (= 390.87-2~bpo9+1~mx17+2) but it is not going to be installed
                     Depends: nvidia-driver-bin (= 390.87-2~bpo9+1~mx17+2) but it is not going to be installed
                     Depends: xserver-xorg-video-nvidia (= 390.87-2~bpo9+1~mx17+2) but it is not going to be installed
                     Depends: nvidia-vdpau-driver (= 390.87-2~bpo9+1~mx17+2) but it is not going to be installed
                     Depends: nvidia-alternative (= 390.87-2~bpo9+1~mx17+2)
                     Depends: nvidia-kernel-dkms (= 390.87-2~bpo9+1~mx17+2) or
                              nvidia-kernel-390.87
    E: Unable to correct problems, you have held broken packages.
    • This reply was modified 2 months ago by russellb23.

    entropy

    #17232
    Member
    Avatar
    russellb23

    Nice hearing that you’ve made nvidia working for you. I am having trouble installing nvidia-driver from the repos. Here is my error log

    
    >> sudo apt-get install nvidia-driver
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     nvidia-driver : Depends: nvidia-driver-libs (= 390.87-2~bpo9+1~mx17+2) but it is not going to be installed or
                              nvidia-driver-libs-nonglvnd (= 390.87-2~bpo9+1~mx17+2) but it is not going to be installed
                     Depends: nvidia-driver-bin (= 390.87-2~bpo9+1~mx17+2) but it is not going to be installed
                     Depends: xserver-xorg-video-nvidia (= 390.87-2~bpo9+1~mx17+2) but it is not going to be installed
                     Depends: nvidia-vdpau-driver (= 390.87-2~bpo9+1~mx17+2) but it is not going to be installed
                     Depends: nvidia-alternative (= 390.87-2~bpo9+1~mx17+2)
                     Depends: nvidia-kernel-dkms (= 390.87-2~bpo9+1~mx17+2) or
                              nvidia-kernel-390.87
    E: Unable to correct problems, you have held broken packages.

    entropy

    #17247
    Member
    caprea
    caprea

    Yes, I’ve seen your other post, but didn’t have the time to look for until now.
    And yes you are right, the nvidia installation is not running properly.
    It looks like a backports driver from mx-repo should be installed without activating the backports for all dependencies.(So there is a problem which wasn’t there at least some month ago)

    In short, what worked for me here actually without any problems despite all this,
    open the baked in nvidia-installer from the terminal

    sudo ddm-mx -i nvidia

    You will be asked some questions, in your case for bumblebee and you will be asked for looking also in the backports. Say yes.

    You will also be asked which driver to install normal or backports repo. Say backports.

    This worked for me on antiX17.3.1

    Graphics:
      Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
      vendor: Gigabyte driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0412 
      Device-2: NVIDIA GM206 [GeForce GTX 960] vendor: Micro-Star MSI driver: nvidia 
      v: 390.87 bus ID: 01:00.0 chip ID: 10de:1401 
      Display: server: X.Org 1.19.2 driver: nvidia resolution: 1920x1080~60Hz 
      OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 v: 4.6.0 NVIDIA 390.87 
      direct render: Yes 
    

    What kind of hardware do you have?

    BTW, this new driver from backports should build again the 4.20 kernel, I didn’t try until now.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.