64 bit only – antiX-21-runit-beta2 available for testing.

Forum Forums antiX-development Development 64 bit only – antiX-21-runit-beta2 available for testing.

  • This topic has 251 replies, 23 voices, and was last updated Nov 12-4:22 pm by Brian Masinick.
Viewing 15 posts - 1 through 15 (of 252 total)
  • Author
    Posts
  • #65314
    Forum Admin
    anticapitalista

      I have not made this ‘open to the public’ by uploading to Sourceforge and mirrors, but only here:

      http://download.tuxfamily.org/antix/Testing/

      Hope it’s not too slow to download.

      This includes all latest runit changes suggested by Xecure, and it uses slimski login manager and zzzFM.
      It is classed as a beta release, but should work mostly just fine.
      Post here comments, bugs etc.

      Philosophers have interpreted the world in many ways; the point is to change it.

      antiX with runit - leaner and meaner.

      #65315
      Member
      andyprough

        I’m not getting any connection at all from that link this morning.

        $ ping http://download.tuxfamily.org/antix/Testing/
        ping: http://download.tuxfamily.org/antix/Testing/: Name or service not known
        #65316
        Forum Admin
        anticapitalista

          Can you visit the site?

          This works for me

          wget http://download.tuxfamily.org/antix/Testing/antiX-21-b2-runit_x64-full.iso

          Philosophers have interpreted the world in many ways; the point is to change it.

          antiX with runit - leaner and meaner.

          #65323
          Member
          andyprough

            Can you visit the site?

            This works for me

            wget http://download.tuxfamily.org/antix/Testing/antiX-21-b2-runit_x64-full.iso

            Yeah, that’s working. Download is pretty fast, probably just about two minutes.

            #65324
            Member
            calciumsodium

              Iotop does not show any runsv log services running as observed in the previous a1 and b1 versions. Good job solving this previous problem.

              I don’t see a herbsluftwm desktop option.

              #65325
              Forum Admin
              anticapitalista

                You should see it (herbstluftwm) at the login screen by toggling F1.

                We basically removed the logs (not sure if that is a good idea or not to be honest).
                I think we missed a couple though, eg acpid, ssh

                I’m also not too sure if user really wants all the symlinks in /etc/service/
                Although the deamon itself does not run with a blank down file, it seems sv still checks for it eg cron, cups.
                If you delete all folders in /etc/services/ (or better unlink them to /etc/sv/*) EXCEPT the following connman (actually if you use ceni it isn’t necessary), dbus, dhclient, elogind, getty-tty1, getty-tty1, slimski, udevd, both RAM as CPU usage goes down with no obvious issues I can see.

                Anyone know how Void or artiX linux sets up services running once installed to hard disk?

                Philosophers have interpreted the world in many ways; the point is to change it.

                antiX with runit - leaner and meaner.

                #65326
                Forum Admin
                anticapitalista

                  Also, technically removing these symlinks /etc/service/dbus and /etc/service/elogind still boots to desktop without any obvious issues I can see.

                  Philosophers have interpreted the world in many ways; the point is to change it.

                  antiX with runit - leaner and meaner.

                  #65328
                  Member
                  calciumsodium

                    You should see it (herbstluftwm) at the login screen by toggling F1.

                    Yes, I can see the herbstluftwm option when togging F1 at the login screen. But when one clicks on main menu Desktop > Other Desktops > , I don’t see the herbstlufwm option. I see this option in other versions.

                    #65329
                    Member
                    calciumsodium

                      In previous tests of antiX runit versions, @Xecure taught us to use iotop to check for the runsv log services. Using iotop, I don’t see any runsv log services running. But when I use htop, most of the runit services are runsv.

                      Is this something to be worried about? Or is this OK? I don’t know enough. This is what I am observing.

                      Also, using iotop, I notice that the service kworker seems to be running alot. Is this something to look at, or is this normal usage.

                      #65330
                      Forum Admin
                      anticapitalista

                        It was removed from the Desktop menu starting with antiX-19 IIRC because some users would click on it out of curiosity, not read the pop-up message and then get stuck.

                        Philosophers have interpreted the world in many ways; the point is to change it.

                        antiX with runit - leaner and meaner.

                        #65331
                        Member
                        Xecure

                          There was a small bug in gpm service (sorry for that). It is fixed here.

                          For some reason, if /etc/default/runit file doesn’t exist, on installed, runsv tries to start to write to the disk for 3 services (). Creating a symlink to /etc/default/runit-antix
                          sudo ln -s /etc/default/runit-antix /etc/default/runit

                          I don’t see a herbsluftwm desktop option.

                          There is a problem getting to herbstluft from the live boot menus. I will see what happened there. You can reach herbstluft from the slimski F1 toggle (log out first), or make it appear on the “Other Desktops” menus with the command
                          sudo /usr/local/lib/desktop-session/desktop-session-update-wm-menus -f

                          We basically removed the logs (not sure if that is a good idea or not to be honest).
                          I think we missed a couple though, eg acpid, ssh

                          acpid and openssh-server automatically add the runit services to /etc/sv, so nothing else we should do.

                          logs (at least for acpid on this ISO) require the existence of a user named runit-log from group adm (runit-log:adm). On some devuan posts they stated user “_runit-log” (see the “_” symbol) instead. I think that this user should be created by the runit installer, but it isn’t, so something else needs to create it instead of services expect it to exist.

                          A log folder can be created for any of the services. If you add this run file:

                          #!/bin/sh
                          set -e
                          NAME=template
                          LOG="/var/log/runit/$NAME"
                          test -d "$LOG" || mkdir "$LOG"
                          exec chpst svlogd -tt "$LOG"

                          Replacing “NAME=template” with the correct service name, it will work properly and log as root to /var/log/runit/$NAME

                          If you decide it is a better idea to have logs, then let me know and I will edit the runit-services-antix project.

                          • This reply was modified 2 years, 6 months ago by Xecure. Reason: Explain better

                          antiX Live system enthusiast.
                          General Live Boot Parameters for antiX.

                          #65332
                          Member
                          Xecure

                            In previous tests of antiX runit versions, @Xecure taught us to use iotop to check for the runsv log services.

                            In fact, it shows all processes writing to disk (I/O). It was useful to check the bad behavior of runit logs of runit runsv services erroring out.

                            But when I use htop, most of the runit services are runsv.

                            That is correct, all services are processes running. runsv <service-name> for each service.

                            Also, using iotop, I notice that the service kworker seems to be running alot.

                            That is not a service but the “kernel worker” (“kworker” is a placeholder process for kernel worker threads). It is the kernel interacting and doing things. I see this popping much more often in kernels 5.XX compared to kernel 4.XX. I suppose this is the result of adding so many things to the kernel.

                            antiX Live system enthusiast.
                            General Live Boot Parameters for antiX.

                            #65334
                            Moderator
                            caprea

                              After installation to harddrive the /.icewm/menu-applications file was empty. I had to reinstall desktop-defaults-antix to get a complete menu.
                              slimski login manager looks very good and works.

                              #65337
                              Member
                              calciumsodium

                                After installation to harddrive the /.icewm/menu-applications file was empty.

                                Hi @caprea,
                                That is strange. I cannot reproduce this error. In my install to hard drive of this B2-test version, the /.icewm/menu-applications file is not empty. I see the list of programs under each of the menu options.

                                #65340
                                Member
                                Xecure

                                  There are some service folders that are empty, and some where the run file non-executable (leads to error loading those services in installed). For example gpm has a plain run file and ofono is an empty folder.

                                  I’m also not too sure if user really wants all the symlinks in /etc/service/
                                  Although the deamon itself does not run with a blank down file, it seems sv still checks for it eg cron, cups.
                                  If you delete all folders in /etc/services/ (or better unlink them to /etc/sv/*) EXCEPT the following connman (actually if you use ceni it isn’t necessary), dbus, dhclient, elogind, getty-tty1, getty-tty1, slimski, udevd, both RAM as CPU usage goes down with no obvious issues I can see.

                                  I will try to fix up the init-system-helpers so that update-rc.d and service commands will disable/enable start/stop runit services.

                                  antiX Live system enthusiast.
                                  General Live Boot Parameters for antiX.

                                Viewing 15 posts - 1 through 15 (of 252 total)
                                • You must be logged in to reply to this topic.