Add volume icon to min-icewm

Forum Forums New users New Users and General Questions Add volume icon to min-icewm

  • This topic has 19 replies, 8 voices, and was last updated Dec 30-3:13 pm by andfree.
Viewing 5 posts - 16 through 20 (of 20 total)
  • Author
    Posts
  • #4408
    Anonymous

      all the time

      Yes, consistently.
      Others can easily test to confirm or refute.

      Here’s the topic where I mentioned the issue in oldforums: tweaking/improving the desktop menu defaults
      and placed a tip/comment within the fluxbox v1.38-ski default menu

      #4493
      Member
      andfree

        As the error says the /.config/icewm/startup file does not exist.

        For that matter neither does any of the other files because the “~” is missing from the front of the file path. (should be ~/.icewm/startup not /.icewm/startup)

        You will probably find better luck opening these files through the control centre.
        Control centre -> Desktop -> Edit icewm settings
        And
        Control centre -> session -> user desktop session.

        It’s when I open these files through the control centre that they are absolutely blank.

        If you want volumeicon in the toolbar, choose the icewm option and scaledown what you don’t want in the ¬/.desktop-session/startupfile

        There’s nothing there to scaledown, as I’ve already said.

        Here is how Rok runs Xcalc. A terminal only application in his taskbar.But I do this in my AntiX 15 laptop.

        prog "Xcalc" /usr/share/icons/Adwaita/32x32/apps/accessories-calculator.png desktop-defaults-run -t xcalc

        This has worked for me, too.

        Ahhhh, so lxterminal is now the default in AntiX17. Ok, this is from a full AntiX17, so if it doesn’t work, you will need to change the icon to one that does exist. You can find out if it exists by opening a terminal and at the command line typing (yes, you can copy/paste it in).

        ls -l /usr/share/icons/Faenza-Cupertino-mini/status/16/audio-volume-medium.png

        in order to see if alsamixer exists and works you can then type

        alsamixer

        If both are good, add this line to the toolbar file (as shown above), save it, and then do MENU logout, hover over the arrow, and click restart icewm

        prog “Volume Control-Mixer” /usr/share/icons/Faenza-Cupertino-mini/status/16/audio-volume-medium.png desktop-defaults-run -t alsamixer

        $ ls -l /usr/share/icons/Faenza-Cupertino-mini/status/16/audio-volume-medium.png
        -rw-r--r-- 1 root root 678 Feb 23  2016 /usr/share/icons/Faenza-Cupertino-mini/status/16/audio-volume-medium.png

        Alsamixer exists and works.

        I have changed the toolbar as this:

        # This is a default toolbar definition file for IceWM
        #
        # Place your personal variant in $HOME/.icewm directory.
        ### Commonly used applications
        prog "Unplug Removable Device" /usr/share/icons/Faenza-Cupertino-mini/devices/32/drive-removable-media-usb.png unplugdrive.sh
        prog "Xcalc" /usr/share/icons/Adwaita/32x32/apps/accessories-calculator.png desktop-defaults-run -t xcalc
        prog “Volume Control-Mixer” /usr/share/icons/Faenza-Cupertino-mini/status/16/audio-volume-medium.png desktop-defaults-run -t alsamixer

        I restart the session, but there’s not an icon for alsamixer.

        • This reply was modified 6 years, 5 months ago by andfree.
        • This reply was modified 6 years, 5 months ago by andfree.
        #4497
        Member
        maroc

          I have changed the toolbar as this:

          
          # This is a default toolbar definition file for IceWM
          #
          # Place your personal variant in $HOME/.icewm directory.
          ### Commonly used applications
          prog "Unplug Removable Device" /usr/share/icons/Faenza-Cupertino-mini/devices/32/drive-removable-media-usb.png unplugdrive.sh
          prog "Xcalc" /usr/share/icons/Adwaita/32x32/apps/accessories-calculator.png desktop-defaults-run -t xcalc
          prog “Volume Control-Mixer” /usr/share/icons/Faenza-Cupertino-mini/status/16/audio-volume-medium.png desktop-defaults-run -t alsamixer

          I restart the session, but there’s not an icon for alsamixer.

          If you look closely, you’ll notice that the line for AlsaMixer contains non-standard quotes. Use the same quotation marks as in the other lines, and everything will work alright.

          #4501
          Anonymous

            ~/.config/icewm/startup file does not exist.

            Aw, post #2 contained a typo… which carried through to later posts.
            The correct path (and what ControlCenter would attempt to open in geany) is ~/.icewm/startup

            when I open […] through the control centre that they are absolutely blank.

            This would occur if someone logged into desktop session using root account.
            So, let’s rule out that possibility:
            Did you accidentally (or intentionally) log into desktop session using root account?

            To continue troubleshooting:
            verify that a ~/.icewm directory exists, and that the startup file exists, and all items are owned by your user (e.g. demo:demo)
            q
            (Also note the permissions. All should be readable+writable; the icewm startup file should be executable)

            If the startup file exists, “OpenWith” leafpad or other text editor. If it is, in fact, blank… I’m not confident we’ll figure out “how that happened”.
            If it is not blank, edit/save your changes then restart icewm to check the result.

            #4507
            Member
            andfree

              If you look closely, you’ll notice that the line for AlsaMixer contains non-standard quotes. Use the same quotation marks as in the other lines, and everything will work alright.

              This was the case. Now it works. Thanks.

              when I open […] through the control centre that they are absolutely blank.

              This would occur if someone logged into desktop session using root account.
              So, let’s rule out that possibility:
              Did you accidentally (or intentionally) log into desktop session using root account?

              Yes, this is what I did (with the toshiba laptop). But now I’m using the compaq laptop and I see that both ~/.icewm/startup & /.icewm/startup are blank, and I also see that both ~/.desktop-session/startup & /.desktop-session/startup are not blank.

              verify that a ~/.icewm directory exists, and that the startup file exists, and all items are owned by your user (e.g. demo:demo)

              There is a ~/.icewm directory (at the user account) and a /.icewm directory (at the root account). Both of them contain a startup.disabled file.

            Viewing 5 posts - 16 through 20 (of 20 total)
            • You must be logged in to reply to this topic.