Alarm Clock GStreamer Issue

Forum Forums General Software Alarm Clock GStreamer Issue

This topic contains 7 replies, has 3 voices, and was last updated by caprea Sep 1-7:34 am.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #11981
    Member
    marius
    marius

    GStreamer Error in the Alarm Clock

    Trying to play an MP3 will return that error. Trying to play a FLAC …the Alarm acts like it is playing it, but no sound is heard (i.e. nothing happens visibly or audibly).

    I ran an apt-get to install the gstreamer plugins:

    apt-get install gstreamer1.0-plugins-good`

    Evidently, they are already installed. I can play FLACs and MP3s with XMMS.

    #11983
    Member
    marius
    marius

    I forgot to add that the Alarm Clock I installed is from:
    apt-get install alarm-clock-applet

    #11986
    Member
    caprea
    caprea

    Could you try to install
    gstreamer1.0-fluendo-mp3

    You sure have to close alarm-clock-applet completely, and start it again afterwards.

    • This reply was modified 1 year, 1 month ago by caprea.
    #11998
    Member
    marius
    marius

    I should have mentioned in the first post that I installed pulseaudio. I apologize.

    Tried the above recommendation by caprea. Closed & tried again. Same result. Rebooted. Now it acts as if it is playing the file, but there is no sound.

    #12003
    Member
    Avatar
    nonico

    Can’t say for sure, but sometimes these problems are fixed by installing the “bad” and/or “ugly” gstreamer plugins.

    #12004
    Member
    caprea
    caprea

    Yes, you can try to deinstall the fluendo plugin and install the gstreamer1.0-plugins-ugly and bad, to see if this gives better result.

    On the other hand,because pulseaudio is installed, is pavucontrol installed (I would suggest to do so)and is the alarm-clock shown there under playback ?
    Maybe try out the settings in pavucontrol, it depends on how you want to play the sound.
    e.g in my case
    I have connected a HD-monitor with loudspeakers and a hifi system
    If I want to hear the alarm clock over the monitor, I have to set the internal analog to off under Configuration in pavucontrol.

    #12010
    Member
    marius
    marius

    Thank you for the suggestions. Nothing has worked. Curiously, in pavucontrol, nothing is shown when Alarm Clock tries to play a song.

    #12018
    Member
    caprea
    caprea

    Is gstreamer1.0-pulseaudio installed ?

    Just tried on a live-usb to get the alarm-clock to work
    Installed pulseaudio and pavucontrol

    From gstreamer is installed
    gstreamer1.0-fluendo-mp3
    gstreamer1.0-plugins-base
    gstreamer1.0-plugins-good
    gstreamer1.0-pulseaudio
    libgstreamer-plugins-base1.0-0
    libgstreamer1.0-0

    Plays now sound.Good luck !

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.