Also lost audio here [solved]

Forum Forums Orphaned Posts antiX-16 “Berta Cáceres” Also lost audio here [solved]

  • This topic has 6 replies, 4 voices, and was last updated Nov 14-3:33 pm by Anonymous.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2524
    Anonymous

      Antix 16.2 64 bit, recently reinstalled so this system starts with zero updates, zero additions. Audio works fine.

      Ran synaptic, refreshed, using stretch repositories.

      Marked all updates, applied, and sat back listening to music from Youtube.

      Part way through the update, about 30% done, audio shuts off.

      Seems like the only audio related update was Alsa.

      Commit Log for Sun Nov 12 21:28:35 2017
      Removed the following packages:

      edited by skidoo:
      list of 1,471 package names uploaded to pastebin
      pastebin.com/c8jthZpr
      consider: soup-to-nuts inline lists like this will add noise to search results !

      The result of the matter seems to be that Alsa switched my sound device. I have been using audio through the Realtek ALC662 onboard 5.1 sound system, but Alsa has decided to use the ATI DVI interface of my add in graphics card that I’m using. Somewhere, nothing asked the user what to do, but in any event, I would like to reconfigure this.

      https://www.antixforum.com/forums/topic/lost-audio-output-help/ discusses a muting problem, my audio is not muted.

      $ cat /proc/asound/car*/co* | grep Codec
      Codec: Realtek ALC662 rev1
      Codec: ATI R6xx HDMI`

      System has the correct codec for the ALC662.

      $ inxi -A
      Audio:     Card-1 Advanced Micro Devices [AMD/ATI] RV710/730 HDMI Audio [Radeon HD 4000 series]
                 driver: snd_hda_intel
                 Card-2 NVIDIA MCP61 High Definition Audio driver: snd_hda_intel
                 Sound: Advanced Linux Sound Architecture v: k4.4.10-antix.1-amd64-smp
      mmmmna@Reantix64b162:~

      I think the correct card is card-2, since I’m using the nVidia sound which the system chipset provides. I’m supposing the Realtek ALC662 is just a driver family which nVidia system chipset uses.

      Looking for suggestions of what to run to select and configure the proper card.

      #2525
      Moderator
      caprea

        Did you try in antiX Control Center under hardware to choose the default soundcard ?

        If this doesn’t help,you can look in soundsystem, if anything is muted.
        If this all doesn’t help, please post the output of
        aplay /usr/share/sounds/alsa/Front_Center.wav

        #2530
        Anonymous

          Control Centre -Hardware -Set Default Sound Card was correctly set to the nVidia sound card. Testing the sound produced a message that the Test Failed (could not connect to the selected device) Do I want to set the card again? I repeated the test, and the result was the same error message.

          Posted above, rechecked, still nothing muted.

          aplay /usr/share/sounds/alsa/Front_Center.wav

          mmmmna@Reantix64b162:~
          $ sudo aplay /usr/share/sounds/alsa/Front_Center.wav
          ALSA lib pcm_equal.c:236:(_snd_pcm_equal_open) Problem with control file .alsaequal.bin.
          aplay: main:788: audio open error: Operation not permitted
          mmmmna@Reantix64b162:
          #2532
          Forum Admin
          anticapitalista

            Don’t use sudo, just aplay /usr/share/sounds/alsa/Front_Center.wav

            Philosophers have interpreted the world in many ways; the point is to change it.

            antiX with runit - leaner and meaner.

            #2533
            Forum Admin
            anticapitalista

              You could also try this.

              If you have asoundrc or asound.conf in etc (they may be hidden) delete them. Do the same if you have them in your home user directory.
              Then run alsamixer again

              Philosophers have interpreted the world in many ways; the point is to change it.

              antiX with runit - leaner and meaner.

              #2538
              Forum Admin
              SamK

                I think there is a good chance that this combination of playing via ALSA while installing ALSA updates

                Marked all updates, applied, and sat back listening to music from Youtube.

                Commit Log for Sun Nov 12 21:28:35 2017
                ...
                alsa-tools (1.0.28-1) to 1.1.3-1
                alsa-utils (1.0.28-1) to 1.1.3-1
                alsamixer-equalizer-antix (0.1.2) to 0.1.3
                ...
                

                Produced

                `mmmmna@Reantix64b162:~

                ALSA lib pcm_equal.c:236:(_snd_pcm_equal_open) Problem with control file .alsaequal.bin.
                …`

                Before doing anything more drastic try the following:
                Stop ALSA
                sudo service alsa-utils stop

                Delete .alsaequal.bin. It is a hidden file in your home directory and will be automatically recreated when you get ALSA working again.
                rm ~/.alsaequal.bin

                Start ALSA
                sudo service alsa-utils start

                Make sure everything is not muted and the volume is turned up

                Play a test file
                speaker-test -c2 -twav -l3

                #2555
                Anonymous

                  actions are in order of replies:

                  Don’t use sudo, just aplay /usr/share/sounds/alsa/Front_Center.wav

                  $ aplay /usr/share/sounds/alsa/Front_Center.wav
                  ALSA lib pcm_equal.c:236:(_snd_pcm_equal_open) Problem with control file .alsaequal.bin.
                  aplay: main:788: audio open error: Operation not permitted
                  mmmmna@Reantix64b162:~

                  You could also try this.

                  If you have asoundrc or asound.conf in etc (they may be hidden) delete them. Do the same if you have them in your home user directory.
                  Then run alsamixer again

                  $ ls -la /etc/asou*
                  -rw-r--r-- 1 root root 806 Jun 23  2016 /etc/asound.conf
                  -rw-r--r-- 1 root root 923 Jun 15 11:56 /etc/asound.conf.PREAMP
                  mmmmna@Reantix64b162:~
                  $ pwd
                  /home/mmmmna
                  mmmmna@Reantix64b162:~
                  $ ls -la .as*
                  -rw-r--r-- 1 mmmmna mmmmna 52 Nov 14 06:59 .asoundrc
                  mmmmna@Reantix64b162:~
                  $ rm /etc/asound.conf
                  rm: remove write-protected regular file '/etc/asound.conf'? y
                  rm: cannot remove '/etc/asound.conf': Permission denied
                  mmmmna@Reantix64b162:~
                  $ sudo rm /etc/asound.conf
                  [sudo] password for mmmmna: 
                  mmmmna@Reantix64b162:~
                  $ ls -la /etc/asou*
                  -rw-r--r-- 1 root root 923 Jun 15 11:56 /etc/asound.conf.PREAMP
                  mmmmna@Reantix64b162:~
                  $ ls -la .as*
                  -rw-r--r-- 1 mmmmna mmmmna 52 Nov 14 06:59 .asoundrc
                  mmmmna@Reantix64b162:~
                  $ rm .asoundrc 
                  mmmmna@Reantix64b162:~
                  $ ls -la .as*
                  ls: cannot access '.as*': No such file or directory
                  mmmmna@Reantix64b162:~
                  $ 

                  Ran alsamixer, all volumes up, nothing muted, no sound, but when I raised volume for Front Mic, the speakers raised volume of a hissing sound.

                  Moving to what SamK suggested:

                  $ sudo service alsa-utils stop
                  [ ok ] Shutting down ALSA...done.
                  mmmmna@Reantix64b162:~
                  $ rm ~/.alsaequal.bin 
                  mmmmna@Reantix64b162:~
                  $ sudo service alsa-utils start
                  [ ok ] Setting up ALSA...done.
                  mmmmna@Reantix64b162:~
                  $ speaker-test -c2 -twav -l3
                  speaker-test 1.1.3
                  Playback device is default
                  Stream parameters are 48000Hz, S16_LE, 2 channels
                  WAV file(s)
                  Rate set to 48000Hz (requested 48000Hz)
                  Buffer size range from 2048 to 8192
                  Period size range from 1024 to 1024
                  Using max buffer size 8192
                  Periods = 4
                  was set period_size = 1024
                  was set buffer_size = 8192
                   0 - Front Left
                   1 - Front Right
                  Time per period = 2.857779
                   0 - Front Left
                   1 - Front Right
                  Time per period = 3.007953
                   0 - Front Left
                   1 - Front Right
                  Time per period = 3.007962
                  mmmmna@Reantix64b162:~
                  $ 

                  Worked perfectly, thanks to everyone!

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.