alt+TAB not working

Forum Forums Official Releases antiX-21/22 “Grup Yorum” alt+TAB not working

  • This topic has 6 replies, 3 voices, and was last updated Jan 18-12:10 am by seaken64.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #75264
    Member
    ATGhQlsvhij19tw5jgDi

      Hi,
      if I run a full screen programs (eg video with mpv) alt+TAB works fine, but if I run MAME full screen and I press alt+TAB to temporarily go back to one of my other windows running, nothing happens.

      I have little if not experience with the default antix DE and cannot understand how and if I can achieve what I wish to do.
      I have already searched online but no luck

      Thank you.

      #75268
      Moderator
      BobC

        It sounds like MAME is taking over the Alt+Tab. I’m not familiar with that program, but see if you can disable it from taking over those keys.

        Daily driver distro https://www.antixforum.com

        #75403
        Member
        ATGhQlsvhij19tw5jgDi

          Thank you BobC.

          I do not think it is MAME’s fault (or anyway the full-screen program in itself) but something more related to how icewm and the DE in itself manages alt+TAB function.

          I have used MAME with several other distributions and never an issue.

          If I run “mame -window” the alt+TAB works fine.

          thanks!

          Elio

          #75406
          Moderator
          BobC

            Other programs work fine and respond to Alt+TAB when in full screen mode. I suggest running your mame program from the toolbar with the -window parameter or change its .desktop file to use that parameter. And yes, I consider it to be mame’s fault since all other programs I tried work fine.

            Daily driver distro https://www.antixforum.com

            #75420
            Member
            ATGhQlsvhij19tw5jgDi

              thank you very much BobC for the reply and your testings.
              Yes, a fairly decent work around is to launch it with the -window flag.
              Thanks!!

              🙂

              #75426
              Moderator
              BobC

                I suggest you try the window option and then do an F11 for full screen, then try the Alt+Tab

                Daily driver distro https://www.antixforum.com

                #75438
                Member
                seaken64

                  You may also be able to use desktop workspaces. antiX IceWM has two workspaces set up but you can add more.

                  Seaken64

                Viewing 7 posts - 1 through 7 (of 7 total)
                • You must be logged in to reply to this topic.