Android connection lost after deleting rox-filer and zzzfm

Forum Forums General Software Android connection lost after deleting rox-filer and zzzfm

  • This topic has 4 replies, 3 voices, and was last updated Nov 8-6:29 pm by anti-apXos.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #122746
    Member
    xanthian

      Hi, and thank you very much for your great work!
      As written in the title, I deleted rox-filer AND zzzfm trying to align the software to my desktop minimal i3 with thunar.
      Android connection app is not working any more, it gives me two messages, 1st one “Please check if you have ALLOWED…” and 2nd “Unable to mount device…”
      Today I reinstalled rox-filer and zzzfm, but the same messages are displayed when trying to use the “Android Device USB connect”.
      It seems that I messed things up somehow. Is there any way to re-establish connection with Android devices via USB?
      Thanks in advance!

      #122752
      Member
      anti-apXos

        You tested and successfully connected to your phone before removing zzzfm and rox-filer? Removing those programs shouldn’t have any effect on the MTP script, but I don’t kow for sure, I guess, since I haven’t tested. The MTP mount script that comes with antiX never worked for me and many other users have reported the same, though it seems to depend on the model of phone you have.

        The antiX script basically relies on jmtpfs, so you should try plugging in your phone and then from a terminal run

        jmtpfs /media/mtp
        

        and see what it tells you. You might need to mkdir the /media/mtp directory first. If you get an error about permission denied, try

        sudo jmtpfs -o allow_other /media/mtp
        

        In my case, that’s the only command I need to connect to my phone as an MTP device, so I gave up trying to use the connect script.

        #122802
        Member
        xanthian

          Thanks, the second command worked perfectly after making the directory! That was the only thing that didn’t work, now Antix works perfectly!
          Question solved, thank you!

          #122804
          Member
          PPC

            The GUI to connect to android devices was tested on several phones and tablets and seemed to work perfectly, so it was integrated into antiX. Unfortunatly there’s so much variation on the hardware and software of android devices that the original script fails to work on an increasing number of devices (it still works perfectly on my android devices). I’ll probably, when I have the time, just try to addapt the original script to also include, in case of failure to connect, to try to do something like “sudo jmtpfs -o allow_other /media/mtp” to force the connection, even if it requires entering the password…
            Of course I would appreciate is someone could perform those changes to the original script… I would test them and commit them to the antiX’s git, for anticapitalista’s to check and decide to integrate into antiX or not.

            P.

            #122952
            Member
            anti-apXos

              @PPC, I took a look at the android-device-usb-connect.sh script and tried to get it working with my phone (a Samsung Galaxy A5). There are additional issues beyond just the need to run jmtpfs as root. Any earlier attempt to access the phone results in no response when trying to mount it afterwards. I was able to rework the original script so that it tries to mount the device immediately rather than checking the connection and then mounting after.

              I don’t know if it will be possible to have this method using sudo as a fallback in case a regular attempt to mount as $USER doesn’t work. Even commands to unbind and rebind the whole USB hub do not make my phone respond again once a first attempt has been made. Only physically replugging it works. I’m not sure if this is going to be the same for everyone who has problems with the original script or if it’s just an issue with my particular phone.

              If it is a common problem, I only see two solutions:

              1) If regular jmtpfs mounting without sudo fails, throw up a message saying the phone needs to be physically replugged and then have the user click a button to retry with sudo. This really seems too complicated to be useful to me.

              2) Always use sudo jmtpfs even for phones that don’t need it. This is not ideal, but maybe better than the above.

              Or maybe you can think of another way.

              I’m attaching a modified version of the script that works on my phone in case other people want to test it or use it as a base for additional work. Note that I also added sudo to the unmount operations using fusermount. Without this I get an error that /home/$USER/android_device is not in /etc/mtab so it can’t be unmounted.

              • This reply was modified 6 months, 1 week ago by anti-apXos.
            Viewing 5 posts - 1 through 5 (of 5 total)
            • You must be logged in to reply to this topic.