Antix 17.3 live CD won't Boot into X

Forum Forums Official Releases antiX-17 “Heather Heyer” Antix 17.3 live CD won't Boot into X

This topic contains 5 replies, has 3 voices, and was last updated by BitJam Feb 17-3:07 pm.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #18649
    Member
    Avatar
    Fantomas

    Hi,
    I’m struggeling with live CD booting into X11 on my PIII.
    I figured out that in /etc/X11/xorg.conf the driver was set to vesa. That prevents X to Start into graphical mode.
    I changed it to intel and startx worked. But it is just an GUI without Antix Desktop.
    How can force Antix to use the Intel driver at boot time?

    Regards
    Thomas

    #18650
    Forum Admin
    anticapitalista
    anticapitalista

    Try xorg=intel.

    Also instead of startx , type startx /usr/local/bin/desktop-session rox-icewm (if you are running base or full versions).

    BTW, if you are using 17.3 base/full, read this and use 17.3.1 instead: serious-bug-installing-antix-17-3-full-and-base-versions

    Philosophers have interpreted the world in many ways; the point is to change it.

    #18652
    Forum Admin
    BitJam
    BitJam

    @Fantomask, if it is not too inconvenient, I’d like to see the file /var/log/live/live-init.log. If it’s hard to get it off the live system to post, maybe you could display it with the less command and a take picture of the screen. I’d like to see the live-init section which should look something like this:

    live-init: Localizing/configuring X-Windows
      Creating issue file for antiX 17.pre-rc1 (Heather Heyer) 64-bit
      Turning all boot mount options off
      Turning automount off
      Scanning for hardware specific video modules ...
      Found KMS video module(s) i915
      Automount disabled

    As anti said using the boot parameter “xorg=intel” should fix this problem so you get to X with the windows manager, etc. If you run into a similar problem again and you are dumped to the command line, you can try to restart X with the commands:

    sudo telinit 3
    sudo telinit 5

    Again this should get you to X with the window manager and the other goodies.

    If your system uses intel graphics then we should detect the i915 kernel module and this should prevent us from creating an xorg.conf file with the vesa driver in it. The boot parameters in /proc/cmdline may be useful as well. We are supposed to automatically select a graphics driver (or no driver) that gets X working. If that’s broken then I’d like to fix it.

    Context is worth 80 IQ points -- Alan Kay

    #18660
    Member
    Avatar
    Fantomas

    Hi anti,

    Try xorg=intel.

    That was the solution for the issue.

    Thank you very much for your very quick help 🙂

    #18663
    Member
    Avatar
    Fantomas

    Hi BitJam,
    anti’s suggestion worked for me: xorg=intel.

    Here comes the requested output:

    /var/log/live/live-init.log (it’s the whole content):

    
    Sun Feb 17 09:19:01 EST 2019  /live/etc/init.d/live-init
    [1;32mlive-init[0m: [1;36mLocalizing/configuring X-Windows[0m
    [1;36m  Creating issue file for [1;33mantiX 17 (Heather Heyer) 32-bit[1;36m[0m
      make-fstab: Create new /etc/fstab
      make-fstab: Put 2 hard drive entries into /etc/fstab
      make-fstab: Put 1 removable entry into /etc/fstab
    [1;36m  Scanning for hardware specific video modules ...[0m
    [1;36m  Configuring [1;33m/etc/X11/xorg.conf[1;36m file with [1;33msafe[1;36m[0m
    [1;36m  Populating [1;33m/home/demo[1;36m directory[0m
    
    Sun Feb 17 09:19:19 EST 2019  /live/etc/init.d/live-disable-services
    [1;32mlive-disable-services[0m: [1;36mCustomizing services[0m
    [1;36m  Disabling [1;33mVirtual Box[1;36m services[0m
    [1;36m  Disabling some services ([1;32mL, lean[1;36m)[0m
    [1;36m  Disabling more services ([1;32mX, Xtralean[1;36m)[0m
    
    Sun Feb 17 09:20:09 EST 2019  /live/etc/init.d/live-restore-services
    [1;32mlive-restore-services[0m: [1;36mrestoring service links[0m
    

    xorg.conf:

    
    #-----------------------------------------------------------------------------
    # xorg.conf file
    #
    # Generated by make-xorg-conf sometime around Sun Feb 17 09:19:18 EST 2019
    #
    # If you want to save customizations, delete the line above or this
    # file will get automatically deleted on the next live boot.
    #
    # Command line parameters: --output=/etc/X11/xorg.conf safe
    #-----------------------------------------------------------------------------
    
    Section "Monitor"
        Identifier "Monitor0"
        Option "DPMS" "true"
    EndSection
    
    Section "Device"
        Identifier "Device0"
        Driver     "vesa"
    EndSection
    
    Section "Screen"
        Identifier      "Screen0"
        Monitor         "Monitor0"
        Device          "Device0"
    EndSection
    

    /proc/cmdline:

    
    vga=791 quiet splash=v disable=lx nomodeset xorg=safe
    

    Thank you for your very quick response on my issue 🙂

    regards
    Thomas

    Sun Feb 17 09:20:10 EST 2019 /live/etc/init.d/live-usb-save

    #18673
    Forum Admin
    BitJam
    BitJam

    The “xorg=safe” boot option was causing the xorg.conf to be created with the vesa driver.

    What version of antiX are you using? A number of years ago we got rid of the ANSI color codes in the live-init.log file. They still exist in the live-init.log.color file.

    There are also several other strange things going on. We should have detected your hardware that uses the i915 module but I don’t see it in the output. Also, the combination of “nomodeset” and “xorg=safe” should have worked (at least it used to work) even if you had a modesetting driver.

    If you are using an old version of antiX then it is possible this problem has already been addressed.

    If you don’t mind, and it is not too inconvenient, I’d like to see the output of these commands:
    inxi -SMG
    and
    lsmod

    The “xorg=save” boot parameter should almost always get you to X. The fact that it prevented you from getting to X is a glaring bug that I’d like to fix. You can also email me at @gmail.com. Thanks!

    Context is worth 80 IQ points -- Alan Kay

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.