antiX 17.4.1 just installed: unable to play any sound

Forum Forums General Hardware antiX 17.4.1 just installed: unable to play any sound

  • This topic has 10 replies, 6 voices, and was last updated Sep 8-7:12 am by anticapitalista.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #26840
    Member
    mikey777

      Just installed most recent version of antiX, but am unable to play any sound from DVDs, Youtube, etc …
      How do I fix this?

      ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
      - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
      ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
      - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
      - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

      #26844
      Member
      fatmac

        If I remember right…

        Menu > Control Centre > Hardware > Test Soundcard

        If you hear sound, you need to raise it with the mixer.

        (I’m not on AntiX just now.)

        Linux (& BSD) since 1999
        Ultra Small Form Factor & thin client computers

        #26845
        Member
        olsztyn

          I would suggest – first test sound in Control Center/Hardware/Test Sound. See if it works in the first place.

          Live antiX Boot Options (Previously posted by Xecure):
          http://antixlinuxfan.miraheze.org/wiki/Table_of_antiX_Boot_Parameters

          #26864
          Member
          mikey777

            Many thanks to you both for replying
            Yes this works, but only for headphones, not through the laptop’s speakers.
            I looked in AlsaMixer but don’t see how to switch to speakers …

            ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
            - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
            ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
            - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
            - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

            #26869
            Moderator
            caprea

              If you right-click with the mouse on the volume-icon in the toolbar, you can go to preferences.
              There you should be able to change the channel.

              #26891
              Member
              mikey777

                If you right-click with the mouse on the volume-icon in the toolbar, you can go to preferences.
                There you should be able to change the channel.

                Thanks caprea – I did this but still have the same problem of no sound through the laptop’s inbuilt speakers.
                This is a screenshot of “Preferences”:
                http://imgur.com/a/5BK6yUb

                AlsaMixer shows this (sound card shown)
                http://imgur.com/a/XpGuCf1

                Let me know if you need anymore info to help me fix this.
                Many thanks in advance

                • This reply was modified 4 years, 10 months ago by mikey777.

                ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
                - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
                ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
                - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
                - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

                #26893
                Member
                VW

                  Yes this works, but only for headphones, not through the laptop’s speakers.

                  That sounds like a faulty headphone socket, as in an electrical fault, and not a software fault.

                  “These are the times that try men's souls" - Thomas Paine

                  #26894
                  Moderator
                  caprea

                    The picture shows the display for “Internal” muted.Could you try if it helps to unmute it ?

                    Does the output of
                    aplay /usr/share/sounds/alsa/Front_Center.wav
                    give some hints why it cant play ?

                    Edit: I would set the channel to “master”

                    • This reply was modified 4 years, 10 months ago by caprea.
                    #26898
                    Member
                    mikey777

                      The picture shows the display for “Internal” muted.Could you try if it helps to unmute it ?

                      Does the output of
                      aplay /usr/share/sounds/alsa/Front_Center.wav
                      give some hints why it cant play ?

                      This is the output:

                      marie@antix1:~
                      $ aplay /usr/share/sounds/alsa/Front_Center.wav
                      Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono

                      I don’t think this gives any hint; do tell me your opinion.

                      ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
                      - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
                      ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
                      - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
                      - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

                      #26900
                      Moderator
                      caprea

                        At least there is no error.
                        If alsa recognizes the sound card and the playback command works (it does in this case)
                        there is something wrong in the alsamixer-settings most of the time.
                        Did you unmute the bar for “Internal” on the right side of the picture ?

                        #26901
                        Forum Admin
                        anticapitalista

                          Also,turn up Master and Speaker volume in alsamixer.

                          • This reply was modified 4 years, 10 months ago by anticapitalista.

                          Philosophers have interpreted the world in many ways; the point is to change it.

                          antiX with runit - leaner and meaner.

                        Viewing 11 posts - 1 through 11 (of 11 total)
                        • You must be logged in to reply to this topic.