antiX-17.4 no sound

Forum Forums General Hardware antiX-17.4 no sound

  • This topic has 12 replies, 5 voices, and was last updated Feb 16-12:54 pm by anticapitalista.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #31505
    Member
    AvatarVincent17

    Hello,
    Daughter recently installed antiX 17.4 on an old laptop and she’s very happy with it. However, there is no sound. We have tried many ideas from DDG searches, e.g. and this, without success.

    FWIW, several other distros (incl antiX 17.4 full) from live flash drive also do not have sound on that computer; however Ubuntu did (removed years ago). One can hear a faint “pop pop” from speakers during bootup.

    Much information follows, but I don’t know how to use it 🙁 We’d appreciate any suggestions. The output of aadebug is attached also. Thanks in advance.

    System:
      Host: Hypatia Kernel: 4.9.200-antix.1-486-smp i686 bits: 32 compiler: gcc v: 6.3.0 
      Desktop: Fluxbox 1.3.5 Distro: antiX-17.4.1_386-base Helen Keller 28 March 2019 
      base: Debian GNU/Linux 9 (stretch) 
    Machine:
      Type: Laptop System: ASUSTeK product: M5A v: 1.0 serial: <root required> 
      Mobo: ASUSTeK model: M5A v: 1.0 serial: <root required> BIOS: American Megatrends 
      v: 0205 date: 06/10/2005 
    CPU:
      Single Core: Intel Pentium M type: MCP arch: M Dothan speed: 1729 MHz 
      min/max: 798/1729 MHz 
    Audio:
      Device-1: Intel 82801FB/FBM/FR/FW/FRW High Definition Audio vendor: ASUSTeK 
      driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
      Sound Server: ALSA v: k4.9.200-antix.1-486-smp 
    
    cat /proc/asound/cards
    0 [Intel			]:	HDA-Intel - HDA Intel
    						HDA Intel at 0xfeb38000 irq 24
    lspci -vk| grep -i -A7 audio
    00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 04)
    	Subsystem: ASUSTeK Computer Inc. 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
    	Flags: bus master, fast devsel, latency 0, IRQ 24
    	Memory at feb38000 (64-bit, non-prefetchable) 
    	Capabilities: <access denied>
    	Kernel driver in use: snd_hda_intel
    	Kernel modules: snd_hda_intel
    
    lsmod | grep snd
    snd_hda_codec_hdmi     40960  1
    snd_hda_codec_realtek    69632  1
    snd_hda_codec_generic    65536  1 snd_hda_codec_realtek
    snd_hda_intel          28672  0
    snd_hda_codec          94208  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
    snd_hda_core           53248  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
    snd_hwdep              16384  1 snd_hda_codec
    snd_pcm                86016  4 snd_hda_intel,snd_hda_codec,snd_hda_core,snd_hda_codec_hdmi
    snd_timer              28672  1 snd_pcm
    snd                    57344  7 snd_hda_intel,snd_hwdep,snd_hda_codec,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_pcm
    soundcore              16384  1 snd
    
    aplay -l
    **** List of PLAYBACK Hardware Devices ***
    
    amixer sset Master unmute
    amixer: Unable to find simple control 'Master',0
    amixer controls
    numid=1,iface=CARD,name='Line Out Phantom Jack'
    
    alsamixer
    Card: HDA Intel
    Chip: Realtek ALC880
    This sound device does not have any controls.
    
    speaker-test
    Playback device is default
    Stream parameters are 48000Hz, S16_LE, 1 channels
    Using 16 octaves of pink noise
    Playback open error: -2,No such file or directory
    
    # ls -l /dev/snd
    total 0
    drwxr-xr-x  2 root root       60 Jan  8 20:21 by-path
    crw-rw----+ 1 root audio 116,  2 Jan  8 20:21 controlC0
    crw-rw----+ 1 root audio 116,  3 Jan  8 20:21 hwC0D0
    crw-rw----+ 1 root audio 116,  4 Jan  8 20:21 hwC0D1
    crw-rw----  1 root audio 116,  1 Jan  8 20:21 seq
    crw-rw----+ 1 root audio 116, 33 Jan  8 20:21 timer
    Attachments:
    1. aadebug.txt
    #31672
    Member
    AvatarVincent17

    I guess lack of pcm device in ls /dev/snd means that there is no driver for the very old sound card ALC880. I have found drivers, e.g. at
    touslesdrivers
    configure –with-cards=hda-intel succeeds, but make fails with -Werror=date-time. when this is fixed , make fails with -Werror=implicit-function-declaration (many of them). Drivers from other sources also fail to compile. I’m stumped. 🙁

    EDIT: some progress, maybe.
    1) good old puppylinux-431 has sound on this computer, so no hardware problem.
    2) As suggested here, changed /etc/modprobe.d/alsa to contain the line options snd-hda-intel model=6stack-digout Now aplay -l shows a device, alsamixer has settings and speaker-test proceeds–but still no sound (nothing is muted). I hope someone can suggest the next step.

    • This reply was modified 2 months, 3 weeks ago by Vincent17. Reason: update w/o bump
    #31702
    Member
    capreacaprea

    There are more ways to modify the /etc/modprobe.d/alsa-base.conf for the alc880, I think it depends on the hardware, you have to try which one is right for you.
    http://lxr.linux.no/#linux+v3.2.19/Documentation/sound/alsa/HD-Audio-Models.txt

    #31761
    Member
    AvatarVincent17

    caprea, thank you for that information; I was unaware of module options. I am trying them in combination with others, in other words shooting in the dark. I see that this guy at arch solved a similar problem by adding model=asus and switching to a LTS kernel.

    #31768
    Member
    capreacaprea

    It is always worth a try to change the kernel if hardware is not working properly.
    The package-installer makes it easy, control-centre > system > package installer > kernel

    Maybe you try the 4.19.antix or 4.19.debian
    You can always go back to your old kernel as long as you do not uninstall it.

    If I understand the arch-thread correctly, the model=asus option was not even necessary with the new kernel.

    #31805
    Member
    AvatarVincent17

    Frustrating problem, this. Very large number of web sites consulted, many combinations of snd-hda-intel options tried, NONE give sound. The *stack* model options yield devices so aplay test.wav succeeds, but no sound is heard 🙁

    I’m using a live flash drive, where kernel changes are tedious (D.O. video). I’ll experiment with other kernels when laptop’s owner is around: her install is encrypted.

    Sound is heard through a usb headset (snd-usb-audio module), so purchasing a $10 usb speaker is a backup plan if I don’t find a kernel in which snd-hda-intel works.

    #31806
    Member
    capreacaprea

    Another possibility is to try to install the pulseaudio soundserver and pavucontrol.
    Wouldn’t be the first time that the sound would suddenly appear after doing so.
    After all you have an emergency plan, that’s good, but I have the feeling you are very close.
    The card is not unknown in the web to cause problems.Someone else might come forward with an idea.

    #31807
    Member
    KooKoo

    @Vincent17

    I found a few things.

    (Sorry I don’t use pulseaudio on any system.) 100% alsa Even MX19 loves alsa without apulse too.

    Volume is up. ?

    antixcc.sh > Hardware > all your sound setting are here. I think it is called Control Centre ?

    —————————————————
    Have you tried manualy setting the sound card..

    Set default sound card… Must be done from sudo

    Open alsa mixer with sudo press F6 or S select your card then type sudo alsactl store.

    sudo alsamixer

    sudo alsactl store

    and

    Setting the default device
    Jump to: navigation, search

    Find your desired card with:

    cat /proc/asound/cards

    and then create /etc/asound.conf with following:

    defaults.pcm.card 1
    defaults.ctl.card 1

    Replace “1” with number of your card determined above.
    ———————————————————–

    How do I toggle sound with amixer

    [SOLVED] Can’t unmute using amixer

    Mayhelp

    Asus Driver linux

    Audio driver for ASUS P5GPL
    Audio driver for Linux.
    Realtek ALC880/ALC861 Audio Driver A2.7 for Linux.

    Open Drivers

    Hope you get it sorted.

    • This reply was modified 2 months, 2 weeks ago by Koo.
    • This reply was modified 2 months, 2 weeks ago by Koo.
    • This reply was modified 2 months, 2 weeks ago by Koo.

    MX-19 4.19.0-6-amd6 (i3) : Debian-10 4.19.67-2+deb10u2 (i3) : anitX-19 runit (5.3.14-antix.1-amd64-smp) (i3)
    2 Laps T430 17.2 X220 17.4

    #31814
    Member
    AvatarModdIt

    Hi guys,
    @ koo, thanks, excellent howto.

    Apulse needed though to get sound from Firefox 72.1, Nightly builds and Tor, if used.

    @ caprea, agree, but only if nothing else works, problem is pulseaudio works like a distortion module, sound
    comes out modified. My rather good sound system sounds awful with it. Musicians hate it.

    #31817
    Member
    KooKoo

    @Moddit

    I only use waterfox-classic and just installed brave-browser on MX-19 both sound works just fine with straight alsa and no apulse.

    I’m with you on this one..(My rather good sound system sounds awful with it. Musicians hate it.) Even music lover’s too..

    Thanks for the info..

    • This reply was modified 2 months, 2 weeks ago by Koo.

    MX-19 4.19.0-6-amd6 (i3) : Debian-10 4.19.67-2+deb10u2 (i3) : anitX-19 runit (5.3.14-antix.1-amd64-smp) (i3)
    2 Laps T430 17.2 X220 17.4

    #31819
    Member
    AvatarModdIt

    Inspired by thread I got out my Asus EEPC 1215B. Very different beast, It has never given any
    sound whatsoever with my Frankenstein AntiX mashup.
    @koo, Sound now, with the tiny internal speakers only nuisance value, plug in my Koss Portapro
    headphones, plenty good for travel.

    @Vincent17 you say I’m using a live flash drive, where kernel changes are tedious.

    If your drive is big enough, run live and has full persistence, do all updates then install the new kernel
    follow with remaster. System will then boot with new kernel.
    One of the reasons I use Antix is remaster or create new iso is made so easy compared to other distros I
    have used. Some of those make it more than tedious and extremely time consuming like hours not minutes :-(.

    Hope you have sound on your device now.

    #32787
    Member
    AvatarVincent17

    Thanks for your ideas regarding sound on this very old computer. caprea and Koo, I have tried all your suggestions, but still no success.

    Moddit wrote, “Hope you have sound on your device now.” Yes, we do: I purchased a bluetooth dongle for $5. Since we’re using antiX base, we had to install blueman and pulseaudio from package manager and pulseaudio-module-bluetooth from synaptic.

    On the small chance that this might be useful to someone else, here’s a summary of our unsuccessful efforts to get sound with alsa:
    1) Hardware is ok: sound with Puppylinux (kernel 2.6.30.5). Always checked for muted outputs.
    2) Tried hundreds of combinations of module options for <b>snd-hda-intel</b>, if someone mentioned somewhere that it helped: model, position_fix, enable, enable_msi, probe_mask, single_command, bdl_pos_adj. (One guy said you have to reboot after changing module, not just restart alsa. If that is true, I wasted a lot of time) Only #stack models result in sound card detected, but no sound.
    3) Tried kernels 4.9.160, 4.9.200, “Fallback Debian 4.9 32-bit”, 4.19.25-486 and antiX-16. As caprea noted, a guy at slackware got sound by using an LTS kernel. I would try an old kernel if someone tells me where to find it, but I’d be worried about security for permanent use.
    4) ALC880 driver d.l. from opendrivers, techspot, touslesdrivers, drivers.eu, but each time configure or make failed with errors I don’t know how to fix.
    5) Pulseaudio: graph shows file playing, no sound. Removed after testing.
    6) In a 2007 post at puppylinux , hardware heavy tempestuous wrote

    XMMS [has] a visual display which indicates whether audio is working at the software level. If you see the display working, then you know that the problem is either getting the mixer settings right (with alsamixer) or hardware connections. One of the problems with the snd-hda-intel driver is sending the audio output to the correct physical pin outs on the motherboard, because there are many different motherboard manufacturers who use the Intel HD codec. Because of this problem, the snd-hda-intel driver has been known to send the audio output to the WRONG connection – like the mic input, for example.

    The display is showing sound, so I used <b>hdajackretask</b> to try a bunch of settings: nothing. It seems that maybe something can be done with either hda-verb or hda-analyzer.py, but I’m out of my depth there and have no idea how to proceed. I’m not afraid of breaking anything, thanks to frugal/manual save 😉
    8) web search greatest hits:
    https://wiki.sabayon.org/index.php?title=HOWTO:_Resolve_Problems_with_HDA-Intel_Sound_Cards
    https://docs.slackware.com/howtos:hardware:audio_and_snd-hda-intel
    https://www.mjmwired.net/kernel/Documentation/sound/alsa/HD-Audio-Models.txt “based on kernel version 4.9”
    https://www.mjmwired.net/kernel/Documentation/sound/alsa/HD-Audio.txt

    #32834
    Forum Admin
    anticapitalistaanticapitalista

    Try the antiX 4.4 kernel in the repos.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.