Antix 19.2 ctrl+ alt not working in IceWM with FR keymap

Forum Forums General Hardware Antix 19.2 ctrl+ alt not working in IceWM with FR keymap

Tagged: 

  • This topic has 2 replies, 2 voices, and was last updated Apr 11-1:24 am by stick.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #34553
    Member
    Avatarstick

    Hi,

    I’m using Antix on a number of PC’s now and love it — thanks to the team! Problem is that most of my machines have FR keyboards. On those machines, Crtl+Alt does not behave as intended in IceWM. For example, wingrid shortcuts do not work. Now, I can work around that easily by remapping or using the numpad. The real problem is that some applications need Ctrl+Alt for specific functions. With an FR keymap, with Ctrl+Alt pressed, as soon as one uses a mousebutton, the focus window minimises 🙁 I put “generic 105 key” and then “France” map when configuring the machines ( also tried “France, alt” or other FR-maps, generic 101 key etc. etc. — it does not matter). As soon as I change the keymap to US, or “US with French letters”, Ctrl+Alt works normally again. However this is no solution, since FR keyboards are AZERTY, so very hard to type anything correctly anymore then). Also, changing to Fluxbox or JWM solves the problem as well, but I would really like to get it working in IceWM.
    The state changes due to pressing Ctrl+Alt together do show up in xev.
    Anyone have any idea how to fix this in IceWM?

    #34556
    Moderator
    masinickmasinick

    IceWM respects key modification mappings. I believe that the Help features for IceWM have some explanations; if I’m mistaken, then I recently read them by using a Web search for IceWM setup. If you can’t find it, write back and I’ll see if I can pull it up and directly either reference it or paste the relevant details. For the practice, see if you can find it, and if not, please let us know and we’ll try to give you direct instructions or references.

    Brian Masinick

    #34569
    Member
    Avatarstick

    Hi,
    Had a deep look at the “preferences” and “keys” files in $HOME/.icewm. Did not find any modifier for how IceWM reacts to Ctrl+Alt — this combination is a modifier in itself and cannot be configured? (i.e. there is no way to say “Mod2″=”Alt Gr + Ctrl” instead of “Alt + Ctrl”)? This would help, FR keyboards distinguish between the Left Alt key and the Right Alt key, which is Alt Gr.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.