antiX-19.4 for testers

Forum Forums antiX-development Development antiX-19.4 for testers

  • This topic has 55 replies, 9 voices, and was last updated May 11-6:44 pm by Brian Masinick.
Viewing 15 posts - 1 through 15 (of 56 total)
  • Author
    Posts
  • #58458
    Forum Admin
    anticapitalistaanticapitalista

    I have uploaded a 64bit full version of antiX-19.4.
    This is just to check there are no clangers, before building final versions.
    Get it from here: antiX-19.4

    Please post feedback if there are showstoppers.

    File will be available for 48 hours.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #58464
    Member
    XecureXecure

    Everything seems to work well on a VM. It autoscales, which is nice. Also, very nice to have the newest Control Centre in antiX 19, with the new Software tab.
    Changing to different WM works properly.
    Repos work well, and changing repos works as expected.
    There is a small gtk misconfiguration related to the icon theme (there seems to be a mix between papirus-antix-mini and Adwaita) but nothing that cannot be fixed with LXAppearance. I wouldn’t change it, as it seems to work properly, but others can report their experience.

    I will try installing on VM and report back in a bit.

    EDIT: Installation OK. Everything seems to work as normal. Nothing else to report for now. Tomorrow I will test on USB on real hardaware to test the antix-connect script and how well connman works out of the box.

    • This reply was modified 1 week, 3 days ago by Xecure. Reason: Installed on VM
    #58476
    Member
    Avatarcalciumsodium

    1. The battery status in the .conkyrc file:

    The option that was given in this file:

    Battery: ${battery_percent BAT0}% ${alignr}${color8}${battery_bar 8,70 BAT0} # You may need to change BAT0 to BAT1 or add the same line again if you have more then one battery.

    did not work on my laptop. It keeps saying Battery: 0%

    What worked for me was the code found in antiX 19.1:

    ${execi 1000 acpi 2>/dev/null | grep -q . && echo “Battery: “}${execi 10 acpi -b 2>/dev/null | cut -d” ” -f3,4 | sed ‘s/,$//’}

    I added this code to the .conkyrc file and it worked. Perhaps give the user this option as well to check battery status?

    2. Thank you for removing the faulty “Default” option for Themes in the menu that was present in antiX 19.3, and antiX bullseye a2-full and a2-runit.

    3. I noticed that the kernel is 4.9.0-264. A thought is to make it consist with the naming of the 5.10.X series as well. For example in the anti21 series, include 5.10.0-27 instead of 5.10.27 kernel. Just a thought.

    #58477
    Moderator
    christophechristophe

    Running from live-usb.

    Connman comes up with wifi enabled on first boot, like the a21-a2, attempting to connect — nice.

    Still get the rox pinboard error – no pinboard in use — I would like to see that error message hidden, personally (no pun intended). I figure a new user doesn’t need nor want to see it. It may well alarm them. (But it’s not a new thing, I know.)

    Everything is looking good!

    • This reply was modified 1 week, 3 days ago by christophe.
    • This reply was modified 1 week, 3 days ago by christophe.
    #58480
    Moderator
    christophechristophe

    Testing as frugal from hdd.

    Everything is smooth & fast!

    #58481
    Member
    Avatarskidoo

    The “set font szie DPI” brings an unexpected result ~~ control panel skin becomes generic and several buttons on the Desktop tab (and elsewhere within ControlCenter) disappear

    I’m guessing it should (it just needs to) drop elevated permissions before returning
    ,

    #58482
    Member
    Avatarskidoo

    ControlCenter } System } alternatives configurator (/usr/bin/galternatives)

    User has no “control”, because it is launched without elevated permissions.
    Attempting to apply any change brings a nonsensical error dialog (“your system may already be in an unstable state”)

    #58483
    Member
    Avatarskidoo

    As explained previously,
    (for some of the scripted utilities will go off the rails if “su” mode is in effect)
    this item should be removed.

    ControlCenter } Session } password prompt (/usr/bin/gksu-properties)

    #58485
    Moderator
    Brian MasinickBrian Masinick

    I’m here on a Dell Inspiron 5558 laptop running antiX 19.4 from USB.

    I’ve already added several of the apps I currently have on my installed instance to this USB and I’ve remastered it.

    I’ll try rebooting it next. If successful I’ll install it over 19.3 and then investigate reported issues to see if I also experience them. As far as the simple load, it works.

    Only issue I saw booting from the initial USB was the need to boot in failsafe mode (something I’ve had to do recently with several distributions).

    Brian Masinick

    #58486
    Member
    Avatarskidoo

    ControlCenter } Live } Edit Exclude files

    iso-snapshot-exclude.list
    gitlab indicates the merge request had been accepted for the expanded list…
    but it is still not present on this “all packages up to date” release.
    https://gitlab.com/antiX-Linux/iso-snapshot-antix/-/blob/master/iso-snapshot-exclude.list

    Line 1 of the installed iso-snapshot-exclude.list still, incorrectly, states:
    rsync excludes file for iso-snapshot

    (iso-snapshot utilizes mksquashfs, not rsync, and mksquashfs intreprets globbing patterns differently)

    #58487
    Member
    Avatarskidoo

    .

    #58488
    Moderator
    Brian MasinickBrian Masinick

    ControlCenter } System } alternatives configurator (/usr/bin/galternatives)

    User has no “control”, because it is launched without elevated permissions.
    Attempting to apply any change brings a nonsensical error dialog (“your system may already be in an unstable state”)

    I am seeing the same issue.

    Brian Masinick

    #58489
    Moderator
    Brian MasinickBrian Masinick

    Installed over antiX 19.3 with the new 19.4. The installation itself completed successfully.

    USB has to reboot failsafe; hard drive installation can be booted normally.

    Issues reported by skidoo can be reproduced on both USB and installed instances.

    Brian Masinick

    #58501
    Forum Admin
    anticapitalistaanticapitalista

    .

    If you Continue, it loads the site.
    Only Dillo shows this, wonder why?

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #58507
    Member
    AvatarPPC

    @skidoo- I’ve noticed the exact same error message in my antiX 19.3 for ages… I’ve always thought it was due to Dillo not recognizing the certificate format, or some similar bug… I’ve always assumed Dillo is ancient and does not recognize lots of stuff that were updated since it’s last version came out, but I never checked that out…

    Edit: Dillo’s last version is some 7 years old, and I also found this in duckduckgo:

    How to easily fix Apache serving old SSL certificate?


    “Browsers often cache website SSL certs. We often see this as a common reason for showing up the old certificates. When the new certificate is not updated in the browser, visitors will see the old expired certificate. ”
    Maybe Dillo has an old antixforum.com certificate cached?

    Edit 2:
    I tried clearing ~/.dillo and running dillo again, using the terminal, to check out is it had some old certificate stored there. when I opened antixforum.com, I got this warning in the terminal (as always, if I click to open the page, it opens normally):

    Nav_open_url: new url='https://www.antixforum.com/'
    a_Nav_expect_done: repush!
    ** WARNING **: Ignoring unsafe author style that might reveal browsing history

    Edit 3 (and final edit):
    https://unix.stackexchange.com/questions/324692/how-to-fix-dillo-https-missing-issuer-certificate

    It is stated that this is some kind of problem with the latest Dillo’s version, that did not happen in the previous one. Also, a “fix” is suggested there…

    P.

    • This reply was modified 1 week, 2 days ago by PPC.
    • This reply was modified 1 week, 2 days ago by PPC.
    • This reply was modified 1 week, 2 days ago by PPC.
Viewing 15 posts - 1 through 15 (of 56 total)
  • You must be logged in to reply to this topic.