[SOLVED] AntiX 19 – Assessment Summary

  • This topic has 14 replies, 4 voices, and was last updated Jun 4-1:50 am by Xecure.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #29065
    Member
    olsztyn

    Relative to me experience with antiX 19 is that it is solid and polished with many enhancements implemented and aesthetics (fonts!) vastly improved. The only bugs relevant to me that I encountered were:
    – Encrypted antiX Live did not work because of boot partition assignment and encryption protocol (luks 2). This was fixed with luks 1 specification (Thank you BitJam!).
    – On some of my laptops (particularly ones with nVidia chips such as T410) drop-down menu selection in Chromium/Chrome do not work in Fluxbox (my choice of DM). As they work fine with IceWM I assume this is some bug in Fluxbox, not in antiX 19, though strangely this is not occurring in antiX 17…
    As I have read other reports of issues and their resolutions it seemed to me that there no (non-political) antiX bugs left that are considered significant and general across multiple hardware…
    I would appreciate if someone could correct me on the above statement, pointing me to any significant issues discovered I missed and hopefully in pipeline for resolution. I apologize if such list already exists and I failed to find it…
    Again, many thanks to antiX developers for such near-perfect Linux implementation…
    Best Regards.

    • This topic was modified 1 year, 7 months ago by Brian Masinick. Reason: Issue solved
    #29097
    Member
    skidoo
    Helpful
    Up
    0
    ::

    drop-down menu selection in Chromium/Chrome do not work in Fluxbox

    A window manager paints the titlebar and, optionally, the bounding border surrounding an application window.
    A window manager has zero influence regarding what gets painted within the application window.

    suggestion: Try choosing an alternate GTK theme (via lxappearance), then launch the browser and recheck the appearance of the “drop-down menu selection”

    pointing me to any significant issues discovered

    Wheeeee…
    I suppose you don’t realize this comes across as
    I don’t have time to read the announcements and skim the forum posts, so please collate and regurgitate all salient details for my easy consumption.

    “if such list already exists”
    If a “list” exists, I haven’t seen it.
    One by one, as issues have been reported, updated packages have been released.
    If your system is fully up-to-date, an “already-fixed” list would probably be moot, eh.

    edited to add:
    maybe you were looking for the “bugtracker” list, linked from the antiforum.com homepage?
    buglist.cgi?bug_status=__all__…&product=antiX%20Linux

    • This reply was modified 2 years, 2 months ago by skidoo.
    #29139
    Member
    olsztyn
    Helpful
    Up
    0
    ::

    maybe you were looking for the “bugtracker” list,

    Thanks skiddo. Bugtracker is good enough for me. I apologize I failed to come across it. I did not mean asking that someone puts together any special list other than that.

    A window manager paints the titlebar and, optionally, the bounding border surrounding an application window.
    A window manager has zero influence regarding what gets painted within the application window.

    Just for the record, it is not about what gets painted. Menu items show fine. It is that clicking on drop down menu items does nothing in Fluxbox but works fine in IceWM, particularly on hardware furnished with nVidia.
    I can live with this, of course, e.g. on such laptops I can switch Fluxbox to IceWM, so I am not asking to find a solution, thus wasting precious time of antiX team. It does not seem to have been reported by anyone else so must be not important…
    Thanks again and Regards…

    #29145
    Member
    skidoo
    Helpful
    Up
    0
    ::

    It is that clicking on drop down menu items does nothing

    Aha, I am able to reproduce what you are describing.
    I installed chromium and browsed to antixforum.com and switched between iceWM and fluxbox.

    Forum dropdown
    – Recent posts
    – Latest topics

    During fluxbox session, mouse left-click while hovering e.g. Latest topics “does nothing”.
    Can workaround by right-clicking while hovering and choose Open in a new tab… but that’s not a solution.

    Actually, some of the time, even when under iceWM… the mouse clicks while hovering seemed to be ignored during my testing.

    Upon examining the ~/.fluxbox/keys file, I didn’t find any “OnWindow…” keybinds which could be trapping that mouseclick event. Not a chromium user, but I skimmed through its “Settings” and toggled various items, but didn’t find any changes that fixed the onHover misbehavior.

    Thanks to your post, at least I was able confirm & future readers will be aware that this is a “Known Issue”

    #29147
    Member
    olsztyn
    Helpful
    Up
    0
    ::

    Thanks skidoo for confirming this through your testing.
    Just to mention, this was working for me in antiX 17 across all my laptops… On antiX 19 it seems to work on Thinkpad X61 I am typing now but not on various other laptops, strangely as it is…
    Regards.

    #36572
    Member
    olsztyn
    Helpful
    Up
    0
    ::

    Aha, I am able to reproduce what you are describing.
    I installed chromium and browsed to antixforum.com and switched between iceWM and fluxbox.

    Forum dropdown
    – Recent posts
    – Latest topics

    During fluxbox session, mouse left-click while hovering e.g. Latest topics “does nothing”.
    Can workaround by right-clicking while hovering and choose Open in a new tab… but that’s not a solution.

    Actually, some of the time, even when under iceWM… the mouse clicks while hovering seemed to be ignored during my testing.

    Upon examining the ~/.fluxbox/keys file, I didn’t find any “OnWindow…” keybinds which could be trapping that mouseclick event. Not a chromium user, but I skimmed through its “Settings” and toggled various items, but didn’t find any changes that fixed the onHover misbehavior.

    Thanks to your post, at least I was able confirm & future readers will be aware that this is a “Known Issue”

    Sorry to report but in result of some very recent updates of antiX 19.2 Hannie Schaft it appears that this problem (confirmed by skidoo as above) reappeared.
    As I was doing frequent updates via antiX updater I am not able to pinpoint exactly which updates caused this to be reverted to not working again.
    This teaches me again to refrain from indiscriminate updates of antiX without thorough testing…
    Thanks for your attention…

    #36578
    Member
    Xecure
    Helpful
    Up
    0
    ::

    Could you check your apt history log (/var/log/apt/history.log) and see what programs have been updated lately? I believe someone mentioned in the forum that you can use aptitude to go back to a previous package (downgrade). See if it was a chrome/chromium update, a library update, or something suspicious. It may be too much work for you right now, so look at the dates, try to remember last time you used chrome and this didn’t happen, and save a file listing all updates during that range of time. Maybe it can help in the future for yourself or if someone else reports this problem you can figure this out between you.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #36579
    Member
    olsztyn
    Helpful
    Up
    0
    ::

    Thanks Xecure for the suggestions. I will try to do this tracing of the antiX update that caused reverting to this defect as soon as I can. I just realized that may not be exactly recent as this defect did not seem to happen on all laptops and having multiple laptops I recently happened to work on the ones where it works fine.
    As this defect happens to me on Fluxbox but does not happen on IceWM (although skidoo reported this happening for him on IceWM too) I may need to resort to using IceWM in the interim.
    In trying to track down when this defect was re-introduced I will try to dig out the original antiX 19.2 ISO (not the 19.2.1, which seems to already exhibit this problem from my testing I just performed).
    In any case thanks and Regards.

    #36593
    Member
    olsztyn
    Helpful
    Up
    0
    ::

    Could you check your apt history log (/var/log/apt/history.log) and see what programs have been updated lately? I believe someone mentioned in the forum that you can use aptitude to go back to a previous package (downgrade). See if it was a chrome/chromium update, a library update, or something suspicious.

    Thanks again Xecure for suggestions…
    I spent lots of time today trying to track at what point of antiX updates this problem resurfaced and so far I can only narrow down to a wide window timeline:
    – This defect was noticed after installation of antiX 19. Reported in this thread at the beginning – Nov. 2019.
    – I remember that after confirmation by skidoo it still took a long time before it was eventually fixed – to my pleasant surprise as I already lost any hope it was paid any attention…
    – I remember it was still working with installation of Hannie Schaft as I was testing with multiple laptops and using Hannie Schaft often clicking on dropdown menus, such as ‘Current Posts’ on antiX forum as an example…
    – Various updates followed, where some resulted in discovery of other issues and suddenly noticed dropdown menus were not working anymore…

    Now, to set my expectations:
    – Considering it took long time before I saw this problem fixed in antiX 19 I understand it is probably not a priority on antiX plate, particularly that it affects only Fluxbox (although skidoo reported experiencing this in IceWM too). From my own experience this does not work in Fluxbox but does work so far in IceWM. On top of the fact that Fluxbox users appear to be a minority and this problem seems to be for Chromium/Chrome, such minority of users would not make attention to this problem of much importance.
    – As I like solid and predictable operation of antiX it leaves me little choice but to move from Fluxbox to IceWM until this problem gets resolved some time in the future. This is regrettable particularly considering that hardware volume buttons problem on Fluxbox just got fixed thanks to syntax change in Fluxbox config file developed by BobC. Thanks again BobC and Xecure!

    In a word, now being forced to IceWM I can live with this workaround until defect resolved in the future…
    Thanks again and Regards…

    #36599
    Forum Admin
    anticapitalista
    Helpful
    Up
    0
    ::

    It is not a question of priority, but I cannot reproduce this chrome bug.
    antiX-19-full 64 bit and 32 bit fully updated (frugal).
    No issues with latest chrome.
    Tried fluxbox, Rox-fluxbox, Space-fluxbox and min-fluxbox.
    I don’t have nvidia card though.

    Can anyone else reproduce this bug?

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #36723
    Member
    Xecure
    Helpful
    Up
    0
    ::

    I have tried to test this on every one of my systems and failed to reproduce this issue.
    I believe this is related to your hardware, but I also believe there is a workaround in the chrome://settings and chrome://flags tabs.
    Enter the chrome://flags tab and disable the option named “GPU rasterization” (you can search for it using the search box at the top). Restart chrome.
    If this doesn’t work, try disabling “Use hardware acceleration when available” in chrome://settings (search for it at the top) and restart chrome.
    This issue has propped up in chrome many times, if you search the webs for black drop down box chrome linux The “solution” isn’t the best, as some webpages will slow down.

    I will try asking for a friend to lend me their laptop with nvidia card, but don’t expect too much.

    • This reply was modified 1 year, 7 months ago by Xecure. Reason: fix spelling

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #36733
    Member
    olsztyn
    Helpful
    Up
    0
    ::

    I believe this is related to your hardware, but I also believe there is a workaround in the chrome://settings and chrome://flags tabs.

    Yes. This defect happens on some of my laptops furnished with nVidia. Particularly two – Thinkpad T410, nVidia version. I will re-test fresh on Intel based but I remember from my experience back in November it was not happening there.
    I tried both options, turning off these flags. No difference.

    However I want to be understood:
    – As I expected, looking for fault in Chromium or Chrome is not the right path. The main reason is that the same Chromium or Chrome works fine with dropdown menus when using IceWM. I understand skidoo reported it happened to him but in my experience not a single occurrence of such failure on IceWM while on Fluxbox it happens every time. My testing ground is antixforum.com, where clicking on Recent Posts or any other dropdown in any tab, or any other site, does nothing on Chrome in Fluxbox but works perfectly in IceWM. Chrome settings are exactly the same, with no need to turn off Rasterization of accelleration.
    – My understanding is that Fluxbox is not maintained in term of active development anymore (neither is IceWM). Both are ‘stabilized’ past legacy. Therefore I do not ask that someone will waste any time to identify root cause and perhaps fix it. More reasonable path is to try to use IceWM, as long as it somewhat works, and put up with its own share of bugs and quirks, if they are not too annoying…
    Thanks again and Regards…

    #36744
    Forum Admin
    anticapitalista
    Helpful
    Up
    0
    ::

    I saw this on the Internet. Might work, might not. Can you try opening chrome in a terminal with the following.

    google-chrome --disable-features=SendMouseLeaveEvents

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #36753
    Member
    olsztyn
    Helpful
    Up
    0
    ::

    google-chrome –disable-features=SendMouseLeaveEvents

    That’s it, it worked!. So does this mean IceWM starts Chrome with disabling this event in similar manner or perhaps there is a setting somewhere on Fluxbox to change?…

    Just re-tested. Out of my nine test laptops this problem occurs just on Thinkpad T410 nVidia version (tested on two laptops of this model to make sure hardware is not accidentally defective). The other seven test laptops do not seem to exhibit this problem on Fluxbox. None has this problem on IceWM.
    Tested using the same USB stick, to ensure the same antiX environment:

    T520 nVidia graphics 1920×1200 – two laptops – Works fine on both.
    T410 nVidia graphics 1440×900 – two laptops – Fails on both every time to recognize clicks on dropdown menus.
    T410 Intel graphics 1440×900 – one laptop – Works fine.
    x220 (Intel graphics) 1366×768 – one laptop – Works fine.
    xX61 (Intel graphics) 1024×768 – two laptops – Works fine.
    Z61P (Radeon graphics) 1920×1200 – one laptop – Works fine.

    This same USB stick booted to IceWM desktop worked fine on all these nine laptops.
    Again, this is an issue that affects just me. So please do not waste additional time for such trivial minority of users. If there is a setting somewhere in Fluxbox I will try to figure this out…
    Thanks and Regards…

    #36780
    Member
    Xecure
    Helpful
    Up
    0
    ::

    Good thing anticapitalista found a way. I was really burnt out trying to install nvidia drivers on a live system. nouveau worked well and I couldn’t replicate the bug on a nvidia based laptop using nouveau, and trying to test it with nvidia drivers was too complicated for me.

    Another problem solved. Well done to both, olsztyn for keeping hope and patiently testing on every one of your devices, and anticapitalista for not giving up and finding a solution.

    (Crazy theory) Probably the difference between fluxbox and iceWM is that fluxbox has more interaction inside fluxbox windows than iceWM and is always ready to send/receive Mouse and keyboard events, which may interfere with how the program inside the window works. No real idea, just saying crazy things about something I don’t even understand.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.