AntiX 19 – Assessment Summary

Forum Forums Official Releases antiX-19 “Marielle Franco” AntiX 19 – Assessment Summary

This topic contains 4 replies, has 2 voices, and was last updated by olsztyn Nov 8-11:31 am.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #29065
    Member
    Avatar
    olsztyn

    Relative to me experience with antiX 19 is that it is solid and polished with many enhancements implemented and aesthetics (fonts!) vastly improved. The only bugs relevant to me that I encountered were:
    – Encrypted antiX Live did not work because of boot partition assignment and encryption protocol (luks 2). This was fixed with luks 1 specification (Thank you BitJam!).
    – On some of my laptops (particularly ones with nVidia chips such as T410) drop-down menu selection in Chromium/Chrome do not work in Fluxbox (my choice of DM). As they work fine with IceWM I assume this is some bug in Fluxbox, not in antiX 19, though strangely this is not occurring in antiX 17…
    As I have read other reports of issues and their resolutions it seemed to me that there no (non-political) antiX bugs left that are considered significant and general across multiple hardware…
    I would appreciate if someone could correct me on the above statement, pointing me to any significant issues discovered I missed and hopefully in pipeline for resolution. I apologize if such list already exists and I failed to find it…
    Again, many thanks to antiX developers for such near-perfect Linux implementation…
    Best Regards.

    #29097
    Member
    Avatar
    skidoo

    drop-down menu selection in Chromium/Chrome do not work in Fluxbox

    A window manager paints the titlebar and, optionally, the bounding border surrounding an application window.
    A window manager has zero influence regarding what gets painted within the application window.

    suggestion: Try choosing an alternate GTK theme (via lxappearance), then launch the browser and recheck the appearance of the “drop-down menu selection”

    pointing me to any significant issues discovered

    Wheeeee…
    I suppose you don’t realize this comes across as
    I don’t have time to read the announcements and skim the forum posts, so please collate and regurgitate all salient details for my easy consumption.

    “if such list already exists”
    If a “list” exists, I haven’t seen it.
    One by one, as issues have been reported, updated packages have been released.
    If your system is fully up-to-date, an “already-fixed” list would probably be moot, eh.

    edited to add:
    maybe you were looking for the “bugtracker” list, linked from the antiforum.com homepage?
    buglist.cgi?bug_status=__all__…&product=antiX%20Linux

    • This reply was modified 6 days, 13 hours ago by skidoo.
    #29139
    Member
    Avatar
    olsztyn

    maybe you were looking for the “bugtracker” list,

    Thanks skiddo. Bugtracker is good enough for me. I apologize I failed to come across it. I did not mean asking that someone puts together any special list other than that.

    A window manager paints the titlebar and, optionally, the bounding border surrounding an application window.
    A window manager has zero influence regarding what gets painted within the application window.

    Just for the record, it is not about what gets painted. Menu items show fine. It is that clicking on drop down menu items does nothing in Fluxbox but works fine in IceWM, particularly on hardware furnished with nVidia.
    I can live with this, of course, e.g. on such laptops I can switch Fluxbox to IceWM, so I am not asking to find a solution, thus wasting precious time of antiX team. It does not seem to have been reported by anyone else so must be not important…
    Thanks again and Regards…

    #29145
    Member
    Avatar
    skidoo

    It is that clicking on drop down menu items does nothing

    Aha, I am able to reproduce what you are describing.
    I installed chromium and browsed to antixforum.com and switched between iceWM and fluxbox.

    Forum dropdown
    – Recent posts
    – Latest topics

    During fluxbox session, mouse left-click while hovering e.g. Latest topics “does nothing”.
    Can workaround by right-clicking while hovering and choose Open in a new tab… but that’s not a solution.

    Actually, some of the time, even when under iceWM… the mouse clicks while hovering seemed to be ignored during my testing.

    Upon examining the ~/.fluxbox/keys file, I didn’t find any “OnWindow…” keybinds which could be trapping that mouseclick event. Not a chromium user, but I skimmed through its “Settings” and toggled various items, but didn’t find any changes that fixed the onHover misbehavior.

    Thanks to your post, at least I was able confirm & future readers will be aware that this is a “Known Issue”

    #29147
    Member
    Avatar
    olsztyn

    Thanks skidoo for confirming this through your testing.
    Just to mention, this was working for me in antiX 17 across all my laptops… On antiX 19 it seems to work on Thinkpad X61 I am typing now but not on various other laptops, strangely as it is…
    Regards.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.