antiX-19-b2-full (64 and 32 bit) available

Forum Forums News Announcements antiX-19-b2-full (64 and 32 bit) available

  • This topic has 205 replies, 24 voices, and was last updated Aug 21-4:47 pm by rej.
Viewing 15 posts - 166 through 180 (of 206 total)
  • Author
    Posts
  • #25490
    Member
    christophechristophe

    @masinick – that’s right! I’m so thankful for all that antiX is & does!

    @BobC – yep, that dynamic drives shortcut looks very cool.

    @NoClue – I love the antiX 19 script wallpaper. Also the “ant-iX” artwork! Please post the ant-iX “plain” without the conky, etc. I want to use it! (I’ve always thought of antiX to be like an ant – way more powerful than it’s size. I just think it’s so appropriate.)

    #25523
    AvatarAnonymous

    @christophe

    It’s a reworked ‘apache ant / ant quad’ logo, made to suit ant-iX.

    #25530
    Member
    ileile

    now beta … next is antiXXIX
    (i hope that does not offend anyone pro antiRoman.)
    machine switched to 4.9.186-amd64 all is wonderful.

    #25543
    Member
    rayluorayluo

    Not sure whether this is a bug of antiX 19 b2…

    I tried home persistence today.

    1. The GUI provides a list of size options starting from as small as 5MB. So I played with it first. In next reboot, antiX 19 b2 successfully loaded my homefs and my personal settings were indeed persisted. Great.
    2. Now I want to resize the homefs to a bigger size. The “Set up persistence” GUI tool worked fine and created a bigger homefs.new for me and even automatically copied content from my existing smaller homefs into the homefs.new. So far so good.
    3. However, after reboot, I’m still using the old small homefs, and the homefs.new does not exist somehow has been renamed into homefs.bad. What went wrong?
    4. If I go ahead to redo step 2, and then open my file manager, and manually rename existing smaller homefs to another name, and then rename the homefs.new into homefs, now next reboot will pick up my newly enlarged homefs. But that isn’t supposed to be the right way to use home persistence, is it?

    I did notice that, right when I click and run the “Set up persistence” GUI tool, antiX did ask me to type the current account password. Given that I did NOT use root persistence for now, could that be the reason that the home persistence setting was not saved? But then again, home persistence is not supposed to depend on a root persistence to work, is it?

    By the way, I also noticed that, my homefs tend to be quickly occupied, even after I enlarged it again and again. Are those data really my precious settings (like ~/.vimrc ~/.bashrc etc.), or was it bloated by the browser cache content? UPDATE: They are indeed mostly occupied by /home/.cache/mozilla/firefox and I’ll configure Firefox to move its cache into /tmp.

    • This reply was modified 4 months ago by rayluo.
    • This reply was modified 4 months ago by rayluo.
    • This reply was modified 4 months ago by rayluo.
    #25613
    Forum Admin
    anticapitalistaanticapitalista

    Has anyone tried to install (not frugal) beta2 to a usb device?

    Philosophers have interpreted the world in many ways; the point is to change it.

    #25614
    Member
    christophechristophe

    Trying to install to USB device (8GB stick) right now. (from desktop icon).
    Formatting partition failed, but after error popup, the installer continued.
    It allowed me to continue all parts of installer , but it still is stalled at “formatting the / (root) partition 2%.”
    Killed window & tried again. Failed again, exactly the same.

    Trying cli-installer. Appears to have worked without a problem. Rebooting now & will edit once I can sign back in…

    Yes. cli-installer works perfectly.

    (19.b2, 32-bit.)

    • This reply was modified 4 months ago by christophe.
    • This reply was modified 4 months ago by christophe.
    #25619
    Moderator
    masinickmasinick

    I have put the image directly on USB and run live from USB and I have installed to a hard drive from USB, but I do not recall installing to a USB device as the output or destination drive.

    • This reply was modified 4 months ago by masinick.

    Brian Masinick

    #25638
    Member
    ileile

    Hello anticapitalista
    You asked “tried to install (not frugal) beta2 to a usb device?”

    Yes. got one. , but now I know why You asked. , because of many failures.
    christophe had 32bit success with the cli installer, so I stuck with the antix-installer-gui for trials.
    it was not a clean target; it had a mx install, not live, install on it. usb2 16G.
    A antix-installer update was anticipated so started off with a fresh antix19.b2_x64-full live usb with persistence. No upgrade of the installer was necessary. it had 1.0.9 present. Noticed a cli upgrade that i did not put on. no upgrades done on the fresh live b2_x64 iso.
    Began trials of installs each time selecting entire device option. failed. it would each time create partitions and stop at formatting them. 1%, 2%, 3%.
    Tried a live installer that was created with dd. no different. installs to entire device failed. went back to the persistent live usb to continue trials.
    At each failure I would open gparted and try to create a single partition formatted ext2 by erasing the ext4/12.1G and erasing swap/2G failed partitions. Then tried different varied formats of the single partition. ext4. no . then varied, different formats of the two partitions. fails. Selected custom partitions pointing at the partitions for root and swap failed.
    I removed the package antix-goodies, uninstall. trial install not to entire, but selected the single 14.1 partition and “noswap.” IT Installed. it booted. the partition scheme was 12.1G ext4 plus 2.0Gext4; the 2.0G contained the lost+found and showed as /media/demo. That is not what is desired for the installation (and demo was not the home user name.) Tried again with custom using swap pointing at existing partitions failed. tried again with noswap two partitions failed. noswap to single partition failed.
    back to trying entire some more. formatted it again and again. put a 1M btrfs at beginning and the rest ext2. selected entire device. it installed. that one would not boot. many trials with partitioning and formatting. about one hundred trys in all. all stop right away at beginning fail.
    set a 1M ext2 at front and the rest ext4, hit the entire device button, suddenly it worked that time.
    I switched the kernel to 4.9.186. installed all upgrades including putting back install antix-goodies.
    It is the working proper install that is desired [desired on the first try though] with 12.88G ext4 partition and 2.0G linux-swap partition.

    Machine was still running antix19.a2_64 installed to usb2-32G. and i fell out of the trials. I like the alpha a lot. Alpha has been on every day since release. Now the machine has also the antix19.b2_64 installed to usb2-16G to trial. a fresh install.
    In the middle of the trials it seemed like having any swap partition present just killed it. The only success was without a swap partiton present. The trials got beyond notes; too numerous. Not sure why it worked when it did decide to succeed.

    Thank you for the rox panel visibility fix.

    edit: Ongoing. Yes. got another One. second one.
    booted live fresh persistent b2_64 device.
    Opened NEW fresh out of the package usb2-32G.
    No prep. on new usb. installer gui. select install to entire device.
    installed first time flawless.
    That means only a third usb will establish result.
    The first usb may be fault. will publish after a third usb trial.

    #25647
    Member
    christophechristophe

    Thank you for the rox panel visibility fix.

    +1

    #25668
    Member
    ileile

    Hello anticapitalista
    19.b2_64 install target usb number three usb2-16G. attempts with use entire device.
    This one failed many times. Single partition ext2 it installed , but no boot. It made me question had the correct target for MBR been selected. maybe my mistake.
    Many more failures, same thing twice not working, then single partition ext4 it installs. No boot.
    Many failed attempts using the fresh b2 live media described. fail. using the dd media described. failures. recreated live with rufus as iso [not dd] failures. recreated using live-usb-maker not setting persistence this time. failures.
    Done. Failed. no success with usb third.

    19.b2_64 install target number four usb2-8G.
    using installer the dd one.
    Format single partition ext2 used custom noswap (only 7G drive here) pointing to the one partition.
    Installed. success. It boots.
    The partition scheme is /sda1 6.24ext4 and /sda2 1.0fat32 and 31.72M unallocated.
    The sda2 1.0fat32 information says Status: Mounted on /media/sdb2
    There is no /sdb
    Works, but flawed, then.

    #25687
    Forum Admin
    dolphin_oracledolphin_oracle

    for those installing to USB that fails, please post the /var/log/minstall.log file. thanks!

    if its failing during format/partitioning, please try disabling the automount utility before installing. also, please verify what desktop is in use.

    • This reply was modified 4 months ago by dolphin_oracle.
    • This reply was modified 4 months ago by dolphin_oracle.
    #25705
    Member
    ileile

    Hello anticapitalista and dolphin_oracle
    Ongoing install to usb. The minstall logs were lost when rewriting the live usb. You got me there.
    New day. Used the usb number one successful 19.b2 installed to usb with kernel 4.9.186 fully upgraded for a snapshot. live-usb-maker new installer. antix-installer-gui to entire device, target usb2-16G. failed. that will put that onto the minstall log.
    Then went to automount settings to uncheck the box. apply.
    antix-installer-gui to entire device usb2-16G (this is the usb number three that failed in previous post)
    The installer carried through without fail. it no boot. it is not seen. No chance for boot. Have minstall log of the fail and the success that is not seen for booting. Same as the two previous installer completion with this usb not seen for booting result. Is it unfair that I used the third usb that always failed? importantly it failed for a different reason than the formatting fail that was consistent but discovered by dolphin_oracle.
    The immediate failure was not experienced after disabling automount.
    fluxbox. usb flash day today. no hdd involved in all this.
    I have stared at this installer for days now that when i look at the wallpaper “lines” all i see is progress bars. Like the lines should have printed on them “100%” in white text somewhere.
    Hope the logs help somehow. dolphin_oracle was right about the automount.
    It is the best installer in the business. You will figure this out.
    .(In the log the first fail end 11:06:12, then next install starts )
    adding comment: installer “services” the bluetooth service was uncheck the box … does it look that way in the log?

    Attachments:
    1. domin.txt
    #25710
    Member
    christophechristophe

    Retried minstall in Rox-Icewm:
    Disabling automount at the boot menu fixed it — installs & boots as expected.
    (I tried to save the failed attempt’s minstall.log, but… I copied it to ~/Documents WITHOUT persistence, so I lost it. I can redo if that’s valuable to you.)

    • This reply was modified 4 months ago by christophe.
    #25714
    Member
    Avatarrej

    Xecure –

    Hopefully some of these bugs are only related to having XFCE installed.

    Thanks -Just found your post.

    In AntiX 17, there were no problems with using Xfce, IceWM and Fluxbox.

    In AntiX 19 Beta2 Xfce runs very nicely (except for Rox-filer text files and clock).

    I fresh installed AntiX 19 Beta2 [8-11-2019] on another computer with only IceWM and all the same issues are present.

    What solved Rox-panel visability for me is:

    Right click panel-Rox-Filer – Options – Compatibility – uncheck-“Override window manager control of the pinboard and panels”, whether the installation with Xfce installed or IceWM alone.
    ______________________________
    AntiX 19 B2 running quite well in Xfce, Fluxbox and IceWM on various ThinkPads with a few small finds.

    Present issues found [8-12-2019]:

    Rox-filer and SpaceFM: text files that have been added to folders in “Home” have gear icons – SpaceFM opens properly when clicked. Rox-Filer – just left clicking does nothing, must right click for menu and manually select an application to open.

    Thunar file manager in Xfce or IceWM displays the text files as text documents as it should and opens as expected.
    ———————
    Rox-filer not holding display settings for icon size.
    ———————
    “Preferences” selected or un-selected in the main IceWM menu return to default after setting and logging out.

    Preferences edited through CC-Desktop “edit IceWM Settings” remain set.
    ———————
    IceWM and Fluxbox – After a recent update, custom wallpaper from Home “pictures” folder disappeared and went solid grey. After attempting to re-set it, an error came up indicating it cannot locate the file it is in.

    “Error loading backdrop image:
    Failed to open file””.No such file or directory
    Backdrop removed.”

    Tried dropping custom pictures into usr/share/wallpaper then selecting from CC – result was grey wallpaper, with same error box. They are .png files.

    In the installation with IceWM only, Conky background still has the custom wallpaper image and the rest of the desktop is solid grey.
    ————————
    Cannot use F1 on logout from IceWM to access Xfce – error box comes up “Failed to execute command”.

    Can use “Other Desktops” to get to Xfce only. Which does not work in reverse.
    ————————
    Taskbar (panel) clock holds settings in Xfce, not in IceWM and Fluxbox. It randomly changed to “24hr” and there does not seem to be any option for 12hr in “preferences” or the clock GUI. Looked for an entry in CC-Edit IceWM Settings-preferences and cannot find it, if it is there.

    Note: Clock in Debian 10 Buster complete with configurations same as antiX 19 [installed on same device to determine whether the same behavior is present] also has issues with disappearing from the panel and time configuration, yet maintains “Local time”. Removed it and installed Orage, which works fine.

    Installed Orage in antiX 19 and is set to “localtime” in Xfce4/.config, yet does not reflect that. Otherwise Orage runs fine.

    IceWM also does not stay set on Local time in either panel clock. No option for Local time in CC – System – Set Date and Time.
    ———————-
    Some antiX programs do not have icons.

    • This reply was modified 4 months ago by rej.
    #25727
    Forum Admin
    dolphin_oracledolphin_oracle

    Ok, I’m looking at making some modifications to the installer right now to deal with a strange issue with partitions greater than 15 anyway, so I’ll see about adding something to deal with the automounting.

Viewing 15 posts - 166 through 180 (of 206 total)
  • You must be logged in to reply to this topic.