antiX-19-b3-full and base versions (64 and 32 bit) available

Forum Forums News Announcements antiX-19-b3-full and base versions (64 and 32 bit) available

This topic contains 184 replies, has 30 voices, and was last updated by anticapitalista Oct 18-11:00 am.

Viewing 15 posts - 106 through 120 (of 185 total)
  • Author
    Posts
  • #26540
    Member
    Avatar
    olsztyn

    Another strange behavior: Chrome browser on antiX 19 B3 vs. on antiX 17.2:
    It appears to me that drop down menu items do not work on B3 in Chrome. E.g. clicking on antixforum.com site Forum-> Recent Posts causes drop-down menu to go away but menu item is not triggered. Neither is any other drop down menu item. Works fine in antiX 17. However this could be not antiX 19 issue but rather problem with latest Chrome (ver. 76). This issue does not happen on Firefox ESR.
    Anyone else experienced this issue?

    #26573
    Member
    Avatar
    rej

    BobC-

    Great!

    Now 5th selection down – search YT: “antix 19 review”

    #26574
    Member
    caprea
    caprea

    BobC, very well done, hopefully you stay tuned and we can see more of that soon.

    #26595
    Member
    Avatar
    BobC

    Yes, I rerecorded the audio portion, and uploaded the revised video. I think I will add a link to it in the comments of the other one.

    the revised one is at the link below… Should I be editing the links somehow? I see anti edits the links later to make them smaller on screen space. I tried, but not allowed. Not sure if you prefer I put the video in or the pic, but not allowed to use the iframe:

    antiX19b3 demo II
    https://youtube.com/watch?v=f8BOgHNiSIk%3Ffeature%3Doembed

    Devs, in order to get bluetooth working with my android phone I needed to install and pair using the blueman package. To transfer files to it I needed gnome-bluetooth installed, but I’m not sure people really need that, and it doesn’t appear on the menus. To send things to my phone I usually email it, but I guess that’s kind of clunky. Wouldn’t it be neat to bring up phone files in a folder someplace?

    I suggest blueman be included if you are expecting that people will want to connect to their phones so they can pair the device, which connman didn’t seem to have a way to do. If there is a better way to do that I missed, please let me know…

    Ps: I noticed that if I switch the desktop when booting from USB from default to space-icewm that when I change screen resolution my background is still thinking I am at the original resolution and so I just see 1/6th (top left) of the background and changing pictures doesn’t fix it. The conky is ok if you turn it off then on again. Obviously it’s not a big issue.

    • This reply was modified 1 month, 3 weeks ago by BobC. Reason: edit link
    • This reply was modified 1 month, 3 weeks ago by BobC.
    • This reply was modified 1 month, 3 weeks ago by BobC. Reason: Space FM background problem
    #26610
    Moderator
    masinick
    masinick

    BobC, according to https://www.embedded-computing.com/networking/the-connman it is possible to use Connman with Bluetooth. The interface supported is Bluetooth plugin (using BlueZ). I do not have any personal experience with this; I merely looked it up to see what it can do. The page I cited has some nice diagrams explaining the fairly flexible hardware architecture supported.

    If you read most of the article (and you are able to understand it) most of the setup information appears to be included.

    Other potential references I was able to find:

    https://01.org/connman – The main site

    https://wiki.archlinux.org/index.php/ConnMan – Arch Linux documentation for Connman (may differ from the Debian / antiX implementation

    https://www.mankier.com/1/connmanctl – manual page for Connman

    I hope these resources provide enough information to figure out effective uses for Connman. Prior to its use in the latest software, I’d never seen or heard of it, but the default setup works fine on my Dell Inspiron 5558 laptop with its default wireless interface, though I’ve not used it in any other way. Hopefully these resources will be helpful when any of us need to explore its capabilities in more detail.

    Brian Masinick

    #26618
    Member
    Avatar
    BobC

    Brian, I have bluez installed and the bluetooth daemon running, and I couldn’t get it to show my phone until I installed blueman. I saw someone else with bluetooth issues earlier in the thread. Its no big deal to me, I was just trying it since I saw it there on the screen.

    #26628
    Moderator
    masinick
    masinick

    Brian, I have bluez installed and the bluetooth daemon running, and I couldn’t get it to show my phone until I installed blueman. I saw someone else with bluetooth issues earlier in the thread. Its no big deal to me, I was just trying it since I saw it there on the screen.

    Thanks for the information. This may come in handy; at some point I suspect that I’ll want to do something with Bluetooth integration. I’ve done a little bit of it; generally it’s just been using Bluetooth speakers or headsets to listen to music, but I haven’t done much with cross platform Bluetooth integration; if I do, this will come in handy. Thanks again.

    Brian Masinick

    #26632
    Member
    christophe
    christophe

    anti & dev team: Thank you; ROX panel is working (it is part of my favorite setup).

    In a somewhat related issue, I switch between desktop sessions sometimes, and I noticed unexpected behavior:

    1. Running JWM desktop (with ROX panel running from JWM startup – “rox –top=PANEL”), then switching to ROX-IceWM desktop (without ROX-panel set to run), the panel keeps running.
    2. Switching the session back to (plain) JWM gives me a “ROX-JWM”-type situation: the ROX-panel is there (as it should be), but the desktop icons from Rox-IceWM are still “left over” from the Rox-IceWM session, and the right-click root menu is disabled. A reboot sets things right (until/unless the process is repeated).

    #26664
    Member
    Avatar
    PPC

    Yes, I rerecorded the audio portion, and uploaded the revised video.

    Great work, once again, Bob. I’m assuming you found a video editor application that works for you!

    Side note (off topic)- I commented on the importance of app-select and on the fact that I used dmenu and j4demu- I was not implying that any of those options should be used instead of app-select! They use a interface that most users would not feel confortable with (I did get used to it, because of it’s speed, but I realize that I’m not exactly a average computer user). Rofi has a more “main stream” interface, but I tried it just around the same time I began really using app-select… When I finally install antiX19 final on my netbook, I’ll have to decide if I’ll add a icon for j4-dmenu or just stick with app-select just because of this very particular user case: my netbook is about 10 years old and a single core atom with 1 gig of shared RAM. Opening app-select on that machine takes almost 5 seconds- it’s about the time it takes me to navigate the main menu and click “synaptic”. Using j4-dmenu on that very machine, it opens in less than a second. I just type “syn” and press enter and synaptic launches. I don’t use synaptic enough to have a toolbar quick start icon for it, but when I’m struggling, trying to install some apps and their dependencies, it helps having a lightning way to start synaptic. I usually don’t leave synaptic running because of memory contraints 🙂
    Out side this very particular case, I jump at every change to use toolbar desktop icons (I even created a gui script to add icons to IceWM’s toolbar) or run Dave’s app-select. I believe I was one of the first users to try it and offered some initial input.

    To the Dev’s– For some reason, yesterday, I lost my cabled connection again- once again, closing the wired connection on connman and starting it again was enough to recover the connection, it just took a few seconds… I’m I the only user on cabled internet that reports this situation? Before it used to happen on wireless (I’ve not been testing wireless on that particular netbook). I also report the same bug already mentioned here- running a19b3 live on USB and selecting JWM leaves me unable to use the menu to change back to IceWM (or any other desktop)- I can only do so on the F1 login menu…
    Also the default mouse pointer (black) that turns into a white pointer finger when I over a link, and not the usual black one… (this is a small glitch only, that I got used to).
    Other than these problems, smooth sailing all the way… antix 19b3, with JWM with black theme (available out of the box), firefox ESR (plus a old FF ESR version to use with JAVA), ungoogled chromium, gnome mpv, smtube and libreoffice and some little applications (like skippy for window switching) and scripts are *almost* everything I need for my daily computing for work and watching YouTube cartoons with my baby girl 🙂 – I only notice I’m not using a brand new machine when opening the browser or a office program- because of the small delay…
    One can never say enough thanks for this wonderful “little” (on resources consuption) amazing OS, that keeps old computers working like they are supposed to!

    P.

    P.

    #26671
    Member
    Avatar
    BobC

    PPC, I admit I don’t have a 32 bit (slow) laptop left, anymore. They have all gone to heaven and I can’t get anyone to give me one, and don’t want to spend money for one. So my lowest end machine is a 1998 Pentium III desktop I built for my son and I spent $5 on it a month ago boosting the memory to 512 mb, and another $10 on an ATI Radeon card because none of the AGP or PCI nVidia cards I had would work on Buster above 640×480. I agree we should test on slow machines so that the results are at least reasonable for all users. 5 seconds is pretty long to me as well.

    I also like using toolbar icons to save going to the menus. I change them by hand, but I agree that if there was an easy way that normal people could maintain it easily, that would be better.

    My suggestion would be to add your j4 or dmenu on Super+Space or Ctrl+Shift+Space in the keys file. If J4 is really an improvement over dmenu, you should ask anticapitalista if he can find a way to include it and add it to the standard keys. Another possibility would be for the keys file to have J4 used instead of dmenu if J4 is installed, similar to how it decides which calculator program to run when you hit the Calculator key on a multimedia keyboard.

    Dmenu is already included on the Fluxbox keys file on Super+Alt+P is I read it right, but I don’t know if anyone uses that.

    !!dmenu
    Mod4 Mod1 P :ExecCommand $(ls -lL <code>echo $PATH | tr : ' '</code> 2>/dev/null | awk 'NF>2 && $1 ~ /^[^d].*x/ {print $NF}' | sort -u | dmenu -b -fn 10x20 -nb black -nf white -sb grey -sf black)

    I also have the missing IceWM change desktops issue.

    • This reply was modified 1 month, 2 weeks ago by BobC.
    #26904
    Member
    Avatar
    BobC

    FYI, I booted and installed antiX19 base 32 bit on both my Pentium II-400 with 256 mb (from 1995) and on my Dual Pentium III-750 with 2 gb (from 1997) from DVD. Neither is able to boot from USB. I really don’t think its fast enough to be usable on the Pentium II-400, but it did load and run. I will test the new IceWM 1.6.1 on the Pentium III today after the didst-upgrade completes.

    #26906
    Member
    sdsddsd
    sdsddsd

    To mount an android device via mtp in spacefm, I have to manually type into the adressline “mtp://”. After that the device is showing up and working normal. Tested with two different phones/tablet.
    Dont know if this is an antix related problem.

    #26909
    Member
    Avatar
    olsztyn

    Compatibility of antiX and Fluxbox appears to possibly have an issue or two:
    Case 1 – Chrome:
    Installed Chrome 76 stable. Strange behavior is that left click on dropdown menus does not seem to trigger menu selection. This is under Space-Fluxbox (my desktop). E.g. on antixforum clicking on ‘Recent Posts’ dropdown item does nothing.
    After changing desktop to Space-JWM – no such problem – works perfectly. The same behavior is on Chrome 77 beta and unstable.
    Case 2:
    In addition to Chrome stable (76) installed 77 beta (the same happens with unstable). Under Space Fluxbox I see menu item for Chrome 77 but clicking on it does nothing. Also mini icon is missing. However if I use Appselect, no such problem. it starts normally.
    Switched to Space-JWM and no such problem whatsoever. Icon is there and program starts normally from menu item.
    Reinstalls of Chrome do not help in terms of correcting this issue.
    Therefore: Since it works fine with Space-JWM but does not with Fluxbox, does this not point to Fluxbox?
    As a side observation (I think I saw this noticed in this forum): Desktop list seems missing IceWM on both Fluxbox and Space-JWM and some existing desktops are repeated…

    #26910
    Member
    Avatar
    olsztyn

    Compatibility of antiX and Fluxbox appears to possibly have an issue or two:

    I should have been more precise in this statement… It is not antiX issue. It might be just recent versions of Chrome and Chromium that do not seem to agree with Fluxbox. Firefox ESR is fine with drop-down menu items.
    On Case 2 Chromium starts with no issue from Fluxbox menu and has mini icon but seems to exhibit Case 1 issue of not triggering drop-down menu items.
    Upon further testing of these Fluxbox/Chrome issues it appears it also happens on antiX17.2, so it is not in any way related to antiX 19 B3.

    #26911
    Member
    Avatar
    olsztyn

    Also I realize that since these issues proved not related to antiX 19 B3 but to Fluxbox/Chrome instead, this topic does not belong in this thread. Please move it to wherever it should be…

Viewing 15 posts - 106 through 120 (of 185 total)

The topic ‘antiX-19-b3-full and base versions (64 and 32 bit) available’ is closed to new replies.