Antix-19 BUG — Automount Drives does NOT work

Forum Forums Official Releases antiX-19 “Marielle Franco” Antix-19 BUG — Automount Drives does NOT work

This topic contains 19 replies, has 5 voices, and was last updated by RobK88 Nov 8-8:14 am.

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #28636
    Member
    Avatar
    RobK88

    I just did a clean install of antiX-19 using the x386 liveDVD.
    The installation completed without any errors.
    I am able to boot into antiX-19, run Firefox etc.

    But automounting of drives does not appear to work like it did in antiX-17.
    After I insert my USB flash drive, formatted in exFAT, into the USB port of my laptop, nothing happens.
    The USB flash drive is NOT automounted.

    To mount the drive, I had to do the following in the terminal:

    sudo mkdir /media/Lexar
    sudo mount -t exfat /dev/sdb1 /media/Lexar

    I also tried my antiX-19 Live DVD. After inserting it into my laptop’s DVD drive, the antix-19 DVD did not automount.

    I checked the settings in the antiX Control Center (which I did not change). The default settings for automount is ON.

    I also tried to manually mount the USB flash drive using the Control Centre. It also failed… (Another bug?)

    I did not have any of these problems with antiX-17 using the same kernel 4.9.193.

    Any ideas? Or is this a bug.

    • This topic was modified 2 weeks, 3 days ago by RobK88.
    • This topic was modified 2 weeks, 3 days ago by RobK88.
    • This topic was modified 2 weeks, 3 days ago by RobK88.
    #28660
    Member
    Avatar
    RobK88

    Update: I was able to get automounting to work with my CDROM (but I still get get automounting to work with my USB Flash Drive).

    To get automounting to work with my CDROM, I had to first manually create the mountpoint in Terminal:

    sudo mkdir /media/cdrom

    Then after I insert a CD or DVD, nothing really happens until I try to open up /media/cdrom, then a message appears telling me that the CD or DVD is being mounted. Then I can see the files and directories on the CD or DVD.

    I wish I could get automounting to work with my USB flash drive. Still no luck.

    But I did notice something very strange. When I look at the properties of /media/cdrom in rox-filer, it shows that /media/cdrom is a mountpoint for /dev/cdrom…
    But when I look at the properties of /media/Lexar, it does not show it as a mountpoint. It says it is a “inode/directory …. folder”.

    It sure looks like there is a bug with respect to automounting of USB flash drives.

    #28680
    Forum Admin
    Dave
    Dave

    Are spacefm / the spacefm backend packages installed? I think auto mounting is reliant upon the spacefm mounting functions

    Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

    #28683
    Member
    Avatar
    RobK88

    As part of the clean install of antiX-19 Full (i386), the following spacefm packages were installed:

    desktop-defaults-spacefm-antix
    spacefm
    spacefm-common

    If there are other packages that I need, please let me know.

    But I suspect this is a bug in antiX-19. Automounting of USB drives worked just fine of antiX-17 on this same laptop.

    #28684
    Forum Admin
    anticapitalista
    anticapitalista

    Are you talking about all automounting or just of exfat drives?

    I just tested fat16, fat32, ntfs, ext4 formatted usb sticks and all automount running antiX-19-full 32 bit (live).
    exfat does not automount (but we already know that from your first post).
    The title should be ‘Antix-19 BUG — Automount exfat Drives does NOT work’
    and that is because pmount in Debian doesn’t recognize the exfat file format.

    • This reply was modified 2 weeks, 2 days ago by anticapitalista.
    • This reply was modified 2 weeks, 2 days ago by anticapitalista.
    • This reply was modified 2 weeks, 2 days ago by anticapitalista.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #28688
    Member
    Avatar
    RobK88

    Thanks for the quick reply. I just found an old USB flash drive formatted in FAT32 and tried it.
    The USB flash drive formatted in FAT32 did automount.

    So it looks like only USB drives formatted in exFAT do not automount.

    As for the title of my post, it is probably more accurate to change it to “Antix-19 BUG — Automount exfat and CDROM Drives does NOT work”.

    To get automounting of CDROM drives to work, I had to manually create the mountpoint in terminal first. (i.e. sudo mkdir /media/cdrom ). It really should work out of the box.

    It is a pity that automounting of exFAT drives does not work since exFAT is one of the few disk formats supported in Mac, Windows and Linux. exFAT is also designed to support large drives whereas fat32 never was.

    #28689
    Forum Admin
    anticapitalista
    anticapitalista

    Re – cdrom – /media/cdrom directory should have been created on boot if a cdrom/dvd drive is present.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #28694
    Forum Admin
    dolphin_oracle
    dolphin_oracle

    could the OP post the /etc/udevil/udevil.conf file please?

    • This reply was modified 2 weeks, 2 days ago by dolphin_oracle.
    #28698
    Forum Admin
    dolphin_oracle
    dolphin_oracle

    never mind, I see in the shipping antiX 19 the recommended options are there, but they don’t appear to be used.

    I can mount manually if an existing mountpoint.

    sudo mount -t /dev/sdb1 /media/USB-DATA

    fuse-exfat does spit out some errors, so it may be that the udevil routines (used by spacefm and devmon/automount-antix) in use do not recognize the output or something.

    • This reply was modified 2 weeks, 2 days ago by dolphin_oracle.
    #28701
    Member
    Avatar
    skidoo
    #28724
    Member
    Avatar
    RobK88

    Many thanks for all the info.

    I tried adding exfat to the allowed_types in udevil.conf but it did not work. exfat disks were not automounted. This change even caused a FIFO error to be thrown at boot-up.

    I find it strange that the udevil.conf file includes many configuration settings for mounting exfat disks but it is not possible to include exfat in the allowed-types variable in udevil.conf.

    #28975
    Member
    Avatar
    RobK88

    FYI — If I run SpaceFM and then insert my USB Flash drive formatted in exFAT, the USB Flash drive does show up in the sidebar.
    But when I click on it, SpaceFM throws the following error:

    
    FUSE exfat 1.3.0
    WARN: volume was not unmounted cleanly.
    fuse: mountpoint is not empty
    fuse: if you are sure this is safe, use the 'nonempty' mount option

    I wish I knew what mountpoint SpaceFM was trying to use….

    P.S. I can cleanly mount and unmount the USB Flash Drive formatted in exFAT using the command line in Terminal.

    But the minute I plug the flash drive in, antiX-19 attempts to automount it and fails. That is why you see the “WARN: volume was not unmounted cleanly” message.

    • This reply was modified 1 week, 2 days ago by RobK88.
    #28992
    Forum Admin
    dolphin_oracle
    dolphin_oracle

    It may be possible with spacefm to set up a new handler for exfat file systems. that would not help the automount system though.

    #28994
    Forum Admin
    anticapitalista
    anticapitalista

    You can turn off automounting if it helps you via Control Centre – Disks -Configure Automount.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #29013
    Member
    Avatar
    skidoo

    could the OP post the /etc/udevil/udevil.conf file please?

    comparing the content of udevil.conf in antiX 17 vs antiX 19 I noticed that
    udevil.conf in antix17 explicitly specifies fmask values among default mount options for the following (antix19 does not):
    default_options_vfat, default_options_exfat, default_options_msdos, default_options_umsdos, default_options_ntfs

    and
    allowed_media_dirs= /media/$USER, /run/media/$USER
    ^— for antiX 17, /media was also listed here

    What happened to cause this change?

    antiX stretch and antiX buster repos both offer a “udevil” package, but the upstream debian buster repo offers a higher-versioned udevil package.

    debian stretch version did specify explicit fmask values
    https://sources.debian.org/src/udevil/0.4.4-1/etc/udevil.conf/
    but did not specify “/media” as one of the allowed_media_dirs
    ^—- the udevil.conf provided by the antiX -packaged version did (still does) specify “/media” as one of the allowed_media_dirs

    In the slim.conf provided by debian buster repo (which winds up installed into antiX 19)
    https://sources.debian.org/src/udevil/0.4.4-2/etc/udevil.conf/
    /media is not specified
    and
    explicit fmask values are omitted

    .

    excerpt from man mount.ntfs

    “By default, files and directories are owned by the effective user and group of the mounting process, and everybody has full read, write, execution and directory browsing permissions. You can also assign permissions to a single user by using the uid and/or the gid options together with the umask, or fmask and dmask options.”

    excerpt from man mount.exfat
    umask=value (The default is 0)
    uid=n (Set the owner for all files and directories. The default is the owner of the current process.)
    gid=n (Set the group for all files and directories. The default is the group of the current process.)

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.