Antix-19 BUG — Automount Drives does NOT work

Forum Forums Official Releases antiX-19 “Marielle Franco” Antix-19 BUG — Automount Drives does NOT work

  • This topic has 20 replies, 6 voices, and was last updated Nov 19-11:19 am by dr-kart.
Viewing 6 posts - 16 through 21 (of 21 total)
  • Author
    Posts
  • #29088
    Member
    Avatarskidoo

    this post is a work-in-progress (accidentally posted while still typing)

    FIFO

    • This reply was modified 2 months, 1 week ago by skidoo.
    #29090
    Member
    Avatarskidoo

    I tried adding exfat to the allowed_types in udevil.conf but it did not work. exfat disks were not automounted. This change even caused a FIFO error to be thrown at boot-up.

    I find it strange that the udevil.conf file includes many configuration settings for mounting exfat disks but it is not possible to include exfat in the allowed-types variable in udevil.conf.

    (pedantic attention to detail) actually, it would be “allowed_types” ~~ underscore, not hyphen. Altering that line, alone, without also adding lines to declare “options”… could have potentially led to the FIFO error you witnessed.

    Did you just edit one line, or did you ALSO add lines for
    default_options_exfat= and allowed_options_exfat= as seen in the udevil.conf for antiX 17
    ?

    My suggestion is to replace the entire content of udevil.conf with the exact, full, content found in the udevil.conf which was shipped in antiX 17, then retry.

    #29092
    Member
    AvatarRobK88

    Interesting.. Can someone post the udevil.conf file from AntiX-17.4.1?

    Do you think exfat USB drives will automount in antiX-19 if I replace the antiX-19 udevil.conf file with the one from AntiX-17.4.1?

    #29093
    Member
    Avatarskidoo

    contents of udevil.conf file from AntiX-17.4.1 extracted from http://repo.antixlinux.com/stretch/pool/main/u/udevil/udevil_0.4.2-1_amd64.deb
    https://pastebin.com/raw/2Xh9tkDs

    Do you think exfat USB drives will automount in antiX-19 if I replace the antiX-19 udevil.conf file with the one from AntiX-17.4.1?

    anticapitalista’s post mentioned “won’t automount [..] because pmount in Debian doesn’t recognize the exfat file format.”
    IIUC, that affects only “automount=all,usb” boot cheatcode and “ControlCenter }} ConfigureAutomounting“.

    Via spaceFM + udevil, you should still be able to accomplish automounting.
    If you are running a “xxxx-space” desktop session, automount could (I haven’t tested) automatically occur at start of session.
    Alternatively, adding “spacefm -d” to session startup file may accomplish automount.

    .

    #29132
    Member
    AvatarRobK88

    Thanks skidoo. I will play around with udevil.conf this weekend and see how it goes.

    #29510
    Member
    Avatardr-kart

    FYI — If I run SpaceFM and then insert my USB Flash drive formatted in exFAT, the USB Flash drive does show up in the sidebar.
    But when I click on it, SpaceFM throws the following error:

    
    FUSE exfat 1.3.0
    WARN: volume was not unmounted cleanly.
    fuse: mountpoint is not empty
    fuse: if you are sure this is safe, use the 'nonempty' mount option

    I wish I knew what mountpoint SpaceFM was trying to use….

    P.S. I can cleanly mount and unmount the USB Flash Drive formatted in exFAT using the command line in Terminal.

    But the minute I plug the flash drive in, antiX-19 attempts to automount it and fails. That is why you see the “WARN: volume was not unmounted cleanly” message.

    +1. Same here.Had to manually mount my exfat drive.

Viewing 6 posts - 16 through 21 (of 21 total)
  • You must be logged in to reply to this topic.