AntiX 19 Core static ip no DNS

Forum Forums General Software AntiX 19 Core static ip no DNS

  • This topic has 4 replies, 2 voices, and was last updated Nov 19-7:36 am by anticapitalista.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #29339
    Member
    Avatarbrudal1

    Hello,
    i want to use a nameserver on my AntiX 19 Core Live System

    My /etc/network/interfaces is actual this:
    ————————————
    auto lo
    iface lo inet loopback

    auto eth0
    iface eth0 inet static
    address 192.168.0.34
    broadcast 192.168.255.255
    dns-namservers 8.8.8.8
    gateway 192.168.0.1
    netmask 255.255.255.0
    network 192.168.0.0
    ————————————–

    when i was insert the “dns-nameservers” i restart the network with:
    service networking restart

    then i test add it prepend domain-name-servers 8.8.8.8; to /etc/dhcp/dhclient.conf and i restart the network

    but when i ping google.de i get allways:

    “Name or service no know”

    i want to insert the nameserver config to the /etc/resolve.conf file but i cant write this file ( Error writing /etc/resolv.conf: No such file or directory )

    i test with
    readlink /etc/resolv.conf

    i get
    ../run/resolvconf/resolv.conf

    but the folder /run/resolvconf does not exists

    how i can config the nameserver at the AntiX 19 Core Live System?

    I dont no what can i do

    #29365
    Member
    Avatarbrudal1

    I make a test:

    1. i config the eth0 with ceni to DHCP –> the /etc/resolv.conf exists –> DNS works

    2. i config the eth0 with ceni to my static IP –> the /etc/resolv.conf exists –> DNS works

    3. i remaster the system with live-remaster and reboot -> the /etc/resolv.conf does not exists –> DNS does not work

    how can i insert the resolv.conf, when i remaster the system on my pendrive??

    #29369
    Forum Admin
    anticapitalistaanticapitalista

    Are you using disable=lxmd cheat ie the default on antiX-core? If so, make it disable=lx or don’t use it.

    Also look in /usr/local/share/live-files/general-files/etc

    Whatever changes you made to dhclient.conf and/or interfaces, copy to the correct folder here.
    This will stop them from being overwritten.

    • This reply was modified 3 weeks, 2 days ago by anticapitalista.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #29499
    Member
    Avatarbrudal1

    The Boot Options are “quiet disable=lxdF 3 kdb=de toram”

    I copy the File

      /etc/network/interfaces

    and

      /etc/resolv.conf

    to

      /usr/local/share/live-files/general-files/etc/network/interfaces</u> respectively
      /usr/local/share/live-files/general-files/etc/resolv.conf

    and the remaster the system with live-remaster.

    But the system start allways with dhcp.
    it’s the same when i change the Boot Options to “kdb=de toram”

    #29507
    Forum Admin
    anticapitalistaanticapitalista

    Adding m to disable= will block all networking.
    Does that help?

    Philosophers have interpreted the world in many ways; the point is to change it.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.