antiX 19 Install Fail On External Hard Drive

Forum Forums New users New Users and General Questions antiX 19 Install Fail On External Hard Drive

  • This topic has 3 replies, 3 voices, and was last updated Dec 4-1:22 pm by ladiko.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #28859
    Member
    Avatarrfinco

    Hello,

    I tried to install antiX 19 32bit and 64bit to an external USB HDD, and the install failed at the point of preparing the partitions. I tried both GUI and CLI installers with the same result. I installed antiX 19 64bit to the internal SATA HDD without any problem.

    I installed the following distros to the same external USB HDD without any problems:

    – Debian 10 64bit
    – MX Linux 19 64bit
    – Ubuntu 18.04.3 64bit
    – Peppermint-10-20190514 64bit

    While doing the GUI install, the failure message that I got was:

    “Failed to format required partitions”

    After dismissing this message, the whole install window was disabled, and I had to dismiss it with the upper right corner “X” button.

    Here is the complete CLI install session:

    
    demo@antix1:~
    $ sudo cli-installer
      make-fstab: Remove all dynamic entries from /etc/fstab
      make-fstab: Create new /etc/fstab
      make-fstab: Ignore iso9660 filesystem on device /dev/sda1
      make-fstab: Put 4 hard drive entries into /etc/fstab
      make-fstab: Put 5 removable entries into /etc/fstab
    
    Requirements for minimum installation:
    
    antiX-full: hard-disk 4.0GB  RAM 64MB
    
    antiX-base: hard-disk 3.0GB  RAM 48MB
    
    antiX-core: hard-disk 1.0GB  RAM 48MB
    
    antiX-net:  hard-disk 0.7GB  RAM 48MB
    
    Make sure you are connected to 
    
    the net BEFORE running this installer
    
    ====Disk and partition Information====
    Name     Size   FS        Label
    sda2 -   3.1M - Fat32   - EFI-LIVE
    sdf1 -  70.5G - ext4   
    sdf2 -     4G - swap   
    
    Do you want to repartition the disk (y/N)? n
    
    Root partition (hda1, sda2, etc): sdf1
    
    Deleting the contents of the sdf1 partition.
    This may take some time. Please wait....
    
    Use separate '/home' partition (y/N)? n
    Are you running antiX-net (y/N)? n
    /usr/local/bin/cli-installer: line 494: syntax error: unexpected end of file
    demo@antix1:~
    $ 
    

    From inxi, sda is live boot flash drive, sdf is external HDD being installed to:

    
    >>>
    System:    Host: antix1 Kernel: 4.9.193-antix.1-amd64-smp x86_64 bits: 64 compiler: gcc v: 8.3.0 
               Desktop: IceWM 1.5.5+git20190610 Distro: antiX-19_x64-full Marielle Franco 16 October 2019 
               base: Debian GNU/Linux 10 (buster) 
    Machine:   Type: Desktop System: Compaq Presario 061 product: RK519AA-ABA SR2044NX NA680 v: 0nx1411RE101ASTE300 
               serial: CNH64027N2 
               Mobo: Hewleet-Packard model: Asterope3 v: 1.0 serial: N/A BIOS: American Megatrends v: 3.17 date: 07/26/2006 
    Memory:    RAM: total: 2.88 GiB used: 252.5 MiB (8.6%) 
               Array-1: capacity: 4 GiB note: est. slots: 2 EC: None max module size: 2 GiB note: est. 
               Device-1: DIMM0 size: 2 GiB speed: Unknown type: DDR2 
               Device-2: DIMM1 size: 1 GiB speed: Unknown type: DDR2 
    Drives:    Local Storage: total: 78.26 GiB used: 57.1 MiB (0.1%) 
               ID-1: /dev/sda type: USB vendor: PNY model: USB 2.0 FD size: 3.73 GiB 
               ID-2: /dev/sdf type: USB vendor: Samsung model: HM080HI size: 74.53 GiB 
               Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GH24NSB0 rev: LN00 dev-links: cdrom,cdrw,dvd,dvdrw 
    

    Anybody have this happen?

    Thanks. rfinco..

    #30131
    Member
    Avatarladiko

    antiX-19_x64-base.iso\antiX\linuxfs\usr\local\bin\cli-installer has a mistake. Line 303 should have a “fi” before “echo” to close the if case. http://www.shellcheck.net reports this error as well.

    • This reply was modified 1 week ago by ladiko.
    • This reply was modified 1 week ago by ladiko.
    #30134
    Forum Admin
    anticapitalistaanticapitalista

    As the release notes state:

    Known Issues:

    * sis drivers no longer work (we’ll see if we can get it working for later editions)
    * Rox and spacefm desktop RAM usage is higher than expected
    * connman does not connect to sdio bluetooth controller (rtl8723bs) on Intel Compute Stick STCK1A8LFC
    * The presence of /etc/asound.conf causes repeated second long gaps in HDMI sound
    * cli-installer needs to be upgraded before use on full and base. (core and net use the latest versions)
    * Creating an encrypted live-USB fails unless an older version of Live_USB Maker is used. The version on antiX-17 does create an encrypted Live_USB of antiX-19
    * Although the antiX FAQ has been updated, some parts may need further revision

    antiX-19 isos available.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #30135
    Member
    Avatarladiko

    I see, i installed antiX for the first time today. Didnt think of an upgrade before an installation.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.