antiX-21/22 to antiX-23

Forum Forums Official Releases antiX-23 “Arditi del Popolo antiX-21/22 to antiX-23

  • This topic has 52 replies, 17 voices, and was last updated Apr 14-12:07 am by DragonGirlsAndTrucks.
Viewing 8 posts - 46 through 53 (of 53 total)
  • Author
    Posts
  • #121508
    Member
    abc-nix
      
      The following packages will be REMOVED:
        acpi-support* acpi-support-base* acpid* anacron* cmst* connman* console-common* dnsmasq* gpm* haveged* hdparm* lm-sensors* ntp* ntpsec*
        openssh-server* runit-core-services-antix* runit-init-antix* smartmontools* sysvinit-utils-antix* tlp*

      @kirara Read your message properly. You are running the RUNIT version/edition. So just DONT remove sysvinit-utils-antix.

      Know that the sysvinit init services still work on the runit edition thanks to antiX having a compatibility layer. That is probably why you never realized that you were running the runit edition.

      If you want to use the pure sysvinit based antiX system, then backup your files and install antiX 23 from the full ISO, install the packages you were using and restore your files from the backup.

      #121509
      Forum Admin
      anticapitalista

        @kirara – so we know what init you started with, post output of
        cat /etc/antix-version

        Philosophers have interpreted the world in many ways; the point is to change it.

        antiX with runit - leaner and meaner.

        #137471
        Member
        Hector_A

          Hello,

          Currently using antiX 21 with great success. It’s really an amazing OS. Blazingly fast, low footprint and extremely dependable.

          I also use a proprietary CAD program (BricsCAD) and discovered that its newest version (V24) will NOT run with Kernel 4.9.0. I keep an old HP Mini as a backup, too old and slow, but it has Kernel 5. So have installed the program there and it works. But hardly usable due to its low speed and a very small screen.

          The conclusion appears to be an upgrade of the Kernel in my main laptop, a Dell XPS13 9350, which although being 8 years old it still going strong.

          I’m not sure how to proceed in this case, being the first time faced with the task.

          Will be quite thankful for some guidance to proceed.

          #139294
          Member
          DragonGirlsAndTrucks

            I’m a huge noob, but I’d like to add that I had to comment out the bullseye repo, and add deb http://ftp.halifax.rwth-aachen.de/mxlinux/packages/antix/bookworm bookworm main nosystemd nonfree rather than deb-src http://ftp.halifax.rwth-aachen.de/mxlinux/packages/antix/bookworm bookworm main nosystemd nonfree

            I chose to let this file be updated to the maintainer’s version, which gave me this:

            # Use with Debian Bookworm repositories.
            deb [signed-by=/etc/apt/keyrings/antix-archive-keyring.gpg] http://la.mxrepo.com/antix/bookworm bookworm main nonfree nosystemd  
            #deb-src http://la.mxrepo.com/antix/bookworm bookworm main nosystemd nonfree  
            # Use with Debian Testing/'rolling' repositories.
            #deb http://la.mxrepo.com/antix/testing testing main nosystemd nonfree
            #deb-src http://la.mxrepo.com/antix/testing testing main nosystemd nonfree
            # Use with Debian Sid repositories.
            #deb http://la.mxrepo.com/antix/sid sid main nosystemd nonfree
            #deb-src http://la.mxrepo.com/antix/sid sid main nosystemd nonfree

            And I am now getting these errors from apt commands:

            apt: /lib/x86_64-linux-gnu/libc.so.6: version`GLIBC_2.32′ not found (required by /lib/x86_64-linux-gnu/libapt-pkg.so.6.0)
            apt: /lib/x86_64-linux-gnu/libc.so.6: version`GLIBC_2.34′ not found (required by /lib/x86_64-linux-gnu/libapt-pkg.so.6.0)
            apt: /lib/x86_64-linux-gnu/libc.so.6: version`GLIBC_2.33′ not found (required by /lib/x86_64-linux-gnu/libapt-pkg.so.6.0)
            apt: /lib/x86_64-linux-gnu/libstdc++.so.6: version`GLIBCXX_3.4.29′ not found (required by /lib/x86_64-linux-gnu/libapt-pkg.so.6.0)

            Any suggestions would be appreciated.

            • This reply was modified 4 days, 13 hours ago by DragonGirlsAndTrucks.
            • This reply was modified 4 days, 13 hours ago by DragonGirlsAndTrucks.
            • This reply was modified 4 days, 13 hours ago by DragonGirlsAndTrucks.
            #139303
            Member
            PPC

              Any suggestions would be appreciated.

              Hum… Those glibc errors make me think you broke your antiX installation. My suggestion? Back up any important data and simply install antiX 23.1… It will probably be faster than trying to fix what you broke. I’m a relatively advanced Linux user, I’ve been using it for over 20 years, and using antiX for about 7… and I never even tried what you tried to do, because… well, I know it can break my OS. The single biggest drawback of using antiX is not being able to simply update from a main version to another (ex: from v. 22 to v.23), I always have to install the new version. That’s why my work computer is still on v.22

              P.

              #139305
              Member
              sybok

                @dragongirlsandtrucks:
                I know that someone ran into a similar issue in the past.
                It seems that the updates were somehow… not in the necessary order or interrupted.

                First, back-up all the relevant stuff (typically /etc/ and content of your /home/ including ~/.* files and directories, e.g. ~/.mozilla/ folder with your Firefox profile).

                1) Was “bullseye” changed to “bookworm” it in all the /etc/apt/sources.list.d/*.list files?
                2) Please post output of ‘ls -lh /lib/x86_64-linux-gnu/libc.so.6’ (=> is the file there?) and ‘apt-cache policy libc6’ (=> version of libc6).
                3) You could try to download the ‘libc6’ (and probably the ‘libstdc++6’) package manually and attempt to install it using more low-level tool ‘dpkg’ if that utility works.
                sudo dpkg -i <path to the DEB file>
                These two packages come from Debian without modifications specific to antiX, hence you can download them from the Debian web-pages related to packages.

                https://packages.debian.org -> search for the <package name> in stable (currently ‘bookworm’) distribution -> open the web-page of the package -> scroll down to bottom of the page to find “Download <package name>” -> click on the link corresponding to your architecture (most likely ‘amd64’).

                The relevant links in case of ‘libc6’ are:
                https://packages.debian.org/bookworm/libc6
                https://packages.debian.org/bookworm/amd64/libc6/download

                If that does not fix apt or it breaks the system even more, then simply re-install your system as @PPC suggested.

                #139476
                Member
                DragonGirlsAndTrucks

                  Yep, looks like it bricked it. Ended up reinstalling from fresh. Didn’t want to have to reconfigure and reinstall things from a fresh install, but I was able to pull my files just fine with a USB HDD reader and another linux machine before reinstalling. Lesson learned.

                  Thanks, guys.

                  #139485
                  Member
                  DragonGirlsAndTrucks

                    I will also note that my machine [Dell XFR E6420 | i7-2640m | 8GB RAM | 1TB Samsung 870 SSD] seems to be running more efficiently with the new version. I know it may seem that it’s the case because I have a fresh install, but it never ran this well before. The CPU temp seems to be better – I’ve barely had the fans kick on so far. CPU util on idle is averaging 3%.

                    • This reply was modified 2 days, 21 hours ago by DragonGirlsAndTrucks.
                  Viewing 8 posts - 46 through 53 (of 53 total)
                  • You must be logged in to reply to this topic.