antiX-21-beta2 iso files available.

Forum Forums News Announcements antiX-21-beta2 iso files available.

Tagged: ,

  • This topic has 125 replies, 18 voices, and was last updated Oct 13-10:10 pm by bunkbail.
Viewing 15 posts - 106 through 120 (of 126 total)
  • Author
    Posts
  • #67806
    Moderator
    Brian Masinick
    Helpful
    Up
    0

    Most gui MX programs that we use on antiX have already been moved to /usr/bin (if they were in /usr/local/bin) eg package-installer, boot-repair, iso-snapshot etc. This seems sensible to me.

    For script-based apps using gtkdialog, yad, dialog and cli based apps, I like how we have it at the moment ie using /usr/local/bin.

    I like that division of applications too – Executable binary images in /usr/bin and executable scripts in /usr/local/bin.

    Brian Masinick

    #67834
    Forum Admin
    dolphin_oracle
    Helpful
    Up
    0

    sorry about the moving of ddm-mx out of /usr/local. I didn’t realize it would cause an issue for control center or I would have said something.

    #67968
    Moderator
    ModdIt
    Helpful
    Up
    0

    Update errors this morning, used RTWH Aachen and then Chemnitz repo, both giving same failure message.
    Could have tested without the new slimski config but users are likely to install it so went that way.
    Running otherwise fully updated Beta 2 from USB Stick.
    No full installation to internal disk as see no point, portable system is fast booting and running fine.

    full-upgrade error list:

    Neue Version der Konfigurationsdatei /etc/slimski.conf wird installiert …
    invoke-rc.d: unknown initscript, /etc/init.d/dbus not found.
    slimski-themes-extras-antix (0.2.1) wird eingerichtet …
    Trigger für mailcap (3.69) werden verarbeitet …
    Trigger für desktop-file-utils (0.26-1) werden verarbeitet …
    Trigger für initramfs-tools (0.140) werden verarbeitet …
    update-initramfs: Generating /boot/initrd.img-5.10.57-antix.1-amd64-smp
    modinfo: ERROR: could not get modinfo from ‘fjes’: Invalid argument
    cp: Fehler beim Lesen von ‘/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/geneve.ko’: Eingabe-/Ausgabefehler
    modinfo: ERROR: could not get modinfo from ‘atusb’: Invalid argument
    modinfo: ERROR: could not get modinfo from ‘cc2520’: Exec format error
    modinfo: ERROR: could not get modinfo from ‘fakelb’: Exec format error
    cp: Fehler beim Lesen von ‘/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ieee802154/mac802154_hwsim.ko’: Eingabe-/Ausgabefehler
    cp: Fehler beim Lesen von ‘/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/slip/slhc.ko’: Eingabe-/Ausgabefehler
    cp: Fehler beim Lesen von ‘/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ppp/ppp_generic.ko’: Eingabe-/Ausgabefehler
    cp: Fehler beim Lesen von ‘/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ppp/ppp_mppe.ko’: Eingabe-/Ausgabefehler
    cp: Fehler beim Lesen von ‘/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ppp/ppp_synctty.ko’: Eingabe-/Ausgabefehler
    cp: Fehler beim Lesen von ‘/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ppp/pppox.ko’: Eingabe-/Ausgabefehler
    cp: Fehler beim Lesen von ‘/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ppp/pppoe.ko’: Eingabe-/Ausgabefehler
    cp: Fehler beim Lesen von ‘/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ppp/pptp.ko’: Eingabe-/Ausgabefehler
    cryptsetup: ERROR: Couldn’t resolve device overlay
    cryptsetup: WARNING: Couldn’t determine root device
    WARNING: Unknown X keysym “dead_belowmacron”
    WARNING: Unknown X keysym “dead_belowmacron”
    WARNING: Unknown X keysym “dead_belowmacron”
    WARNING: Unknown X keysym “dead_belowmacron”
    I: The initramfs will attempt to resume from /dev/sdc5
    I: (UUID=b6962c42-1aa9-429f-a464-d2c7482f0bf4)
    I: Set the RESUME variable to override this.
    depmod: ERROR: failed to load symbols from /var/tmp/mkinitramfs_7RIFyB/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/geneve.ko: Exec format error
    depmod: ERROR: failed to load symbols from /var/tmp/mkinitramfs_7RIFyB/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ppp/ppp_generic.ko: Invalid argument
    depmod: ERROR: failed to load symbols from /var/tmp/mkinitramfs_7RIFyB/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ppp/ppp_mppe.ko: Invalid argument
    depmod: ERROR: failed to load symbols from /var/tmp/mkinitramfs_7RIFyB/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ppp/ppp_synctty.ko: Invalid argument
    depmod: ERROR: failed to load symbols from /var/tmp/mkinitramfs_7RIFyB/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ppp/pppox.ko: Invalid argument
    depmod: ERROR: failed to load symbols from /var/tmp/mkinitramfs_7RIFyB/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ppp/pppoe.ko: Invalid argument
    depmod: ERROR: failed to load symbols from /var/tmp/mkinitramfs_7RIFyB/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ppp/pptp.ko: Invalid argument
    depmod: ERROR: failed to load symbols from /var/tmp/mkinitramfs_7RIFyB/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/slip/slhc.ko: Invalid argument
    depmod: ERROR: failed to load symbols from /var/tmp/mkinitramfs_7RIFyB/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ieee802154/fakelb.ko: Exec format error
    depmod: ERROR: failed to load symbols from /var/tmp/mkinitramfs_7RIFyB/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ieee802154/cc2520.ko: Exec format error
    depmod: ERROR: failed to load symbols from /var/tmp/mkinitramfs_7RIFyB/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ieee802154/atusb.ko: Invalid argument
    depmod: ERROR: failed to load symbols from /var/tmp/mkinitramfs_7RIFyB/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/ieee802154/mac802154_hwsim.ko: Exec format error
    depmod: ERROR: failed to load symbols from /var/tmp/mkinitramfs_7RIFyB/lib/modules/5.10.57-antix.1-amd64-smp/kernel/drivers/net/fjes/fjes.ko: Invalid argument
    Trigger für libc-bin (2.31-13) werden verarbeitet …
    Trigger für man-db (2.9.4-2) werden verarbeitet …
    Trigger für dbus (1.12.20-2) werden verarbeitet …
    Trigger für menu (2.1.48) werden verarbeitet …
    Writing Menu: fluxbox
    Writing Menu: icewm
    Writing Menu: jwm
    demo@antix1:~

    “dead_belowmacron” I think the French President would be very upset with this error message 🙂

    • This reply was modified 2 weeks, 5 days ago by ModdIt.
    • This reply was modified 2 weeks, 5 days ago by ModdIt.
    #67971
    Member
    Robin
    Helpful
    Up
    0

    Hello ModdIt
    just switch to »one_and_one« mirror at Frankfurt, this is proven to be reliable always, at least for me.
    It’s not for the first time Aachen and Chemnitz mirrors fail.

    Btw, I also get always this funny »dead_belowmacron« message at startup, but it doesn’t seem to have any influence, everything works fine anyway.

    Greetings
    Robin

    #67972
    Forum Admin
    anticapitalista
    Helpful
    Up
    0

    @moddlt

    Have a look at /etc/default/console-setup. It should look something like this.

    CHARMAP="UTF-8"
    
    CODESET="guess"
    FONTFACE="VGA"
    FONTSIZE="8x16"

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #67977
    Moderator
    ModdIt
    Helpful
    Up
    0

    @anticapitalista, thanks, will change the settings, I fixed the macron error several times, it sometimes comes back with updates.

    full update with repos changed now throws below error.

    Entpacken von connman (1.36-2.3.0antix4) über (1.36-2.3.0antix1) …
    dpkg: Fehler beim Bearbeiten des Archivs /tmp/apt-dpkg-install-aY0x41/10-connman_1.36-2.3.0antix4_amd64.deb (–unpack):
    Versuch, »/usr/share/runit/sv/connman/finish« zu überschreiben, welches auch in Paket runit-services-base-antix 0.1.7 ist
    /usr/bin/deb-systemd-helper: error: unable to read connman-wait-online.service
    /usr/bin/deb-systemd-helper: error: unable to read connman.service

    #68414
    Member
    bunkbail
    Helpful
    Up
    0

    Hi guys, a new poster here. I’m a long time user of antix, I’ve been using it on my laptop for years and now I wanted try it out on my main PC. I loaded up the iso using Ventoy but X is not starting and stuck on bootscreen. Probably the nouveau driver is too old for my GPU (3060ti)? How can I load up X, coz I wanted to install antix so bad haha.

    #68421
    Member
    Xecure
    Helpful
    Up
    0

    Hi, bunkbail.
    Please make sure when you launch antiX 21b2 that you select to boot with the latest 5.10 kernel. I am not sure if this is related to the problem, but I mention it just in case.
    antix21b2-latest-kernel

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #68437
    Member
    bunkbail
    Helpful
    Up
    0

    Hi Xecure, thanks for the reminder. I did that, but the issue still persist. I attach the log from X if it helps.

    EDIT: the forum board doesn’t allow me to attach the log and also posting the pastebin link smh

    [ 324.741]
    X.Org X Server 1.20.11
    X Protocol Version 11, Revision 0
    [ 324.742] Build Operating System: linux Debian
    [ 324.743] Current Operating System: Linux antix1 5.10.57-antix.1-amd64-smp #1 SMP PREEMPT Sun Aug 8 11:11:51 EEST 2021 x86_64
    [ 324.743] Kernel command line: BOOT_IMAGE=/antiX/vmlinuz1 quiet splasht disable=lxF disable_theme desktheme=dark
    [ 324.744] Build Date: 13 April 2021 04:07:31PM
    [ 324.744] xorg-server 2:1.20.11-1 (https://www.debian.org/support)
    [ 324.744] Current version of pixman: 0.40.0
    [ 324.745] Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    [ 324.745] Markers: (–) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 324.747] (==) Log file: “/home/demo/.local/share/xorg/Xorg.0.log”, Time: Wed Oct 6 16:10:12 2021
    [ 324.748] (==) Using config directory: “/etc/X11/xorg.conf.d”
    [ 324.748] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
    [ 324.748] (==) No Layout section. Using the first Screen section.
    [ 324.748] (==) No screen section available. Using defaults.
    [ 324.748] (**) |–>Screen “Default Screen Section” (0)
    [ 324.748] (**) | |–>Monitor “<default monitor>”
    [ 324.748] (==) No monitor specified for screen “Default Screen Section”.
    Using a default monitor configuration.
    [ 324.748] (==) Automatically adding devices
    [ 324.748] (==) Automatically enabling devices
    [ 324.748] (==) Automatically adding GPU devices
    [ 324.748] (==) Max clients allowed: 256, resource mask: 0x1fffff
    [ 324.748] (WW) The directory “/usr/share/fonts/X11/cyrillic” does not exist.
    [ 324.748] Entry deleted from font path.
    [ 324.748] (WW) The directory “/usr/share/fonts/X11/75dpi/” does not exist.
    [ 324.748] Entry deleted from font path.
    [ 324.748] (WW) The directory “/usr/share/fonts/X11/75dpi” does not exist.
    [ 324.748] Entry deleted from font path.
    [ 324.748] (==) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/100dpi/:unscaled,
    /usr/share/fonts/X11/Type1,
    /usr/share/fonts/X11/100dpi,
    built-ins
    [ 324.748] (==) ModulePath set to “/usr/lib/xorg/modules”
    [ 324.748] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
    [ 324.748] (II) Loader magic: 0x55ed78aa0e40
    [ 324.748] (II) Module ABI versions:
    [ 324.748] X.Org ANSI C Emulation: 0.4
    [ 324.748] X.Org Video Driver: 24.1
    [ 324.748] X.Org XInput driver : 24.1
    [ 324.748] X.Org Server Extension : 10.0
    [ 324.749] (++) using VT number 1

    [ 324.749] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
    [ 324.750] (–) PCI:*(10@0:0:0) 10de:2489:1462:c972 rev 161, Mem @ 0xfb000000/16777216, 0xd0000000/268435456, 0xe0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/131072
    [ 324.750] (II) LoadModule: “glx”
    [ 324.751] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    [ 324.751] (II) Module glx: vendor=”X.Org Foundation”
    [ 324.751] compiled for 1.20.11, module version = 1.0.0
    [ 324.751] ABI class: X.Org Server Extension, version 10.0
    [ 324.865] (==) Matched nouveau as autoconfigured driver 0
    [ 324.865] (==) Matched nv as autoconfigured driver 1
    [ 324.865] (==) Matched modesetting as autoconfigured driver 2
    [ 324.865] (==) Matched fbdev as autoconfigured driver 3
    [ 324.865] (==) Matched vesa as autoconfigured driver 4
    [ 324.865] (==) Assigned the driver to the xf86ConfigLayout
    [ 324.865] (II) LoadModule: “nouveau”
    [ 324.865] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
    [ 324.865] (II) Module nouveau: vendor=”X.Org Foundation”
    [ 324.865] compiled for 1.20.10, module version = 1.0.17
    [ 324.865] Module class: X.Org Video Driver
    [ 324.865] ABI class: X.Org Video Driver, version 24.1
    [ 324.865] (II) LoadModule: “nv”
    [ 324.866] (WW) Warning, couldn’t open module nv
    [ 324.866] (EE) Failed to load module “nv” (module does not exist, 0)
    [ 324.866] (II) LoadModule: “modesetting”
    [ 324.866] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
    [ 324.866] (II) Module modesetting: vendor=”X.Org Foundation”
    [ 324.866] compiled for 1.20.11, module version = 1.20.11
    [ 324.866] Module class: X.Org Video Driver
    [ 324.866] ABI class: X.Org Video Driver, version 24.1
    [ 324.866] (II) LoadModule: “fbdev”
    [ 324.866] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
    [ 324.866] (II) Module fbdev: vendor=”X.Org Foundation”
    [ 324.866] compiled for 1.20.0, module version = 0.5.0
    [ 324.866] Module class: X.Org Video Driver
    [ 324.866] ABI class: X.Org Video Driver, version 24.0
    [ 324.866] (II) LoadModule: “vesa”
    [ 324.866] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
    [ 324.866] (II) Module vesa: vendor=”X.Org Foundation”
    [ 324.866] compiled for 1.20.9, module version = 2.5.0
    [ 324.866] Module class: X.Org Video Driver
    [ 324.866] ABI class: X.Org Video Driver, version 24.1
    [ 324.866] (II) NOUVEAU driver Date: Sat Jan 23 12:24:42 2021 -0500
    [ 324.866] (II) NOUVEAU driver for NVIDIA chipset families :
    [ 324.866] RIVA TNT (NV04)
    [ 324.866] RIVA TNT2 (NV05)
    [ 324.866] GeForce 256 (NV10)
    [ 324.866] GeForce 2 (NV11, NV15)
    [ 324.866] GeForce 4MX (NV17, NV18)
    [ 324.866] GeForce 3 (NV20)
    [ 324.866] GeForce 4Ti (NV25, NV28)
    [ 324.866] GeForce FX (NV3x)
    [ 324.866] GeForce 6 (NV4x)
    [ 324.866] GeForce 7 (G7x)
    [ 324.866] GeForce 8 (G8x)
    [ 324.866] GeForce 9 (G9x)
    [ 324.866] GeForce GTX 2xx/3xx (GT2xx)
    [ 324.866] GeForce GTX 4xx/5xx (GFxxx)
    [ 324.866] GeForce GTX 6xx/7xx (GKxxx)
    [ 324.866] GeForce GTX 9xx (GMxxx)
    [ 324.866] GeForce GTX 10xx (GPxxx)
    [ 324.866] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [ 324.866] (II) FBDEV: driver for framebuffer: fbdev
    [ 324.866] (II) VESA: driver for VESA chipsets: vesa
    [ 324.866] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
    [ 324.980] (EE) [drm] Failed to open DRM device for pci:0000:0a:00.0: -19
    [ 324.980] (EE) open /dev/dri/card0: No such file or directory
    [ 324.980] (WW) Falling back to old probe method for modesetting
    [ 324.980] (EE) open /dev/dri/card0: No such file or directory
    [ 324.980] (II) Loading sub module “fbdevhw”
    [ 324.980] (II) LoadModule: “fbdevhw”
    [ 324.980] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
    [ 324.980] (II) Module fbdevhw: vendor=”X.Org Foundation”
    [ 324.980] compiled for 1.20.11, module version = 0.0.2
    [ 324.980] ABI class: X.Org Video Driver, version 24.1
    [ 324.980] (EE) Unable to find a valid framebuffer device
    [ 324.980] (WW) Falling back to old probe method for fbdev
    [ 324.980] (II) Loading sub module “fbdevhw”
    [ 324.980] (II) LoadModule: “fbdevhw”
    [ 324.980] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
    [ 324.980] (II) Module fbdevhw: vendor=”X.Org Foundation”
    [ 324.980] compiled for 1.20.11, module version = 0.0.2
    [ 324.980] ABI class: X.Org Video Driver, version 24.1
    [ 324.980] (II) FBDEV(2): using default device
    [ 324.980] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
    [ 324.980] (EE) Screen 0 deleted because of no matching config section.
    [ 324.980] (II) UnloadModule: “modesetting”
    [ 324.980] (EE) Screen 0 deleted because of no matching config section.
    [ 324.980] (II) UnloadModule: “fbdev”
    [ 324.980] (II) UnloadSubModule: “fbdevhw”
    [ 324.980] (EE)
    Fatal server error:
    [ 324.980] (EE) Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices
    [ 324.980] (EE)
    [ 324.980] (EE)
    Please consult the The X.Org Foundation support
    at http://wiki.x.org
    for help.
    [ 324.980] (EE) Please also check the log file at “/home/demo/.local/share/xorg/Xorg.0.log” for additional information.
    [ 324.980] (EE)
    [ 324.982] (EE) Server terminated with error (1). Closing log file.

    • This reply was modified 1 week, 2 days ago by bunkbail. Reason: reupload the log file
    • This reply was modified 1 week, 2 days ago by bunkbail. Reason: adding log blockquote
    #68455
    Member
    skidoo
    Helpful
    Up
    0

    testing here the assertion that the forum now rejects embedded pastebin links

    https://pastebin.com/KchQvvFC

    still works fine from my house…

    • This reply was modified 1 week, 2 days ago by skidoo.
    #68495
    Member
    bunkbail
    Helpful
    Up
    0

    testing here the assertion that the forum now rejects embedded pastebin links

    https://pastebin.com/KchQvvFC

    still works fine from my house…

    That’s odd because the board redirected me to the edit page 6 times when I attempted to add pastebin links. The 7th attempt I decided to just post them in quotes and it finally went through.

    Anyways, I finally got it done but with very crude workaround. I swapped out the 3060ti with my old 1060 card and installed everything I need including the Nvidia drivers. Everything is working fine and fast and after installing Gnome the footprint remained relatively small.

    antiX gnome

    #68498
    Forum Admin
    anticapitalista
    Helpful
    Up
    0

    @bunkbail – is that sysvinit or runit version with gnome?

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #68499
    Member
    bunkbail
    Helpful
    Up
    0

    @bunkbail – is that sysvinit or runit version with gnome?

    It is sysvinit since that’s the one that comes with the antiX 21b2 iso. I haven’t fiddle around the init system yet. Probably will install OpenRC, but honestly I don’t know which one is the best for me, I’m so used to systemd.

    #68584
    Member
    skidoo
    Helpful
    Up
    0

    The 7th attempt I decided to just post them in quotes and it finally went through.

    The preferred method for adding embedded links into a post (should work first time and every time):

    Atop the textarea box where you compose a post is a “toolbar”.
    Click the

      LINK

    button (may not be obvious that it is a button until mouse cursor hovers it).
    A popup dialog displays 2 entry boxes ~~ paste the URL into top entry, and again into the lower entry if you wish the full URL to be displayed as hyperlink anchor text. If you prefer, you can instead enter into the second box some freeform text to serve as the anchor text.

    #68642
    Member
    tosim
    Helpful
    Up
    0

    When, and will there be a 32b, core version available with antix21? Thank you.

Viewing 15 posts - 106 through 120 (of 126 total)
  • You must be logged in to reply to this topic.