Antix 21 extremely sluggish on Acer Travelmate 4000

Forum Forums Official Releases antiX-21/22 “Grup Yorum” Antix 21 extremely sluggish on Acer Travelmate 4000

  • This topic has 7 replies, 4 voices, and was last updated Feb 6-3:33 pm by BobC.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #76878
    Member
    LostInAntix

      Hi there,

      I just tried to install Antix 21 on an old Acer Travelmate 4000 laptop.
      This is a 32 bit laptop with Centrino M processor.

      I had MX running before, but guessed that Antix would be better suited for this machine.

      I started Antix from a USB stick and I’m running live so to speak. I choose all default options.
      I tried to boot with forcepae option, because experience has learned that this processor apparently misses that flag.

      Sofar, Antix works extremely s-l-u-g-g-i-s-h

      Although Conky does not display much processor activity everything goes in slow motion.

      Typing : half of the characters are missing (I’m a 2 finger typist…)
      Touchpad : cursor slowly drag along,
      clicking : half of the time clicks are missed

      The information from inxi -zv8 comes in slowmotion in the terminal, block by block of 6 lines or so.

      What can this be?

      Any help highly appreciated.

      I’m a Linux user for a couple of years. I know a thing or two from cmd line use, but I’m a newbie on Antix.

      Below output from inxi

      
      $ inxi -zv8
      System:
        Kernel: 4.9.0-279-antix.1-486-smp i686 bits: 32 compiler: gcc v: 10.2.1 
        parameters: quiet splasht disable=lxF 
        Desktop: IceWM 2.8.0 vt: 7 dm: N/A 
        Distro: antiX-21_386-base Grup Yorum 31 October 2021 
        base: Debian GNU/Linux 11 (bullseye) 
      Machine:
        Type: Laptop System: Acer product: TravelMate 4000 v: Rev 1 
        serial: <filter> Chassis: type: 10 v: Rev.1 serial: <filter> 
        Mobo: Acer model: TravelMate 4000 v: Rev 1.0 serial: <filter> BIOS: ACER 
        v: 3A10 date: 10/12/2004 
      Battery:
        ID-1: BAT0 charge: 8.2 Wh (100.0%) condition: 8.2/65.1 Wh (12.7%) 
        volts: 16.8 min: 14.8 model: SMP-SONY 04ZL type: Li-ion serial: N/A 
        status: Charging cycles: 395 
        ID-2: BAT1 charge: N/A condition: N/A volts: N/A model: N/A type: N/A 
        serial: N/A status: N/A 
      Memory:
        RAM: total: 1.22 GiB used: 143.9 MiB (11.5%) 
        RAM Report: 
        permissions: Unable to run dmidecode. Root privileges required. 
      PCI Slots:
        Permissions: Unable to run dmidecode. Root privileges required. 
      CPU:
        Info: Single Core model: Intel Pentium M bits: 32 type: MCP arch: M Dothan 
        family: 6 model-id: D (13) stepping: 6 microcode: 18 cache: L2: 2 MiB 
        bogomips: 1598 
        Speed: 800 MHz min/max: 600/1600 MHz Core speed (MHz): 1: 800 
        Flags: acpi bts clflush cmov cx8 de dts est fpu fxsr mca mce mmx msr mtrr 
        pbe pge pse sep ss sse sse2 tm tm2 tsc vme 
        Vulnerabilities: Type: itlb_multihit status: KVM: Vulnerable 
        Type: l1tf status: Vulnerable 
        Type: mds 
        status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
        Type: meltdown status: Vulnerable 
        Type: spec_store_bypass status: Vulnerable 
        Type: spectre_v1 
        mitigation: usercopy/swapgs barriers and __user pointer sanitization 
        Type: spectre_v2 
        mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
        Type: srbds status: Not affected 
        Type: tsx_async_abort status: Not affected 
      Graphics:
        Device-1: AMD RV350/M10 / RV360/M11 [Mobility Radeon 9600 / 9700] 
        vendor: Acer Incorporated ALI Extensa 3000 series laptop: driver: radeon 
        v: kernel alternate: radeonfb bus-ID: 01:00.0 chip-ID: 1002:4e50 
        class-ID: 0300 
        Display: x11 server: X.Org 1.20.11 driver: loaded: ati,radeon 
        unloaded: fbdev,modesetting,vesa display-ID: :0.0 screens: 1 
        Screen-1: 0 s-res: 1280x800 s-dpi: 96 s-size: 338x211mm (13.3x8.3") 
        s-diag: 398mm (15.7") 
        Monitor-1: LVDS res: 1280x800 hz: 60 
        OpenGL: renderer: ATI RV350 v: 2.1 Mesa 20.3.5 direct render: Yes 
      Audio:
        Device-1: Intel 82801DB/DBL/DBM AC97 Audio 
        vendor: Acer Incorporated ALI Extensa 3000 series laptop: 
        driver: snd_intel8x0 v: kernel bus-ID: 00:1f.5 chip-ID: 8086:24c5 
        class-ID: 0401 
        Sound Server-1: ALSA v: k4.9.0-279-antix.1-486-smp running: yes 
      Network:
        Device-1: Broadcom BCM4401 100Base-T 
        vendor: Acer Incorporated ALI Extensa 3000 series laptop driver: b44 
        v: 2.0 port: 3000 bus-ID: 02:02.0 chip-ID: 14e4:4401 class-ID: 0200 
        Device-2: Intel PRO/Wireless 2200BG [Calexico2] Network driver: ipw2200 
        v: 1.2.2kmprq modules: wl port: 3000 bus-ID: 02:04.0 chip-ID: 8086:4220 
        class-ID: 0280 
        IF: eth1 state: down mac: <filter> 
        IF-ID-1: eth0 state: down mac: <filter> 
        WAN IP: No WAN IP found. Connected to web? SSL issues? Try enabling dig 
      Bluetooth:
        Message: No bluetooth data found. 
      Logical:
        Message: No logical block device data found. 
      RAID:
        Message: No RAID data found. 
      Drives:
        Local Storage: total: 63.34 GiB used: 801.4 MiB (1.2%) 
        SMART Message: Unable to run smartctl. Root privileges required. 
        ID-1: /dev/sda maj-min: 8:0 vendor: Hitachi model: IC25N060ATMR04-0 
        size: 55.89 GiB block-size: physical: 512 B logical: 512 B 
        speed: <unknown> type: N/A serial: <filter> rev: AD4A scheme: MBR 
        ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: SanDisk model: Cruzer Blade 
        size: 7.45 GiB block-size: physical: 512 B logical: 512 B type: N/A 
        serial: <filter> rev: 1.26 scheme: MBR 
        SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
        Optical-1: /dev/sr0 vendor: TSSTcorp model: CDDVDW SN-S082H rev: SB01 
        dev-links: cdrom,cdrw,dvd,dvdrw 
        Features: speed: 24 multisession: yes audio: yes dvd: yes 
        rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
      Partition:
        ID-1: /live/boot-dev raw-size: 4.42 GiB size: 4.38 GiB (99.03%) 
        used: 794.2 MiB (17.7%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 
        label: antiX-Live-usb uuid: 98578a92-ea3f-4dd5-9aba-9af8ddd6e347 
        ID-2: /media/antiX-uefi raw-size: 50 MiB size: 49.9 MiB (99.77%) 
        used: 7.2 MiB (14.5%) fs: vfat dev: /dev/sdb2 maj-min: 8:18 
        label: antiX-uefi uuid: F75B-E7DF 
      Swap:
        Kernel: swappiness: 10 (default 60) cache-pressure: 50 (default 100) 
        ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) priority: -1 
        dev: /dev/sda2 maj-min: 8:2 label: swapMX 
        uuid: c74d3c37-b870-4b08-be13-6fd003d9c9df 
      Unmounted:
        ID-1: /dev/sda1 maj-min: 8:1 size: 53.86 GiB fs: ext4 label: rootMX19 
        uuid: f63079fb-6809-41cd-95e0-42d07282a74d 
      USB:
        Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 6 rev: 2.0 
        speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
        Device-1: 1-4:2 info: SanDisk Cruzer Blade type: Mass Storage 
        driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 200mA 
        chip-ID: 0781:5567 class-ID: 0806 serial: <filter> 
        Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 
        speed: 12 Mb/s chip-ID: 1d6b:0001 class-ID: 0900 
        Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 
        speed: 12 Mb/s chip-ID: 1d6b:0001 class-ID: 0900 
        Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 1.1 
        speed: 12 Mb/s chip-ID: 1d6b:0001 class-ID: 0900 
      Sensors:
        System Temperatures: cpu: 58.0 C mobo: N/A 
        Fan Speeds (RPM): N/A 
      Repos:
        Packages: apt: 1204 lib: 581 
        Active apt repos in: /etc/apt/sources.list.d/antix.list 
        1: deb http://la.mxrepo.com/antix/bullseye bullseye main nosystemd nonfree
        Active apt repos in: /etc/apt/sources.list.d/bullseye-backports.list 
        1: deb http://deb.debian.org/debian bullseye-backports main contrib non-free
        Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
        1: deb http://ftp.us.debian.org/debian/ bullseye-updates main contrib non-free
        Active apt repos in: /etc/apt/sources.list.d/debian.list 
        1: deb http://ftp.de.debian.org/debian/ bullseye main contrib non-free
        2: deb http://security.debian.org/ bullseye-security main contrib non-free
        No active apt repos in: /etc/apt/sources.list.d/various.list 
      Processes:
        CPU top: 5 of 134 
        1: cpu: 6.9% command: slimski pid: 3457 mem: 9.98 MiB (0.7%) 
        2: cpu: 4.7% command: roxterm pid: 4545 mem: 26.8 MiB (2.1%) 
        3: cpu: 4.0% command: xorg pid: 3514 mem: 51.8 MiB (4.1%) 
        4: cpu: 2.0% command: [kworker/0:1] pid: 22 mem: 0.00 MiB (0.0%) 
        5: cpu: 1.4% command: icewm pid: 3783 mem: 14.7 MiB (1.1%) 
        Memory top: 5 of 134 
        1: mem: 51.8 MiB (4.1%) command: xorg pid: 3514 cpu: 4.0% 
        2: mem: 26.8 MiB (2.1%) command: roxterm pid: 4545 cpu: 4.7% 
        3: mem: 25.2 MiB (2.0%) command: rox pid: 3991 cpu: 1.1% 
        4: mem: 15.7 MiB (1.2%) command: volumeicon pid: 3897 cpu: 0.2% 
        5: mem: 14.7 MiB (1.1%) command: icewm pid: 3783 cpu: 1.4% 
      Info:
        Processes: 134 Uptime: 4m wakeups: 4 Init: SysVinit v: 2.96 runlevel: 5 
        default: 5 tool: service Compilers: gcc: 10.2.1 alt: 10 Shell: Bash 
        v: 5.1.4 running-in: roxterm inxi: 3.3.06 
      
      #76879
      Moderator
      BobC

        Don’t expect miracles, 1500 bogomips is not a fast machine.

        I would suggest running the minimal-IceWM or IceWM desktop instead of Rox-IceWM. You can change it when you boot, or from the main menu > Desktop > Other Desktops. The more programs you have running, the slower it will respond.

        Maybe someone else can chime in on why the keyboard is lagging.

        BTW: you got flagged as spam. I unblocked it for you, but go easy on things…

        #76880
        Forum Admin
        anticapitalista

          1. There is no forcepae option
          2. Is the usb port usb1.1 or usb2? If the former, any distro will run like it is in treacle.

          Philosophers have interpreted the world in many ways; the point is to change it.

          antiX with runit - leaner and meaner.

          #76891
          Anonymous

            .

            #76925
            Member
            LostInAntix

              @BobC : I don’t expect miracles, but MX and other ‘light’ flavours run without too much problems.
              About spam: I am using a VPN, so had to change to get things working here and the cmd line prompt was visble in in my post (demo at …). I guess that that caused them spam notification.
              I tried switching to minimal-ICEWM and that doe not make any difference.

              @Anticapitalista: forcepae did not make any difference and hence I did not use it later, but other distros needed it.
              If I interpret inxi well, my stick is on a USB 2 port (480MB/s)

              USB speed won’t hopefully influence keyboard and mouse ptr speed…
              btw before the desktop shows up (empty background) the mouse ptr moves normally.
              I don’t have many programs open , just the terminal and/or Geany, if I would type for example
              “Antix is extremely slow”
              I would probably see something like :
              “tis extmy ow”

              #76927
              Moderator
              BobC

                I wonder if its spending all its CPU cycles reporting errors?

                I have a 400 mhz Pentium II with 768 mb of memory that is tolerable when running from the hard drive. From DVD or USB its slow, but not like what you are experiencing.

                I wonder if your hardware has a kernel issue, but I wouldn’t know what might work better other than to look at what kernel works with MX.

                BTW, antiX is spelled antiX. The antiX devs are the most helpful on the planet if treated well.

                #76928
                Member
                LostInAntix

                  It does not report errors and since MX works well I’d expected the same or better performance. It is very clear there is something not right at core level, but since I have no in-depth knowledge about kernel issues etc. I ask for some advise.

                  Can I check logs for example?
                  If so, which ones and where do I find them?

                  Thank you

                  #76929
                  Moderator
                  BobC

                    Try running dmesg from the terminal. Maybe you will see errors there?

                    Or, do you know how to use mc (midnight commander)? That’s what I use to dig around and look at things like this.

                    Look at each of the recent logs in /var/log for clues…

                    Sorry, I’m not the expert here.

                    • This reply was modified 2 years, 2 months ago by BobC.
                  Viewing 8 posts - 1 through 8 (of 8 total)
                  • You must be logged in to reply to this topic.