[SOLVED]: antix 22. install forces legacy-boot flag on root position

Forum Forums Official Releases antiX-21/22 “Grup Yorum” [SOLVED]: antix 22. install forces legacy-boot flag on root position

  • This topic has 10 replies, 3 voices, and was last updated Jan 24-5:48 pm by dmx.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #98046
    Member
    dmx

      I’m installing Antix22 on a Yoga 2 11 laptop running Windows 10, in dual boot.
      The laptop is using UEFI with GPT partitions. Antix is installing on the root partition created, but even though the EFI positions are given, with swap and a BOOT-GRUB supplied as requested for the GPT partitions, the install process forces a legacy-boot flag on the root partition, gray’s out the ESP option, and I can only boot the HD system but booting the live system, reading the grub file and choosing the installed system from there.

      The live system was updated and upgraded, and the installer was reinstalled to the latest version.

      Taking the legacy-boot flag off does not let the boot repair fix this.

      How do I force an EFI install of grub?

      • This topic was modified 1 year, 5 months ago by Brian Masinick. Reason: SOLVED
      #98052
      Member
      sybok

        Hi, it’s been a while since I wrestled with (U)EFI.

        0) Did you check the downloaded ISO for integrity before creating the live-USB?
        1) What are your BIOS settings regarding boot (secure boot on/off, UEFI-only/first and legacy)?
        2) Please, post ‘inxi’ output when booted live.

        Regarding 1): Perhaps, BIOS boots both (U)EFI (first/preferred) and Legacy (second) and legacy gets somehow preferred.

        #98066
        Member
        dmx

          I didn’t check the ISO integrity, but I’m confident in the install as it is.
          BIOS doesn’t pick up Antix because it is not listed in the EFI boot partition. Maybe I could just tweak someone else’s directory and build it manually? Seems to be the only thing missing.
          I had tried a Debian 22 install and that one did create the directory, but Debian is missing drivers for my laptop so I got rid of it, without keeping the boot directory. No problem with the EFI dual booting with Debian.
          So I’m not trying to debug the Antix install but rather looking for how to (re) install grub on an EFI system. That’s the only thing missing.
          Do I need grub-efi? It’s installation will remove components of the present grub that came with the distribution, so I hesitate.
          Or is there a description of the Antix boot directory in the EFI partition that I could just copy and tweak in mine?
          That’s where I’m at right now.

          #98071
          Moderator
          caprea

            Please sharesudo parted -l from live stick
            How is the EFI system partition flagged?

            #98074
            Member
            sybok

              My only guess was you did not boot to (U)EFI but to Legacy. This, I believe, should suffice for an EFI install with most modern Linux distributions.
              Apart from that, I do not know the antiX capabilities of reinstalling/fixing grub.
              I did that once manually on a Debian-based system using chroot-ing.
              I checked antiX control centre -> Maintenance -> Boot repair offers re-install on ESP (EFI System Partition), MBR or PBR.

              As it seems, @caprea picked this up and I will “watch” and learn.
              Good luck, @dmx.

              #98075
              Moderator
              caprea

                @sybok, I just wanted to add something to the informations you already asked for to solve the problem.Please stay and lets try together.

                #98089
                Member
                dmx

                  As I said, the install process forces a legacy-boot flag on the root partition. I took it off. The parted listing will thus not show this when I get to publishing it.
                  The Live distro does not repair the grub installation, graying out the ESP option that cannot be ticked. It only allows MBR and the partition as booting methods (boot sectors). But my laptop is booting exclusively in the ESI mode, no legacy boot option is attempted, this does not let me boot Antix from the POST results, which only offers the Windows boot.

                  I’m considering manually fixing the boot record on the appropriate partition, if I could get my hands on a sample directory from a successful install. I might reinstall Debian, which installs correctly grub on the ESI partitions, and go from there. I’d like to avoid the hassle of reinstalling another OS, preferably.

                  I’ll answer Caprea with the info you guys are asking when I get a minute, or two, to reboot that laptop. Note that I’m more looking into how to install grub on an ESI device. That’s my question. Why Antix did not do it, it’s interesting, but I’m not worried with that, since Debian does it without a flaw on this machine (even if drivers are missing for my laptop). It is thus obvious to me that my setup is not the problem. Do you agree with this line of reasoning?

                  #98106
                  Member
                  sybok

                    But my laptop is booting exclusively in the ESI mode

                    If this is indeed the BIOS setting (ESI -> EFI?), it may force the live-USB to boot in the EFI mode.

                    Assuming all (including booting) is done the same way as with Debian that worked may suggest a failure in the antiX USB medium.
                    BTW, what is the version of Debian and its kernel?
                    You wrote “Debian 22” but current is Debian 11 (bullseye) and I assume that you simply mistyped.

                    Or it may suggest antiX installer not handling some of the fancy stuff correctly.
                    I experienced issues with RAID (so did Fedora) and secure boot with antiX in recent past.

                    If we got stuck here, perhaps, Debian documentation on Lenovo Yoga (though a different Yoga versions but bullseye Debian) could help you with the drivers:
                    http://wiki.debian.org/InstallingDebianOn/Lenovo/Ideapad%20Yoga%20Slim%207%2015IIL05%20%28%20bullseye%20%29

                    #98130
                    Member
                    dmx

                      Right, Debian 11 (Bullseye). As I’m already running Antix on an older EEEPC, I like having it on the Yoga too. The option of figuring how to get Debian to recognize all the old hardware of the Yoga is a complication I would like to avoid. In the worst case scenario, I’ll stick with slow Windows 10 already on it, although just getting the boot process to recognize the Antix on it would be my preference. I could also just boot the live Antix usb drive and from there load the HD version. As long as I don’t forget the usb key…

                      So, back to my original question: does the package grub-efi, which wants to uninstall the grub given with the release, install grub on an EFI partition?

                      #98137
                      Member
                      sybok

                        To be honest, I am not 100% certain of these technical details; my guess is it should [install GRUB2 on the EFI partition], if such a partition exists and you have a read/write access.

                        Which assumes that you have a separate EFI partition created during/before install of the 1st system, i.e. Windows (hence the request for ‘sudo fdisk -l’)
                        Is any of the fancy capabalities used e.g. by Windows (RAID, fast-startup, secure-boot) enabled?
                        Does the current BIOS/Windows setting prevent you from *mounting* the EFI partition with write permissions?
                        Did you try to explicitly mount it read+write when booted in the live medium?
                        What were the results?
                        This could be something to block the option ESP in the installer.
                        Or a failure when creating the live-USB; I experienced some live-USB media creation tools and distributions having issues with EFI in the past and corrupted downloads as well.

                        Which kernel did you boot into in the live-antiX installer (comparing the version with the Debian – was it older, newer)?
                        This could be the difference between Debian (you mentioned worked) and antiX (not yet there).
                        Did you update antiX live-USB to the latest kernel available when making the updates of the live-system?

                        I once had an issue with antiX-19.3 installer and I had to install the latest antiX-kernel available at that time (currently 5.10.142) in order to be able to boot on that new HW.

                        I do not wish to be nitpicky about the ISO-integrity but I once started a topic with my mouse suddenly not working reliably and it turned out all I had to do was to look at its bottom, see that the laser diode is off and that I need to clean the USB contact.

                        Info: grub-efi is a dummy package that depends on (CPU-)architecture ‘grub-efi-$ARCH’; then e.g. grub-efi-amd64 is a GRUB2 to be used with EFI-AMD64 architecture.

                        #98179
                        Member
                        dmx

                          SOLVED
                          While dealing with the grub install in verbose mode, the problem became obvious: kernel mismatch (my fault). Once the right kernel installed, grub recognized the EFI boot system and installed correctly on the EFI partition. Note that the default kernel freezes my machine after a few minutes so I have to install a previous kernel on this laptop.

                          Thank you for your help. Even if I finally solved this myself, it helps a lot to have someone interact with you to prompt you to think out of the box you put yourself in.

                        Viewing 11 posts - 1 through 11 (of 11 total)
                        • You must be logged in to reply to this topic.