antiX-22 pppoe

  • This topic has 12 replies, 3 voices, and was last updated Oct 22-2:08 pm by user_x.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #91100
    Member
    user_x

      The antiX-22_386-base.iso installed
      dsl-cable without any Routers available
      ..While instalation connman was disabled … also was called apt purge connman

      With pppoeconf or by other ways I change /etc/network/interfaces, /etc/ppp/peers/provider, …
      But if call pon
      Shows error.
      pppd … … libsystemd.so not found

      Is this a bug or did I do something wrong?

      #91101
      Member
      user_x

        And was runed apt purge iptables ufw
        I attached currently interfaces nftables.conf provider files

        • This reply was modified 1 year, 4 months ago by user_x.
        • This reply was modified 1 year, 4 months ago by user_x.
        • This reply was modified 1 year, 4 months ago by user_x.
        Attachments:
        #91107
        Forum Admin
        rokytnji

          The antiX-22_386-base.iso installed
          dsl-cable without any Routers available

          looks like auto eth0 had nothing to see by what you wrote. Certainly not conmans fault. Does base iso even come with conman?

          For the libsystem.do error. antiX comes systemd free in website and forum announcements.

          Howdy and Welcome.

          Sometimes I drive a crooked road to get my mind straight.
          Not all who Wander are Lost.
          Motorcycle racing is rocket science.

          Linux Registered User # 475019
          How to Search for AntiX solutions to your problems

          #91111
          Member
          user_x

            > Does base iso even come with conman?
            Yep. But I not have any wi-fi & etc…
            pon in terminal is the best for me 🙂

            eth0 works.
            but first time had launch with ip link set eth0 up
            …I thought it may be dependence pppd from those systemd …
            I’m still a little weak in linux

            • This reply was modified 1 year, 4 months ago by user_x.
            • This reply was modified 1 year, 4 months ago by user_x.
            • This reply was modified 1 year, 4 months ago by user_x.
            #91122
            Forum Admin
            rokytnji

              I’m a little weak also, so you are not alone.

              I don’t have your type of connections so I may sound kinda lost.

              Sometimes I drive a crooked road to get my mind straight.
              Not all who Wander are Lost.
              Motorcycle racing is rocket science.

              Linux Registered User # 475019
              How to Search for AntiX solutions to your problems

              #91125
              Member
              user_x

                I checked.
                I installed antiX-22_x64-base.iso and the symptoms are the same.
                If I put antiX-21_x64-base.iso , then everything works like clockwork.

                The antiX-22 shows something strange.

                root@zz:/home/zzz# plog
                tail: невозможно открыть '/var/log/syslog' для чтения: Нет такого файла или каталога
                root@zz:/home/zzz# poff
                /usr/bin/poff: No pppd is running.  None stopped.
                root@zz:/home/zzz# pon dsl-provider
                /usr/sbin/pppd: error while loading shared libraries: libsystemd.so.0: cannot open shared object file: No such file or directory


                Thank you for your attention 🙂
                //translate.google
                maybe I need to write to some BugFix, but I don’t know how

                #91138
                Forum Admin
                rokytnji

                  Missing libsystemd.so is not a bug either.

                  Spoke too soon. I have it on my antiX 21 64 bit full install.

                  $ locate systemd.so.0
                  /usr/lib/x86_64-linux-gnu/libsystemd.so.0
                  Seems their is ton of stuff in /etc/systemd folder on my install which is a full install. Not base.

                  harry@biker:~
                  $ cd /etc/systemd
                  harry@biker:/etc/systemd
                  $ ls
                  system user
                  harry@biker:/etc/systemd
                  $ cd system
                  harry@biker:/etc/systemd/system
                  $ ls
                  bootlogs.service mount-configfs.service rmnologin.service
                  bootmisc.service mountdevsubfs.service sendsigs.service
                  brightness.service mountkernfs.service single.service
                  checkfs.service mountnfs-bootclean.service sockets.target.wants
                  checkroot-bootclean.service mountnfs.service syslog.service
                  checkroot.service multi-user.target.wants timers.target.wants
                  halt.service network-online.target.wants umountfs.service
                  hostname.service paths.target.wants umountnfs.service
                  killprocs.service printer.target.wants umountroot.service
                  mountall-bootclean.service rc.local.service urandom.service
                  mountall.service reboot.service

                  
                  You can use my commands and compare base folder contents with my full install.                                                                    
                  
                  • This reply was modified 1 year, 4 months ago by rokytnji.

                  Sometimes I drive a crooked road to get my mind straight.
                  Not all who Wander are Lost.
                  Motorcycle racing is rocket science.

                  Linux Registered User # 475019
                  How to Search for AntiX solutions to your problems

                  #91148
                  Forum Admin
                  anticapitalista

                    Try installing libelogind0 (if it got removed), reboot.

                    Alternatively, can you connect without using pppoeconf? eg dhclient eth0

                    Philosophers have interpreted the world in many ways; the point is to change it.

                    antiX with runit - leaner and meaner.

                    #91155
                    Member
                    user_x

                      >

                      libelogind0 (if it got removed), reboot.

                      mount /media/rootantiX21
                      apt install /media/rootantiX21/home/zzz/libelogind0_246.10-3.0antix1_i386.deb
                      root@zz:/home/zzz# pon dsl-provider
                      Plugin rp-pppoe.so loaded.

                      errors is dissapears, but internet don’t works… i forget about reboot 🙂
                      ..one moment 🙂

                      Updatte:
                      Nop. The same.

                      $ pon dsl-provider
                      Plugin rp-pppoe.so loaded.
                      zzz@zz:~
                      $ host google.com
                      ;; connection timed out; no servers could be reached
                      zzz@zz:~
                      $ sudo apt update
                      .... Errors

                      /etc/ppp/resolv.conf is OK
                      ip link

                                $ ip link
                                1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1
                                    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
                                    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN mode DEFAULT group default qlen 1000
                                        link/ether 00:19:21:48:e5:7e brd ff:ff:ff:ff:ff:ff
                                        3: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1492 qdisc pfifo_fast state UNKNOWN mode DEFAULT group default qlen 3
                                            link/ppp 

                      … about a Internet withut ppp … i need more time .)

                      • This reply was modified 1 year, 4 months ago by user_x.
                      #91160
                      Forum Admin
                      anticapitalista

                        I think the problem might be with the systemd-free ppp package.

                        Can you try this one – http://download.tuxfamily.org/antix/Testing/

                        Philosophers have interpreted the world in many ways; the point is to change it.

                        antiX with runit - leaner and meaner.

                        #91169
                        Member
                        user_x

                          I’m sorry … perhaps my mistakes has be.
                          after be instaled this ppp i386 don’t looks internet.
                          Then I installed antiX-22_x64-base.iso … NOTHING daemons don’t set to OFF

                          and is

                          root@zz:~# apt list libelogin*
                          Вывод списка… Готово
                          root@zz:~# mount /media/antiX-21
                          root@zz:~# echo /media/antiX-21/home/zzz/libelogind0_*
                          /media/antiX-21/home/zzz/libelogind0_246.10-3.0antix1_amd64.deb /media/antiX-21/home/zzz/libelogind0_246.10-3.0antix1_i386.deb
                          root@zz:~# apt install /media/antiX-21/home/zzz/libelogind0_246.10-3.0antix1_amd64.deb
                          ... OK
                          root@zz:~# apt list libelogin*
                          Вывод списка… Готово
                          libelogind0/now 246.10-3.0antix1 amd64 [установлен, локальный]
                          root@zz:~# pppoeconf
                          awk: cmd. line:1: warning: regexp escape sequence \:' is not a known regexp operator
                          Plugin rp-pppoe.so loaded.
                          root@zz:~# plog
                          tail: невозможно открыть '/var/log/syslog' для чтения: Нет такого файла или каталога
                           // Not Found
                          root@zz:~# echo /var/log/*log
                          /var/log/dpkg.log /var/log/minstall.log /var/log/slimski.log /var/log/Xorg.0.log
                          root@zz:~# pon dsl-provider
                          Plugin rp-pppoe.so loaded.
                          root@zz:~# host antixforum.com
                          antixforum.com has address 70.32.23.120
                          antixforum.com mail is handled by 0 antixforum.com.
                          root@zz:~# apt update
                          ... ALL WORKS

                          maybe this sequence “pppoecanf after libelogind0” … may be daemons …
                          but without those ppp packages.

                          Many Thanks 🙂 and i’m sorry by my English … some next time i’ll be back ,) with i386

                          PS:
                          after apt install ppp_2.4.9-1+1.0nosystemd2_amd64.deb
                          works too….

                          • This reply was modified 1 year, 4 months ago by user_x.
                          • This reply was modified 1 year, 4 months ago by user_x.
                          • This reply was modified 1 year, 4 months ago by user_x.
                          #91204
                          Member
                          user_x

                            Big Thanks again.
                            There was a slight hitch with i386 because,
                            as it turned out, rpcbind has been stopped… for some unknown reason

                            Reinstalled antiX-22_386-base.iso without disabling any daemons
                            and … works.
                            With other ppp and without libelogind0

                            $ su
                            Пароль: 
                            root@zz:/home/zzz# mount /media/200-DATA
                            root@zz:/home/zzz# echo /media/200-DATA/nnn/*.deb
                            ....
                            root@zz:/home/zzz# apt install /media/200-DATA/nnn/ppp_2.4.9-1+1.0nosystemd2_i386.deb
                            ... OK
                            root@zz:/home/zzz# pppoeconf
                            awk: cmd. line:1: warning: regexp escape sequence '\:' is not a known regexp operator
                            Plugin rp-pppoe.so loaded.
                            root@zz:/home/zzz# poff
                            root@zz:/home/zzz# cp -T /etc/ppp/peers/provider /etc/ppp/peers/provider~up
                            root@zz:/home/zzz# cp -T /etc/ppp/peers/dsl-provider /etc/ppp/peers/provider
                            root@zz:/home/zzz# pon
                            Plugin rp-pppoe.so loaded.
                            root@zz:/home/zzz# host antixforum.com
                            antixforum.com has address 70.32.23.120
                            antixforum.com mail is handled by 0 antixforum.com.
                            root@zz:/home/zzz# apt update
                            ... OK
                            #91215
                            Member
                            user_x

                              rpcbind has been stopped…

                              … or it is irrelevant
                              after uninstalling connman resolver don’t resolves ))

                              works after that … for example

                              ln -s /etc/ppp/resolv.conf /etc/resolv.conf
                              chmod 0644 /etc/resolv.conf
                              

                              but I don’t know how right is this

                            Viewing 13 posts - 1 through 13 (of 13 total)
                            • You must be logged in to reply to this topic.