antiX-23.1 won’t boot on an old PC

Forum Forums Official Releases antiX-23 “Arditi del Popolo antiX-23.1 won’t boot on an old PC

  • This topic has 32 replies, 8 voices, and was last updated Apr 10-1:32 pm by Xunzi_23.
Viewing 15 posts - 1 through 15 (of 33 total)
  • Author
    Posts
  • #138338
    Member
    Len E.

      The old pc in question is a Compaq Presario with nvidia-304 level graphics card.

      Installs were attempted on 23.1 versions 386-base, 386-full, x64-base, 386-base
      runit, and on the 386_init-diversity-edition_UNOFFICIAL options init-s6-rc and
      init-s6-66. On the last 2, the installer dialog omitted the user-id-and-passwords
      panel so were cancelled.

      On the 1st 4 versions, the initial post-install boot-up was characterized by the monitor continuously clicking on and off, with no graphics appearing.
      Command line login was possible using the blank-3 addition to the grub menu
      boot command. One significant anomaly was the absence of a
      /home/user/.Xauthority file.

      ***************************************************************
      Fortunately, a simple workaround was available.
      The antix-23_386-base.iso was downloaded from the SourceForge repository
      and was installed without incident and works fine.

      The plan going forward is to synaptic-lock and sudo apt-mark hold the
      linux-headers-5.10.188 and linux-image-5.10.188 packages as a first step before
      sudo apt-get upgrade and further customizations.

      Len E.

      #138344
      Moderator
      BobC

        It sounds like video is possibly an issue, but you don’t seem to even know what CPU it has. Easy options: You could try booting the 32 bit version with the Safe video mode, or Failsafe mode.

        Take a look at the sticky posts and provide the suggested system info. It may be that the system has components that are no longer supported, and if true, you will need to run code from when it was supported. Obviously, without knowing any system info, I can’t even begin to guess.

        Also, tell us the most recent debian based distro and version it worked well with? And what kernel did it have?

        #138477
        Member
        Len E.

          Hi BobC

          I booted the antix-23.1_386-base DVD, selected the Safe Video option, and
          reinstalled it. On the initial post-install bootup, there was the usual stream of
          text output on the screen and then the screen went blank. After about 5 minutes
          with the blank screen, a command-line login prompt appeared.
          A significant message in the text output on the screen was
          “no inittab.d directory found”.
          ****************************************************************
          I don’t know what the sticky posts are, but I’ve attached a file of Inxi text output
          which hopefully provides enough information about my Compaq Presario.
          *****************************************************************
          The most recent debian based distro installed on the machine works well.
          It is inoffizielles-lmde-6-mate-32bit-de-20231112-1641.iso, from the SourceForge
          repository of the Linux Mint Deutsch user group. It uses the 6.1.0-2-686 kernel.

          Len E.

           sudo inxi -CMdm
          Machine:
            Type: Desktop System: Compaq-Presario product: NY540AA-ABL CQ5210F v: N/A 
            serial: MXX948005F 
            Mobo: PEGATRON model: NARRA5 v: 5.00 serial: 102287370002485 BIOS: Phoenix 
            v: 5.52 date: 09/14/2009 
          Memory:
            RAM: total: 2.80 GiB used: 980.5 MiB (34.2%) 
            Array-1: capacity: 4 GiB slots: 2 EC: None 
            Device-1: A0 size: 1 GiB speed: 800 MT/s 
            Device-2: A1 size: 2 GiB speed: 800 MT/s 
          CPU:
            Topology: Dual Core model: AMD Athlon II X2 215 bits: 64 type: MCP 
            L2 cache: 1024 KiB 
            Speed: 800 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 800 2: 800 
          Drives:
            Local Storage: total: 465.76 GiB used: 21.65 GiB (4.6%) 
            ID-1: /dev/sda vendor: Western Digital model: WD5000AAKS-65V0A0 
            size: 465.76 GiB 
            Optical-1: /dev/sr0 vendor: hp model: DVD-RAM GH40L 
            dev-links: cdrom,cdrw,dvd,dvdrw 
            Features: speed: 40 multisession: yes audio: yes dvd: yes 
            rw: cd-r,cd-rw,dvd-r,dvd-ram 
          
          • This reply was modified 1 week, 3 days ago by rokytnji.
          Attachments:
          #138480
          Moderator
          BobC

            It sounds like you didn’t try the Failsafe boot I suggested?

            The first thread at the top of the list is the unofficial FAQ thread.

            This command would be better. The one you attached doesn’t show the graphics info, and I expect that is where your problem lies, so I can’t give any suggestions.
            inxi -Fxz

            Also, take a look for boot errors:
            sudo dmesg

            I would suggest running antiX full 64 bit sysvinit just because you have a 64 bit CPU and its the most common version. Since the other distro worked with a 6.1.0 kernel I’d suggest trying a similar version of kernel with antiX. Kernels (including Debian kernels as well as antiX ones) are available from the Software installer and Package installer (Synaptic). Liquorix kernels can be added from their repos.

            #138655
            Member
            Len E.

              Hi BobC: an interim report.

              I booted the antiX-23.1_386-base DVD, selected the Failsafe boot option, and
              reinstalled it, with the same result as with the Safe Video option.
              With the command-line login prompt on the screen, I logged in and ran
              the sudo dmesg command.
              What appeared was a screenful of a highly-repetitive messages of the form:

              [226.309736] no MTRR for e0000000, 80000000, found
              ^ ^ ^ ^ ^
              || || || || ||
              [259.260036] no MTRR for e0000000, 80000000, found

              I checked several distros, including the antiX-23_386-base and the
              lmde-6-mate distros installed on this same machine, and all contained
              library files of the form mtrr and mtrr.h.
              ********************************************************
              I ran your recommended inxi command, generating the following output:

              
              sudo inxi -Fxz
              System:
                Kernel: 5.10.188-antix.1-486-smp arch: i686 bits: 32 compiler: gcc v: 13.2.0
                  Desktop: IceWM v: 3.4.1 Distro: antiX-23_386-base Arditi del Popolo 27
                  August 2023 base: Debian GNU/Linux 12 (bookworm)
              Machine:
                Type: Desktop System: Compaq-Presario product: NY540AA-ABL CQ5210F v: N/A
                  serial: <filter>
                Mobo: PEGATRON model: NARRA5 v: 5.00 serial: <filter> BIOS: Phoenix
                  v: 5.52 date: 09/14/2009
              CPU:
                Info: dual core model: AMD Athlon II X2 215 bits: 64 type: MCP arch: K10
                  rev: 2 cache: L1: 256 KiB L2: 1024 KiB
                Speed (MHz): avg: 800 min/max: 800/2700 boost: disabled cores: 1: 800
                  2: 800 bogomips: 10849
                Flags: ht lm nx pae sse sse2 sse3 sse4a svm
              Graphics:
                Device-1: NVIDIA C61 [GeForce 6150SE nForce 430] vendor: Hewlett-Packard
                  driver: nouveau v: kernel arch: Curie bus-ID: 00:0d.0
                Display: x11 server: X.Org v: 1.21.1.7 driver: X: loaded: nouveau
                  unloaded: fbdev,modesetting,vesa dri: nouveau gpu: nouveau
                  resolution: 1280x960~60Hz
                API: OpenGL v: 2.1 Mesa 22.3.6 renderer: NV4C direct-render: Yes
              Audio:
                Device-1: NVIDIA MCP61 High Definition Audio vendor: Hewlett-Packard
                  driver: snd_hda_intel v: kernel bus-ID: 00:05.0
                Sound API: ALSA v: k5.10.188-antix.1-486-smp running: yes
              Network:
                Device-1: NVIDIA MCP61 Ethernet vendor: Hewlett-Packard type: network bridge
                  driver: forcedeth v: kernel port: fc00 bus-ID: 00:07.0
                IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
              Drives:
                Local Storage: total: 465.76 GiB used: 5.66 GiB (1.2%)
                ID-1: /dev/sda vendor: Western Digital model: WD5000AAKS-65V0A0
                  size: 465.76 GiB
              Partition:
                ID-1: / size: 35.24 GiB used: 5.66 GiB (16.1%) fs: ext4 dev: /dev/sda12
              Swap:
                Alert: No swap data was found.
              Sensors:
                System Temperatures: cpu: 17.9 C mobo: N/A
                Fan Speeds (RPM): N/A
              Info:
                Processes: 112 Uptime: 5m Memory: 2.83 GiB used: 377.6 MiB (13.0%)
                Init: SysVinit runlevel: 5 Compilers: gcc: 12.2.0 Packages: 1403 Shell: Sudo
                v: 1.9.13p3 inxi: 3.3.25
              

              To be continued ……
              Len E.

              #138664
              Moderator
              BobC

                If you attach the dmesg output, we could look at it…

                sudo dmesg > dmesgoutput.txt

                #138751
                Member
                Len E.

                  Hi BobC: an update

                  I ran the sudo dmesg > dmesgoutput.txt command and I’ve attached the
                  file to this reply.
                  ***********************************************************
                  After running the dmesg command, I entered a sudo startx command, and the
                  following abbreviated icewm menu came up:

                  Terminal —-> brings up roxterm which does work
                  Web Browser —-> brings up Links, which I don’t know how to use
                  Monitors —-> I didn’t check out the sub menus
                  Toolbar —-> “ “ “
                  Windows —-> “ “ “
                  Settings —-> “ “ “
                  Logout —-> None of the exit options work: I used a sudo poweroff
                  command from roxterm to terminate the session.
                  *************************************************************

                  To be continued ……
                  Len E.

                  • This reply was modified 1 week ago by Len E..
                  #138752
                  Member
                  Len E.

                    (original file uploaded not accepted)
                    Hi BobC:

                    The dmesgoutput.txt file is 58K in size.

                    I don’t know why it is not an acceptable upload ?????

                    Len E.

                    • This reply was modified 1 week ago by Len E..
                    #138757
                    Member
                    Robin

                      Since this is an old nvidia card you might want to upgrade the kernel to a 6.x version. I had to do this once for my notebook with an old nvidia card; reason is, the nouveau driver starts working for the older cards only from a distinct kernel version onwards (it was 5.15 if I recollect properly). Before this I encountered precisely the very same issues with nvidia (including logoff and suspend issues) you describe. Single way to run the old kernels would be to downgrade xorg to the version present at antiX 17.4.1 and install the proprietary nvidia 104.137 stuff (which covers your card also, seem 340.x drivers don’t.), what is not recommended (and what was probably never tested after antiX 19, there is a thread somewhere in forum describing the basics of the manoeuvre)

                      So my suggestion is: Update to most recent 6.x antiX or debian kernel.

                      ————–
                      Edit:
                      On antiX 23.1 full the 5.10.197-antix.1 kernel works fine for me on the old nvidia. So it might be possible the noveau driver updates have been backported to the later versions of 5.10 kernel series…

                      ————-
                      Edit 2

                      (original file uploaded not accepted)

                      Put it into a .zip container, then upload should work.

                      Windows is like a submarine. Open a window and serious problems will start.

                      #138760
                      Member
                      Len E.

                        Hi BobC:
                        Trying Robin’s zip recommendation:

                        Attachments:
                        #138762
                        Member
                        Len E.

                          Hi Robin:

                          Thanks for the tip on using zip !!!!
                          Earlier in this post, BobC recommended trying antix-23.1-full,
                          and based on your experience with it, I’ll certainly proceed.

                          Thanks again !!
                          Len E.

                          #138763
                          Moderator
                          BobC

                            The fact that sudo startx partially worked is forward progress.

                            Why don’t you try startx alone without sudo?

                            X doesn’t like running as root.

                            Please create and post the dmesgoutput.zip file.

                            Also create and post the xorglog.zip file created with the command below. If you like you can use the file manager to create zip files, but its just as easy to me to use the terminal, and easier to give an example here.

                            $ zip ~/xorglog.zip /var/log/Xorg.0.log
                              adding: var/log/Xorg.0.log (deflated 80%)
                            bobc@antix1:~
                            $ ls -l
                            total 228
                            drwxr-xr-x  2 bobc bobc   4096 Aug  3  2023 Desktop
                            drwxr-xr-x  2 bobc bobc   4096 Aug  3  2023 Documents
                            drwxr-xr-x  6 bobc bobc   4096 Jan 21 11:36 Downloads
                            drwxr-xr-x 20 bobc bobc   4096 Aug  3  2023 Live-usb-storage
                            drwxr-xr-x  2 bobc bobc   4096 Aug  3  2023 Music
                            drwxr-xr-x  3 bobc bobc   4096 Aug  5  2023 Pictures
                            -rw-r--r--  1 bobc bobc 186595 Jan 26 01:16 screenshot.jpg
                            drwxr-xr-x  3 bobc bobc   4096 Aug  6  2023 source
                            drwxr-xr-x  2 bobc bobc   4096 Jan 25 06:58 Videos
                            -rw-r--r--  1 bobc bobc   8200 Apr  5 20:05 xorglog.zip
                            
                            #138767
                            Moderator
                            BobC

                              So maybe a newer kernel will fix it. Robin’s video card is similar to yours.

                              https://www.antixforum.com/forums/topic/antix-23-on-32bit-single-core-impressions-and-observations/

                              #138839
                              Member
                              Len E.

                                Hi BobC: Further to your latest suggestions:

                                I rebooted antiX-23.1_base_386, waited for the command line prompt after the
                                blank screen, and logged in.
                                I ran startx, without sudo.
                                The command aborted with a series of error messages; the last 4 lines were:
                                (EE) Server terminated with error (1). Closing log file
                                xinit: giving up
                                xinit: Unable to connect to X server: Connection refused
                                xinit: server error
                                *****************************************************
                                I’ve attached the dmesgoutput and xorglog zip files.

                                Len E.

                                • This reply was modified 3 days, 19 hours ago by Len E..
                                #138844
                                Moderator
                                BobC

                                  I do see an ACPI firmware error and other ACPI errors.

                                  I don’t see any Xorg errors, but it obviously isn’t working.

                                  Did you try the failsafe boot option?

                                  Did you try Robin’s solution? 5.10 kernel isn’t high enough, needs to be over 5.15 if you read what he said. He has a similar card to yours, so try what worked for him.

                                Viewing 15 posts - 1 through 15 (of 33 total)
                                • You must be logged in to reply to this topic.