antiX-23-alpha1-runit-full (64bit) for testing

Forum Forums antiX-development Development antiX-23-alpha1-runit-full (64bit) for testing

Tagged: 

  • This topic has 436 replies, 24 voices, and was last updated Mar 21-8:50 pm by Brian Masinick.
Viewing 15 posts - 301 through 315 (of 437 total)
  • Author
    Posts
  • #100723
    Member
    Xunzi_23

      anticapitalista wrote

      -Perhaps the best way to tackle this is to have a simple tool that sets it up for user
      just by making a couple of choices and pressing a button.-

      Fine with me, perhaps on full version in control center so new users can quickly find the
      toolsetup?.

      Just need to somehow communicate that what is standard on other distros is off in antiX.

      Hard to make everybody happy.

      #100728
      Member
      Robin

        Seeing a strange issue here on antiX 23 testing (fully apt-upgraded most recently), 6.1.10 antiX kernel:

        Confusingly wrong file versions of executables are used:

        $ which yt-dlp
        /usr/bin/yt-dlp
        $ yt-dlp --version
        2023.01.06
        

        OK, that’s what was expected, it’s the default.

        When installing e.g. yt-dlp from manually download (from yt-dlp site, checksum matches) to

        $ sudo cp ./yt-dlp /usr/local/bin
        $ sudo chmod 755 /usr/local/bin/yt-dlp

        it is shown properly by

        $ which yt-dlp
        /usr/local/bin/yt-dlp

        But still:

        $ yt-dlp --version
        2023.01.06
        while:
        $ /usr/local/bin/yt-dlp --version
        2023.02.17

        So all commands using yt-dlp without explicitly prefixing with the full path to the new version fail on youtube with error due to still outdated version is used.

        And another one: (downloaded the amd 64 bit linux version from prasmussen for use in antiXscreenshot2, checksum matches)

        $ which gdrive
        /usr/local/bin/gdrive
        $ gdrive version
        bash: /usr/local/bin/gdrive: cannot execute: required file not found
        $ strace /usr/local/bin/gdrive
        execve("/usr/local/bin/gdrive", ["/usr/local/bin/gdrive"], 0x7ffca678e0f0 /* 41 vars */) = -1 ENOENT (No such file or directory)
        strace: exec: No such file or directory
        +++ exited with 1 +++
        $ ls -l /usr/local/bin/gdrive
        -rwxr-xr-x 1 root root 8210397 28. Mai 2021  /usr/local/bin/gdrive
        $ gdrive help
        bash: /usr/local/bin/gdrive: cannot execute: required file not found
        

        What am I doing wrong? Or is this an issue in antiX 23? I haven’t seen this happen on antiX 22. Please, could somebody countercheck, whether this happens only for me?

        Windows is like a submarine. Open a window and serious problems will start.

        #100731
        Forum Admin
        anticapitalista

          @Robin

          Upstream yt-dlp puts the script in /usr/local/bin and as far as I can tell it does not remove what is in /usr/bin
          Debia, MX Linux and antiX puts the binaries in /usr/bin.

          So either only use binaries from Debian/MX/antiX and wait for any upgrades, or only use the upgrade route directly from yt-dlp

          No idea about gdrive.

          Philosophers have interpreted the world in many ways; the point is to change it.

          antiX with runit - leaner and meaner.

          #100732
          Member
          Robin

            Many thanks @anticapitalista
            The solution for yt-dlp is pretty easy. You only need to copy it to /usr/bin instead of /usr/local/bin to make it work properly, even together with MPV.
            (sure, you have to install python3-brotli package manually for some strange reason to make it work, this is what the mx package also does.)
            On antiX 22 the mx-packaged yt-dlp works fine.

            But what I still don’t understand is:
            Why points “which” to the proper file, while it is actually not used by the antiX 23 system? That’s my basic concern. Will this happen to all the other programs in /usr/local/bin also when another version in /usr/bin is present? This version override by placing new versions to /usr/local/bin has worked fine in antiX 22 always.

            About gdrive: The binary works fine on antiX 22, and here on antiX 23 the system says „file not found”, even when present and set executable obvouosly, and to wherever I put the file. There ends my knowledge to find out why this strange thing happens. If not finding a solution I’ll have to remove the very function from antiXscreenshot2 for antiX 23. That would be a pitty.

            Windows is like a submarine. Open a window and serious problems will start.

            #100751
            Member
            Robin

              @anticapitalista
              Update: gdrive “file not found” issue is solved. Whatever file it was, which was not found: It’s an issue with the binary provided on the original site obviously. It’s not suitable for antiX 23 for some reason, even if it is clearly stated all libraries should be statically linked, able to run on any 64bit linux. (and the 32bit version on any 32bit linux)

              Working solution for antiX 23: Build it on your own from the sources.

              $ wget http://go.dev/dl/go1.20.1.linux-amd64.tar.gz
              $ shasum -a256 go1.20.1.linux-amd64.tar.gz

              should come up with
              000a5b1fca4f75895f78befeb2eecf10bfff3c428597f3f1e69133b63b911b02
              Then extract it the archive to /usr/go
              $ sudo tar -C /usr/local -xzf go1.20.1.linux-amd64.tar.gz
              Add the path to your environment variable:
              $ export PATH=$PATH:/usr/local/go/bin
              Check whether go was installed properly.

              $ go version
              go version go1.20.1 linux/amd64

              You need also to install build-essential package from the repos to make it work:

              sudo apt-get update
              sudo apt-get install build-essential

              Then build the gdrive file will work fine:

              $ go install github.com/prasmussen/gdrive@latest
              go: downloading github.com/prasmussen/gdrive v0.0.0-20230101202704-c12170d37eeb
              go: finding module for package golang.org/x/oauth2
              go: finding module for package github.com/soniakeys/graph
              go: finding module for package golang.org/x/oauth2/google
              go: finding module for package github.com/sabhiram/go-gitignore
              go: downloading github.com/soniakeys/graph v0.0.0
              go: downloading github.com/sabhiram/go-gitignore v0.0.0-20210923224102-525f6e181f06
              go: downloading golang.org/x/oauth2 v0.5.0
              go: finding module for package golang.org/x/net/context
              go: finding module for package google.golang.org/api/drive/v3
              go: finding module for package google.golang.org/api/googleapi
              go: downloading golang.org/x/net v0.7.0
              go: downloading google.golang.org/api v0.110.0
              go: found golang.org/x/oauth2 in golang.org/x/oauth2 v0.5.0
              go: found golang.org/x/oauth2/google in golang.org/x/oauth2 v0.5.0
              go: found github.com/sabhiram/go-gitignore in github.com/sabhiram/go-gitignore v0.0.0-20210923224102-525f6e181f06
              go: found github.com/soniakeys/graph in github.com/soniakeys/graph v0.0.0
              go: found golang.org/x/net/context in golang.org/x/net v0.7.0
              go: found google.golang.org/api/drive/v3 in google.golang.org/api v0.110.0
              go: found google.golang.org/api/googleapi in google.golang.org/api v0.110.0
              go: downloading cloud.google.com/go/compute/metadata v0.2.3
              go: downloading github.com/soniakeys/bits v1.0.0
              go: downloading google.golang.org/grpc v1.53.0
              go: downloading github.com/google/uuid v1.3.0
              go: downloading github.com/googleapis/gax-go/v2 v2.7.0
              go: downloading cloud.google.com/go/compute v1.18.0
              go: downloading go.opencensus.io v0.24.0
              go: downloading google.golang.org/protobuf v1.28.1
              go: downloading google.golang.org/genproto v0.0.0-20230209215440-0dfe4f8abfcc
              go: downloading github.com/googleapis/enterprise-certificate-proxy v0.2.3
              go: downloading golang.org/x/text v0.7.0
              go: downloading github.com/golang/groupcache v0.0.0-20200121045136-8c9f03a8e57e
              go: downloading github.com/golang/protobuf v1.5.2
              go: downloading golang.org/x/sys v0.5.0

              You’ll find the new binary file for gdrive in ~/go/bin folder. Copy it with root permissions to /usr/local/bin, et voilà:

              $ gdrive version
              gdrive: 2.1.1
              Golang: go1.20.1
              OS/Arch: linux/amd64
              $ gdrive help
              gdrive usage:
              gdrive [global] list [options]                                 List files
              gdrive [global] download [options] <fileId>                    Download file or directory
              ...
              

              Do you see any chance to put this into a package within antiX repo, so I can remove the voluminous binary file from the antiXscreenshot2 package and set a dependency instead to this deb package?

              Windows is like a submarine. Open a window and serious problems will start.

              #100758
              Member
              stevesr0

                re: trim.

                My question: Does a “default” antiX install set up trim in such a way that it DOESN’T immediately remove deleted files/directories?

                My assumption has been that the default trim setup depended upon the SSD, not the OS install. I understood that linux (Unlike Windows, where “delete” automatically sends a file to a trash folder) will automatically setup deleted files and directories for immediate deletion. If trim is set up by the manufacturer or the install to remove “deleted” files and directories immediately, they will be gone for good and generally NOT recoverable with testdisk or other utilities.

                So I am interested in understanding the safest way of setting up a system if it has an SSD that might be setup in its firmware to use trim. If I don’t have delete set up to send a file or directory to a trash folder, where/how do I edit the trim setup so it DOESN’T immediately run, but only periodically or when I tell it to?

                stevesr0

                (I am asking not only for myself, but for what I assume might be many others who don’t understand the ins and outs of trim. A reference to a step by step would be great.)

                #100771
                Member
                Xunzi_23

                  @steves,
                  please stick to the other thread where you posted pretty much same.

                  The impossible takes a little longer.

                  Maybe you should use the FT10 from PPC which if I remember correctly includes a
                  recycle bin like windoze.

                  #100801
                  Member
                  stevesr0

                    Hi Xunzi_23,

                    I think having a single thread for comments on trim would be great. Currently, I see it mentioned on four active threads. It seems tough to arrange to consolidate them into one.

                    I was certainly guilty of posting the same comment on multiple threads. I figured it was a reasonable point to make and people reading one thread might not seek to read all.

                    Thanks for your comment.

                    stevesr0

                    #101313
                    Member
                    Robin

                      Next test:

                      Just found out my monitor has invisible built in speakers, to be accessed by hdmi audio through video card. So I gave it a first time try. Here my findings on antiX 23,alpha, most recently apt-upgraded, running 6.1.10 antix kernel.

                      To make it short: everything works great out of the box.

                      – hdmi audio is supported for asus graphics card (ATI) immediately after booting.
                      – no boot parameter was needed.
                      – no special alsa setting needed.
                      – no additional sound server (piperwire, pulseaudio, jack or whatever) was needed.
                      – you simply have to unmute the hdmi card in alsamixer (Use F6 to select the HDMI device, there will be probably a single switch, press M to toggle mute/unmute the output.)

                      For a quick test do:

                      $ inxi -A
                      Audio:
                        Device-1: Intel 5 Series/3400 Series High Definition Audio
                          driver: snd_hda_intel
                        Device-2: AMD Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series]
                          driver: snd_hda_intel
                        Sound Server-1: ALSA v: k6.1.10-antix.1-amd64-smp running: yes

                      – works fine on plain alsa, but there is no volume control available for this device. Probably the hdmi sound chip doesn’t provide hardware volume control. You can only mute and unmute the device. (On cost of system resources you can add an alsa software volume control plugin, that’s the way pulseaudio also deals with this issue, but it is no good on weak machines.) For the following just make sure the control is actually unmuted.

                      $ aplay -l
                      **** List of PLAYBACK Hardware Devices ****
                      card 0: MID [HDA Intel MID], device 0: VT1708S Analog [VT1708S Analog]
                        Subdevices: 1/1
                        Subdevice #0: subdevice #0
                      card 0: MID [HDA Intel MID], device 1: VT1708S Digital [VT1708S Digital]
                        Subdevices: 1/1
                        Subdevice #0: subdevice #0
                      card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0 *]
                        Subdevices: 1/1
                        Subdevice #0: subdevice #0

                      From the output take the card number and the device number of the card, (in the example here: card 1, device 3) and insert the values found to the following command behind “plughw:”, comma separated:

                      $ aplay -D plughw:1,3 /usr/share/sounds/alsa/Front_Center.wav
                      or/and
                      $ speaker-test -D "hw:1,3" -c2 -twav

                      OK, this monitor has pretty poor audio quality if you are used to hifi audio output via external old school analog stereo amplifier… But at least it works.

                      To use HDMI-out you can either set it as default alsa device, or tell each application you want to listen to, this way to use the hdmi device as output. Example for MPV: start it on console entering the command

                      mpv --audio-device="alsa/hw:1,3" './videofile.mp4'

                      (use the findings about card and device number from the test above here also)

                      In MPV you’ll have available a software volume control by pressing 0 and 9 keys, or m key for software toggle mute (this doesn’t affect hardware mute toggle in alsamixer).

                      Interesting: having two or more separate audio devices present, you can assign different programs to use the different output independently. While playing music through the hifi output you can assign all kind of system sounds to the additional hdmi monitor output.

                      1st terminal window (e.g. roxterm)
                      mpv --audio-device="alsa/hw:1,3" './videofile_01.mp4'
                      2nd terminal window (e.g. roxterm)
                      mpv --audio-device="alsa/hw:0,0" './videofile_02.mp4'

                      or even, if you have connected two monitors and run on a twinview setup:
                      1st terminal window (e.g. roxterm)
                      mpv --audio-device="alsa/hw:1,3" --fs --fs-screen=0 './videofile_01.mp4'
                      2nd terminal window (e.g. roxterm)
                      mpv --audio-device="alsa/hw:0,0" --fs --fs-screen=1 './videofile_02.mp4'

                      Makes much more sense with different programs, e.g. playing music using xmms to the hifi analog output, while all the system sounds and sound from other programs are strictly mapped to the HDMI monitor, so you will not hear an annoying “BING” from some firefox window on full loudness in between the music, scarring you the pants of, but it will come in modest loudness from the monitor speakers instead.

                      Works distortion free on an intel core i3, can’t check on other (weaker) machines, these don’t have hdmi graphics cards here.

                      Windows is like a submarine. Open a window and serious problems will start.

                      #101315
                      Member
                      Robin

                        Solution for missing volume alsamixer controls of hdmi output found.

                        alsamixer with added hdmi volume control

                        Soft volume control can get added to the alsamixer panel by creating the file ~/.asoundrc in homedirectory:

                        pcm.asushdmi {
                            type            softvol
                            slave.pcm       "hw:1,3"
                            control.name    "HDMI Playback Volume"
                            control.card    1
                        }

                        After the addition you’ll need to run speaker-test on this device to first time use it. Only then the slider will be visible in alsamixer.
                        $ speaker-test -D "asushdmi" -c2 -twav

                        Then open alsamixer, either from terminal window or from antiX taskbar context menu of speaker icon. F6 Key, select the HDMI devive. The volume slider should be present now. It can be used by all programs now as audio output. You’ll notice only “HDMI” as part of the assigned name is displayed. The rest of the name string was only used to determine whether the control should be only used for playback, not for recording. This is necessary, since the hdmi chip doesn’t provide any audio recording channels or controls.

                        alsamixer with added hdmi volume control

                        To make use of this new mixer control, you need to tell the programs you plan to send their output to HDMI instead of default analog hifi output, to use “asushdmi” instead of “default”.

                        Example similar to the one from above, but now using the alsamixer controls:

                        1st terminal window:
                        mpv --audio-device="alsa/asushdmi" './videofile_01.mp4'
                        2nd terminal window:
                        mpv --audio-device="alsa/default" './videofile_02.mp4'

                        You can now use the controls in alsamixer to regulate the volume for each output device separately now.

                        To remove an erroneously or wrongly set contol, you need two steps:

                        1.) Remove the lines containing the section containing the additional control definition from the ~/.asoundrc file in your home folder, save it.
                        2.) Then in a terminal window use the alsactl clean command on the device. To remove the above example use:
                        alsactl clean 1 "name='asushdmi'" "name='HDMI Playback Volume'"
                        wherein 1 is the card number, the names must match the control name and the new device name you had assigned.

                        Further reading:
                        http://alsa.opensrc.org/Softvol
                        http://alsa.opensrc.org/How_to_use_softvol_to_control_the_master_volume

                        Maybe this helps to find a way to have the alsamixer’s hdmi audio output controls present by default in future antiX.

                        Windows is like a submarine. Open a window and serious problems will start.

                        #101323
                        Moderator
                        Brian Masinick

                          @Robin: Thank you very much for sharing your findings and explanation of the mixer controls.
                          This is valuable information and greatly appreciated.

                          --
                          Brian Masinick

                          #101338
                          Member
                          calciumsodium

                            Concerning web browsers in antiX23 alpha 1:

                            I wanted to test the use of web browsers in this alpha 1 test system on an older two-core CPU system.

                            I downloaded these latest browsers:

                            chromium 110.0.5481.177-1
                            firefox-esr 102.8.0esr-1
                            google-chrome-stable 110.0.5481.177-1
                            palemoon 32.0.0-1.gtk3.mx21
                            seamonkey amd64 2.53.15~mozillabinaries-1mx21+1

                            For each of these tests, I watched the youtube video on each of these browsers:

                            http://www.youtube.com/watch?v=hS_VW8pdIec

                            For each browser, I waited until the CPU % stabilized and recorded the CPU %.
                            Then I rebooted to reset the computer for the next test.

                            These are my results:

                                                liquorix 6.1.13-1 kernel            antiX 6.1.10 kernel
                            browser             CPU %                               CPU%
                            chromium            23 %                                36 %
                            firefox-ESR         55 %                                65 %
                            google-chrome       20 %                                32 %
                            palemoon            87 %                                88 %
                            seamonkey           82 %                                48 %
                            mpv (360p)          8 %                                 10 %
                            

                            The chromium browsers performed best on both the liquorix and the antiX kernels.
                            Palemoon and seamonkey did not perform well on the liquorix kernel.
                            Palemoon did not perform well on the antiX kernel.
                            Seamonkey performed well on the antiX kernel.

                            This is my test system:

                            System:
                              Host: antix1 Kernel: 6.1.10-antix.1-amd64-smp arch: x86_64 bits: 64
                                Desktop: IceWM v: 3.3.1
                                Distro: antiX-23-runit_x64-full Grup Yorum 3 February 2023
                            Machine:
                              Type: Desktop System: Dell product: Inspiron 530 v: N/A
                                serial: <superuser required>
                              Mobo: Dell model: 0G679R v: A00 serial: <superuser required> BIOS: Dell
                                v: 1.0.18 date: 02/24/2009
                            CPU:
                              Info: dual core Intel Core2 Duo E7300 [MCP] speed (MHz): avg: 1596
                                min/max: 1600/2667
                            Graphics:
                              Device-1: Intel 82G33/G31 Express Integrated Graphics driver: i915
                                v: kernel
                              Display: x11 server: X.Org v: 1.21.1.6 driver: X: loaded: intel gpu: i915
                                resolution: 1280x1024~60Hz
                              OpenGL: renderer: i915 (: G33) v: 2.1 Mesa 22.3.3
                            Network:
                              Device-1: Intel 82562V-2 10/100 Network driver: e1000e
                              Device-2: Realtek RTL8188FTV 802.11b/g/n 1T1R 2.4G WLAN Adapter type: USB
                                driver: rtl8188fu
                            Drives:
                              Local Storage: total: 232.89 GiB used: 9.98 GiB (4.3%)
                            Info:
                              Processes: 133 Uptime: 1m Memory: 2.42 GiB used: 447.9 MiB (18.1%)
                              Shell: Bash inxi: 3.3.19
                            #101339
                            Moderator
                            Brian Masinick

                              @calciumsodium:

                              Great idea and excellent tests!

                              That makes me interested in examination of the modules and parameters set for our kernels versus the Liquorix kernels.

                              Whatever they are, it’s clear that Liquorix is optimized for high CPU performance, which also requires higher CPU utilization. That’s fine with current technology hardware and not at all for seriously aging systems.

                              antiX is definitely optimized for resource conservation and your tests empirically demonstrate that very clearly.

                              --
                              Brian Masinick

                              #101341
                              Member
                              olsztyn

                                These are my results:

                                Thank you for these meticulous tests. Surprising results…

                                Live antiX Boot Options (Previously posted by Xecure):
                                http://antixlinuxfan.miraheze.org/wiki/Table_of_antiX_Boot_Parameters

                                #101371
                                Member
                                grey_rat

                                  Graphics:
                                  Device-1: Intel 82G33/G31 Express Integrated Graphics driver: i915
                                  v: kernel
                                  Display: x11 server: X.Org v: 1.21.1.6 driver: X: loaded: intel gpu: i915
                                  resolution: 1280×1024~60Hz
                                  OpenGL: renderer: i915 (: G33) v: 2.1 Mesa 22.3.3

                                  For Mesa 22+ need install 21.3.9 “mesa-amber” http://ftp-master.debian.org/new/mesa-amber_21.3.9-1.html
                                  For G31 need enabled hardware acceleration https://www.antixforum.com/forums/topic/browsers-for-old-cpus/page/9/#post-98718
                                  In Firefox <84, palemoon, seamonkey hardware acceleration disabled by default
                                  For Firefox 92+ need OpenGL 3 Video Cards. For G31 media.av1.enabled – false or extension h264ify, gfx.webrender.unaccelerated-widget.force — true https://www.antixforum.com/forums/topic/browsers-for-old-cpus/page/10/#post-101210

                                  • This reply was modified 1 year, 2 months ago by grey_rat.
                                  • This reply was modified 1 year, 2 months ago by grey_rat.
                                  • This reply was modified 1 year, 2 months ago by grey_rat.
                                Viewing 15 posts - 301 through 315 (of 437 total)
                                • You must be logged in to reply to this topic.