antiX-23-alpha1-runit-full (64bit) for testing

Forum Forums antiX-development Development antiX-23-alpha1-runit-full (64bit) for testing

Tagged: 

  • This topic has 436 replies, 24 voices, and was last updated Mar 21-8:50 pm by Brian Masinick.
Viewing 15 posts - 346 through 360 (of 437 total)
  • Author
    Posts
  • #101626
    Member
    Wallon

      In antiX Store (packageinstaller), I can’t install Java for LibreOffice.

      #101627
      Forum Admin
      anticapitalista

        Many thanks to everyone who has posted feedback in this thread.
        In a few days, I’ll close this thread because I’m going to upload beta1 and testers should download that instead and provide further feedback particularly things that got fixed and things that still need fixing.

        beta1 *might* be up-gradable to final – but no promises.

        Philosophers have interpreted the world in many ways; the point is to change it.

        antiX with runit - leaner and meaner.

        #101632
        Member
        Xunzi_23

          Thanks for info anticapitalista, My little based on experience, wishlist,
          the return of sound card chooser to control center, so many devices need it, 3
          user devices in last two weeks. Others will need it for testing on the beta1.

          I also see users/shoppers following an article in Heise Ct and asking for sound cards,
          to improve output quality. Good Audigy is getting rarer than hens teeth.

          6 Series kernel so NVidia equipped devices do not green screen crash. Affected 4
          devices during last two weeks. One user the welshman, both of his computers
          refused to boot on either new or old kernel. Same goes for the one I am using now.

          My stick with the kernel 6 you offered runs without issues using open drivers.

          • This reply was modified 1 year, 2 months ago by Xunzi_23.
          #101634
          Member
          Xunzi_23

            Libreoffice, needs
            default-jre default-jre-headless libreoffice-java-common,

            Be nice to have in Package installer as otherwise users have to search
            LO Org for requirements.

            An environment of choice such as oracle or amazon offerings can also be
            used.

            Without the java the excellent LanguageTool extension will not work,
            highly recommend it.

            Latest Libreoffice is still stuck in debian experimental. The Months roll by.
            Packet from LO Org is causing no trouble (up to now anyway :-).

            • This reply was modified 1 year, 2 months ago by Xunzi_23.
            #101657
            Member
            techore

              @anticapitalista, at what spot does the core release fall into with the new releases? Last? I stated that I would be patient and will be.. but curious. No PM so couldn’t reach out to you that way so I apologize if off topic.

              #101666
              Moderator
              Brian Masinick

                @Wallon: I went back to verify the usual situation and the alternative to resolve it.

                The package locales contains the locale definitions; this is probably the package that contains the 71 locales.
                The package localepurge is the usual Debian based package to remove locales. It has a GUI interface and you uncheck the locales you do not wish to include.

                Our distribution has another package, locale-antix.

                “This package contains a GUI application that lets the user set and change
                the system language (or user language if running desktop-session-antix).
                It also brings a script to recommend the correct packages to improve
                language support for installed apps automatically. Try it, the command is
                check-lang-support.”

                The one I have experience with is localepurge; I had to go into the package list to find it and make sure I had the name correct, but I use this with antiX, MX Linux, siduction, and any other Debian-based distributions I use.

                --
                Brian Masinick

                #101667
                Member
                Wallon

                  @Brian: Thank you for doing this reminder. I also use the three options you mentioned.

                  As a translator, I worked a lot on this antiX program. Users will be able to find this program like this:
                  1) Main menu,
                  2) Applications,
                  3) Preferences,
                  4) User language.
                  I personally use all the options of this nice little program.

                  But I think it would be easiest during the installation from the Live Demo USB stick to install at most two languages. The user’s language and maybe English (USA).

                  Best regards,
                  Wallon

                  #101668
                  Moderator
                  Brian Masinick

                    Regarding post #101613 concerning zzzFM opening all the time, I looked in the zzzFM manual and found these words near the bottom in reference to the behavior of udevil.

                    “Set SUID

                    After installing udevil, /usr/bin/udevil should have the suid bit already set. If not, set it like this:

                    sudo chown root:root /usr/bin/udevil
                    sudo chmod u+s,go-s,ugo+x /usr/bin/udevil
                    ls -l /usr/bin/udevil
                    -rwsr-xr-x 1 root root 226625 May 22 08:13 /usr/bin/udevil

                    OR, to restrict execution of udevil to the ‘plugdev’ group only:

                    sudo chown root:plugdev /usr/bin/udevil
                    sudo chmod u+s,go-s,o-x /usr/bin/udevil
                    ls -l /usr/bin/udevil
                    -rwsr-xr– 1 root plugdev 226625 May 22 08:13 /usr/bin/udevil

                    OR, if you don’t want to use udevil for mounting, you can unset suid:

                    sudo chown root:root /usr/bin/udevil
                    sudo chmod ugo-s,ugo+x /usr/bin/udevil
                    ls -l /usr/bin/udevil
                    -rwxr-xr-x 1 root root 226625 May 22 08:13 /usr/bin/udevil

                    You can also limit users and groups by editing /etc/udevil/udevil.conf”
                    zzzFM manual at file:///usr/share/doc/zzzfm/zzzfm-manual-en.html#udevil-and-devmon

                    --
                    Brian Masinick

                    #101669
                    Moderator
                    Brian Masinick

                      In addition, from file:///usr/share/doc/zzzfm/zzzfm-manual-en.html#udevil-and-devmon

                      Networks and Files

                      By default, /etc/udevil/udevil.conf is set to permit mounting of only local fileystems and ISO files,
                      with mounting of networks disallowed. To allow networks and files to be mounted, in /etc/udevil/udevil.conf set:

                      allowed_types = $KNOWN_FILESYSTEMS, file, cifs, nfs, curlftpfs, sshfs

                      You may also need to install curlftpfs or ftpfs (ftp://), cifs-utils or smbfs (smb://), and sshfs (ssh://)

                      --
                      Brian Masinick

                      #101691
                      Member
                      Robin

                        locate command fails on antiX 23 alpha:

                        $ locate antixcc
                        /var/lib/plocate/plocate.db: No such file or directory
                        $ locate leafpad
                        /var/lib/plocate/plocate.db: No such file or directory
                        $ locate geany
                        /var/lib/plocate/plocate.db: No such file or directory

                        Ok, the database needs to get initialised first. But:

                        sudo updatedb
                        runs astonishlingly short, one second at the most, without adding any new files to the database obviously. But the error message is gone after this, while still not locating any files:

                        $ locate antixcc
                          (no output)
                        $ locate leafpad
                          (no output)
                        $ locate geany
                          (no output)

                        /etc/updatedb.conf file doesn’t seem to differ essentially from the one found on antiX 22.

                        Any suggestions?

                        Windows is like a submarine. Open a window and serious problems will start.

                        #101698
                        Moderator
                        Brian Masinick

                          @Robin: I’ll have to check my antiX 23 instance to see if I get the same result; on my antiX 22 system, two of the three requests return the package tree; however leafad does not exist. You probably intended to write locate leafpad, which does exist in my antiX 22 system.

                          --
                          Brian Masinick

                          #101701
                          Forum Admin
                          Dave

                            @Robin.
                            I have the same error for /var/lib/plocate/plocate.db missing on antiX 23. If I ran “sudo updatedb” I also have nothing in return from the database. If I do not use sudo and log in as root via su, running updatedb will take longer and then the locate command works as expected. This is using a virtualbox install (not live). Does it work the same way on your system?

                            Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

                            #101703
                            Member
                            Robin

                              @Brian: You are true, it should read leafpad. It was an example merely, so it doesn’t count. Have fixed it in the above posting anyway. Yes, on antiX 22 everything works fine, also for me. It’s only about antiX 23.
                              @Dave: Unfortunaly the behaviour doesn’t change when running the command as root here. When using the -v commandline option it turns out actually no file is added to the database:

                              root@antix1:/# updatedb -v
                                (no output)
                              root@antix1:/# ls -l /var/lib/plocate/plocate.db
                              -rw-r----- 1 root plocate 969 11. Mär 16:04 /var/lib/plocate/plocate.db
                              root@antix1:/# rm /var/lib/plocate/plocate.db
                              root@antix1:/# updatedb -v
                                (no output)
                              root@antix1:/# ls -l /var/lib/plocate/plocate.db
                              -rw-r----- 1 root plocate 969 11. Mär 16:05 /var/lib/plocate/plocate.db

                              (while on antiX 22 using the -v command line option makes an endless list scrolling up the console window. Btw, on antiX 22 the path to the database is /var/lib/mlocate/mlocate.db)

                              Windows is like a submarine. Open a window and serious problems will start.

                              #101704
                              Forum Admin
                              Dave

                                @Robin.
                                Ok then are you using a live version of antiX for testing?
                                If so it is likely because overlayfs is being used on the root partition which is likely seen by updatedb as a bind mount.
                                Try setting prune_bind_mounts=”yes” to prune_bind_mounts=”no”

                                Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

                                #101705
                                Member
                                Robin

                                  then are you using a live version of antiX

                                  Yes, it’s a frugal.

                                  it is likely because overlayfs is being used on the root partition which is likely seen by updatedb as a bind mount

                                  Has this been changed from antiX 22 to antiX 23? Since also antX 22 is running as frugal install here, have used identical install procedure.

                                  Try setting prune_bind_mounts=”yes” to prune_bind_mounts=”no”

                                  Fixes the issue. Database is updated now properly when using sudo as well as when being root.
                                  Wondering, since I had checked before that on antiX 22 the very setting also reads “yes”, and there it works with this.

                                  Many thanks, Dave!

                                  Windows is like a submarine. Open a window and serious problems will start.

                                Viewing 15 posts - 346 through 360 (of 437 total)
                                • You must be logged in to reply to this topic.