antix-23 arch i386 / kernel uname with “-486”

Forum Forums Official Releases antiX-23 “Arditi del Popolo antix-23 arch i386 / kernel uname with “-486”

  • This topic has 8 replies, 3 voices, and was last updated Apr 25-10:23 pm by OsgPCQ.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #140102
    Member
    OsgPCQ

      Hi,

      If I understood correctly i386’s arch of antiX after v15 are compiled at least for i686/P6 CPU.
      (With some CPU features like CMOV, so not compatible even with i586/P5).

      But:
      uname -a
      Linux antix1 5.10.188-antix-1-486-smp #1 SMP…

      To avoid more confusion do you think it’s possible to remove or change the “-486”?

      This request is to try to have better information for people playing with retro-computing.

      Best regards
      Vince

      #140105
      Member
      Robin

        I think you are wrong. Check the repos, there are always two flavours of an 32 bit antiX kernel: -486 and -686. I think the reason why one of them is named -486 is simply since it wouldn’t run on a 386 CPU… The -686 flavour is self explaining, I guess.

        $ apt-cache search linux-image | grep antix | grep -v amd64
        linux-image-4.19.276-antix.2-486-smp - Linux kernel, version 4.19.276-antix.2-486-smp
        linux-image-4.19.276-antix.2-686-smp-pae - Linux kernel, version 4.19.276-antix.2-686-smp-pae
        linux-image-4.4.0-296-antix.1-486-smp - Linux kernel, version 4.4.0-296-antix.1-486-smp
        linux-image-4.4.0-296-antix.1-686-smp-pae - Linux kernel, version 4.4.0-296-antix.1-686-smp-pae
        linux-image-4.9.0-326-antix.1-486-smp - Linux kernel, version 4.9.0-326-antix.1-486-smp
        linux-image-4.9.0-326-antix.1-686-smp-pae - Linux kernel, version 4.9.0-326-antix.1-686-smp-pae
        linux-image-5.10.181-antix.1-486-smp - Linux kernel, version 5.10.181-antix.1-486-smp
        linux-image-5.10.181-antix.1-686-smp-pae - Linux kernel, version 5.10.181-antix.1-686-smp-pae
        linux-image-5.10.188-antix.1-486-smp - Linux kernel, version 5.10.188-antix.1-486-smp
        linux-image-5.10.188-antix.1-686-smp-pae - Linux kernel, version 5.10.188-antix.1-686-smp-pae
        linux-image-5.10.197-antix.1-486-smp - Linux kernel, version 5.10.197-antix.1-486-smp
        linux-image-5.10.197-antix.1-686-smp-pae - Linux kernel, version 5.10.197-antix.1-686-smp-pae

        Windows is like a submarine. Open a window and serious problems will start.

        #140110
        Member
        OsgPCQ

          The name 686-smp-pae is indeed clear (it’s not the kernel booted by default).

          If I’m not wrong the i386/80386 kernel drop support is on 2012 since kernel v3.8.
          But the -486 is definitely not working on my real i586.
          And it’s exactly why I’m asking (not sure if it’s the kernel or something else compiled with CMOV,…).

          On Debian the last version working on i586/P5 is v8.11.1 (Jessie).
          And for example with Debian v11.8.0:
          uname -a
          Linux debian 5.10.0-26-686 #1 SMP

          #140124
          Member
          Robin

            Somewhere in the garret I have still a true 80486dx PC… Would have to try to revive it to check out whether the antiX 486 kernels would run on it or not. Unfortunately I don’t have spare time to do it in near future.

            Have you tried these kernels from the repos on your machine already?

            linux-image-4.4.0-296-antix.1-486-smp
            linux-image-4.9.0-326-antix.1-486-smp
            linux-image-4.19.276-antix.2-486-smp

            Not all kernels work on a specific hardware, so it’s try and error to find a working one, even if it is marked for the generation of CPU.

            Windows is like a submarine. Open a window and serious problems will start.

            #140160
            Member
            OsgPCQ

              Hi @robin,

              First at all: thank you, you make me notice all my antiX v23.1 i386 installation on i686 CPU was still using the NoPAE kernel!
              So I updated it: aptitude install linux-image-5.10.197-antix.1-686-smp-pae

              About the antiX and i80586:
              * antiX v15.1 arch:i386 is working fine on a real i80586/P5, and if I’m not wrong I would say it’s the last version working.
              * antiX v23.1 arch:i386 I never reached to run it on i586, on i686 yes it’s worked, in all case you will need 128MB of memory (and no memory shared with the video card because the initramfs is pretty big).

              I’m now wondering how to install a old kernel as you are mentioning but maybe the kernel is just okay actually and it’s “just” all other packages compiled with new CPU feature?
              (As antiX based on Debian, and the i586 support ended on Debian 8.11.1 (Jessie) https://lists.debian.org/debian-devel-announce/2016/05/msg00001.html).

              Maybe will try to boot antiX v23.1 i386 on my i586 pointing init directly to a bash shell to see what happens (not sure how relevant could be the test)…

              Best regards
              Vince

              PS: Kernel running in my Debian 8.11.1 (i586)
              ii linux-image-3.16.0-11-586 3.16.84-1 i386 Linux 3.16 for older PCs

              #140225
              Member
              OsgPCQ

                So tested the antiX v23.1 arch:i386 with init=/bin/bash :
                * on PIII(i686) with 128Mo(and video memory shared) I got the prompt and all is working (uname, pstree, …).
                * on P5(i586) with 128Mo(and video 16Mo dedicated) got a kernel Error.

                On i586:
                Recording the screen, sometime like this:
                * …
                * Trying to unpack rootfs image as initramfs…
                * …
                * …usbcore
                * …usbhid?
                * …input
                * …drop_monitor
                * …NET: registred protocol family 10
                * …traps: modprobe[76] trap invalid opcode ip:b7f83225 sp:… in ld-linux.so.2[b7f68000+23000]
                * … (moretraps)
                * …
                * … NET: Registered protocol family 17
                * …
                * … Loading compiled-in X.509 certificates
                * … traps: modprobe[84] trap invalid opcode ip:b7fe7225 sp:bf861680 error:0 in ld-linux.so.2[b7fcc000+23000]
                * …
                * …Key type encrypted registered
                * …evm: Initialising EVM extended attributes:
                * …Freeing unused kernel image (initmem) memory: 764K
                * …panic+0xaf/0x270
                * …EIP: 0x80a1d0e
                * …
                * … Kernel Offset: disabled
                * … —[ end Kernel panic – not syncing: Attempted to kill init! exit code=0x000000004 ]—

                Maybe the point is after antiX v15 ld-linux / glibc are compiled with CMOV,… CPU extensions.
                (Was more or less what I understood initially).

                What we have:
                * We still have two kernels the “i486” and the “i686” PAE.
                * i686 PAE is not the default one.
                So my SUPPOSITION here, it’s to support some old i686 CPU without PAE!

                About the name of the kernel I SUPPOSE its really a i486 compiled one (and “”working”” on my i586), but the rest of the distribution is i686 compiled?

                So maybe my initial request just don’t make any sense as kernel looks a real i486 one!!! 😉
                Arch i386, and i386 i486 i586 i686 and fun stuff, but maybe this more even more!

                Really curious to have your opinion, confirmation and all corrections here!

                #140236
                Forum Admin
                anticapitalista

                  Have a look at the kernel config file in /boot to see what is happening

                  Philosophers have interpreted the world in many ways; the point is to change it.

                  antiX with runit - leaner and meaner.

                  #140336
                  Member
                  OsgPCQ

                    Thank you @anticapitalista!

                    config-5.10.197-antix.1-486-smp
                    #CONFIG_M486SX is not set
                    CONFIG_M486=y
                    #CONFIG_M586 is not set
                    #CONFIG_M586TSC is not set
                    #CONFIG_M586MMX is not set
                    #CONFIG_M686 is not set
                    #CONFIG_MPENTIUMII is not set
                    #CONFIG_MPENTIUMIII is not set
                    #CONFIG_MPENTIUMM is not set
                    #CONFIG_MPENTIUM4 is not set
                    CONFIG_X86_32=y
                    CONFIG_X86=y

                    config-5.10.197-antix.1-686-smp-pae
                    CONFIG_M686=yq
                    CONFIG_X86_CMOV=y

                    Will check soon the glibc…

                    #140445
                    Member
                    OsgPCQ

                      apt-get source libc6
                      cd /debian
                      vi rules
                      But I’m not able to understand how it’s compiled, lot of
                      dpkg-architecture -qDEB_BUILD_ARCH

                      ldd /usr/lib/i386-linux-gnu/libc.so.6
                      ldd /lib/ld-linux.so.2
                      statically linked

                      Have two questions more:
                      * how to know the compilation option for ld-linux?
                      * kernel are maintained directly par Debian or antiX team?

                    Viewing 9 posts - 1 through 9 (of 9 total)
                    • You must be logged in to reply to this topic.