antiX-23-full-runit 64 bit for testers only

Forum Forums antiX-development Development antiX-23-full-runit 64 bit for testers only

  • This topic has 233 replies, 25 voices, and was last updated Sep 4-8:05 am by blur13.
Viewing 15 posts - 1 through 15 (of 234 total)
  • Author
    Posts
  • #112870
    Forum Admin
    anticapitalista

      Although the downloaded iso shows it is a ‘proper’ release and not a beta,
      I would like some feedback on how viable this version of antiX with many changes to runit will work.
      I repeat this is NOT a final version, but a beta.

      I have updated how antiX uses runit to remove as much dependency on sysVinit as possible.
      All seem to work in my tests, but I have basically kept to the defaults and not installed anything.

      I suspect that there will be issues with unmounting devices on reboot/shutdown, but I really don’t know.

      So, please give it a trial running live, fugal with and without persistence/remastering as well as installed to a hard drive or a virtual machine.

      If everything is working well, then this will become the final of runit-full.
      If there are issues, then I will revert back to our runit implementation used in beta2.

      For our translators, this has all the latest changes but I’m sure I have missed some things so your input will be very valuable.

      Here is the link to the iso: http://download.tuxfamily.org/antix/Testing/

      Philosophers have interpreted the world in many ways; the point is to change it.

      antiX with runit - leaner and meaner.

      #112876
      Member
      calciumsodium

        Hello,
        Thanks for letting us test new software.
        For the purposes of this test, I wanted to compare the new init setup of this version (I will call this system antiX23 b3) versus the antiX23 b1 earlier version which has the previous runit init setup. I have them both installed in different partitions on this same computer. I tried to make both systems the same in terms of software that I use and same startup.

        I used start-t icewm to compare boot times.
        The new antiX23 runit system boots faster than the older runit system of antiX23 b1. It is noticeable.

        
        system         boot time (s)
        antiX23 b1     24.6
        antiX23 b3     20.0
        

        In terms of performance, mpv runs good. Firefox-esr runs OK. Google-chrome runs great.

        I have to report on the sound. It seems to me that the sound in my antiX 23 b1 system, which just uses ALSA, sounds very good and crisp.

        The sound in this new antiX 23 b3 with pipewire seems muffled compared to my antiX 23 b1 system, on the same computer with the same speaker.

        Several years ago, I tested pipewire when Xecure first suggested trying it. I did not have a good impression of it back then. I am trying pipewire with a fresh set of ears without any bias. I still don’t think it is any better than the basic ALSA. Just my own opinion.

        Besides this, very good system.

        • This reply was modified 7 months, 1 week ago by calciumsodium.
        • This reply was modified 7 months, 1 week ago by calciumsodium.
        #112884
        Member
        RJP

          Very good, only couple of minor things. Menu has still mixed localized and there is an AT-SPI error when installing programs via Terminal.

          • This reply was modified 7 months, 1 week ago by RJP.
          • This reply was modified 7 months, 1 week ago by RJP.
          #112891
          Member
          Xunzi_23

            Sadly No sound. Setup of Audigy card and speaker test successful.

            No Output sm tube ytfzf and player for applications it
            Looks like output is locked to S/PDIF I use analog audio port

            That looking in Pulse audio volume control, seems pulse audio
            and pipewire are installed and active.

            First time I ever had sound issues with antiX in either stable or beta 1 and 2.

            Seems to revert to alsa means rather more than just having a switch entry in control
            center as had been requested some time ago. I have not found a suitable for noobs way
            but may be blind to the obvious.

            Having experienced the gritty degraded sound from pulse my high quality card and
            speakers would be wasted with it.

            #112894
            Member
            madanadam

              In live cd if I select Turkish lang both kernel crashes. I think it’s because of plain apostroph in translation. It’s because of -(-. I will change them in transifex before latest release. I have replaced plain apostroph (‘) with (’) in Turkish translations e few days ago. But initrd uses old one.

              Current Transifex Translation:
              http://app.transifex.com/anticapitalista/antix-development/translate/#tr/live-initrd-init/81616736

              Error is at line 179 of file ‘/live/locale/xlat/tr/init.xlat’

              _Unknown_option_s_in_X_Unknown_option_s_Y_="%s'de bilinmeyen seçenek(ler). Bilinmeyen seçenek(ler): %s"

              • This reply was modified 7 months, 1 week ago by madanadam.
              Attachments:
              #112897
              Moderator
              caprea

                @RJP, the DBus.error.ServiceUnknown will go away, if at-spi2-core gets installed.

                I also would like antiX to stick with pure alsa, pipewire is fine if someone needs eg. bluetooth sound, but if pipewire is not needed antix should stay mean and lean, clean alsa.

                #112898
                Member
                Xunzi_23

                  Got sound back in ytfzf combo, the process was rather involved, removing a lot of packages
                  reinstalling MPV, installing alsamixergui. Still no sound.

                  Key in this case: Also needed to copy over from earlier home.

                  .asoundrc file: Content
                  defaults.pcm.!card Audigy2
                  defaults.ctl.!card Audigy2

                  Sorry to say in this case inclusion of active pipewire was a distinct put off. Getting sound certainly
                  nothing a new user should be subjected to.

                  I still think the better way is to have alsa as standard and a scripted pipewire pulse setup button
                  for anyone having issues they may be able to solve that way.

                  I was unable to get sound from pipe/pulse with possible exception of the speaker test even though I tried
                  for about 40 minutes and became very frustrated.
                  My assumption is the speaker test circumvents pulse pipewire.

                  #112900
                  Member
                  sybok

                    Hi, I have a question.

                    Is there any automation involved in testing (alpha(s), beta(s) and) new release (candidates)?
                    I.e. series of automated tests run using a certain framework (Python’s unittests, Lintian, Ansible playbooks) that can be run from within the new system once installed?
                    E.g. installing packages, (un)mounting partitions etc.
                    Also, what would be scenarios of interest?

                    I have some experience with Python’s unittests and perhaps, I could contribute something that can be re-used in the future.
                    If not, having a list of tests to go through would be useful for manual testers as well.

                    References:
                    http://lintian.debian.org/manual/index.html
                    http://members.loria.fr/LNussbaum/files/fosdem07-auttest.pdf
                    http://docs.ansible.com/ansible/latest/reference_appendices/test_strategies.html

                    #112901
                    Member
                    RJP

                      @xunzi_23 Have you tried playback-device-test for diagnosing?

                      https://www.antixforum.com/forums/topic/no-sound-at-all/page/3/#post-110884

                      #112902
                      Member
                      Xunzi_23

                        After changes to get sound working I attempted to remaster the live USB stick.

                        after more than 25 minutes and 7% i gave up. Device is an I5 quad core clocking
                        to about 2500mHz depending on load. All cores were used.

                        Remastering on beta 2 with a much larger size due additional applications is
                        about 8 to 10 minutes.

                        #112903
                        Member
                        PPC

                          Thanks for this “surprise” mix of beta3/RC1, anticapitalista!

                          I took a look at it, running live (I have no virtualbox on any of my computers currently).

                          *Localization problems:

                          – On IceWM manager GUI, the “Run menu entry” is missing from the localization files – I just checked. This is due to a mistake I made when writing the script. I just checked and I forgot to mark that variable (in line 67, as localizable, adding a $)- sorry, everyone!
                          Edit: I already made a commit fixing that. This means that eventually that string will be placed for localization in Transifex and the localizations will be used on the script

                          .desktop files used in pt are not the latest

                          – I’m not sure if the devs can do anything about that, but the tooltips in Control Centre show up in English, despite me having translated them all to pt

                          Control Centre does not use the latest localization (ex: antiX program remover – does not show up localized in pt)

                          – If at all possible, please, do use the pt_br language files for pt in this softwares: gksu, mirage, claws, etc (I made a detailed entry on the Forum requesting that)- so portuguese users can have the OS almost 100% in Portuguese (the localization files do exist. pt-br is pt, they just use some different words for somethings -ex: “arquivo” instead of “Ficheiro”-, but we understand it perfectly)

                          *Assorted suggestions, possible problems:
                          On-board on screen keyboard works out of the box! Nice. But, although it shows pt keyboard (with ç and ~) when I click those virtual keys, the system keyboard instantly jumps to US (the flag on the system tray changes instantly, as does the virtual keyboard) and I get the US key output…

                          add-desktop still is a problematic version, that does not work as an app-select plugin.

                          if possible, re-add Firefox to the first tab in Package Installer

                          – The most recent version of antix-goodies is not included (does not include the GUI to connect to Shared folders).

                          Package Installer and deb-installer are not 100% localized, at least in pt – if possible they should be put up for localization on Transifex. Note1: they may not be perfectly localized, but are completely usable. NOTE2: I think that 32bits apps do not show in the antiX 64bits version of Package Installer… but they show up and are installable under “apt”. Example: try “apt search zsnes” and you find 2 hits. Search for the same string in the “Enabled Repositories” tab, in Package Installed, and you find nothing.

                          -rox-filer recently reported problem – trying to open text files using terminal apps is still present. There is an work-around, that I presented on antiX-23 beta2 thread…

                          -Would it be at all possible to include, out of the box, a more recent LibreOffice version?

                          – Maybe the GUI to mount Shared Folders can easily be added to the “shares” tab in Control Centre, when it’s included in antiX?

                          I think it really requires 2 switcher GUIs: for Pipewire (the most important one) and for the compositor. If a feature is not on the menu/ or has a GUI in Control Centre, almost 100% of the users won’t know that option even exists. Regular people do not study all of an OS config file to learn exactly what to edit to turn on or off some feature, they just don’t. That’s ok for advanced features, that are only used by experts.
                          But disabling an audio system that can use needlessly extra system resources, or as in an above post, strangely not work with audio setups, should have a GUI.
                          I’ll try to adjust my proposed GUI’s and upload them to yad-goodies…

                          – I completely agree that pipewire and related services should come preinstalled and that a GUI to enable disable it should be included. A different matter is if pipewire should be enabled by default- I say yes, I agree with anticapitalista. But I would also completely agree if it’s off by default. Let me explain my reasoning: Some features that (in my opinion and particular use case) just wast RAM are enabled by default in antiX- like Desktop Icons and the language flag thingie in system tray. In particular, the desktop icons are there not because anticapitalista particulary likes them (I clearly stated he does not use desktop icons), but because most people expect that an OS offers desktop icons out of the box. The same reasoning can be done about Pipewire- users expect that they install the most used FOSS browser in the world, Firefox, and it has sound out of the box… and that requires something other than just alsa (I know, we have apulse, but regular users that do not use the terminal and don’t even dream of editing a config files can’t use it). So it makes sense, for most users, to have pipewire enabled- even if I disable it by default myself, because I just edit firefox’s .desktop file to make it use apulse. But if I want to play some commercial games, I do need to enable pipewire… The most important point: do include a simple way to toggle Pipewire on/off – then it does not matter much if it’s on or off by default (but I still suggest- leave it enabled by default).

                          *Nice points:
                          – Sound works flawlessly on my desktop

                          – Volume icon shows up on system tray (it did not do that in beta2, when I installed and enabled Pipewire)

                          – I think all the features added to zzzfm work perfectly and it’s almost perfectly localized. I’m very please to see the Recycle bin working flawlessly, even when dealing with files that have strange characters or spaces in their names. It took a lot of work to achieve that.

                          – Still Lightning fast and uses very little RAM. Boots very fast, looks great. Honestly, I think most people will think it runs some kind of KDE D.E….

                          – Installing almost any software from our “App store” (package installer) is an extremely pleasant process – it works in a simple way, does not even show the terminal, allows access to (almost) all packages that are in the Debian repo.

                          – Overal the look and feel of this version are amazing, most settings are very easily costumizable from GUI’s (and about 100% of them, by editing config files made available in Control Centre). It’s extremely feature rich- now including, by default, a GUI that provides real time thumbnails of all non minimized windows on the current virtual desktop, has a “search” option on the main menu, that also allow to pin (or unpin) apps to (almost) any place the user wants. antiX now is almost as user friendly as Mx-Linux or any other “mainstream” OS, but, you know, running even on a patatoe…

                          – Fun fact: The current version is so perfect to me, that I basically just have to open the GUI to configure IceWM, tweak half a dozen settings and I end up with a system that is about 99% the same antiX-22 that I have installed on my computers.

                          • This reply was modified 7 months, 1 week ago by PPC.
                          #112904
                          Member
                          PPC

                            @anticapitalista – I just sent merge requests (over at http://gitlab.com/antiX-Linux/yad-goodies) for the 2 GUIs to Enable/Disable Pipewire from the system startup and the Enable/Disable the Compositor. There are 6 files in total: 2 scripts, the 2 required tiny images (that are expected to be on the same folder as the scripts) and 2 .desktop files.
                            If you want I can also upload the UFW GUI that uses the same exact interface (simpler to use that the previous one I created, I hope).

                            Edit: I did not check, but I hope that the changes that I proposed (on the beta2 thread, I think) to Fluxbox init file are implemented, or else, fluxbox users that enable the compositor will end up with every single thing in the system transparent in a way that will make it almost unusable…

                            P.

                            • This reply was modified 7 months, 1 week ago by PPC.
                            #112907
                            Member
                            calciumsodium

                              Can I ask why the runit services getty-tty3, getty-tty4, getty-tty5, getty-tty6, and getty-ttyS0 are enabled as defaults in this antiX23 b3 when those runit services are disabled as defaults in the previous betas? The previous betas seem to work well without these specific runit services enabled.

                              Thanks.

                              Attachments:
                              #112909
                              Member
                              olsztyn

                                I have updated how antiX uses runit to remove as much dependency on sysVinit as possible.
                                All seem to work in my tests, but I have basically kept to the defaults and not installed anything.
                                I suspect that there will be issues with unmounting devices on reboot/shutdown, but I really don’t know.

                                My two cents having just come back from Europe and having an opportunity to do some initial testing:
                                – Startup time appears to be faster. Have not done measurements yet though.
                                – Shutdown time – huge difference. Very quick.
                                – I do not experience any issues with mounting/unmounting devices on shutdown or otherwise. Tested just on two machines though.

                                It appears excellent to me after relatively brief testing, not experiencing any issues so far.
                                Just my minor subjective comments, that appear to be in sync with what PPC already brought up:
                                – Pipewire sound – I do not experience any issues in terms of working in general but perhaps it would be good to have pure Alsa option as well, so some sort of switch in Control Center, particularly considering sound quality degradation brought up by @calciumsodium in his post above. I did not have a chance yet to compare some quality speakers to have an opinion in this respect. On basic audio speakers I do not hear any difference.
                                – In configuration startup options I do not like sound icon delay of 5 sec. to appear. I am aware of pipewire components timing issue but I was hoping that when pipewire runit services are developed this issue would be solved.

                                I will continue testing as much as time permits but my general impression this test version is excellent. Works with no material issues that I can detect so far…
                                Thank you!

                                Live antiX Boot Options (Previously posted by Xecure):
                                http://antixlinuxfan.miraheze.org/wiki/Table_of_antiX_Boot_Parameters

                                #112910
                                Member
                                olsztyn

                                  Can I ask why the runit services getty-tty3, getty-tty4, getty-tty5, getty-tty6, and getty-ttyS0 are enabled as defaults in this antiX23 b3 when those runit services are disabled as defaults in the previous betas? The previous betas seem to work well without these specific runit services enabled.

                                  I forgot to question this as well, although noticed and had this concern in mind…
                                  Thank you calciumsodium for bringing this up!

                                  Live antiX Boot Options (Previously posted by Xecure):
                                  http://antixlinuxfan.miraheze.org/wiki/Table_of_antiX_Boot_Parameters

                                Viewing 15 posts - 1 through 15 (of 234 total)
                                • You must be logged in to reply to this topic.