antiX-23 released.

Forum Forums News Announcements antiX-23 released.

  • This topic has 190 replies, 37 voices, and was last updated Oct 14-5:02 am by andfree.
Viewing 15 posts - 166 through 180 (of 191 total)
  • Author
    Posts
  • #117085
    Member
    PPC

      As per this thread https://www.antixforum.com/forums/topic/network-printer-not-detected/

      antiX 23 sysv version seems to come with avahi-deamon installed, but lacking the script required to enable that process (and thus having network printers working).

      The solution is provided by caprea on that very same thread- create the required script (copying the contents of the one caprea made available on his post). Then users can enable avahi’s process either via terminal or using the GUI provided in Control Centre.

      P.

      #117237
      Member
      PPC

        Another tiny “bug” that I noticed in antiX 23 sysv 64bits Full, running Live: IceWM’s menu does not show the “Install” line (at least not in the pt locale). JWM and Fluxbox do correctly show the installer in the menu…

        Edit: not a bug, but an improvement request for future updates- as stated on other threads, I’m looking for ways to stop apps usually thought to be part of the system (like the Volume Icon or the App launcher) to open multiple times, having multiple instances running, which is not the expected behavior.

        To stop more than one instance of volumeicon running: add to, ~/.bashrc, the line:
        alias volumeicon="pidof volumeicon || volumeicon &"

        -To allow only one desktop-session-exit window to be run from the IceWM menu (if one is already open, it gains focus):
        Edit IceWM preferences file, in the line “LogoutCommand”, so it reads:
        LogoutCommand="wmctrl -a 'Exit Session' || desktop-session-exit"

        -To allow only one app-select window to be run from the IceWM menu (if one is already open, it gains focus):
        Unfortunatly I found, for now, no easy “one solution” for this, because my proposal implies editing icewm’s Menu file, that’s different for all locales.
        In English, the app-select entry (usually the first), would be something like ( edited the text that is displayed in the menu and the icon):

        runonce "Search (and manage app launchers)" /usr/share/icons/papirus-antix/48x48/categories/d-feet.png "app-select.App-select" app-select

        EDIT: A simpler change to implement to the menu file is keeping the original “app-select” line, replacing the command “app-select”, at the end of the line with:
        sh -c "icesh if -class 'app-select.App-select' then activate else runonce app-select"

        EDIT:
        While looking for an easy way to allow the keyboard shortcut Ctrl + Space to run only one instance of app-select, I came to a 2 step solution that can also be used in the menu:

        (I edited out outdated instructions that were here)

        Edit IceWM’s “Keys” file so the ctrl + space line reads (you can point to a different place, if the file is not in your home folder:
        (I edited out outdated instructions that were here)

        key "Ctrl+Space" sh -c "icesh if -class 'app-select.App-select' then activate else runonce app-select"

        EDIT:
        To allow only one task manager to open when you click the cpu/etc info square on the system tray (if it’s already running, it will gain focus):
        Edit IceWM’s Preferences file so the CPUStatusCommand reads:

        CPUStatusCommand="icesh if -class 'lxtask.Lxtask' then activate else runonce lxtask"

        I think this covers avoid unnedded and repeated icons/windows for volumeicon, app-select, Exit-session and lxtask, when summoned from the GUI that what most users do). Please notice that you can run more than one instance of app-select and lxtask, from the Terminal, if you so wish. I did not find any possible reason for forcing more than 1 volumeicon or more than 1 Exit Session instances at the same time, so I think it’s safe to assume this changes do not deprive advanced users from running whatever they like from the terminal.
        NOTE: many thanks to @anti-apxos and @blur13 for letting us know how powerful iceseh really is (over at https://www.antixforum.com/forums/topic/suggestion-edit-icewm-menu-so-only-one-instance-of-app-select-can-be-launched/#post-117331)

        P.

        • This reply was modified 8 months ago by PPC.
        • This reply was modified 8 months ago by PPC.
        • This reply was modified 8 months ago by PPC.
        #117378
        Member
        PPC

          I just noticed than in antiX-23, at least (I can’t recall on previous versions)- the “zip” package is not installed. Since it’s almost a standard for compressed files, it’s a bit strange. Can it be included, at least in “full”?

          P.

          #117389
          Moderator
          Brian Masinick

            If not, no big deal: sudo apt-get update; sudo apt-get install zip

            All set; ten-fifteen seconds to type if you’re a slow typer like me and
            a similar amount of time for the commands to install; easy, and done.

            --
            Brian Masinick

            #117390
            Member
            PPC

              All set; ten-fifteen seconds to type

              Yes, I know. That’s what I did. But you do have to know exactly what package to install, and many newbie users don’t know and will end up asking for help here in the forum, saying they can’t access their zipped files… It’s basically the only type of commonly used file that antiX does not offer support to, out of the box (images, office documents, pdfs, epubs, mp3, several video formats, all of them can be accessed in antiX Full), Zip seems to be the biggest exception.

              Edit: But as always, you are right, Mr. Masinick – I forgot to mention how to solve the problem and add zip support to antiX. Thanks for that!

              • This reply was modified 8 months ago by PPC.
              #117394
              Moderator
              Brian Masinick

                I’ll be willing to answer questions like these as often as they’re asked; it’s one of the simpler things to do.

                --
                Brian Masinick

                #117396
                Member
                marcelocripe

                  I just noticed than in antiX-23, at least (I can’t recall on previous versions)- the “zip” package is not installed. Since it’s almost a standard for compressed files, it’s a bit strange. Can it be included, at least in “full”?

                  So is this the problem that prevents the Compression Manager from working correctly?

                  Então é este o problema que impede o Gerenciador de Compactação de funcionar corretamente?

                  #117397
                  Member
                  PPC

                    So is this the problem that prevents the Compression Manager from working correctly?

                    It works perfectly… but if you do not install the “zip” package, it will only work for other compressed file formats, other than “zip”.

                    P.

                    #117402
                    Moderator
                    Brian Masinick

                      On my system when I checked earlier today, “gzip” WAS installed; zip was not;
                      just in case, it’s easy to do this (and then you can be certain that BOTH are installed):
                      sudo apt-get update; sudo apt-get install --reinstall zip gzip

                      In this way, if they ARE installed, they’ll be “reinstalled”; if they are not installed,
                      they will be installed; worst case, you download and (re)-install two packages; but if
                      they are not installed, they’ll get installed, so unless you are bandwidth restricted,
                      this is a completely safe thing to do. (even if you are bandwidth restricted, neither
                      of these packages is large, so the “risk” is very minimal.)

                      --
                      Brian Masinick

                      #117437
                      Member
                      techore

                        the “zip” package is not installed. Since it’s almost a standard for compressed files

                        In my experience, I mostly see “zip” on Windows. Linux has better archive tools in my opinion but there is no “best” archive tool. Depends on the use case.

                        An alternative to the ‘zip’ package is ‘p7zip-full’.

                        From Debian’s package page: http://packages.debian.org/bookworm/p7zip-full

                        Installing p7zip-full allows File Roller to use the very efficient 7z compression format for packing and unpacking files and directories. Additionally, it provides the 7z and 7za commands.

                        #117441
                        Member
                        greyowl

                          I notice that 7zip is available in Synaptic Package Manager for installing.

                          Dell Latitude D620 laptop with antiX 22 (64 bit)

                          #117765
                          Member
                          namida12

                            I ordered a pack of 5 16 gig flash drives, and a SAMSUNG 970 EVO PLUS M.2 2280 1TB PCIe Gen 3.0 x4, NVMe 1.3 V-NAND Internal Solid State Drive (SSD) MZ-V7S1T0B/AM.

                            I read every post in this thread, and do not see anyone with my problems:
                            1. Installing the sysVinit full 64 bit version after updating the live seems to work once, on a reboot, or starting system after shutdown. AntiX does not like my password on the second, third, forth, fifth or subsequent boots. I also tried to install several times without doing all the updates before I found that was a required procedure before an install…
                            2. The runit 64 bit full flash drive after updating the live media, sound, YouTube and video work well. After several different installs I can not get sound video or YouTube to work, Netflix, Max, or YouTube do not work, I have several instructional videos, on flash drives and they do not play. I can advance them using the mouse to jump several frames or 10% and it appears the video is complete, but useless as it will not play/advance in any of the software in antiX. I tried installing VLC that I have not needed to use for several versions of antiX. VLC does not play online video, DVD, or a instructional flash drive video.

                            64 bit versions of antiX Live media (sysVinit and runit) will play online video or a instructional flash drive video before updating and after updating…

                            Putting my NVMe Internal Solid State Drive back into the desktop believe it is an update beta 2 version everything appears to work properly…

                            demo@antix1:~
                            $ sudo ps_mem.py 
                            [sudo] password for demo: 
                             Private  +   Shared  =  RAM used	Program
                            116.0 KiB +   0.5 KiB = 116.5 KiB	seatd
                            112.0 KiB +   6.5 KiB = 118.5 KiB	runit [updated]
                            120.0 KiB +   7.5 KiB = 127.5 KiB	runsvdir [updated]
                             96.0 KiB +  54.5 KiB = 150.5 KiB	pipewire-start (3)
                            260.0 KiB +   0.5 KiB = 260.5 KiB	startup
                            276.0 KiB +   0.5 KiB = 276.5 KiB	icewm-session
                            216.0 KiB + 228.0 KiB = 444.0 KiB	cat (2)
                            320.0 KiB + 125.5 KiB = 445.5 KiB	udevil
                            528.0 KiB +  99.5 KiB = 627.5 KiB	gconfd-2
                            740.0 KiB +   1.0 KiB = 741.0 KiB	dbus-launch (2)
                            808.0 KiB +   0.5 KiB = 808.5 KiB	desktop-session
                            820.0 KiB +   3.0 KiB = 823.0 KiB	getty (6)
                            824.0 KiB +   2.5 KiB = 826.5 KiB	at-spi-bus-launcher
                            896.0 KiB +  48.5 KiB = 944.5 KiB	connmand
                            996.0 KiB +   5.5 KiB =   1.0 MiB	wpa_supplicant
                              1.0 MiB +   0.5 KiB =   1.0 MiB	udevd
                            880.0 KiB + 189.5 KiB =   1.0 MiB	at-spi2-registryd
                              1.0 MiB +  97.5 KiB =   1.1 MiB	runsv [updated] (11)
                            700.0 KiB + 413.5 KiB =   1.1 MiB	devmon
                              1.0 MiB + 449.5 KiB =   1.4 MiB	upowerd
                              1.3 MiB + 378.0 KiB =   1.7 MiB	dbus-daemon (4)
                              1.7 MiB + 138.5 KiB =   1.8 MiB	nacl_helper
                              1.2 MiB + 812.0 KiB =   1.9 MiB	sudo (2)
                            912.0 KiB +   1.2 MiB =   2.1 MiB	chrome_crashpad_handler (2)
                              2.1 MiB + 192.5 KiB =   2.3 MiB	conky
                              1.8 MiB + 555.5 KiB =   2.3 MiB	bash
                              3.5 MiB + 159.5 KiB =   3.7 MiB	volumeicon
                              3.9 MiB +   0.5 KiB =   3.9 MiB	slimski
                              5.7 MiB + 359.5 KiB =   6.0 MiB	wireplumber
                              5.8 MiB + 662.5 KiB =   6.5 MiB	icewm
                              7.4 MiB + 304.5 KiB =   7.7 MiB	pipewire
                              9.1 MiB +   2.1 MiB =  11.1 MiB	zzzfm
                             12.4 MiB + 334.5 KiB =  12.8 MiB	pipewire-pulse
                             15.0 MiB +   5.1 MiB =  20.1 MiB	roxterm
                             64.7 MiB +  14.8 MiB =  79.4 MiB	Xorg [updated]
                            431.6 MiB + 180.8 MiB = 612.4 MiB	chrome (11)
                            ---------------------------------
                                                    788.7 MiB
                            =================================
                            demo@antix1:~
                            $ 
                            
                            demo@antix1:~
                            $ inxi -Fxz
                            System:
                              Kernel: 5.10.188-antix.1-amd64-smp arch: x86_64 bits: 64 compiler: gcc
                                v: 13.2.0 Desktop: IceWM v: 3.4.1 Distro: antiX-23-runit_x64-full Arditi
                                del Popolo 26 August 2023 base: Debian GNU/Linux 12 (bookworm)
                            Machine:
                              Type: Desktop Mobo: ASRock model: B450M Pro4 serial: <superuser required>
                                UEFI: American Megatrends v: P3.50 date: 07/18/2019
                            CPU:
                              Info: quad core model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64
                                type: MCP arch: Zen/Zen+ note: check rev: 1 cache: L1: 384 KiB L2: 2 MiB
                                L3: 4 MiB
                              Speed (MHz): avg: 2987 high: 3018 min/max: 1400/3600 boost: enabled cores:
                                1: 2950 2: 3006 3: 2975 4: 3018 bogomips: 28747
                              Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
                            Graphics:
                              Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
                                driver: amdgpu v: kernel arch: GCN-5 bus-ID: 07:00.0 temp: 41.0 C
                              Display: server: X.Org v: 1.21.1.7 driver: X: loaded: amdgpu
                                unloaded: fbdev,modesetting,vesa dri: radeonsi gpu: amdgpu
                                resolution: 2560x1440~60Hz
                              API: OpenGL v: 4.6 Mesa 22.3.6 renderer: AMD Radeon Vega 8 Graphics
                                (raven LLVM 15.0.6 DRM 3.40 5.10.188-antix.1-amd64-smp) direct-render: Yes
                            Audio:
                              Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
                                v: kernel bus-ID: 07:00.1
                              Device-2: AMD Family 17h/19h HD Audio vendor: ASRock driver: snd_hda_intel
                                v: kernel bus-ID: 07:00.6
                              Sound API: ALSA v: k5.10.188-antix.1-amd64-smp running: yes
                              Sound Server-1: PipeWire v: 0.3.65 running: yes
                            Network:
                              Device-1: Realtek RTL8125 2.5GbE driver: r8169 v: kernel port: e000
                                bus-ID: 03:00.0
                              IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
                              Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
                                vendor: ASRock driver: r8169 v: kernel port: d000 bus-ID: 04:00.0
                              IF: eth1 state: down mac: <filter>
                            Drives:
                              Local Storage: total: 945.97 GiB used: 8 GiB (0.8%)
                              ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
                                size: 931.51 GiB temp: 35.9 C
                              ID-2: /dev/sda type: USB model: USB DISK 3.0 size: 14.46 GiB
                            Partition:
                              Message: No partition data found.
                            Swap:
                              Alert: No swap data was found.
                            Sensors:
                              System Temperatures: cpu: 40.9 C mobo: N/A gpu: amdgpu temp: 40.0 C
                              Fan Speeds (RPM): N/A
                            Info:
                              Processes: 201 Uptime: 18h 43m Memory: 5.71 GiB used: 2.73 GiB (47.8%)
                              Init: runit runlevel: 2 Compilers: gcc: 12.2.0 Packages: 1688 Shell: Bash
                              v: 5.2.15 inxi: 3.3.25
                            demo@antix1:~
                            

                            JR

                            #117795
                            Member
                            PPC

                              Another Suggestion to improve usability among new users, probably handy for regular users: have arandr show a reminder, everytime it’s used to change screen settings (this pops up just once every time arandr is run, for the first time the user changes screen settings):

                              Either change arandr .desktop (what I propose) or add an alias to .bashrc, so runnign arandr runs this one liner script (or a variation of it):
                              arandr & watch -g xrandr --query && yad --center --window-icon="/usr/share/icons/papirus-antix/48x48/devices/display.png" --title="antiX" --text="If you want to keep any resolution change after your reboot, please don't forget to save that configuration under the name 'default.sh',\n in the default folder $HOME/.screenlayout\n That way, the command that sets the resolution you want on your screen(s) will run every time antiX starts" --button=" x "

                              This would avoid users complaining that’s too hard to permanently change screen settings… To be honest, I used arandr for years until I found out it could save the settings in the form of a command, and that antix runs that command, if found, everytime it boots- it’s the almost perfect solution, but not ‘advertised’ to our users…

                              More advanced users will probably already know that and just be nagged by the warning… So probably a more developed version should include a “Do not show this warning again” check-box, that saves a ‘flag file’ that the future script would check, before displaying any warning…

                              EDIT: I changed the yad window contents to make it more explicit what users should do to make the change permanent.

                              P.

                              • This reply was modified 7 months, 3 weeks ago by PPC.
                              #117797
                              Member
                              techore

                                Oops. Posted in the wrong thread.

                                • This reply was modified 7 months, 3 weeks ago by techore.
                                #117799
                                Member
                                blur13

                                  I tried it, didnt work. The yad part works. Its something with arandr & watch -g xrandr –query

                                  Anyways, putting that in .bashrc would break easy and helpful things like being able to run arandr -h to show the help output.

                                Viewing 15 posts - 166 through 180 (of 191 total)
                                • You must be logged in to reply to this topic.