antiX-23 released.

Forum Forums News Announcements antiX-23 released.

  • This topic has 190 replies, 37 voices, and was last updated Oct 14-5:02 am by andfree.
Viewing 15 posts - 91 through 105 (of 191 total)
  • Author
    Posts
  • #115793
    Moderator
    Brian Masinick

      The issues a few people are having with audio is disappointing. My experience has been so positive that I thought we’d finally conquered one of the most common issues; clearly I was wrong but perhaps this presents additional opportunities to better understand audio and video setups and come up with some ways to perform different steps for different configurations.

      Any ideas?

      --
      Brian Masinick

      #115797
      Member
      stevesr0

        Hi Xunzi_23,

        1. When you say speaker test worked, where did the sound come from?

        2. Does sound work on these machines with headphones?

        3. What does PAVUCONTROL show?

        4. In htop or other program were pipewire and Wireplumber running?

        5. Did alsamixer list Pipewire as the server?

        6. I didn’t find any posts about particular brands of sound cards that don’t work with Pipewire. Since Pipewire depends on alsa, I would think if it works with alsa, it should work with pipewire.

        7. While I think it should be automatic, is it possible you have to be a member of a group for Wireplumber (which pipewire requires) to work? IIRC, I had to be a member of the video group.

        stevesr0

        #115816
        Member
        marcelocripe

          abc-nix wrote:

          If the issue is not kernel related (if you see this happen again in the future), remove the ampersand (the ‘&’ symbol) for pipewire-start in the startup file.

          This way, it will force the startup script to wait for the pipewire-start script to complete before continuing with the next instruction.

          Many thanks for these instructions.

          #115837
          Forum Admin
          Dave

            If the issue is not kernel related (if you see this happen again in the future), remove the ampersand (the ‘&’ symbol) for pipewire-start in the startup file.

            This way, it will force the startup script to wait for the pipewire-start script to complete before continuing with the next instruction.

            @abc-nix. Does ‘pipewire-start && volumeicon &’ work? That way only volumeicon would need to wait for pipewire-start to complete (not starting if it fails) and not the whole startup script.

            Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

            #115838
            Member
            meurglys

              I too am experiencing weird issues with the volumeicon. it shows up sporadically on startup in both Icewm and Herbstluftwm on antix 23, SysV. In my polybar, pipewire starts reliably, and I have pipewire in my HLWM startup.

              I tried changing the user-startup-session startup to sleep 2 pipewire-start and left the sleep 5 for the volumicon, and for some reason it sometimes fails to load pipewire. I changed it back to the default setting, and tried taking pipewire out of my HLWM autostart to see if it would run, but no dice.

              As it stands now, sound works, most of the time…..the volume icon doesn’t always appear. I’m wondering, if wireplumber has to be called first, before pipewire in one of the autostarts.

              • This reply was modified 8 months, 3 weeks ago by meurglys.
              • This reply was modified 8 months, 3 weeks ago by meurglys.
              • This reply was modified 8 months, 3 weeks ago by meurglys.
              #115845
              Member
              Xunzi_23

                Hi steves, I have wasted several hours stubbornly trying to get pipewire to work correctly every boot
                and show working volume icon. And give output to the amplifiers an analogue out.

                The devices I support have all, with little effort, had sound working fine with alsa.
                They are now working again as expected/no complaints burning my ears :-).

                Not a criticism of antiX or the work of others, just a personal statement.
                Audio on linux is complex, adding more complexity without immediate reliable improvement is not
                my way of doing things.

                My antiX 23 master stick now has as much of pipewire as possible purged and will stay that way.
                If a user I like wants bluetooth I might try and make it work, but more likely say ok go for it
                but leave me out.

                #115846
                Member
                Wallon

                  Dear Marcelocripe,

                  This morning I ran antiX 23 Full Sysvinit 64 bits on my MSI desktop CPU Intel i5-6400 with the JWM window manager.
                  I no longer had the sound volume icon and I had no sound.

                  I changed the window manager and loaded IceWM. The sound volume icon appeared and I had sound.

                  I put the JWM window manager back on. The sound volume icon appeared and the sound worked.

                  It’s really strange the way Pipewire behaves in antiX.
                  My hardware is 100% compatible with Pipewire because I never have any problems with Debian 12 Systemd Gnome.
                  For the moment, it doesn’t matter if I have to change my window manager to enable sound.

                  Kind regards,
                  Wallon

                  #115852
                  Member
                  PPC

                    Hi, everyone, being on vacations with my daughter only now I really have a chance to comment on this release:

                    – On terms of usability, default look and feel and ease of use and compatibility with hardware, this is probably the best antiX version ever.

                    Unlike what’s said on another thread, I do not think that antiX is only for people that know about computers – the default set up of the Full version allows anyone that knows how to use a computer to do the most common tasks, like: using the browser, using an office suite, installing software from an “app store”, that does not have pretty pictures but is pretty much self explanatory, update the system whenever the user wants (but not automatically, not without installing a GUI app that takes care of that), or configure the system, using Control Centre or IceWM Control Center (that, in an Inception like way is available also from inside control Centre).

                    – That “taints” this great version? Not much, but technical stuff that can put off some users:
                    The first “problem”, that affects users with relatively more modern hardware is installing to an UEFI system – that problem was caught very early and is addressed in the Release Notes… unfortunately not early enough so a fix is included in the final iso files. Folks will have to wait for a x.1 version for that.. Note: unexpected stuff happens when anyone, even major Software production houses are releasing very complex pieces of software- that happened to me, when I was releasing a version of FT10 that is nowhere as complex as a full blow OS, like antix.
                    The second “problem” directly affected me- sound. I did the majority of testing of antiX-23 betas on my Dell work desktop, and knew that they work exactly as expected. I only tested antiX-23 final 64bits Full sysv LIVE version on my under-powered netbook and I was disappointed. antiX is the single OS that I’ve used in the last 7-8 years that never had any problem with my hardware. Everything worked perfectly out of the box. On my netbook, that no longer happens: if I boot my netbook in Live mode using the modern kernel, I do not have sound at all (I’ll have to take notes and report that with full details, but I’m way from that computer now). If I boot my netbook in Live mode using the older kernel, I do have sound- but something is not working correctly – volumeicon does not autostart (well, it did, exactly once). To be able to change the volume, I do have to use the CLI volume control available from Control Centre. I did not notice any sound problem when I tested beta2 on that netbook (and do not recall it happening, or I would have reported it then). Being an old, under-powered and particularly crappy piece of hardware, I did not expect that netbook to work correctly with the latest kernel, but I expected no problems with the older kernel.
                    As anticapitalista advised, during the beta testing phase, when pipewire is disabled, probably antiX sysv requires a full reboot. Running it live, I can’t really do it in a simple way, when I disable pipewire. I’ll try to download the runnit version and test if disabling pipewire works as expected (and as I tested on my desktop- getting pure Alsa sound, as it seems).
                    EDIT:
                    -A Third usability problem in setting up antiX has plagged it since it started using connman as a Network Manager- due to the it’s windows appears on-screen, on some resolutions, the window that allows users to configure Wi-fi networks does not display the “Ok” button, on the lower right side- it’s there, but users have to use the scroll bar to get to it. On some resolutions, the “ok” button is fully/partly seen, avoiding that problem, on other resolution it’s completly out of sight, which may confuse users that are not very computer savvy and see no obvious way to accept the network credentials…

                    If you are a non English speaker, you can use the Language GUI to make sure that your system is 99,9% set up in your own language (in pt, the only thing I noticed was not perfectly localized was a couple of menu entries and LibreOffice)- many thanks to anticapitalista for including localizations to essential system apps, like gksu, mirage, claws…

                    To all folks that report sound problems- please do test the new GUI, in antiX Menu > Applications > Accessories, to enable/disable pipewire, and then select the option to log off and log back on (on antiX using runnit) or reboot (on antiX using sysv).

                    Final remarks:

                    – antiX is, in my option, the lightest full blow Linux OS that you can use, on devices from 20 years ago to the the ones from 20 minutes ago. Once it’s correctly set up it’s reliable, fast, easy to use, and simply gorgeous, lacking almost nothing that modern OSes offer (it now even comes with a compositor, that you can enable from antiX Menu > Applications > Accessories; you can enable System notifications installing, from Package Installer, Dunst).
                    – People coming for other OSes will have to get used to clicking the “antiX Updater” toolbar icon to check for updates, at least once a week (I advise every other day). Yes, you cam keep using your system during the update process, even if your computer is almost 20 years old, No, you do not need to use the Terminal, No, you do not need to reboot during normal updates, Yes, it sometimes takes less than a minute, there’s nothing wrong with your computer- it’s just that fast.
                    – People coming from other OSes do not need to know how to use the terminal and will not have to know how to edit config files- everything is done using simple GUI’s (and by that I mean every setting that users normally want to perform – like changing screen resolution, setup a printer, change the wallpaper, change the theme to a darker/lighter one, installing software from a “store”, or installing a .deb file, adding icons to the toolbar, to the desktop, pin applications to the menu, change the contents of the menu, show/hide seconds on the clock, use 12/24h clock, changing the position of the toolbar, managing the startup of the system, turning the Firewall on/off, installing/removing applications, etc)
                    – The only real sticky situation is getting LibreOffice (and the system in general) to respect the default choice of paper – that sometimes afflicts people that still have to actually print stuff.

                    If you are lucky enough to not have problems installing on an UEFI system and the sound works perfectly for you, then I may say that probably antiX deserves an A+ (or 20 out of 20 grade). If you are affected by those problems, please wait until version 23.1 comes out, in some months (I hope)…

                    • This reply was modified 8 months, 3 weeks ago by PPC.
                    #115869
                    Member
                    oops

                      I have tried to add some WMs and a DE to antix-amd64-runit (and x32-runit), modified some config into desktop-session.conf, … then DE XFCE is ok, WM i3 is OK, butVM Wmaker do not work and i do not know why?.

                      Also, I have installed the package “xserver-xephyr_1.20.14-1~mx21ahs+1_amd64.deb” from MX with success, the antix23 xserver-xephyr is listed into the package list but not available in my repository. And by xephyr WMaker works.

                      Edit: the xserver-xephyr package is OK now … Thank you.

                      • This reply was modified 8 months, 3 weeks ago by oops.
                      • This reply was modified 8 months, 3 weeks ago by oops.
                      #115915
                      Member
                      abc-nix

                        @abc-nix. Does ‘pipewire-start && volumeicon &’ work?

                        I will have to test it out, but I think the delay is necessary for slower systems (dbus communication and such). There is another alternative I am exploring, that is to add the order to launch wireplumber with pipewire adding the instruction inside the /usr/share/pipewire/pipewire.conf config file (or $XDG_CONFIG_HOME/pipewire/pipewire.conf even better).

                        Then, we could remove the wireplumber starting command from pipewire-start. The sleep before the volume icon may still be necessary, though.

                        • This reply was modified 8 months, 3 weeks ago by abc-nix.
                        #115933
                        Member
                        abc-nix

                          I have found that adding the launch option inside pipewire.conf seems to work properly.

                          Make a custom folder for pipewire in your config folder
                          mkdir $XDG_CONFIG_HOME/pipewire
                          Copy the default config file for pipewire
                          cp /usr/share/pipewire/pipewire.conf $XDG_CONFIG_HOME/pipewire/
                          Edit $XDG_CONFIG_HOME/pipewire/pipewire.conf and add anywhere inside context.exec
                          { path = "wireplumber" args = "" }
                          or
                          { path = "/usr/bin/wireplumber" args = "" }

                          Optionally, you could also add pipewire-pulse in the same manner,

                          Then, edit /usr/local/bin/pipewire-start with privileges and remove or comment the line that launches wireplumber (and pipewire-pulse if you also added it into the pipewire config file).

                          Save and reboot.

                          Now we only need people who suffer with the volume-icon problem to test. I rebooted the live system a few times and it seems to work OK. I didn’t touch the volume-icon sleep delay though.

                          #115942
                          Moderator
                          caprea

                            @abc-nix, I am affected by the issue that wireplumber does not start and therefore no volume icon appears and no sound is available.
                            But only sometimes, and rarely, mostly after a reboot from another system.I tried your suggestion and it definitely works here.
                            I made the changes for both wireplumber and pipewire-pulse.
                            The volume-icon delay is still needed here.
                            antiX23, 64bit full runit installed to ssd.

                            #115945
                            Member
                            blur13

                              @abc-nix

                              Impressive! This implementation must be *much* faster than starting the services separately. I added both wireplumber and pipewire-pulse to the config. Before, I needed sleep 3 between pipewire and wireplumber, and another sleep 2 before launching any application dependent on wireplumber (in my case conky with a script that shows the current volume, but I would assume volumeicon as well).

                              Now I’ve removed all sleep commands from the startup file and it works.

                              Someone should tip off the devs at MX fluxbox.

                              #115957
                              Member
                              fladd

                                With tabs still being broken in zzzfm (https://www.antixforum.com/forums/topic/antix-23-alpha1-runit-full-64bit-for-testing/page/15/#post-99478), is there a simple way to disable tabs entirely? Such that none of the favorite links on the left will open a new tab and everything reuses the main tab?

                                #116010
                                Member
                                ile

                                  hello anticapitalista
                                  antiX-installer 23.09.01
                                  trial oem switch of minstall
                                  on antiX 23 runit full never showed oobe.
                                  on antiX 23 runit base never showed oobe.
                                  on antiX 23 x64 full the oobe succeeded; installed with new credentials and user directory name from oobe; a /demo directory is furnished in /home. demo is not an account in Administration <antiX-user>
                                  on antiX 23 x64 base the oobe succeeded; installed with new credentials and user directory name from oobe; a /demo directory is furnished in /home. demo is not an account in Administration <antiX-user>

                                Viewing 15 posts - 91 through 105 (of 191 total)
                                • You must be logged in to reply to this topic.