antiX-bullseye-a2-runit_x64-full.iso available

Forum Forums antiX-development Development antiX-bullseye-a2-runit_x64-full.iso available

  • This topic has 152 replies, 16 voices, and was last updated Jul 8-5:18 pm by Ampersand.
Viewing 15 posts - 136 through 150 (of 153 total)
  • Author
    Posts
  • #59309
    Member
    Xecure
    Helpful
    Up
    0

    Thank you for helping with this logs problem.

    It is good to know this is the main issue with the runit release, and that it is now solved on your system. As anticapitalista stated, future releases have logs disabled, so no need for the “Disable all logs” button. I will fix the part of the script that helps create log configurations automatically just in case someone wants to use and enable logs on services that don’t have them configured. But I will do that when I have the time.

    I see the issue re htop

    Thanks for taking a look. If you have time, also test other cli programs that interact with the mouse, like ceni.

    I will take a look to see if I can get ceni to work if I remove connman. Does ceni no longer need a resolv.conf file?

    Next (testing) version will come with logs disabled.

    Thanks for letting us know. I am really considering moving to runit permanently on all systems on the next release.
    I saw that void also has the logs disabled by default, so it seems to be the normal behavior for runit based systems (haven’t tested Artix yet).

    BTW – although it is probably safer for users not to disable elogind, antiX offers consolekit2 as an alternative.

    Should I also lock consolekit2 service (if it needs a service, I don’t know) as an essential service? Or is it better to permit elogind to be disabled/removed?

    Thanks for your time.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #59348
    Member
    calciumsodium
    Helpful
    Up
    0

    When I boot up in a2-runit,

    I get this error message:

    [ xxx] elogind[xxx]: Failed to fully start up daemon: No such file or directory

    I was searching and users of Artix-runit also encountered the same thing. They say that:
    “The only reason for that is because runit services are started in parallel, elogind immediately looks for a dbus service, while dbus was still initializing. So, no, that error should not concern you, but I’m looking for way to turn that message off.”

    One solution was:
    ” It might not be a clean fix, but I just slapped “sleep 1s” before the dbus check and there’s no error message for me anymore.”

    Is this a good fix? If so, how do I do add this “sleep delay” before the dbus check. I could not figure out how to do this.
    Thanks.

    #59350
    Member
    Xecure
    Helpful
    Up
    0

    I searched for the Artix forum post you mention. They see two errors. One, the one you quoted. The other, which is related to dbus, is:
    [ 3.670727] elogind[605]: Failed to connect to system bus: No such file or directory

    I am not sure it will help, but you can try editing with root privileges the file /etc/sv/elogind/check and add the sleep 1 command before the check.

    It seems to be just an annoying but benign error message, because you are able to log in.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #59361
    Member
    calciumsodium
    Helpful
    Up
    0

    My initial attempts to add the sleep 1 command to the /etc/sv/elogind/check file still resulted in the

    [ xxx] elogind[xxx]: Failed to fully start up daemon: No such file or directory

    error message during boot.

    The original /etc/sv/elogind/check file contained:

    #!/bin/sh

    # race: greyed buttons on lightdm/sddm
    # make sure that elogind can see the login and that will open a session for the>

    loginctl show-seat seat0 >/dev/null && exit 0

    exit 1

    So I tried the three combinations below. All did not remove the elogind error message during boot.

    Trial 1:
    loginctl show-seat seat0 >/dev/null && exit 0
    exit 1
    sleep 1

    Trial 2:
    sleep 1
    loginctl show-seat seat0 >/dev/null && exit 0
    exit 1

    Trial 3:
    loginctl show-seat seat0 >/dev/null && exit 0
    sleep 1
    exit 1

    #59365
    Member
    calciumsodium
    Helpful
    Up
    0

    Another thing that I am looking at regarding a2-runit is how fast it boots up compared to a2-sysvinit.

    This is how I did the test:
    I have dual installed both antix-bullseye-a2-runit and antix-bullseye-a2-sysvinit on the same laptop Toshiba Satellite C55-B5300 laptop. Both were set with autologin. With the laptop off, I would press the power button on and immediately press a timer. When the grub screen comes on, I would pick either OS and press Enter right away in order to bypass the grub timer. I would let the OS boot and when I first see the mouse cursor, I would immediately stop the timer and record how much time has elapsed from the pressing of the power button to the appearance of the mouse cursor in the middle of the screen.

    Note: In both OS, I had set pulseaudio and redshift to autostart. This was the only modification I made with respect to autostart. With respect to a2-runit, I had disabled services that had the LOG issues concerning runsv.

    My results:

    a2-runit:
    Trial 1: 40.39 s
    Trial 2: 40.88 s
    Ave: 40.64 s

    a2-sysvinit:
    Trial 1: 42.92 s
    Trial 2: 42.54 s
    Ave: 42.73 s

    Basically, there was not much difference. Two seconds is not that much of a difference. So, we can’t really claim that runit is faster than sysvinit for loading antiX?

    Thanks

    #59367
    Member
    skidoo
    Helpful
    Up
    0

    Basically, there was not much difference. Two seconds

    Thanks for checking and reporting this detail.

    elogind[605]: Failed to connect to system bus: No such file or directory

    In an MX Linux forum topic, anticapitalista posted to mention something about ” check your bootline, lxd ” ( remove the d, if present )

    redshift

    Naw. c’mon ~~ that isn’t called until after user login has occurred, right?
    Benchmarking will be subjectively inconsistent//meaningless unless we agree on what shall be measured. Timings should cite the timestamp of an agreed bootlog event. Even so, liveboot vs installed may affect the comparative timings.

    #59368
    Member
    Xecure
    Helpful
    Up
    0

    My initial attempts to add the sleep 1 command to the /etc/sv/elogind/check file still resulted in the

    [ xxx] elogind[xxx]: Failed to fully start up daemon: No such file or directory

    error message during boot.

    It seems that I was wrong and the check is only done later on. Maybe edit the run file and add sleep1 before the first exec commands, looking like this:

    #!/bin/sh
    sleep 1
    exec 2>&1
    exec /usr/lib/elogind/elogind

    See if this makes it so elogind takes longer to start (and start after dbus has already started), instead of the check script which only tests if elogind is running.

    About runit vs sysvinit startup time, it improves the more CPU cores/threads the machine has. For me, the great advantage of runit is the simplicity of services compared to sysvinit (at least for me, I cannot understand the sysvinit services files or runlevels at all)).

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #59371
    Member
    skidoo
    Helpful
    Up
    0

    I will fix up the service manager to add a button to disable all logs or be able to disable the ones with log status “?”.
    The vital/essential services I hard-coded are based on anticapitalista’s answer a few pages back.

    regarding log status “?”
    I’ve sent to pastebin a notefile (900+ lines) containing my collected details/descriptions
    for each “service” commonly present in antiX17+antiX19.

    The “?” displayed by service manager gui would be difficult nearly impossible to overcome. After a “service” has (double forked, setsid) detached a child process… the program generating the service manager gui would be hard-pressed to matchup the name of the initiating “service” vs processID of currently running spawned-by-a-service processes. A lookup list would probably only be possible if someone installed and ran every common “service” and took notes, listing the recognizable procname(s) of long-running processes associated with each service item.

    https://pastebin.com/bKvMBASe

    ALTHOUGH INITSCRIPTS ARE GENERICALLY, COLLECTIVELY, OFTEN DESCRIBED AS
    “SERVICES” OR “DAEMONS”… MANY INITSCRIPTS PERFORM “RUN-AND-DONE(EXIT)” ACTIONS
    EACH TIME (DURING A CHANGE OF RUNLEVELS) THEY ARE INVOKED

    https://antix-skidoo.github.io/archive/bum_verbose_descriptions.html
    MY EARLIER ATTEMPT TO COLLATE/CONVEY DETAILS OF /etc/init.d ITEMS
    (LITTERED WITH ARCANE ITEMS, e.g. “schoolbell” AND “screen-cleanup”)
    -=-
    HTML, BECAUSE TOO UNWIELDY TO PRESENT AS A WIKITABLE

    #59389
    Member
    calciumsodium
    Helpful
    Up
    0

    Hi @Xecure,
    I modified the /etc/sv/elogind/run file with the sleep 1 command. Unfortunately, this addition of the sleep 1 command did not get rid of the

    [ xxx] elogind[xxx]: Failed to fully start up daemon: No such file or directory

    error message during boot.

    This is the modified /etc/sv/elogind/run file:
    !/bin/sh
    sleep 1
    exec 2>&1
    exec /usr/lib/elogind/elogind

    • This reply was modified 5 months ago by calciumsodium.
    #59390
    Member
    calciumsodium
    Helpful
    Up
    0

    I varied the sleep time in the /etc/sv/elogind/run file:

    sleep 1.1, sleep 1.2, sleep 1.3, sleep 1.4, sleep 1.5 all did produce the elogind boot error.

    Interesting, sleep 2 did NOT produce the elogind error.

    I also timed how long it takes from pressing the power on button to the initial appearance of the mouse cursor with the sleep 2 command added.
    The total start up time was 40.43 seconds, which is the same as with no sleep command option.

    I think this is one way to get around this elogind error.

    • This reply was modified 5 months ago by calciumsodium.
    #59395
    Moderator
    Brian Masinick
    Helpful
    Up
    0

    Nice work!

    Brian Masinick

    #59402
    Member
    calciumsodium
    Helpful
    Up
    0

    Thank you @Xecure for pointing me in the right direction about the elogind boot error issue.

    #59417
    Member
    Xecure
    Helpful
    Up
    0

    Well done persisting calciumsodium. In the end a 2 second wait gave runit enough time to load other services before elogind. This will surely help many in the future.

    @skidoo. WOW! This is very useful. I will take the table, save it as a database text file and use some of the info for the service manager. This is very good for understanding each service. Thank you very very much.

    The log status “?” I use when it cannot determine if the service is up or down. I will explore other possibilities and build on it.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #59433
    Member
    skidoo
    Helpful
    Up
    0

    The log status “?” I use when it cannot determine if the service is up or down.

    As food for thought toward UI development, here’s an archive.org helpdoc page for the BUM (boot-up manager). In the embedded screenshots, you’ll notice a “dashed line icon” was displayed for indeterminate items.

    https://web.archive.org/web/20180807213542/http://www.marzocca.net/linux/bumdocs.html

    #62907
    Member
    Ampersand
    Helpful
    Up
    0

    Well, when booted from a live usb it works as well as some previous versions on the same machine…
    May be apart from that when I selected ceni in connman/ceni selection miniapp (from the level of Rox desktop) all the networks disappeared and only reboot solved this.

    You devs need any special benchmarks to run or test, or whatever…?

    • This reply was modified 3 months, 1 week ago by Ampersand.
    • This reply was modified 3 months, 1 week ago by Ampersand.
    Attachments:

    I am not much into this linux thing...

Viewing 15 posts - 136 through 150 (of 153 total)
  • You must be logged in to reply to this topic.