Antix cannot start after upgrade

Forum Forums New users New Users and General Questions Antix cannot start after upgrade

  • This topic has 17 replies, 4 voices, and was last updated Apr 27-6:15 am by ModdIt.
Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #57951
    Member
    AvatarBudgie

    Returning to an old friend my 32 bit T42 having spilt drink on 64bit laptop screen, I saw Antix not used for 264 days and thought I should update. A while later all was OK until I rebooted and now I cannot start the machine. I get error message:-
    error: symbol “grub_register_command_lockdown not found.
    Sorry typing here not great after spill!
    I would like to try and recover my Antix system but need help please.

    #57952
    Member
    XecureXecure

    Hi.
    It seems one of grub updates broke some functionality (based on this thread in debian bug report).

    Try booting your system with a live-USB with antiX 19.3 . Once you can boot inside, connect to the internet, fully upgrade the live system, and try using the Boot Repair program (Control Centre Maintenance > Boot repair) to first reinstall grub (if on a UEFI system, select EFI, if on Legacy_BIOS system, select MBR).
    After reinstalling grub, try “Repair grub” on the same program to update all grub entries.
    After this, reboot and try accessing your installed system.

    If the problem persists, you will have to chroot to installed system using a live system and reinstall grub. We will explore this option (if needed) once you report back with the results of the first offered solution.

    #57958
    Member
    AvatarBudgie

    Hi and many thanks for your prompt reply. This gets more embarrassing with every step.

    In short the IBM T42 will not boot the USB Antix Live stick I just created.
    Following the advice on the Antix site I first tried to run the AppImage of the recommended software for creating the Antix Live stick. This crashed, I suspect because my laptop is using wayland but whatever it crashed. I then went to the dark side and used Rufus on Windoze. I was offered a choice of ISO mode or DD mode. I tried ISO mode and then tried the stick. The T42 BIOS was set for USB CD or FDD but neither would boot.
    I wondered if USB was OK so tried to boot it from my laptop, the one with the spill damage which now has a few keys not working.
    I couldn’t boot from the USB because the bios is set for secure boot. First time I have even tried to use this with a boot USB so I have no idea what to do next. Only good news is that I have been able to order a new keyboard for the laptop.
    I wonder if the USB stick uses USB 3 and that T42 cannot read it.
    Stuck.
    Should I burn an Antix CD and install from CD as a new install or try burning a live CD first? All advice welcome.

    #57961
    Member
    XecureXecure

    It doesn’t matter if the USB device is USB3. The only important part is connecting to a USB2 port if USB3 is problematic.

    I have no idea why you cannot boot to the USB device. It should work the same as making any live-USB with any other distro, and then booting into it.

    A note, booting to an antiX live USB system will not trigger Secure boot, so there must be something wrong with how the live-USB was created.

    Try again with an MX linux ISO, instead of antiX, as the procedure to fix grub should be the same.

    #57962
    Moderator
    AvatarModdIt

    Hi Budgie,
    USB 3 does not affect file system I use sticks on USB one to 3.1 without pain.
    I would use rufus in dd mode.
    On many laptops you can turn off secure boot.
    With regard to spill damage most laptops will work with an external usb keyboard and mouse.
    Stubborn ones need a docking station GRRR.

    You are actually lucky I have a T410 which has defective keyboard and will not turn on.
    Keyboards are rare as rocking horse poop here in Germany, price higher than for unobtanium
    ingots.

    #57974
    Member
    AvatarBudgie

    Many thanks, I shall persevere but this will have to wait until later as have work to do.

    The IBM T42 is very old now but has been a reliable machine through the years so would like to have it up again and will try using Rufus again.

    The casualty is a Lenovo W530 and after removing keyboard and rinsing it under the tap and drying it appears I have only lost the back arrow key.

    I found Luxnote couldn’t help with keyboard as they had no stock but they suggested I look on Ebay which is where I found my replacement. In fact I find there is an abundant supply on Ebay of various country keyboards, both new and pulls from old machines. I shall find out if what I bought is any good next week!

    Thanks for the support which is much appreciated.

    #57975
    Member
    AvatarBudgie

    I recreated the USB live stick using Rufus on windoze using DD mode, played around with bios boot options and now I have the live Antix version working with a lan connection. I confess I have forgotten how to proceed. I tried the gui updater and it asked for password but I cannot remember what is the PW for the live system please?

    #57976
    Member
    AvatarBudgie

    I have it now and my T42 system is up and running so very many thanks. Now it is running what housekeeping should I do by way of updating/upgrading to be sure the earlier bug has been fixed?

    #57977
    Member
    XecureXecure

    Well done.

    I have had problems with grub upgrades on Legacy_BIOS systems before (because of lack of knowledge) when using a /boot separated partition. For most installations, grub is installed on MBR, so When grub asks where to install, I now would only select the main drive and this no longer gives me any problem. No problems at all on UEFI systems.

    For maintenance, use antiX Updater and antiX autoremove apps. The rest is up to you.

    #58004
    Member
    Avatarskidoo

    I recreated the USB live stick using Rufus on windoze using DD mode

    dd mode?
    So, it’s essentially “a bootable (but non-writable) CD, on a stick“, incapable of “updating/upgrading”… unless you will now immediately install to disk, or setup persistence and target a writable persistence storage device.

    #58021
    Member
    AvatarBudgie

    Hi skidoo,
    Works for me as it was only created to achieve repair after upgrade problem. Antix is installed on T42 laptop as the only OS on the machine and upgrades are done on that machine. Thanks for he reminder of my options.
    Regards,
    Budge

    #58026
    Moderator
    AvatarModdIt

    Budgie, W is a nice laptop, still keyboards available too.

    Re:
    after removing keyboard and rinsing it under the tap and drying it appears I have only lost the back arrow key

    OOPS, depending on where you are living tap water will have a lot of minerals and added agressive chemicals,
    added chlorine is really bad for copper in circuits or elswhere for that matter..

    By all means wash and quickly dry a keyboard, wash in de mineralised water. Wrap in a pillowcase, dry in rice
    or Silica Gel kitty litter. Or bulk silica Gel.
    Both can be either sun dried or dried in oven.

    I have found Silica Gel Kitty litter best for fast dry, a microwave or normal oven will dry the gel kitty litter
    again nicely, start slowly or you get dust. The silica gel kitty litter is the same substance as used in the small
    bags in packages.

    #58028
    Member
    AvatarBudgie

    Hi and many thanks for the suggestions. I agree with all your suggestions and normally I would do exactly as you suggest. In my case I went for speed rather than thoroughness. Our water is from a private supply so no chlorine. Dissolved solids very low although pH a bit lower than 7. Our de-ionised tap is off-line and in another building so expedient solution was to risk the tap.
    I am not sure if any residual hot chocolate that has dried will ever respond to more washing but will wait for replacement. If I get time I may try more rinsing but if new board is OK I think I shall write it down to experience.
    Thanks again.
    Regards,
    Budge.

    #58043
    Moderator
    AvatarModdIt

    Hi Budgie, Maybe better not to rinse again.

    Details are also for any others unfortunately needing emergency reading in this thread at some later date.

    Dried hot chocolate is likely hard to remove due fatty substances involved, unless it is non fat no milk etc.

    Your W laptop is I think still supported by Lenovo, Many others unfortunately no longer. T410 T420 T430.
    No more original keyboards. Annoying as I have a defective T410, no keyboard at present will have tio order
    a pattern part in china and hope it works..

    #58044
    Member
    Avatarskidoo

    ebay.de

    .

    .

    .

    .

Viewing 15 posts - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.