(solved) antiX Core – antix-snapshot-cli – Error

Forum Forums Official Releases antiX-19 “Marielle Franco, Hannie Schaft, Manolis Glezos, Grup Yorum” (solved) antiX Core – antix-snapshot-cli – Error

  • This topic has 3 replies, 2 voices, and was last updated Nov 3-11:42 am by Marco D.G..
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #28875
    Member
    Marco D.G.

    Hi there, I have installed antiX-19_x64-core.iso on a Virtualbox VM then updated and installed the antix-snapshot-cli utility. The problem is that when i create a new Virtualbox VM with the new .iso generated by the antixsnapshot command, after selecting antix-snapshot from the GRUB, it gives me the following Error:

    Error: /init: line 1: can’t create /proc/sys/kernel/hotblug: nonexistent directory
    Error: mount: mounting /live/aufs on /live/aufs failed: No such device

    Fatal Error
    Could not mount afs

    Here is the screenshot: https://prnt.sc/prt26z

    I’ve tried both Kernel 4.9.193-antix.1-amd64-smp and 5.2.8-antix.1-amd64-smp

    In this video from runwiththedolphin the error descripted above does not occur: https://www.youtube.com/watch?v=nEW9r49ttbs

    I don’t know if this matter, but in the installation process I have done:
    gpt
    sda1 1G Linux swap
    sda2 16G Linux filesystem
    sda3 3G Linux filesystem
    write, quit
    root partition: sda2
    file system: ext4
    use sepatate ‘/home’ partition? y
    /home partition: sda3
    is sda3 a new ‘/home’ partition? y
    file system: ext4
    running antix-net? n
    install some apps via cli-aptiX? n
    install grub on MBR? y

    I don’t know if this this even matter, but the disk is an XPG 8200pro NMVE

    VirtualBox VM config:
    2G memory
    2 logic processors
    20GB specified dimension

    I really wanted to use antiX core to build the system by myself, still keeping the fantastic utilities that antiX offers, any help would be appreciated, Marco.

    • This topic was modified 1 year, 7 months ago by Marco D.G..
    • This topic was modified 1 year, 7 months ago by Marco D.G..
    • This topic was modified 1 year, 7 months ago by Marco D.G..
    #28900
    Member
    skidoo
    Helpful
    Up
    0
    :D

    prnt.sc/prt26z
    screenshot shows antiX 14-4-alpha

    youtube.com/watch?v=nEW9r49ttbs
    video is nearly 6 years old
    and the utility “antixsnapshot” (package “antix-snapshot-cli“) mentioned @0:39
    has not been updated for 5 years.

    In 2018, responding to an inquiry similar to yours, I had uploaded an updated version a newer script which provided functionality similar to the earlier utility: https://www.antixforum.com/forums/topic/isofromlive-a-commandline-utility-creates-an-iso-of-a-running-live-system/
    ^— That script was intended for use on a liveboot system, not from an _installed_ system.

    Unless you start from an antiX 19 or antiX 17 liveboot scenario, I would not expect the 2018 script (and certainly not the 2015 utility) to yield a successful result.

    #28901
    Member
    skidoo
    Helpful
    Up
    0
    :D

    https://github.com/antiX-Linux/antix-snapshot-cli/tree/master/new-iso/antiX
    ^— because this provides (injects) a prebuilt initrd.gz suitable for antiX15

    http://repo.antixlinux.com/buster/pool/main/a/antix-snapshot-cli/

    …that package should be removed from the antiX “buster” repository
    (and probably the antix17 “stretch” repository as well)

    #28904
    Member
    Marco D.G.
    Helpful
    Up
    0
    :D

    Thank you skidoo for the reply and sorry if I didn’t think it was an outdated package, I will take a look to the utility you have created but I think i will end up not using it as it seems that installing a desktop enviroment and the gui snapshot tool is the way to go. Best regards Marco.

    • This reply was modified 1 year, 7 months ago by Marco D.G..
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.