antiX Core + Slim help [solved]

Forum Forums Official Releases antiX-19 “Marielle Franco” antiX Core + Slim help [solved]

  • This topic has 8 replies, 5 voices, and was last updated Jan 16-5:31 pm by christophe.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #31697
    Member
    christophechristophe

    Hey guys,

    I’ve been having fun building up from antiX Core, running frugal, using jwm. I’ve been using startx to start x-windows, and everything has worked well. But I wanted to ADD fluxbox to this setup. I tried to add slim & fluxbox. But slim (which I’ve never used except as part of the base or full antiX setup) wouldn’t load my xsession.

    I searched the forum, and the only thing I came up with didn’t help (same result of slim giving the error message & restarting, etc). The help was from here: https://www.antixforum.com/forums/topic/desktop-manager-slim-rejects-my-username-and-password-how-do-i-fix-this/

    I copied the line to my slim.conf, but no change: it still gave the error message & respawned. I added (& commented-out the old one):
    login_cmd exec /bin/bash -login /etc/X11/Xsession %session <strong>(uncomment)</strong>

    Did I misunderstand that this would enable login when booting from a “non-standard-antiX” setup? Do I need to add something else?

    Anyway, I used Ctrl+Alt+F2 to login through the console, ran startx, and I got my (brand-new) fluxbox session. (And here I am asking for help.)

    Any pointers to getting slim working this way? Or should I use a different display mgr?

    my slim.conf:

    • This topic was modified 1 month, 1 week ago by christophe.
    Attachments:
    1. slim.txt
    #31704
    Member
    KooKoo

    I could never get slim login working fluxbox using base version. I tried everything anticapitalista said and could never get slim to work.

    My best advice is to use lightdm worked for me everytime.

    MX-19 4.19.0-6-amd6 (i3) : Debian-10 4.19.67-2+deb10u2 (i3) : anitX-19 runit (5.3.14-antix.1-amd64-smp) (i3)
    2 Laps T430 17.2 X220 17.4

    #31722
    Moderator
    masinickmasinick

    Slim can be tricky, more so than many other login management tools, probably because most of the technology it contains precedes the vast majority of the comparable tools. On the positive side, it’s lean and mean. On the challenging side it’s not as intuitive to configure.

    I suggest borrowing as much of the configuration as possible from an antiX full instance. If you put antiX full on a USB or have another partition on the same system containing the software you can look at the packages and the slim directories and copy what you want and need.

    Brian Masinick

    #31725
    Forum Admin
    anticapitalistaanticapitalista

    Looking at slim.conf, remove the line you added (line 44) and instead uncomment line 36

    login_cmd exec /bin/bash -login /etc/X11/Xsession %session

    Also remove line 65 (sessions jwm,fluxbox)

    Do you have ~/.xinitrc file?

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #31728
    Member
    Avatarskidoo

    maybe #31725 is intended as “instruction, specific to this case, to get it working”.
    I drafted a long post prior to reading that, and my post recommends a cmd_login line which matches that seen in default antiX 19 full.
    Here, I’m prefacing the long post by mentioning that I am not contradicting the instruction provided in #31725 ~~ I’m just covering how the dots are connected to work in the as-shipped antiX full.
    ___________________________

    The topic linked from post #1 discusses antix19core-LXDE —} lightDM + lxdm + (presumably) lxsession.
    That line (in post #1 here) is suitable only for use with a full-blown DE (desktop environment, e.g. LXDE, Xfce, Mate) .

    lightDM and SLiM serve only as “display manager” aka “login manager”.
    — starts Xorg server
    — checks user+password login credentials
    — uses a PAM (kernel pluggable authentication module) mechanism to register a “seat”
    (your tty, er console, input {–} output display hardware marshalled by xserver)
    — invokes the “session manager of choice” component… and then it just waits, serving as a idle wrapper
    (idle until logout/login is requested, or exit/shutdown)

    Upon installation of any display manager package, the DM is registered with rc.d to be automatically started for runlevels 2 and 5.
    If, during installation, another DM is found already present on the system, you are asked to choose which of the DMs will be enabled.
    ^—v
    During a session, if you logout (or you kill the DM process, or it crashes) the rc.d will automatically*** restart the DM.

    *** a sysadmin is free to install multiple DMs and manually change which one (or none) is started for each runlevel.

    The “startx” command is supposed to be (provide) a convenience… but, as an abstraction, it muddies the water.
    Users are resigned to not knowing / caring which display manager and auth mechanism and session manager components will be invoked in order to create their “desktop session”.

    We probably cannot put much weight in the terms “standard” vs NON-standard”.
    — some distros do not use, nor provide, a “startx” command
    — some distros are configured to only start a DM when entering runlevel 5
    — some distros replace rc.d with systemd
    — some distros ship only one DesktopEnvironment or WM
    — the sessionmanager component of a given DesktopEnvironment may demand use of its own WM
    ____________________________________________

    login_cmd setsid /usr/local/bin/desktop-session %session
    https://gitlab.com/antiX-Linux/Build-iso/blob/master/Themes/full/misc/slim.conf

    This SLiM login_cmd line (as seen in antiX full) calls a “session manager” utility named desktop-session which, in turn,
    invokes whichever “session” has been chosen via F1, e.g. “rox-icewm” (and passed as a commandline argument).
    Additionally, and in place of (instead of) sourcing ~/.Xsession, the utility sources both an “all cases” .startup file
    and (depending on which WM has been requested for this session) ~/.fluxbox/startup or ~/icewm/startup or…

    rox desktop manager (and spacefm -d) are windowmanager agnostic.
    Further, either of them can be manually invoked (and killed), at will during the course of a “desktop session”.

    When the antiX “session manager” utility (the desktop-session command) parses the commandline args for a given session request, it selectively starts the requested “desktop manager” (or none) along with the requested “window manager”… and each of those can be (and typically are) configured to autostart additional processes. Along the way, ~/.xinitrc is never sourced. (IIRC, by default, on an antiX full system that file isn’t even present)

    ____________________________________________

    re: “startx [..] error message & restarting”

    https://www.antixforum.com/forums/topic/antix-19-1-based-on-debian-sid-available/

    It seems that if you use startx, you need to also install xserver-xorg-legacy, but it is not needed if you use slim.
    If user does chooses slim login manager, you MUST edit /etc/slim.conf as shown above otherwise you get the error reported by Koo.

    • This reply was modified 1 month, 1 week ago by skidoo.
    • This reply was modified 1 month, 1 week ago by skidoo.
    #31737
    Member
    christophechristophe

    anticapitalista wrote:

    Do you have ~/.xinitrc file?

    No. I don’t.
    After I edited my slim.conf as you suggested, I found (something like) this in the xinitrc.sample in “fatso” on gitlab. Do I want something like this in the ~/.xinitrc?

    DEFAULT_SESSION=jwm
    case $1 in
    fluxbox)
    	exec fluxbox
    	;;
    *)
    	exec jwm
    	exec $DEFAULT_SESSION
    	;;
    esac
    

    By the way, to everyone, I really appreciate the help & suggestions.

    • This reply was modified 1 month, 1 week ago by christophe.
    • This reply was modified 1 month, 1 week ago by christophe.
    #31742
    Forum Admin
    anticapitalistaanticapitalista

    You don’t need a .xinitrc file.
    You might need to install xserver-xorg-legacy as well as making the edits I mentioned above.

    Aha- core plus frugal — remove the ‘d’ and probably ‘3’ in disable=lxd boot menu

    • This reply was modified 1 month, 1 week ago by anticapitalista.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

    #31754
    Member
    christophechristophe

    Great! Thank you. Will work on this when I get home from work!

    #31779
    Member
    christophechristophe

    THAT DID THE TRICK!!
    Thank you very very much.

    So, to reiterate, from antiX 19 core:
    1.) installed slim.
    1.5) I already DID have xserver-xorg-legacy installed, so that may be necessary…
    2.) made sure login_cmd exec /bin/bash -login /etc/X11/Xsession %session is the uncommented line. (line 36)
    3.) frugal = only disabling “l” in the boot codes. (not d or 3)
    4.) no other strange lines added to /etc/slim.conf
    5.) no ~/.xinitrc added (by an over-zealous, struggling antiXer).

    and slim works.

    (Seems like “antiX magic” to me…)

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.