antiX frugal install, iptables problem

Forum Forums New users New Users and General Questions antiX frugal install, iptables problem

This topic contains 3 replies, has 2 voices, and was last updated by thomasl Feb 10-8:35 am.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #18490
    Member

    thomasl

    I have a fresh antiX frugal install up and running that mirrors much of the basic configuration of my MX install and it all went mostly smoothly. I still have small differences in the way zsh handles the keyboard in antiX but that is a minor inconvenience. I have adapted the iceWM menu and defined my keyboard shortcuts, that’s all fine and dandy. And the apps I’ve installed (not many so far) do work as they do under MX.

    There’s one thing though that I just can’t get to work and that is my iptables setup. This works flawlessly in MX but it simply won’t load in antiX. The offending lines are these:

    -A INPUT -m conntrack –ctstate RELATED,ESTABLISHED -j ACCEPT
    -A OUTPUT -m conntrack –ctstate ESTABLISHED -j ACCEPT

    The error for both is “iptables: Protocol wrong type for socket.”

    I have googled left and right but none of the solutions I found worked (and some were above my head, I’m afraid). Has anyone got an idea why this works under MX but refuses to load under antiX? (MX has iptables 1.6.1, antiX has 1.6.0 but I do not think that is an issue here.)

    #18492
    Member

    skidoo

    update the linux kernel on your system then retest. Does this solve the problem?
    v—^
    .

    #18500
    Member

    thomasl

    Thanks @skidoo for that link (the googling I did already indicated that it might be some sort of kernel problem). I’ve read through that thread and I think that this may well be the same regression. I can’t ATM test the updated kernel but I will try to do so next week and report back.

    #18555
    Member

    thomasl

    Have just updated the kernel to 4.9.153, problem is solved. Thanks again…!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.