antiX Sid debian repos

Forum Forums News Sid Upgraders antiX Sid debian repos

This topic contains 83 replies, has 11 voices, and was last updated by fungalnet Mar 13-6:46 am.

Viewing 9 posts - 76 through 84 (of 84 total)
  • Author
    Posts
  • #13284
    Member
    Xaver
    Xaver

    # apt-get install gksu
    The following packages have unmet dependencies:
    gksu : Depends: libgksu2-0 (>= 2.0.8) but it is not going to be installed

    Next step: Find out, which packages are bloicking libgksu2-0:
    # apt install libgksu2-0
    The output should tell you that.

    • This reply was modified 4 months, 1 week ago by Xaver.
    • This reply was modified 4 months, 1 week ago by Xaver.
    • This reply was modified 4 months, 1 week ago by Xaver.
    #13290
    Forum Admin
    anticapitalista
    anticapitalista
    root@antix1:/home/anticap# apt-cache policy gksu
    gksu:
      Installed: 2.0.2-9+b1
      Candidate: 2.0.2-9+b1
      Version table:
     *** 2.0.2-9+b1 500
            500 http://repo.antixlinux.com/sid sid/main amd64 Packages
            100 /var/lib/dpkg/status
    root@antix1:/home/anticap# apt-cache policy libgksu2-0
    libgksu2-0:
      Installed: 2.0.13~pre1-9+b2
      Candidate: 2.0.13~pre1-9+b2
      Version table:
     *** 2.0.13~pre1-9+b2 100
            100 /var/lib/dpkg/status
         2.0.13~pre1-9+b1 500
            500 http://repo.antixlinux.com/sid sid/main amd64 Packages
    root@antix1:/home/anticap# apt-cache policy libgksu2-dev
    libgksu2-dev:
      Installed: (none)
      Candidate: 2.0.13~pre1-9+b1
      Version table:
         2.0.13~pre1-9+b1 500
            500 http://repo.antixlinux.com/sid sid/main amd64 Packages
    root@antix1:/home/anticap# 

    This is on my sid box. Are you sure you have the antiX repos enabled? Maybe try a different antiX mirror?

    Philosophers have interpreted the world in many ways; the point is to change it.

    #13299
    Member
    fungalnet
    fungalnet

    Yes it says it can’t be installed because it needs libgtop-2-0-10 that can’t be installed
    although libgtop-2-0-11 is already installed

    the repository is repo.antixlinux.com/sid and deb.debian
    I just did an update/upgrade to see if something changed, but it is still the same.

    #13300
    Forum Admin
    anticapitalista
    anticapitalista

    What app do you have that needs libgtop-2-0-10?

    The gtop library reads information about processes and the state of the system. It is used by the GNOME desktop environment.

    My bold addition.

    libgtop-2.0-10 is no longer in the debian/sid repos

    • This reply was modified 4 months, 1 week ago by anticapitalista.
    • This reply was modified 4 months, 1 week ago by anticapitalista.
    • This reply was modified 4 months, 1 week ago by anticapitalista.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #13332
    Member
    fungalnet
    fungalnet

    it says that libgksu needs libgtop but -10, which doesn’t exist, and it doesn’t like -11 version.
    Are you saying that if you remove your gksu/libgksu completely you can reinstall it?
    Anyway, it is not a big difference to me working at the terminal, just wanted to keep some siduction menus functional. But it is not installable in my regular antix sid where I hadn’t installed it before and libgtop is not installed.

    #13333
    Forum Admin
    anticapitalista
    anticapitalista

    Ok, I see the problem – I’ll put the libgtop2 -10 version debs into antiX sid repos. They are already in antiX testing repo

    Philosophers have interpreted the world in many ways; the point is to change it.

    #13337
    Member
    Xaver
    Xaver

    gksu works fine with libgtop-2.0-11 on my antix sid with siduction repos:

    gksu/sid,now 2.0.2-9+b1 amd64  [installiert]
    libgtop-2.0-11/unstable,now 2.38.0-2 amd64  [Installiert,automatisch]

    What is strange in my case:

    $ apt search libgksu2-0
    Sortierung... Fertig
    Volltextsuche... Fertig
    libgksu2-0/sid 2.0.13~pre1-9+b1 i386
      library providing su and sudo functionality

    But synaptic shows, that libgksu2-0/sid 2.0.13~pre1-9+b2 is installed.
    Maybe I have installed it manually in order to fix the issue. But I cannot remember it.

    • This reply was modified 4 months ago by Xaver.
    • This reply was modified 4 months ago by Xaver.
    • This reply was modified 4 months ago by Xaver.
    • This reply was modified 4 months ago by Xaver.
    #19364
    Member
    fungalnet
    fungalnet
    
    Err:2 http://repo.antixlinux.com/sid sid InRelease
      The following signatures were invalid: EXPKEYSIG DB36CDF3452F0C20 antiX (antix repo) <antix@daveserver.info>

    Is there something wrong with the mirror or have the keys been updated?

    • This reply was modified 5 days, 7 hours ago by fungalnet.
    #19379
    Member
    fungalnet
    fungalnet

    For those users getting the EXPKEYSIG error.

    3 steps, in a terminal

    1. wget 'https://download.tuxfamily.org/antix/releases/antix-archive-keyring.asc'

    2. sudo apt-key add antix-archive-keyring.asc

    3. apt-get update

    OK now

Viewing 9 posts - 76 through 84 (of 84 total)

You must be logged in to reply to this topic.