antix-testing /buster is breaking up

Forum Forums General Software antix-testing /buster is breaking up

Tagged: 

This topic contains 19 replies, has 5 voices, and was last updated by fungalnet Jul 21-9:36 am.

Viewing 5 posts - 16 through 20 (of 20 total)
  • Author
    Posts
  • #11461
    Member
    fungalnet
    fungalnet

    same image reburned, all I did is dist-upgrade and adding a kernel

    The following packages were automatically installed and are no longer required:
      cpp-6 dh-python libaudio2 libicu57 libisl15 libllvm3.9 libllvm5.0 libmng1 libmpfr4 libntfs-3g871
      libperl5.24 libpython3.5-minimal libpython3.5-stdlib libqtcore4 libqtgui4 libvte-common libvte9
      libwayland-egl1-mesa libxfont1 perl-modules-5.24 python3-distutils python3-lib2to3 python3.5
      python3.5-minimal qtcore4-l10n
    Use 'sudo apt autoremove' to remove them.
    The following NEW packages will be installed:
      dict libcap2-bin libdns-export1100 libfribidi0 libgdbm-compat4 libicu-le-hb0 libicu60 libindicator3-7
      libisc-export169 libisl19 libllvm6.0 libmaa4 libncurses6 libncursesw6 libprocps7 librecode0 libtinfo6
      libwayland-egl1 parted recode wamerican
    The following packages will be upgraded:
      adwaita-icon-theme antix-libs apt apt-transport-https apt-utils base-passwd bash bash-completion
      binutils binutils-common binutils-x86-64-linux-gnu bsdmainutils bsdutils build-essential cli-aptix
      cli-installer-antix cli-shell-utils conky conky-std console-data console-setup console-setup-linux
      cpanminus cpp cpp-6 cpp-7 cron dbus dbus-x11 dconf-gsettings-backend dconf-service debconf
      debconf-i18n debconf-utils debianutils desktop-defaults-core-antix dh-python dirmngr distro-info-data
      dosfstools dpkg e2fslibs e2fsprogs eudev fdisk file findutils fontconfig fontconfig-config g++ g++-7
      gcc gcc-6-base gcc-7 gcc-7-base gcc-8-base gdisk gettext-base git git-man glib-networking
      glib-networking-common glib-networking-services gnome-icon-theme gnupg gnupg-agent gnupg-l10n
      gnupg-utils gpg gpg-agent gpg-wks-client gpg-wks-server gpgconf gpgsm gpgv grub-common grub-pc
      grub-pc-bin grub2-common gsettings-desktop-schemas gtk-update-icon-cache gtk2-engines-pixbuf
      hicolor-icon-theme ifupdown inxi iproute2 isc-dhcp-client isc-dhcp-common iso-codes iso-snapshot-antix
      iso-template-antix kbd keyboard-configuration less libapparmor1 libapt-inst2.0 libapt-pkg5.0 libasan4
      libasound2 libasound2-data libatk-bridge2.0-0 libatk1.0-0 libatk1.0-data libatomic1 libatspi2.0-0
      libaudit-common libaudit1 libavahi-client3 libavahi-common-data libavahi-common3 libbinutils libblkid1
      libbsd0 libc-bin libc-dev-bin libc-l10n libc6 libc6-dev libcairo-gobject2 libcairo2 libcap-ng0
      libcc1-0 libcilkrts5 libcom-err2 libcomerr2 libcpan-distnameinfo-perl libcups2 libcurl3-gnutls
      libcurses-perl libdatrie1 libdbus-1-3 libdconf1 libdebconfclient0 libdrm-amdgpu1 libdrm-common
      libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libedit2 libegl-mesa0 libegl1 libegl1-mesa
      libelf1 liberror-perl libeudev1 libevdev2 libexif12 libext2fs2 libfdisk1 libfile-pushd-perl libfm-data
      libfm-extra4 libfm-gtk-data libfm-gtk4 libfm-modules libfm4 libfontconfig1 libgbm1 libgcc-7-dev
      libgcc1 libgcrypt20 libgdbm5 libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgif7 libgl1 libgl1-mesa-dri
      libgl1-mesa-glx libglapi-mesa libglib-perl libglib2.0-0 libglibmm-2.4-1v5 libglvnd0 libglx-mesa0
      libglx0 libgmp10 libgnutls30 libgomp1 libgpg-error0 libgraphite2-3 libgtk-3-0 libgtk-3-common
      libgtk2.0-0 libgtk2.0-common libharfbuzz0b libidn11 libimlib2 libinput-bin libinput10 libisl15 libitm1
      libjson-glib-1.0-0 libjson-glib-1.0-common liblcms2-2 libldap-2.4-2 libldap-common libllvm3.9
      libllvm5.0 liblognorm5 liblsan0 liblz4-1 liblzo2-2 libmagic-mgc libmagic1 libmodule-cpanfile-perl
      libmount1 libmpdec2 libmpfr6 libmpx2 libncurses5 libncursesw5 libnetfilter-conntrack3 libnewt0.52
      libnghttp2-14 libnpth0 libobrender32v5 libobt2v5 libp11-kit0 libpango-1.0-0 libpangocairo-1.0-0
      libpangoft2-1.0-0 libpangoxft-1.0-0 libparted-fs-resize0 libparted2 libpciaccess0 libpcre2-8-0
      libperl5.26 libpng16-16 libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libpopt0
      libprocps6 libproxy1v5 libpsl5 libpython3-stdlib libpython3.6-minimal libpython3.6-stdlib libqtcore4
      libqtgui4 libquadmath0 libreadline5 libreadline7 librtmp1 libsasl2-2 libsasl2-modules-db libseccomp2
      libselinux1 libsemanage-common libsemanage1 libsepol1 libsigc++-2.0-0v5 libsigsegv2 libslang2
      libsmartcols1 libsoup-gnome2.4-1 libsoup2.4-1 libsqlite3-0 libss2 libssl1.0.2 libssl1.1
      libstdc++-7-dev libstdc++6 libsystemd0 libtasn1-6 libthai-data libthai0 libtiff5 libtinfo5 libtsan0
      libubsan0 libunistring2 libuuid1 libvte-2.91-0 libvte-2.91-common libvte9 libwacom-common libwacom2
      libwayland-client0 libwayland-cursor0 libwayland-egl1-mesa libwayland-server0 libx11-6 libx11-data
      libx11-xcb1 libxapian30 libxatracker2 libxcb-dri2-0 libxcb-dri3-0 libxcb-glx0 libxcb-present0
      libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-sync1 libxcb-xfixes0 libxcb1 libxfont2 libxft2
      libxkbcommon0 libxml2 libxshmfence1 libzstd1 lightdm-gtk-greeter linux-compiler-gcc-7-x86
      linux-libc-dev live-usb-maker locales make man-db mime-support mount multiarch-support nano
      ncurses-base ncurses-bin neofetch openbox patch pcmanfm pcmciautils perl perl-base perl-modules-5.26
      pinentry-curses policykit-1 procps psmisc python3 python3-distutils python3-lib2to3 python3-minimal
      python3.6 python3.6-minimal qtcore4-l10n readline-common remaster-antix rsyslog sed sensible-utils
      squashfs-tools sudo synaptic tar tor tzdata ucf util-linux wget whiptail whois x11-apps
      x11-session-utils x11-utils x11-xkb-utils x11-xserver-utils xarchiver xfonts-utils xfsprogs xinit
      xserver-xorg-input-libinput xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-radeon
      xterm zlib1g
    367 upgraded, 21 newly installed, 0 to remove and 0 not upgraded.
    Need to get 13.7 MB/258 MB of archives.
    After this operation, 127 MB of additional disk space will be used.
    Do you want to continue? [Y/n] n
    
    #11463
    Forum Admin
    anticapitalista
    anticapitalista

    That seems to be ok – except it shows you have libsystemd0 already installed.
    What does apt-get purge libsystemd0 show?

    Philosophers have interpreted the world in many ways; the point is to change it.

    #11468
    Member
    fungalnet
    fungalnet

    on my main broken installation with chroot it says to remove “it” and tor and tor-geoip
    the tor I have is from 3.4.x experimental, could that be it?
    Would the existence of libsystemd break the installation to where it can’t boot?

    #11477
    Member
    Avatar
    736b69646f6f

    “Would the existence of libsystemd break the installation to where it can’t boot?”

    According to today’s post by rsmereka Blink Once and Get Systemd, the answer to this question is “no”.

    • This reply was modified 1 year, 3 months ago by 736b69646f6f.
    #11483
    Member
    fungalnet
    fungalnet

    Hating to erase and uninstall and based on the odd behavior even through chroot, where programs in /usr/sbin couldn’t be found, I started looking for problems in init. Sysvinit was still installed after the systemd-in-out during the consolekit problem, but init was not reinstalled. My fault for assuming. Installing back init restored all other resulting problems and dist-upgrade gave a totally different list.
    So I am back in business with linux4.17.4 and everything is in tact.

    One of the hints was update-grub not working through chroot, I thought it was a mounting problem. /usr/sbin/update-grub run but couldn’t find grub-mkconfig. /usr/sbin/grub-mkconfig -o worked. Confusing debian with arch I thought a link from /sbin to /usr/sbin was missing.

    All well! Learning learning learning.

Viewing 5 posts - 16 through 20 (of 20 total)

You must be logged in to reply to this topic.