AntiX17.2 on Fujitsu Scenic E600. System asks root user – keyboardUSB recognize

Forum Forums General Hardware AntiX17.2 on Fujitsu Scenic E600. System asks root user – keyboardUSB recognize

  • This topic has 49 replies, 9 voices, and was last updated Dec 10-2:01 am by Spartak77.
Viewing 15 posts - 1 through 15 (of 50 total)
  • Author
    Posts
  • #13316
    Member
    Spartak77

      In a general computer forum, I’m trying to help a user who wants to install antiX 17.2 on an old PC by a pendrive obtained with unbooting
      The Thread in the forum is this:
      http://www.istitutomajorana.it/forum2/Thread-linux-Antix-kernel

      The computer is Fujitsu SCENIC E600 CPU 4 2.4 GHz RAM 500 MB – 40 GB
      These are the features:

      Processor / Chipset
          • CPU 				Intel Pentium 4   2.4 GHz 
          • Data Bus Speed 		800 MHz 
          • Chipset Type 			Intel 865G 
          • Processor Main Features 	Hyper-Threading Technology 
          • Processor Socket 		Socket 478 
      Cache Memory
          • Installed Size 			L2 cache - 512 KB 
          • Cache Per Processor 		512 KB 
          • Type 				L2 cache 
          • Per Processor Size 		512 KB 
          • Installed Size 			512 KB 
      Memory
          • Max Supported Size 		2 GB 
          • Form Factor 			DIMM 184-pin 
          • Slots Qty 			2 
      Storage
          • Interface Type 		ATA-100 
          • Type 				none 
          • Read Speed 			48x (CD) / 16x (DVD) 
      RAM
          • Memory Speed 				400 MHz 
          • Memory Specification Compliance 		PC3200 
          • Technology 					DDR SDRAM 
          • Installed Size 					512 MB 
          • Rated Memory Speed 			400 MHz 
      Audio & Video
          • Memory Allocation Technology 		Shared Video Memory Technology 2.0 
      Hard Drive
          • Type 						HDD 
          • Interface Type 				ATA-100 
          • Spindle Speed 				7200 rpm 
          • Type 						HDD 
          • Interface Class 				Parallel ATA 
          • Installed Qty 					1 
          • Capacity 					40 GB 
      Storage Controller
          • Interface Type 				Serial ATA-150 
          • Type 						Serial ATA 
          • Installed Qty 					1 
      Storage Controller (2nd)
          • Controller Interface Type 	ATA-100 
          • Installed Qty 			1 
      Processor
          • Installed Qty 			1 
          • Max Supported Qty 		1 
          • Type 				Pentium 4 
          • Manufacturer 			Intel 
          • Clock Speed 			2.4 GHz 
      Optical Storage
          • Drive Type 			CD/DVD 
          • Type 				DVD-ROM 
          • Interface Type 		IDE 
      Miscellaneous
          • Features 
            USB port control, administrator password, chassis intrusion detection, hard drive password, system password, thermal monitoring 
          • Compliant Standards 
            ACPI, CSA, ISO 9241, UL, EN 60950, EN 61000-3-2, EN 61000-3-3, EN55022, EN55024, FCC Class B certified, GS, IEC 60950 
      Networking
          • Data Link Protocol 			Ethernet, Fast Ethernet, Gigabit Ethernet 
          • Remote Management Protocol 	DMI 2.0 
          • Form Factor 				integrated 
          • Features 				Alert on LAN 2, Wake on LAN (WoL) 
      System
          • Type 					personal computer 
          • Hard Drive Capacity 			40 GB 
      Graphics Controller
          • Form Factor 				integrated 
          • Graphics Processor 		Intel Extreme Graphics 2 Dynamic Video Memory Technology 2.0 
          • Video Interfaces 		VGA 
      Mainboard
          • Processor Socket 		Socket 478 
          • Data Bus Speed 		800 MHz 
          • Chipset Type 			Intel 865G 
      Audio Output
          • Form Factor 			integrated 
          • Sound Output Mode 		stereo 
          • Compliant Standards 		AC '97 

      The problems encountered are these:
      In the Live boot phase, this message comes out: gfxboot: not a com32 image
      However, by pressing the TAB key, the user can move forward and load the Live
      When the Live opens, the user said that the system did not see the hard disk.
      Then on my directions, telling him to use SpaceFM as Window Manager and using Center Control → Disk → Mount Device
      System finally sees the hard disk.
      But when he proceeds with the installation, the installer reports this message:
      “partition sda1 is not internal device and you are not a root user”
      I advised to go in
      Start-Menu → Run
      and type
      minstall
      with the “Run as Root” option
      Unfortunately it seems that this is not enough.
      I could recommend to login as root user but I do not know if it is a good thing

      Note. I have advised him to try using a CD or DVD for installation but it does not have a burner and at the moment it does not find anyone who burns the DVD.
      Note. The computer has old ports with aptii attack for the connection with the keyboard, the user does not have a keyboard that connects with that old attack, I think he has borrowed one to try to do the installation, but he has a USB keyboard that the system does not recognize. He would like to use this but he did not give informations to me to identify the keyboard. I asked to type:
      lsusb
      on another computer with another linux system that can recognize the keyboard, but at the moment it is not able to give me directions.
      However, the keyboard is a problem to be solved later, while I would like to help him about the problem of installing the system.
      Failing to help him, I had already suggested to join the forum and ask for help directly here. Meanwhile, I introduced here the problem to solve and then I will invite him to write directly because it’s not helpful if I am an intermediary

      • This topic was modified 5 years, 8 months ago by Spartak77.
      • This topic was modified 5 years, 8 months ago by Spartak77.
      #13324
      Forum Admin
      rokytnji

        I learned from a learned Puppy user on Murga Forums years ago that, Fujitsus could be weird hard ware < bios security hoops to jump > . Because of corp. security concerns . Being business laptops and all. They have a aversion to being customized.

        Not sure what to say other than md5sum checks done? How usb was made.
        I’ll leave this here in case it is of any use to you.
        You can change the search terms in the search box.

        link

        Instead of /dev/sda1. Usually I trust
        sudo blkid

        Before proceeding with a install to get my bearings/feet planted some what..

        Sometimes I drive a crooked road to get my mind straight.
        I don't suffer from insanity. I enjoy every minute off it.
        Motorcycle racing is rocket science.

        Linux Registered User # 475019
        How to Search for AntiX solutions to your problems

        #13328
        Member
        delix02

          what I would do :
          in the live session, open the menu and search in the application folder for the ROOT TERMINAL entry;
          start the terminal and give demo as password.
          In the terminal check the disks with
          fdisk -l

          and then use the command
          cli-installer -h

          I often run mc to get the Midnight Commander started and use this for searching and administrative tasks.

          #13331
          Member
          Spartak77

            @ Rokytnji, @ Delix02
            Thanks for your suggestions. I will report them

            #13336
            Moderator
            caprea

              It’s been a while since I had a live-stick with the message gfxboot: not a com32 image, but as far as I can remember, you can bring it to boot with the tab-trick, but not more than that .
              No live-features can be used, no F2 and so on, no cheatcodes can be used.
              It just boots, usually in english, and is just enough to take a look at a distribution and maybe install it.
              So it’s certainly a good idea to create a new stick with rufus or burn a dvd.
              Spartak77,very cool that you translated the antix-faq to Italian, btw.

              #13347
              Member
              fatmac

                My first thought is to ensure the download is good, check the md5sum.

                Create the USB installer with/using dd. (There used to be a Windows version.)
                Boot the live USB first, create a swap partition, (1GB), & a partition for the installation.
                Then use the installer.

                That machine likely has only got USB 1.1, so it’ll be a slow process.

                Linux (& BSD) since 1999
                Ultra Small Form Factor & thin client computers

                #13348
                Anonymous

                  Rufus for Windows can write ISO or DD.

                  #13369
                  Anonymous

                    hi everyone, this is me and thanks to user SPARTAK77 to have introduced my issue with Antix so i am the guy with the trouble.
                    Obviously i am walker1 member of italian forum too:
                    http://www.istitutomajorana.it/forum2/Thread-linux-Antix-kernel

                    So, i have no CD available at the moment so i burned Antix iso to my bootable USB key that i created by using Rufus and Unetbooting.
                    Anyway, the issue comes when i boot my pc by USB key because it happens Antix logo appears but i can NOT move any key of my keyboard and same for my mouse so i have to turn my pc off everytime i boot like that.

                    My keyboard keys ALWAYS works when i boot a lot of other old Linux iso’s but they don’t with Antix 17.2 iso so my issue is not fault of my keyboard hardware but of iso’s.
                    Infact my keyboard PERFECTLY works when i boot Puppy Linux Tahr 6.0 (very old Linux iso) by USB key.

                    So how can i enable my keyboard keys at “Antix 17.2” USB boot ?

                    By myself i think my pc is very very old (purchased in year 2004) so same for hardware inside my pc so that’s way USB boot gets that issue.
                    Maybe, could you give me an alternative Antix 17.2 modified iso in order i can boot without use keyboard keys ?

                    This is Antix USB boot logo where my keboard never works:

                    boot logo

                    #13384
                    Moderator
                    caprea

                      Did you check the md5sum of the downloaded iso ?
                      If so and all is fine, although other isos are providing the keyboard, could you look in the bios if the usb-legacy support is set to auto or enabled ? (do NOT set it to disabled)
                      Which keyboard is it ?

                      #13406
                      Anonymous

                        yes sure, everything is OK here, inclded my USB keyboard and my USB settings in BIOS.

                        And i do NOT think other isos are providing the keyboard keys to be working…

                        #13407
                        Moderator
                        caprea

                          But you already mentioned Puppy Linux Tahr 6.0 (very old Linux iso) would provide the keyboard ?
                          Sorry if i scared you with the NOT but I wanted to make that clear because if you disabled usb-legacy, it might not be possible to get into the bios anymore. Just a precaution.
                          Anyway you didn’t answer the question about the keyboard.

                          #13427
                          Anonymous

                            yes, some OLD linux version like puppy linux tahr 6.0 perfectly provides the keyboard.
                            But antix 17.2 never does.

                            In my opinion, my hardare pc is very old so new linux version like Antix 17.2 never provides keyboard to work…..
                            I can tell you my pc does not boot through USB so USB boot is not supported on my pc but i have been able to enable USB boot by using PLOP BOOT MANAGER, a tool that can enable USB boot on old pc’s like mine.
                            So maybe new OS’s (like Antix 17.2) should be booted by CD in my old machine….

                            So what should i do to make my keyboard works during Antix 17.2 usb booting ?
                            Or is it impossible ?

                            And also, should it be possible to start Antix 17.2 automatically WITHOUT using any keyboard keys after its USB boot ?
                            And also, should it be possible to edit grub.cfg file (inside /boot/grub/ directory) to make it starts automatically ?

                            This is grub.cfg file content:

                            #------------------------------------------------------------------
                            # file: /boot/grub/grub.cfg for the Live version of antiX
                            #
                            # This file can get updated automatically on a LiveUSB via the save
                            # feature in the text menus.  It is possible to break these updates
                            # by editing this file.
                            #------------------------------------------------------------------
                            loadfont /boot/grub/fonts/font.pf2
                            loadfont /boot/grub/fonts/7x13.pf2
                            loadfont /boot/grub/fonts/dejavu-sans-14.pf2
                            loadfont /boot/grub/fonts/dejavu-sans-16.pf2
                            set timeout=60
                            set gfxmode=1024x768
                            insmod efi_gop
                            insmod efi_uga
                            insmod video_bochs
                            insmod video_cirrus
                            insmod gfxterm
                            insmod png
                            insmod jpeg
                            terminal_output gfxterm
                            set theme=/boot/grub/theme/theme.txt
                            export theme
                            set gfxpayload="3200x1800;2560x1440;2160x1440;1920x1080;1600x1200;1600x1050;1600x900;1440x900;1366x768;1280x1024;1280x800;1280x720;1024x768;auto"
                            # search --no-floppy --set=root --fs-uuid %UUID%
                            set default=1
                            menuentry " antiX-17.2 386-base (4 October 2018)" {
                            linux /antiX/vmlinuz quiet splash=v disable=lx
                            initrd /antiX/initrd.gz
                            }
                            #--custom  menuentry " Custom" {
                            #--custom  linux /antiX/vmlinuz quiet
                            #--custom  initrd /antiX/initrd.gz
                            #--custom  }
                            menuentry " antiX-17.2 386-base Customize Boot (text menus)" {
                            linux /antiX/vmlinuz quiet splash=v disable=lx menus
                            initrd /antiX/initrd.gz
                            }
                            submenu ">>> Advanced Options for antiX-17.2 386-base <<<" {
                            menu_color_normal=white/black
                            menu_color_highlight=yellow/light-gray
                            menuentry " antiX-17.2 386-base Failsafe" {
                            linux /antiX/vmlinuz quiet splash=v disable=lx nomodeset failsafe
                            initrd /antiX/initrd.gz
                            }
                            menuentry "antiX-17.2 386-base Create Bootchart" {
                            linux /antiX/vmlinuz quiet splash=v disable=lx bootchart initcall_debug printk.time=y
                            initrd /antiX/initrd.gz
                            }
                            menuentry " antiX-17.2 386-base (1024x768)" {
                            linux /antiX/vmlinuz quiet splash=v disable=lx
                            initrd /antiX/initrd.gz
                            }
                            menuentry " Power Off" --hotkey=P {
                            halt
                            }
                            menuentry " Reboot"  --hotkey=R {
                            reboot
                            }
                            if [ -f /boot/grub/theme/help.txt ]; then
                            menuentry " Help" --hotkey=H {
                            cat /boot/grub/theme/help.txt
                            echo -n "Press <Enter> to continue "
                            read xxx_help
                            }
                            fi
                            }
                            if [ -f (hd1,gpt1)/EFI/MICROSOFT/BOOT/bootmgfw.efi ]; then
                            menuentry " Boot Windows from Hard Drive (hd1,1)" {
                            insmod ntfs
                            set root=(hd1,gpt1)
                            chainloader (${root})/EFI/MICROSOFT/BOOT/bootmgfw.efi
                            boot
                            }
                            fi
                            # Note: on 32-bit UEFI, in addition to disabling the 64-bit memtest we also
                            # disable looking for Windows past the first partition on the first drive.
                            # On at least one machine, the bootloader fails to work without this.
                            # See: http://forum.mxlinux.org/viewtopic.php?f=107&t=42863
                            if [ "${in_64_bit}" ]; then
                            if [ -f (hd1,gpt2)/EFI/MICROSOFT/BOOT/bootmgfw.efi ]; then
                            menuentry " Boot Windows from Hard Drive (hd1,2)" {
                            insmod ntfs
                            set root=(hd1,gpt2)
                            chainloader (${root})/EFI/MICROSOFT/BOOT/bootmgfw.efi
                            boot
                            }
                            fi
                            if [ -f (hd2,gpt1)/EFI/MICROSOFT/BOOT/bootmgfw.efi ]; then
                            menuentry " Boot Windows from Hard Drive (hd2,1)" {
                            insmod ntfs
                            set root=(hd2,gpt1)
                            chainloader (${root})/EFI/MICROSOFT/BOOT/bootmgfw.efi
                            boot
                            }
                            fi
                            if [ -f (hd2,gpt2)/EFI/MICROSOFT/BOOT/bootmgfw.efi ]; then
                            menuentry " Boot Windows from Hard Drive (hd2,2)" {
                            insmod ntfs
                            set root=(hd1,gpt2)
                            chainloader (${root})/EFI/MICROSOFT/BOOT/bootmgfw.efi
                            boot
                            }
                            fi
                            if [ -f (hd3,gpt1)/EFI/MICROSOFT/BOOT/bootmgfw.efi ]; then
                            menuentry " Boot Windows from Hard Drive (hd3,1)" {
                            insmod ntfs
                            set root=(hd3,gpt1)
                            chainloader (${root})/EFI/MICROSOFT/BOOT/bootmgfw.efi
                            boot
                            }
                            fi
                            if [ -f (hd3,gpt2)/EFI/MICROSOFT/BOOT/bootmgfw.efi ]; then
                            menuentry " Boot Windows from Hard Drive (hd3,2)" {
                            insmod ntfs
                            set root=(hd3,gpt2)
                            chainloader (${root})/EFI/MICROSOFT/BOOT/bootmgfw.efi
                            boot
                            }
                            fi
                            menuentry " Memory Test (64-bit UEFI)" {
                            #--esp set root=(hd0,2)
                            chainloader /boot/uefi-mt/mtest-64.efi
                            }
                            else
                            menuentry " Memory Test (32-bit UEFI)" {
                            #--esp set root=(hd0,2)
                            chainloader /boot/uefi-mt/mtest-32.efi
                            }
                            fi
                            #13435
                            Member
                            delix02

                              it is not a problem of the keyboard but the USB port.
                              Perhaps the port is just too slow to get the keyboard installed to the end before the next command of the installer gets started.
                              Or it is a matter of the version of the USB ports. USB_1 is VERY slow compared to USB_2.

                              I know, it is no solution to your problem but maybe it is a hint at least.

                              #13439
                              Moderator
                              caprea

                                You didn’t mention you are using plop boot manager, you could maybe try to force usb1.1 in plop, it perhaps gives better results.
                                Under 3.3
                                http://www.plop.at/en/bootmanager/thebootmanager.html#b0

                                • This reply was modified 5 years, 8 months ago by caprea.
                                #13466
                                Anonymous

                                  well, u know, i was able to start Antix because i found out BY MYSELF that Antix installer after 10 long minutes and i was not able to find it out before because i immediately thought it could never start but i tried to wait 10 minutes (for an other reason – i was waiting for somple people at home) and i saw slowly and slowly some Antix graphic circles were becoming white and after that Antix installer started.

                                  But….when Antix started to load in a black screen i got these 2 errors together:
                                  1) mounting /dev/loop0 on antix/live failed: Invalid argument

                                  2) Fatal Error Could not mount /live/boot-dev/antiX/linuxfs as a squashfs filesystem
                                  p = power off
                                  r = reboot

                                  So how can i avoid these errors and install Antix now ?

                                Viewing 15 posts - 1 through 15 (of 50 total)
                                • You must be logged in to reply to this topic.