Apache OpenOffice applications don't appear on Fluxbox or JWM Office Menus

Forum Forums General Software Apache OpenOffice applications don't appear on Fluxbox or JWM Office Menus

This topic contains 5 replies, has 4 voices, and was last updated by Len E. Jan 2-3:44 pm.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #14932
    Member
    Avatar
    Len E.

    I’m a long-time user of OpenOffice, and its successor,
    Apache OpenOffice.

    I’m working with Antix-17.1-base, and I’ve installed
    Apache OpenOffice in the standard way:
    -after downloading the latest tarball, and unpacking
    it with the command, sudo tar -xvzf Apache*.gz,
    cd …en-US/DEBS,
    sudo dpkg –install op*.deb —> installs the packages
    cd desktop-integration,
    sudo dpkg –install op*.deb —> installs the menu system

    -when menu updates are applied in icewm, the Apache OpenOffice
    applications appear in the Office menu
    -when menu updates are applied in fluxbox and jwm, the
    applications do NOT appear in the Office menu.

    Why the discrepancy ????

    Len

    #14933
    Forum Admin
    anticapitalista
    anticapitalista

    I misread the post.

    • This reply was modified 3 months, 2 weeks ago by anticapitalista.
    • This reply was modified 3 months, 2 weeks ago by anticapitalista.

    Philosophers have interpreted the world in many ways; the point is to change it.

    #14938
    Member
    Avatar
    skidoo

    FWIW, I peeked at content of the *.desktop files within the sourceforge-hosted “menus[..]deb” file and didn’t find anything WM or DE -specific.
    Some of ’em do have extremely long (2000+ characters) “MimeTypes=” lines, but it’s unclear to me why the update-menu operation would choke (or not) while processing those when it is launched from within a particular WM session.

    #14941
    Forum Admin
    dolphin_oracle
    dolphin_oracle

    is libreoffice installed on base? When I tried this with full, there was a conflict with the desktop-integration package. Removing libreoffice and then reinstalling the desktop-integration package caused openoffice to show in all desktop menus.

    I should mention that I did not get any entry in the menus without removing libreoffice and reinstalling the oo desktop-intregration package.

    #14942
    Member
    Avatar
    Len E.

    To answer dolphin_oracle’s question:

    antix-17.1-base does not have libreoffice pre-installed.

    (I don’t think it’s relevant, but I am using 32-bit software).

    Len

    #14970
    Member
    Avatar
    Len E.

    (Note: the latest version of Apache OpenOffice is 4.1.6)

    An old saying applies in this case: those who forget
    their history are condemned to repeat it.

    I happened to check my notes from last March with my initial
    attempt to install Apache Open Office (the previous version,
    4.1.5) on Antix-17.1-base, and found that none of the menu
    updates worked at that time.

    I’ve just installed a fresh copy of Antix-17.3.1_i386-base on
    a test machine, and installed the latest version (4.1.6) of
    Apache Open Office on it.
    All the menu updates worked !
    ******************************************************************
    I’m not sure exactly who has fixed what since last March, but
    I’m very happy that it has all come together now.

    Thanks to all the responders for shedding light on the original
    problem.

    Len

    • This reply was modified 3 months, 2 weeks ago by Len E..
Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.