Audio too Loud on Antix

Forum Forums New users New Users and General Questions Audio too Loud on Antix

  • This topic has 23 replies, 8 voices, and was last updated Jan 25-11:11 am by keshav-uses-linux.
Viewing 9 posts - 16 through 24 (of 24 total)
  • Author
    Posts
  • #130385
    Moderator
    caprea

      The screenshot above clearly indicates that pipewire is not started on your system.
      Please post
      pgrep -l wire

      You can also look with this command if everything needed is installed on the system
      apt-cache policy pipewire pipewire-alsa pipewire-jack pipewire-pulse wireplumber pavucontrol gstreamer1.0-pipewire antix-pipewire-extras liblua5.3-0

      #130421
      Member
      keshav-uses-linux

        Thanks, so Running

        pgrep -l wire

        gave no response

        apt-cache policy pipewire pipewire-alsa pipewire-jack pipewire-pulse wireplumber pavucontrol gstreamer1.0-pipewire antix-pipewire-extras liblua5.3-0

        running this gave this response (Antix forum is not letting me post the terminal response, so i am ging to host it on a link) :-
        https://nopaste.net/cIqqMDxYp5

        • This reply was modified 5 months, 4 weeks ago by keshav-uses-linux.
        • This reply was modified 5 months, 4 weeks ago by keshav-uses-linux.
        #130450
        Moderator
        caprea

          Thanks,the only thing missing is antix-pipewire-extras, which can be helpful.
          sudo apt install antix-pipewire-extras

          Because you do not get response from pgrep -l wire I’m guessing the startup script from your dektop-session isn’t correctly changed.

          So please look again at your /home/XXXyourusernameXXX/.desktop-session/startup for
          pipewire-start &

          or best post it here or with nopaste
          geany /home/XXXyourusernameXXX/.desktop-session/startup

          #130457
          Member
          abc-nix

            running this gave this response (Antix forum is not letting me post the terminal response, so i am ging to host it on a link) :-
            https://nopaste.net/cIqqMDxYp5

            Based on the repo statistics, the mirror you are using is over 3 months out of date. Try with a different mirror.

            • This reply was modified 5 months, 4 weeks ago by abc-nix.
            #130459
            Member
            keshav-uses-linux

              Thanks,the only thing missing is antix-pipewire-extras, which can be helpful.
              sudo apt install antix-pipewire-extras

              Okay, now i have successfully installed antix-pipewire-extras

              Because you do not get response from pgrep -l wire I’m guessing the startup script from your dektop-session isn’t correctly changed.

              So please look again at your /home/XXXyourusernameXXX/.desktop-session/startup for
              pipewire-start &

              or best post it here or with nopaste
              geany /home/XXXyourusernameXXX/.desktop-session/startup

              So, here’s the startup file

              #!/bin/bash
              ## fix HiDPI screen if necessary.
              ## Not needed if there is no HiDPI screen 
              autoscale-antix
              ## Only use ONE (or neither)
              ## Simple script to check for connectivity (NCA). 
              ## If no network connection is detected, activate wi-fi networks, open connman and go straight to the wi-fi connections tab.
              network-check-antix &
              ## OR More comples tool (NCR) that provides on screen info while waiting for a network connection to be established.
              ## NRS reports in both GUI and non-GUI environments. 
              #network-readiness-state &
              ## Puts connman gui monitor icon on the taskbar
              #cmst -m & 
              ## Uncomment if using pulseaudio (you need to install it). Make sure it starts before volumeicon.
              #pulseaudio -D &
              ## Uncomment if using pipewire (you need to install it). Make sure it starts before volumeicon.
              #start pipewire, pipewire-pulse and wireplumber via script
              pipewire-start &
              pipewire
              ## Puts a volume icon on the taskbar
              sleep 5 && volumeicon &
              ## Enable/Disable automounting
              automount-antix &
              ## Puts a flag on the taskbar to show which keyboard is being used if more than 1 keyboard layout is detected
              fbxkb-start &
              ## Uncomment for easy search from the taskbar
              #search-bar-icon &
              ## Uncomment the following line to mount Samba and/or NFS shares
              #connectshares &
              ## Uncomment to show the configuration gui of a running ssh-conduit-x11vnc server (you need to install ssh-conduit-antix)
              #ssh-conduit-x11vnc.sh gui &
              ## Uncomment to use clipboard manager
              #clipit &
              ## Use pkexec (you need to install policykit-1-gnome)
              #/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 &
              ## Uncomment both to show wicd networking monitor (you need to install wicd).
              #wicd-client -t &
              #grep -q "START_DAEMON=no" /etc/default/wicd || wicd-client -t &
              ## Uncomment after installing apt-notifier
              #apt-notifier & 
              ## Enable Mouse Configuration at Startup
              #ds-mouse -all &
              ## Uncomment if using network-manager  (you need to install it)
              #nm-applet &
              
              #130462
              Member
              keshav-uses-linux

                Based on the repo statistics, the mirror you are using is over 3 months out of date. Try with a different mirror.

                Thank you so much for looking into that big response and giving me a very useful tip! I really appreciate your kindness and generosity.

                • This reply was modified 5 months, 4 weeks ago by keshav-uses-linux.
                • This reply was modified 5 months, 4 weeks ago by keshav-uses-linux.
                #130469
                Moderator
                caprea

                  @abc-nix, very good catch! @keshav-uses-linux, you already know the easiest way to change the mirror is to install and use repo-manager.
                  Afterwards
                  sudo apt update
                  sudo apt full-upgrade

                  Edit: For your better insight, pipewire will only work in the newest version.There have been problems with the old version.

                  ## Uncomment if using pipewire (you need to install it). Make sure it starts before volumeicon.
                  #start pipewire, pipewire-pulse and wireplumber via script
                  pipewire-start &
                  pipewire

                  Please remove the last word pipewire in this section from the startup script to look like this

                  ## Uncomment if using pipewire (you need to install it). Make sure it starts before volumeicon.
                  #start pipewire, pipewire-pulse and wireplumber via script
                  pipewire-start &

                  reboot

                  • This reply was modified 5 months, 4 weeks ago by caprea.
                  #130534
                  Member
                  keshav-uses-linux

                    Ohh thanks, that worked. now i am all setup.

                    #130545
                    Member
                    keshav-uses-linux

                      For anyone who wants a Summary, here is a recap :-


                      How to Fix Audio too Loud on Antixs

                        Causes
                        [*]In my case, i was using an external Audio Interface and for some reason, aslamixer (Default audio manager) only gives a single volume control instead of a secondary preamp volume control,
                        if that not the case for you, then turn down that secondary preamp volume control and use the other volume control for adjustments

                        Solution
                        [*] Ther

                    Viewing 9 posts - 16 through 24 (of 24 total)
                    • You must be logged in to reply to this topic.