Automontaje NFS en el arranque

Forum Forums General Other Languages Spanish Automontaje NFS en el arranque

  • This topic has 12 replies, 3 voices, and was last updated Oct 13-10:02 pm by peixe80.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #116061
    Member
    peixe80

      ¡Hola!

      Desde mi netbook con antiX (con IP local 192.168.0.34) necesito acceder a una carpeta de mi ordenador principal, que corre otra distribución GNU/Linux (con IP local 192.168.0.33). Tengo configurado el archivo /etc/exports en la parte del servidor del siguiente modo:

      /home/[mi_usuario]/[mi carpeta]/ 192.168.0.34(ro,no_subtree_check,async)

      Desde el cliente antiX puedo acceder sin problema con el siguiente comando:

      # mount 192.168.0.33:/home/[mi_usuario]/[mi_carpeta]/ /mnt/[mi-carpeta]/

      Pero necesito automatizarlo para que se monte siempre al arrancar antiX. Para ello, he agregado la siguiente línea al archivo /etc/fstab en el cliente antiX:

      192.168.0.33:/home/[mi_usuario]/[mi_carpeta]/ /mnt/[mi_carpeta]/ nfs ro 0 0

      Pensaba que con esto ya se automontaría en el arranque, pero no lo hace, lo cual me obliga a ejecutar este otro comando después de cada inicio en el cliente antiX:

      # mount -a

      ¿Alguien sabe por qué no se me automonta la carpeta compartida en NFS? ¿Quizá tenga que cambiar algo en “antiX Control Centre / Sistema / Elegir servicios de inicio”? Por si sirve de algo, ahí me aparece así la línea de nfs-common:

      service    | 1 | 2 | 3 | 4 | 5 | 0 | 6 | S
      nfs-common |   |   |   |   |   |   |   | X

      Es decir, solo está marcada la última columna (S), pero no he querido tocar nada, porque no entiendo qué significa cada columna… ¿Alguna ayuda?

      ¡Muchas gracias!

      • This topic was modified 7 months, 1 week ago by peixe80.
      • This topic was modified 7 months, 1 week ago by peixe80.
      #116130
      Member
      abc-nix

        Hi.

        Start the system again and try running nfs-common from terminal on your system (I assume antiX 23 sysvinit edition)
        sudo service nfs-common restart
        If there is any error message, please share it with us.
        If the nfs mount points are mounted after restarting the service, then you could add the instruction to restart nfs-common from /etc/rc.local (add the restart service instruction there).

        #116136
        Member
        ChPol

          Hola

          Es posible que antiX esté intentando conectar el recurso compartido antes de que la red esté lista.
          Dado que la conexión se realiza con mount -a
          ¿Por qué no poner simplemente este comando en el archivo startup de su escritorio?

          Una simple observación que puede no ser útil
          A mano usas las opciones: ro,no_subtree_check,async
          ¿No sería más normal poner estas mismas opciones en fstab y no sólo ro?

          Bonne continuation

          #118843
          Member
          peixe80

            Hi.
            Start the system again and try running nfs-common from terminal on your system (I assume antiX 23 sysvinit edition)
            sudo service nfs-common restart
            If there is any error message, please share it with us.
            If the nfs mount points are mounted after restarting the service, then you could add the instruction to restart nfs-common from /etc/rc.local (add the restart service instruction there).

            Hi @abc-nix. Yes, I have antiX 23 sysvinit. There are no errors with nfs-common restart, but the nfs mount point isn’t mounted after that.

            Hola
            Es posible que antiX esté intentando conectar el recurso compartido antes de que la red esté lista.
            Dado que la conexión se realiza con mount -a
            ¿Por qué no poner simplemente este comando en el archivo startup de su escritorio?
            Una simple observación que puede no ser útil
            A mano usas las opciones: ro,no_subtree_check,async
            ¿No sería más normal poner estas mismas opciones en fstab y no sólo ro?
            Bonne continuation

            Hola @ChPol. He agregado “mount -a” al archivo ~/.desktop-session/startup, pero no funciona. Me da la impresión de que quizá el motivo sea que dicho comando ha de ejecutarse como root. Es decir, debería ser “sudo mount -a”, pero no he querido ponerlo así porque supuse que en ese caso me pediría la contraseña, por lo que ya no sería tan automático… ¿Existe alguna forma de hacer que ese comando se ejecute al inicio de forma automática y sin pedir contraseña?

            En cuanto a las opciones del montaje, en un principio había puesto solo “ro” porque en algún tutorial que estuve siguiendo lo dejaban así, pero ya lo he cambiado por “ro,no_subtree_check,async” 🙂

            • This reply was modified 6 months, 1 week ago by peixe80.
            • This reply was modified 6 months, 1 week ago by peixe80.
            #118908
            Member
            ChPol

              Hola

              Si consigues conectarte manualmente con un simple mount -a como usuario simple, no hay razón para usar derechos superiores para hacerlo.
              Tu sesión sartup utiliza los mismos derechos.
              En mi configuración, tengo user para editar. Puede agregar esta opción en el servidor para obtener: 192.168.0.34(rw,user,no_subtree_check,async)

              ¿Estás seguro de que el comando se ejecuta?
              ¿No estás en un escritorio mínimo como IceWM-mínimo o JWM-mínimo?

              • This reply was modified 6 months, 1 week ago by ChPol.
              #119240
              Member
              peixe80

                Hola de nuevo @ChPol

                No, no puedo ejecutar un simple “mount -a” en el cliente; siempre me pide “sudo”.

                He intentado agregar la opción “user” al archivo /etc/exports del servidor, pero no me la admite:

                # cat /etc/exports
                /home/[mi_usuario]/[mi_carpeta] 192.168.0.34(async,no_subtree_check,user,ro) 
                # exportfs -arv
                exportfs: /etc/exports:1: unknown keyword "user"
                exportfs: No file systems exported!

                Gracias por la ayuda 🙂

                P. D.: Mi escritorio es el que viene por defecto: zzz-icewm

                • This reply was modified 6 months, 1 week ago by peixe80.
                #119296
                Member
                ChPol

                  Hola

                  Si necesita utilizar sudo en la estación de trabajo cliente, es realmente una cuestión de derechos.
                  Lo siento, cometí un error. No es algo que configure todos los días.

                  La opción que te di fue añadirlo al archivo fstab del cliento.
                  La línea completa en el archivo fstab del cliento sería :

                  192.168.0.33:/home/[mi_usuario]/[mi_carpeta]/ /mnt/[mi_carpeta]/ nfs rw,user,no_subtree_check,async 0 0

                  Esto da a los usuarios en la estación de trabajo cliente los derechos para montar.

                  Si esto no funciona, intentaremos configurar mount -a sin contraseña, pero habrá que hacerlo en todas las estaciones de trabajo cliente. Pero la manipulación es algo peligrosa.

                  #119332
                  Member
                  peixe80

                    Muchas gracias @ChPol

                    Finalmente me funciona añadiendo en la parte del cliente “mount -a” al archivo ~/.desktop-session/startup y “user” al archivo /etc/fstab. Eso sí, he tenido que quitar en este último la opción “no_subtree_check”, que no admite (si la dejo, devuelve el siguiente error en el montaje: “mount.nfs: an incorrect mount option was specified”).

                    Este es el contenido definitivo de mis archivos de configuración:

                    /etc/exports (servidor):

                    /home/[mi_usuario]/[mi carpeta]/ 192.168.0.34(ro,async,no_subtree_check)

                    /etc/fstab (cliente):

                    192.168.0.33:/home/[mi_usuario]/[mi carpeta]/ /mnt/[mi_carpeta]/ nfs ro,async,user 0 0

                    ~/.desktop-session/startup (cliente):

                    mount -a

                    Solucionado 🙂

                    #119374
                    Member
                    ChPol

                      Me alegro de que al final funcionara.
                      Como la petición de montaje de arranque no funciona, personalmente añadiré la opción noauto para que no produzca errores.

                      192.168.0.33:/home/[mi_usuario]/[mi carpeta]/ /mnt/[mi_carpeta]/ nfs ro,async,user,noauto 0 0

                      Sin edición al principio = sin errores

                      Un saludo

                      #119955
                      Member
                      peixe80

                        Pues lo mismo acabo de hacer yo. ¡Gracias de nuevo!

                        #120033
                        Member
                        peixe80

                          Finalmente he tenido que quitar la opción “noauto”, porque con ella dejó de funcionar el comando “mount -a”.

                          #120042
                          Member
                          ChPol

                            Quizá sea una cuestión de sincronización.
                            Su ordenador arranca demasiado rápido sin errores de red. Añadir una pausa de 10 o 15 segundos antes de mount -a probablemente conseguiría que la interfaz de red estuviera lista para un montaje. En el archivo startup:

                            sleep 10 && mount -a &

                            Pero eso es un poco puntilloso, ya que así es como funciona.

                            • This reply was modified 6 months ago by ChPol.
                            #120354
                            Member
                            peixe80

                              Si es así, prefiero dejarlo como lo tengo (sin “noauto” en el fstab y con un simple “mount -a” en el startup), ya que quiero tener la unidad montada inmediatamente en cuanto se inicia la sesión, pues siempre he de trabajar con ella y prefiero tenerla lista cuanto antes, sin tener que esperar 10-15 segundos. Pero gracias igualmente 🙂

                            Viewing 13 posts - 1 through 13 (of 13 total)
                            • You must be logged in to reply to this topic.