Automount ntfs-partition on dual boot

Forum Forums Orphaned Posts antiX-17 “Heather Heyer, Helen Keller” Automount ntfs-partition on dual boot

  • This topic has 4 replies, 5 voices, and was last updated Oct 31-5:57 pm by rokytnji.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1478
    Member
    Ant17

      Dual booting Antix 17 with Win 10 on a laptop here. Very impressed so far. But:

      I can’t figure out how to mount the laptop’s ntfs-partition? It keeps throwing errors at me. I’d like it to automount both the ntfs partition and Antix’s ext4 partition on boot, but I can’t even access the ntfs partition right now.

      I’m using Space/IceWM.

      Ideas?

      #1484
      Forum Admin
      BitJam

        These may be two separate problems here. To automount internal partitions on live, use the “mount=all” cheat. To automount on an installed system, there should be an entry in /etc/fstab for the partition. Just remove “noauto” from the list of options in that entry. If there is no entry for the partition then add one. It’s good form to identify the partition by its UUID but you don’t have to.

        I sometimes see errors when trying to mount ntfs partitions that contain Windows. Windows can leave the file system in a state that doesn’t allow Linux to mount it. Sometimes booting into Windows and cleanly shutting down will fix the problem. You could also try using the ntfsfix program.

        Context is worth 80 IQ points -- Alan Kay

        #1485
        Forum Admin
        anticapitalista

          In /etc/fstab you should have an entry for the ntfs partition. You need to change noauto to auto for that entry, reboot.
          BitJam beat me to it.

          • This reply was modified 6 years, 4 months ago by anticapitalista. Reason: other post

          Philosophers have interpreted the world in many ways; the point is to change it.

          antiX with runit - leaner and meaner.

          #1491
          Forum Admin
          dolphin_oracle

            a sample entry for ntfs in your fstab might look something like this.

            #Entry for /dev/sda6 :
            UUID=4AAA433BAA4322B5	/media/datapart	ntfs-3g	uid=1000,gid=users,dmask=002,fmask=113,auto,locale=en_US.UTF-8	0	0

            where UUID is the partition, /media/datapart is the mountpoin, ntfs-3g is the type. The rest are options, including the “auto” option so that its mounted on boot.

            #1499
            Forum Admin
            rokytnji

              Caveat to above posts. It’s a Windows 10 thing.

              Link

              Sometimes I drive a crooked road to get my mind straight.
              Not all who Wander are Lost.
              Motorcycle racing is rocket science.

              Linux Registered User # 475019
              How to Search for AntiX solutions to your problems

            Viewing 5 posts - 1 through 5 (of 5 total)
            • You must be logged in to reply to this topic.