Not automatically booting to grub-screen – have I got the correct flags?

Forum Forums General Software Not automatically booting to grub-screen – have I got the correct flags?

  • This topic has 12 replies, 6 voices, and was last updated Sep 12-2:16 pm by mikey777.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #114981
    Member
    mikey777

      A backup copy of antiX21 was successfully made to an SSD using the ‘dd’ command, following shrinkage of the OS-partition to the minimum size possible. It was copied from a 1TB drive (msdos/ext4 format) to a 4TB drive (gpt/ext4 format). I should add that I have a legacy install of antiX (not UEFI).

      My new copy of antiX21 on the 4TB drive boots successfully, but not from the grubscreen. I have to press the Esc-button as it boots up, and select the drive I want to boot from in the boot-list.

      I suspect that the problem lies with the boot flags I’ve applied. I’d really like some advice on this, so that the computer will automatically boot to the grubscreen, after powering up. Below is a gparted screenshot, showing what flags and where they have been applied:

      • This topic was modified 10 months, 3 weeks ago by mikey777.
      • This topic was modified 10 months, 3 weeks ago by mikey777.
      • This topic was modified 10 months, 3 weeks ago by mikey777.
      Attachments:

      ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
      - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
      ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
      - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
      - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

      #115006
      Member
      sybok

        Where does ‘/dev/sda3’ come from? (Did you create it yourself? Is it a remnant of previous usage of that drive? Is it part of the transferred backup?)

        #115009
        Member
        mikey777

          Where does ‘/dev/sda3’ come from? (Did you create it yourself? Is it a remnant of previous usage of that drive? Is it part of the transferred backup?)

          Thanks sybok. The sda3 is not a remnant of previous usage of the drive – it’s newly created.
          I thought that my failure to boot automatically to the grubscreen might be because I don’t have a small bios-grub partition, so I created one using gparted, but it didn’t make any difference. I still had to press the Esc-key on powering up, to get to the boot list and select the drive, before finally arriving at the grubscreen.

          I think a small bios-grub partition (~15 to 20 MB) is needed with gpt-formatted drives, i.e. those larger than 2TB, even for a legacy install. The partition on the drive I’m using is 3TB. Smaller than 2TB, one uses a dos-format for legacy installs (if I’ve understood/remember correctly), and of course without the need for a bios-grub partition.

          • This reply was modified 10 months, 3 weeks ago by mikey777.
          • This reply was modified 10 months, 3 weeks ago by mikey777.

          ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
          - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
          ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
          - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
          - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

          #115014
          Member
          sybok

            I really haven’t tried such stuff like you did… hence my suggestions are best effort guesses to be tried when appropriate backup is available.
            (I’d guess it still is present on the smaller 1TB drive.)

            First, do you have multiple drives (meaning HW) present in the computer?
            A) If yes, then perhaps all you need to do is set boot priority to the 4TB drive in BIOS and that could be all.
            B) If not, then the following applies:

            You mention to have a legacy, non-UEFI, install of antiX:
            Is your HW capable of UEFI?
            1) If not, I would delete the ‘/dev/sda3’ and try ‘antiX Control Centre’ -> ‘Maintenance’ -> ‘Boot repair’ and go with its default option.
            2) If yes, then it could get more tricky.

            BTW, I found a concise information regarding booting in GPT partitioning:
            http://askubuntu.com/questions/657179/where-is-grub-installed-on-a-gpt-disk#657303

            #115025
            Member
            mikey777

              First, do you have multiple drives (meaning HW) present in the computer?

              YES

              (A) If yes, then perhaps all you need to do is set boot priority to the 4TB drive in BIOS and that could be all.

              In laptop settings, boot-order is already set as “Hard Drive” as first booting device. I have 2 x 4TB SSDs install, (sda=antiX21; sdb=backup data files) but “Hard Drive” doesn’t show these drives individually in settings.

              You mention to have a legacy, non-UEFI, install of antiX:
              Is your HW capable of UEFI?

              NO

              1) If not, I would delete the ‘/dev/sda3’ and try ‘antiX Control Centre’ -> ‘Maintenance’ -> ‘Boot repair’ and go with its default option.

              I tried this but it didn’t appear to change the booting behaviour

              I’ll now have a look at the GPT partitioning link you provided.
              Thank you for your help, sybok, very much appreciated.

              ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
              - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
              ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
              - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
              - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

              #115027
              Member
              linuxdaddy

                Hi mickey777,

                Could try deleting sda3 and using gparted to set the “boot” flag on sda1.
                Then run boot repair.

                #115037
                Member
                stevesr0

                  Hi mikey777,

                  On my oldest computer, I have a BIOS/GPT setup. It goes to grub, so that can work.

                  On my system, the first partition (/sda1) is 2 MiB in size and Gparted says it is a “grub2 core.img” file system type. It has a bios_grub flag.

                  Is it possible that it just needs to be the first partition?

                  stevesr0

                  #115043
                  Member
                  RJP

                    You have met a bios-boot-limit. ;)

                    http://tldp.org/HOWTO/Large-Disk-HOWTO-4.html

                    #115103
                    Moderator
                    caprea

                      might be because I don’t have a small bios-grub partition, so I created one using gparted

                      Was it created before installing grub?

                      #115178
                      Member
                      mikey777

                        Hi mickey777,
                        Could try deleting sda3 and using gparted to set the “boot” flag on sda1.
                        Then run boot repair.

                        Thanks for the suggestion, but the problem remained the same.

                        ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
                        - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
                        ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
                        - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
                        - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

                        #115179
                        Member
                        mikey777

                          Hi mikey777,
                          On my oldest computer, I have a BIOS/GPT setup. It goes to grub, so that can work.
                          On my system, the first partition (/sda1) is 2 MiB in size and Gparted says it is a “grub2 core.img” file system type. It has a bios_grub flag.
                          Is it possible that it just needs to be the first partition?
                          stevesr0

                          Good to hear steve that you got your legacy install to work with a BIOS/GPT setup – is it an SSD or HDD?
                          Below is an updated gparted screenshot showing the partitions.

                          Two things:
                          – you and linuxdaddy suggested putting the bios-grub partition first – but how do I change the sda3 assignation to sda1?
                          – grub2 core.img does not appear for the bios-grub under ‘file system ‘ type – I have used ‘boot repair’ but didn’t make any difference

                          In ‘boot repair’ I chose the following options: “reinstall GRUB bootloader on PBR” and “Repair GRUB configuration file”, with sda1 chosen as root location.

                          Edit: On rebooting, I’m unable to even boot from the SSD in computer settings. I’m going to have to recopy antiX21 from my 1TB drive to the larger one and start over, or just start with a fresh install of antiX23 …

                          • This reply was modified 10 months, 2 weeks ago by mikey777.
                          • This reply was modified 10 months, 2 weeks ago by mikey777.
                          • This reply was modified 10 months, 2 weeks ago by mikey777.
                          Attachments:

                          ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
                          - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
                          ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
                          - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
                          - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

                          #115382
                          Member
                          mikey777

                            @stevesr0 @linuxdaddy @sybok
                            Just a quick update.
                            I’ve got the laptop booting again, but only via the laptop’s boot list of drives (as before), pressing the Esc-key after powering-up to get there, and then selecting the OS-drive, after which the grubscreen appears. To get it working again, I had to take bios_grub partition away from its first position in gparted, and move it so that it was located after the three OS-partitions. Stevesr0, as you’ll see below in gparted, the bios_grub partition (now sda4) labelled itself automatically, with grub2core.

                            Some comments…
                            I ran fsck on sda1 – the result showed that there were no file problems on sda1, i.e. = clear
                            I ran fsck on the bios_grub partition, but it doesn’t seem to recognise it (see below)

                            So, in conclusion, we might not have fixed the original problem, but I think I can live with having to press the Esc-key each time I power-up…
                            Many thanks to you sybok, stevesr0 & linuxdaddy, for your interest and attempts to fix the problem. Much appreciated.

                            • This reply was modified 10 months, 2 weeks ago by mikey777.
                            • This reply was modified 10 months, 2 weeks ago by mikey777.
                            • This reply was modified 10 months, 2 weeks ago by mikey777.

                            ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
                            - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
                            ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
                            - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
                            - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

                            #116623
                            Member
                            mikey777

                              First, do you have multiple drives (meaning HW) present in the computer?
                              A) If yes, then perhaps all you need to do is set boot priority to the 4TB drive in BIOS and that could be all.

                              Sybok, yes you were right. I did follow-up on your comment before, but I looked in the wrong place!
                              Before, on booting with F2-key pressed to get to Settings, I went from Settings —> Boot —> Boot Device Priority.

                              What I should have done, and have done now is the following:
                              Settings —> Boot —> Hard Disk Drives, where I reordered the first drive as ‘P0’, as in the screenshot below.

                              Therefore this is now solved, i.e. I’m able to boot directly to the grubscreen. However, I’m unable to indicate this as ‘[SOLVED]’ next to the thread’s title, given that it’s been a while since this thread was started.

                              • This reply was modified 10 months ago by mikey777.
                              • This reply was modified 10 months ago by mikey777.
                              • This reply was modified 10 months ago by mikey777.
                              Attachments:

                              ▪ 32-bit antix19.4-core (SysV init)+LXDE legacy install on :
                              - (2011) Samsung NP-N145 Plus (JP04UK) – single-core CPU Intel Atom N455@1.66GHz, 2GB RAM, integrated graphics.
                              ▪ 64-bit antix21-base (SysV init)+LXDE legacy install on:
                              - (2008) Asus X71Q (7SC002) – dual CPU Intel T3200@2.0GHz, 4GB RAM. Intel Mobile 4 Series, integrated graphics
                              - (2007) Packard Bell Easynote MX37 (ALP-Ajax C3) – dual CPU Intel T2310@1.46GHz, 2GB RAM. SiS Graphics

                            Viewing 13 posts - 1 through 13 (of 13 total)
                            • You must be logged in to reply to this topic.