Battery Monitor built into IceWM showing a black box

Forum Forums New users New Users and General Questions Battery Monitor built into IceWM showing a black box

Tagged: , , ,

  • This topic has 11 replies, 8 voices, and was last updated Nov 26-6:17 pm by argonaut459.
Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #93221
    Member
    spectacles

      Hi everyone I am running AntiX-22 on a samsung nc10 ultrabook from 2009, some specs:

        CPU: Intel Atom N270;
        GPU: Intel GMA 950;
        HDD: 160GB HardDiskDrive;
        RAM: 2GB;

      Essentially our issue is as described in the title, IceWM is not showing our battery charge whatsoever and it makes it difficult to judge when this laptop will need to be charged.

      I looked into quite a bit of weblinks on this issue but mostly found solutions relying on older locations of files and was thus unable to resolve the issue.

      ACPI outputs the following:

      spectacles@small-buntata:~
      $ acpi
      Battery 0: Discharging, 0%,  remaining

      acpitools outputs the following:

      $ acpitool
        Battery #1     : Discharging, -nan%, 00:00:00
        AC adapter     : off-line 
        Thermal info   : <not available>

      If anyone can make us any the wiser on this issue it’d be much appreciated!

      #93248
      Moderator
      BobC

        Boot from USB and try each of the different battery monitoring utilities in the repos and see if you can find one that looks where your’s has the values located. If you could find that out, maybe you could use that to feed your conky or maybe get the IceWM Devs to add that method to their battery indicator.

        Here are a couple other possibilities I found. To be honest I don’t have an answer, but am trying to guess like if it was my machine. Good luck.

        Not for Samsung, but sounds like same issue:
        http://askubuntu.com/questions/1283441/battery-unknown-stays-at-0-but-holds-battery-fine

        Again, not Samsumg, but same issue. Is your BIOS the newest one?
        http://askubuntu.com/questions/100325/how-to-get-the-correct-battery-status

        • This reply was modified 1 year, 8 months ago by BobC.
        • This reply was modified 1 year, 8 months ago by BobC.

        Daily driver distro https://www.antixforum.com

        #93251
        Member
        mcpderez

          What does inxi report? For example, here’s mine.

          $ inxi --battery
          Battery:
            ID-1: BAT0 charge: 16.8 Wh (100.0%) condition: 16.8/16.8 Wh (100.0%)

          On some of my other laptops the condition will be at or close to 0%, which I interpret to mean the battery can no longer hold a charge at all. About how long does it run on the battery after you unplug the AC adapter?

          #93253
          Member
          spectacles

            inxi returns the following

            
            $ inxi --battery
            Battery:
              ID-1: BAT1 charge: 0% condition: N/A/57.7 Wh
                volts: 10.6 min: 11.1
            

            Other than that I’m not sure about the current bios of this device as I’ve only had hands on since the 11th :)

            I appreciate you providing resources and will look in to those now!

            -Specs

            • This reply was modified 1 year, 8 months ago by spectacles.
            #93573
            Member
            banned

              Perhaps it could be as simple as a graphics issue?
              I use LXDE without issues but have graphics issues when using RoxIceWM only.
              Try logging in under zzzJWM and issues disappear on my old HP laptop?
              Click picture below :)
              Good Luck

              • This reply was modified 1 year, 8 months ago by banned.
              • This reply was modified 1 year, 8 months ago by banned.
              Attachments:
              #93574
              Member
              spectacles

                We figured out the issue, Conky with BAT1 instead of BAT0. was showing a weird percentage in the millions but it was seeing something. This seeded the idea the battery was just on it’s way out.

                Later that day we ran the battery for a few hours in the train and it ended up dying as we had to AC available.

                Came to a place with AC, attempted to charge it and after 3 hrs on charger it still died if we booted it without AC connected.

                Ordered a new 12 cell battery (could also be 9, but atleast the improved bigger battery) and since it arrived we have had the monitor function!

                Only issue now is that the AC controller doesn’t seem to recognise when it is full as the AC led always shows orange and doesn’t go to green after 12 hrs and hovers at around 90% in the monitor. We will probably have to run the BIOS smart battery assessment tool a few more nights.

                Thanks all for the aid we will definitely be back!

                #93578
                Member
                banned

                  Yes – I bought my old laptop a new battery and recycled the old one :)
                  Having an efficient AntiX setup helps improve time on battery usage.

                  HOT TIP – Avoid BLOAT – anything that increases CPU load also increases fan speed and drains battery…!
                  I consider Conky as BLOAT on older laptops as I go with our leader – leaner and meaner :)

                  • This reply was modified 1 year, 8 months ago by banned.
                  #93581
                  Member
                  olsztyn

                    HOT TIP – Avoid BLOAT – anything that increases CPU load also increases fan speed and drains battery…!
                    I consider Conky as BLOAT on older laptops as I go with our leader – leaner and meaner

                    In principle, operational bloat as you defined in the first line of the above quote, can be also considered:

                    – Most of the indicators in the system tray of IceWM – right bottom of toolbar
                    – Similarly, most indicators in tray of LXDE.
                    – Extraneous services.

                    However usually there is some golden compromise what want to see on a continual basis during your laptop operation. There is some duplication sometimes, such as battery level in tray and in Conky, which can be optimized.
                    When I worked on reducing LXDE memory footprint I eliminated some applets running from tray, such as clipit.
                    I do not have much operating bloat in antiX 22 Runit, *elogind*-free, JWM… No extraneous apps started until I need something…

                    Live antiX Boot Options (Previously posted by Xecure):
                    http://antixlinuxfan.miraheze.org/wiki/Table_of_antiX_Boot_Parameters

                    #93609
                    Forum Admin
                    rokytnji

                      Weird story time. My Dell XT2 touchscreen wacom netbook battery died to the point of zero volts showing acpi b.

                      I run MX Fluxbox on it because it automagically picks up my wacom pen.
                      So like the OP I make a order for a replacement battery. Plug in the Dell XT2 into the motorcycle shop and leave it on the netbook booted up to a desktop till the battery comes in. To keep up on updates.

                      For a week or so. I saw the red icon in my taskbar and battery showed 0%
                      Was surprised today to see the icon was gone when I went to upgrade it.
                      Checked acpi -b.
                      Battery now shows 100%. Go figure. Will have to test later to see how long the charge lasts.

                      Just thought it was a story worth telling. The new battery is probably still weeks away < only 3600 mah >. So I have time to see what is up with the old one.Be nice to run a spare in the bag.

                      Now one small detail that might have flown over head. I had that laptop booted and running while on the charger. It took a very long time to charge. I don’t know if this would have have been successful without the operating system and the netbook powered down. Because it died that way plugged into the wall to begin with. Shutdown.

                      Sometimes I drive a crooked road to get my mind straight.
                      I don't suffer from insanity. I enjoy every minute of it.
                      Motorcycle racing is rocket science.

                      Linux Registered User # 475019
                      How to Search for AntiX solutions to your problems

                      #93652
                      Moderator
                      Brian Masinick

                        @rokytnji: You’re not the only one who has unusual things take place. For me, sometimes my concentration is good, and other times I wonder if “my head is screwed in properly”!

                        The last time I had a power related issue, I *thought* my power was plugged in. The wall outlet WAS plugged in, but the other end connecting to the laptop was loose, and as a result, power was completely drained. I wondered what was going on, went through my usual problem solving steps, and not more than 1-2 steps into my “procedure” I realized that the power connection to the laptop wasn’t properly secured. Fixed that, and moments later, things were back to normal, and in an hour or so things were fully charged once again.

                        That’s probably happened a few times; at least I have a walk-through procedure to examine, diagnose and repair. Brain reconnected!

                        --
                        Brian Masinick

                        #94060
                        Member
                        banned

                          Yup, me too :) In the interest of efficiency I have always removed the battery level indicator on old laptop…

                          Then I shout **** as the screen dies and the power button light extinguishes – Duh.
                          Who forgot to switch on power socket – Duh.

                          Having Hardinfo’s App installed just requires one icon click to get this information :) If my old brain can’t suss problems. Here is the output by clicking the Copy to Clipboard feature.

                          I could use LXTerminal but like the modern hardinfo interface :)

                          -Battery: BAT0-
                          State : Full
                          Capacity : 100 / Full
                          Battery Technology : Li-ion
                          Manufacturer : LGC-LGC
                          Model Number : EV06055
                          Serial Number : 61934

                          #94154
                          Member
                          argonaut459

                            If I may sidetrack here a bit.
                            Where can I find option to change the power management?
                            Right clicking the battery indicator does nothing, and a program for that didn’t caught my eye.
                            Would be nice to change the setting on when to turn of screen or go to suspend / hibernate

                            Suspend / Hibernate – can never remember which is which … And in German its basically the word used colloquially, which doesn’t hel :D

                            Indeed proloning battery life without cutting performance would be a great topic on itself.
                            With energy prices souring, even for a modern gaming PC, this might be a money saving idea.

                            On topic of the OP question:
                            Tried a different kernel? This may find the battery and with that info, you can probably adjust conky or other tools to check that port.

                          Viewing 12 posts - 1 through 12 (of 12 total)
                          • You must be logged in to reply to this topic.