Bento antiX i486 on laptop Asus A4D (sound turnaround)

Forum Forums antiX-development antiX Respins Bento antiX i486 on laptop Asus A4D (sound turnaround)

Tagged: , ,

  • This topic has 2 replies, 3 voices, and was last updated Sep 19-12:18 pm by anticapitalista.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #60517
    Member
    melodie

    This is a very old laptop, as the BIOS pointed to a date 18 years ago before I changed the CMOS battery. And testing multiple distributions on it, Devuan could make the sound work. Then later I installed Bento antiX (32bits of course) but then the sound didn’t play anymore. So I wondered why, and I just went through the files in /etc/modprobe.d and in the list of packages and found these: http://meets.free.fr/files/nvidia-modem-blacklist.conf

    (while looking into lshw I could see both the nvidia modem and nvidia audio chipset were using the same snd_intel8x0m driver, so I guessed it should be prevented to be loaded somehow, I just had not thought the name of the file could be “a thing” ?).
    Then even after a reboot it was not enough, and before that, trying to use pulseaudio had not worked, it would not succeed in connecting to the pulse server… This is when I decided to install this package from the Devuan repos : debian-pulseaudio-config-override_1.0_all.deb
    http://deb.devuan.org/devuan/pool/main/d/debian-config-override/

    and this did the trick. So I wanted to tell you about it, because it has been a great improvement for this laptop. Then next Bento antiX out will have it too (just the package installed, and the blacklist file).

    I think it would be a good addition to antiX.

    #67514
    Member
    Xecure
    Helpful
    Up
    0

    I saw someone linking to this in Facebook.

    Doesn’t this package simply remove the disable autospawn?

    Description: Debian configuration overrides for pulseaudio
     empty package which overrides upstream configuration.
     .
       - remove /etc/pulse/client.conf.d/00-disable-autospawn.conf

    This is only for sessions NOT using desktop-session-antiX (like xfce, lxde, kde…).
    Wouldn’t you have simply edit this file (/etc/pulse/client.conf.d/00-disable-autospawn.conf or follow the instruction dolphin_oracle explained in its video?
    https://www.antixforum.com/forums/topic/kde-install-help-on-runit-core/#post-34792
    This package should not be needed at all.

    In antiX, using desktop-session, edit desktop-session’s startup file and add pulseaudio -D & before the volume-icon entry, as explained at least 10 times in the forum.

    antiX Live system enthusiast.
    General Live Boot Parameters for antiX.

    #67515
    Forum Admin
    anticapitalista
    Helpful
    Up
    0

    Bentoo doesn’t use the antiX desktop session files, so both of you are correct.

    Philosophers have interpreted the world in many ways; the point is to change it.

    antiX with runit - leaner and meaner.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.