black screen

Forum Forums News Sid Upgraders black screen

  • This topic has 29 replies, 6 voices, and was last updated Jan 31-7:29 am by abc-nix.
Viewing 15 posts - 16 through 30 (of 30 total)
  • Author
    Posts
  • #131198
    Member
    abc-nix

      Please share the output of
      inxi -Faz
      and
      apt policy lightdm

      Finally, if you start lightdm from the tty
      sudo lightdm
      Does it fail to start also?

      #131200
      Member
      benni

        apt policy lightdm
        lightdm:
        Installiert: 1.32.0-4+b1
        Installationskandidat: 1.32.0-4+b1
        Versionstabelle:
        *** 1.32.0-4+b1 500
        500 http://ftp.uni-stuttgart.de/debian testing/main amd64 Packages
        100 /var/lib/dpkg/status
        1.32.0-3.0nosystemd1 500
        500 http://ftp.halifax.rwth-aachen.de/mxlinux/packages/antix/testing testing/nosystemd amd64 Packages

        #131201
        Member
        benni
          $ inxi -Faz
          System:
            Kernel: 6.6.13-amd64 arch: x86_64 bits: 64 compiler: gcc v: 13.2.0
              clocksource: tsc available: hpet,acpi_pm
              parameters: BOOT_IMAGE=/boot/vmlinuz-6.6.13-amd64
              root=UUID=e1280713-491e-4abc-af52-8806697ccbb0 ro
            Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
              v: 4.18.0 vt: 2 dm: LightDM v: 1.32.0 Distro: antiX-22-runit-sid_x64-core
              Grup Yorum 28 October 2022 base: Debian GNU/Linux trixie/sid
          Machine:
            Type: Desktop System: FUJITSU product: ESPRIMO_P956 v: N/A
              serial: <superuser required> Chassis: type: 6 v: C$WX05
              serial: <superuser required>
            Mobo: FUJITSU model: D3402-A1 v: S26361-D3402-A1
              serial: <superuser required> UEFI-[Legacy]: FUJITSU // American Megatrends
              v: 5.0.0.11 R1.17.0.SR.3 for D3402-A1x date: 12/15/2016
          CPU:
            Info: model: Intel Core i5-6600 bits: 64 type: MCP arch: Skylake-S
              gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
              model-id: 0x5E (94) stepping: 3 microcode: 0xF0
            Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
              desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
              desc: 1x6 MiB
            Speed (MHz): avg: 800 min/max: 800/3900 scaling: driver: intel_pstate
              governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 bogomips: 26399
            Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
            Vulnerabilities:
            Type: gather_data_sampling status: Vulnerable: No microcode
            Type: itlb_multihit status: KVM: VMX disabled
            Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
              disabled
            Type: mds mitigation: Clear CPU buffers; SMT disabled
            Type: meltdown mitigation: PTI
            Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
            Type: retbleed mitigation: IBRS
            Type: spec_rstack_overflow status: Not affected
            Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
              prctl
            Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
              sanitization
            Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: disabled,
              RSB filling, PBRSB-eIBRS: Not affected
            Type: srbds mitigation: Microcode
            Type: tsx_async_abort mitigation: TSX disabled
          Graphics:
            Device-1: Intel HD Graphics 530 vendor: Fujitsu Solutions driver: i915
              v: kernel arch: Gen-9 process: Intel 14n built: 2015-16 ports:
              active: HDMI-A-2 empty: DP-1, DP-2, DP-3, HDMI-A-1, HDMI-A-3
              bus-ID: 00:02.0 chip-ID: 8086:1912 class-ID: 0300
            Display: server: X.Org v: 21.1.11 compositor: xfwm v: 4.18.0 driver: X:
              loaded: modesetting unloaded: fbdev,vesa dri: iris gpu: i915
          #131202
          Member
          benni
            display-ID: :1.0 screens: 1
              Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
                s-diag: 582mm (22.93")
              Monitor-1: HDMI-A-2 mapped: HDMI-2 model: LG (GoldStar) FULL HD
                built: 2016 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
                size: 480x270mm (18.9x10.63") diag: 551mm (21.7") ratio: 16:9 modes:
                max: 1920x1080 min: 720x400
              API: OpenGL Message: Unable to show GL data. glxinfo is missing.
            Audio:
              Device-1: Intel 100 Series/C230 Series Family HD Audio
                vendor: Fujitsu Solutions driver: snd_hda_intel v: kernel
                alternate: snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:a170 class-ID: 0403
              Device-2: C-Media CM102-A+/102S+ Audio Controller driver: snd-usb-audio
                type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:2
                chip-ID: 0d8c:0103 class-ID: 0102
              API: ALSA v: k6.6.13-amd64 status: kernel-api
                tools: alsactl,alsamixer,amixer
              Server-1: PipeWire v: 1.0.1 status: off with: wireplumber status: off
                tools: pw-cat,pw-cli,wpctl
              Server-2: PulseAudio v: 16.1 status: active tools: pacat,pactl,pavucontrol
            Network:
              Device-1: Intel Ethernet I219-LM vendor: Fujitsu Solutions driver: e1000e
                v: kernel port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b7 class-ID: 0200
              IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
            Drives:
              Local Storage: total: 3.66 TiB used: 6.75 GiB (0.2%)
              SMART Message: Unable to run smartctl. Root privileges required.
              ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A
                size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
                lanes: 4 tech: SSD serial: <filter> fw-rev: AGGA4104 temp: 39.9 C
                scheme: MBR
              ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
                model: WD10EZEX-07WN4A0 size: 931.51 GiB block-size: physical: 4096 B
                logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
                fw-rev: 1A01 scheme: MBR
              ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 870 QVO 1TB
                size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
                tech: SSD serial: <filter> fw-rev: 1B6Q scheme: GPT
              ID-4: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 860 EVO 500GB
                size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
                tech: SSD serial: <filter> fw-rev: 2B6Q scheme: MBR
              ID-5: /dev/sdd maj-min: 8:48 vendor: JMicron Tech model: Generic
                size: 465.76 GiB block-size: physical: 4096 B logical: 512 B type: USB
                rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
                fw-rev: 0405 scheme: MBR
            Partition:
              ID-1: / raw-size: 287.09 GiB size: 281.52 GiB (98.06%) used: 6.75 GiB (2.4%)
                fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3
            Swap:
              Kernel: swappiness: 10 (default 60) cache-pressure: 50 (default 100)
                zswap: no
              ID-1: swap-1 type: partition size: 15.26 GiB used: 0 KiB (0.0%)
                priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2
              ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -3
                dev: /dev/sdb3 maj-min: 8:19
              ID-3: swap-3 type: partition size: 975 MiB used: 0 KiB (0.0%) priority: -4
                dev: /dev/sdd5 maj-min: 8:53
            Sensors:
              Src: /sys System Temperatures: cpu: 60.0 C pch: 50.0 C mobo: N/A
              Fan Speeds (rpm): N/A
            Info:
              Processes: 187 Uptime: 3m wakeups: 0 Memory: total: 16 GiB
              available: 15.46 GiB used: 2.07 GiB (13.4%) Init: runit v: N/A runlevel: 2
              tool: service Compilers: gcc: 13.2.0 alt: 12/13 Packages: pm: dpkg
              pkgs: 1194 libs: 710 tools: apt,apt-get,aptitude,nala,synaptic Shell: Bash
              v: 5.2.21 running-in: x-terminal-emul inxi: 3.3.31
            bernd@antix:~
            $
            #131249
            Member
            marcelocripe

              Hello benni.

              Welcome to antiX Linux and the Forum.

              I don’t know how to write in English and I send my texts translated by the internet translator. I hope you can understand everything. If your native language is not English, please translate my original Brazilian Portuguese text directly into your language with the help of internet translators and you will get a much better result.

              Please read my real welcome in the Welcome to antiX Linux and the forum (antiX 23) and Welcome to antiX Linux and the forum (antiX 19, 21 and 22) thread.

              Please learn how to ask for help here on the antiX forum by reading the threads I linked in my real welcome. Please note that there are 3 editions of antiX from series 19, 21 or 22 and 23 that have technical support in this forum. Each edition has 4 ISO images (full, base, net and core) on two different boot system types, SyVinit and Runit. If my sum is not wrong, at the present date there are about 32 different types of operating systems. That’s why you need to learn how to ask for help here on the antiX forum.

              marcelocripe
              (Original text in Brazilian Portuguese language)

              – – – – –

              Olá, benni.

              Seja bem-vindo(a) ao antiX Linux e ao fórum.

              Eu não sei escrever em idioma Inglês e envio os meus textos traduzidos pelo tradutor da internet. Eu espero que você consiga compreender tudo. Se o seu idioma nativo não for o Inglês, por favor, traduza o meu texto original em Português no Brasil diretamente para o seu idioma com a ajuda dos tradutores da internet que você obterá um resultado muito melhor.

              Por favor, leia a minha verdadeira boas-vindas no tópico Seja bem-vindo (a) ao antiX Linux e ao fórum (antiX 23) e Seja bem-vindo (a) ao antiX Linux e ao fórum (antiX 19, 21 e 22).

              Por favor, aprenda a pedir ajuda aqui no fórum do antiX lendo os tópicos que eu indiquei na minha verdadeira boas-vindas. Saiba que existem 3 edições do antiX das séries 19, 21 ou 22 e 23 que possuem suporte técnico neste fórum. Cada edição possui 4 imagens ISOs (full, base, net e core) em dois tipos de sistema de inicialização diferentes, o SyVinit e o Runit. Se a minha soma não estiver errada, na presente data são cerca de 32 tipos diferentes de sistema operacionais. É por isso que você precisa aprender a pedir ajuda aqui no fórum do antiX.

              marcelocripe
              (Texto original em idioma Português do Brasil)

              #131261
              Forum Admin
              Dave

                i tryd what u gave to me but it dont worked and no error

                Not even in the log files?
                /Var/log/lightdm.log
                /Var/log/xorg.log

                Computers are like air conditioners. They work fine until you start opening Windows. ~Author Unknown

                #131293
                Member
                benni

                  antiX-sid/antiX-22-sid_x64-core.iso /2022-10-28

                  /Var/log/lightdm.log = no file or directory found
                  /Var/log/xorg.log = no file or directory found$ /var/log/lightdm.log

                  bash: /var/log/lightdm.log: Datei oder Verzeichnis nicht gefunden
                  file or directory not found
                  help me to find it the right way

                  its a runit iso

                  • This reply was modified 1 month ago by benni.
                  • This reply was modified 1 month ago by benni.
                  #131309
                  Member
                  benni

                    bernd@antix:/var/log
                    $ ls
                    alternatives.log dpkg.log lastlog private Xorg.0.log Xorg.1.log.old
                    apt fontconfig.log lightdm samba Xorg.0.log.old Xorg.2.log
                    bootrepair.log fsck nala wtmp Xorg.1.log
                    bernd@antix:/var/log
                    $

                    #131354
                    Member
                    abc-nix

                      Thanks for the system info output. I have a similar system also on testing and with runit (though a bit customized). I will install lightdm and see what the issue may be. If I can get it to work with a custom runit service file I will share it here for you.

                      #131356
                      Member
                      abc-nix

                        lightdm worked for me.

                        $ apt policy lightdm
                        lightdm:
                          Installed: 1.32.0-4+b1
                          Candidate: 1.32.0-4+b1
                          Version table:
                         *** 1.32.0-4+b1 500
                                500 http://ftp.de.debian.org/debian testing/main amd64 Packages
                                100 /var/lib/dpkg/status

                        and the init file is there

                        $ ls -1 /etc/rc2.d/*
                        /etc/rc2.d/S01apt-cacher-ng
                        /etc/rc2.d/S01autofs
                        /etc/rc2.d/S01fancontrol
                        /etc/rc2.d/S01lightdm
                        /etc/rc2.d/S01pcscd
                        /etc/rc2.d/S01schroot
                        /etc/rc2.d/S01sudo
                        /etc/rc2.d/S01tlp
                        /etc/rc2.d/S01virtualbox
                        /etc/rc2.d/S04rc.local

                        And lightdm is running:

                        $ sudo service lightdm status
                        lightdm is running.

                        I will test with a runit service. I will edit once I am successful booting with the runit service. The instructions are below. Don’t follow them yet until I test them.

                        sudo mkdir /etc/sv/lightdm
                        sudo nano /etc/sv/lightdm/run

                        Paste the following inside /etc/sv/lightdm/run:

                        #!/usr/bin/env /lib/runit/invoke-run
                        set -e
                        NAME="lightdm"
                        DAEMON=/usr/sbin/lightdm
                        DEFAULT_DISPLAY_MANAGER_FILE=/etc/X11/default-display-manager
                        DEFAULT_DISPLAY_MANAGER=$(cat $DEFAULT_DISPLAY_MANAGER_FILE)
                        # Exit service if DAEMON is not installed
                        if [ ! -x $DAEMON ]; then
                            exit 161
                        fi
                        # start only if slimski is the default DM
                        if [ "$DEFAULT_DISPLAY_MANAGER" != "$DAEMON" ]; then
                            exit 161
                        fi
                        # Start elogind first (optional)
                        if [ -r /lib/runit/invoke-depend ]; then
                            . /lib/runit/invoke-depend
                            start_dependency dbus
                            start_dependency elogind
                            start_dependency seatd
                        else
                            sv start dbus && sv check dbus || true
                            sv start elogind && sv check elogind || true
                            sv start seatd && sv check seatd || true
                        fi
                        # Load language code
                        . /etc/default/locale
                        export LANG LANGUAGE
                        bl=$(awk -F= -v RS=" " '/^lang=/ {print $2}' /proc/cmdline)
                        export BLANG=$bl
                        exec 2>&1
                        exec $DAEMON

                        sudo nano /etc/sv/lightdm/finish
                        paste the following:

                        #!/bin/sh
                        set -e
                        . /lib/runit/finish-default "$@"

                        create a down file so that it doesn’t start automatically (for now) to avoid an infinite loop.
                        sudo touch /etc/sv/lightdm/down
                        And activate the service with
                        sudo ln -s /etc/sv/lightdm /etc/service

                        reboot and start the service manually with
                        sudo sv start lightdm

                        If everything works, then you can enable autosatup of the service by removing the down file
                        sudo rm /etc/sv/lightdm/down

                        • This reply was modified 1 month ago by abc-nix.
                        #131358
                        Member
                        benni

                          $ ls -l /etc/rc2.d/
                          lrwxrwxrwx 1 root root 17 12. Jan 23:52 S01lightdm -> ../init.d/lightdm / S01lightdm and /init.d/lightdm in the terminal is red marked
                          lrwxrwxrwx 1 root root 37 12. Jan 23:59 S01pulseaudio-enable-autospawn -> ../init.d/pulseaudio-enable-autospawn
                          lrwxrwxrwx 1 root root 14 12. Jan 23:24 S01sudo -> ../init.d/sudo
                          lrwxrwxrwx 1 root root 20 28. Okt 2022 S04rc.local -> /etc/init.d/rc.local

                          $ sudo service lightdm status
                          [sudo] Passwort für bernd:
                          lightdm is not running … failed!
                          bernd@antix:~
                          $

                          • This reply was modified 1 month ago by benni.
                          • This reply was modified 1 month ago by benni.
                          #131359
                          Member
                          abc-nix

                            Everything worked for me. Before following the above steps, try starting lightdm from tty
                            sudo lightdm -d > /var/log/lightdm-debug.log
                            If it doesn’t start, then the issue is not the service but the lightdm program. If you ran the command above, you will now be able to see the debug output in /var/log/lightdm-debug.log
                            Could you share it here?

                            #131361
                            Member
                            benni

                              i installed me a bookworm runit core iso and upgraded it to testing with xfce4 and lightdm
                              it started without problems there it seems is all fine
                              its workes without problems

                              #131382
                              Member
                              benni

                                Thank U for helping me

                                #131406
                                Member
                                abc-nix

                                  Great you got everything working. Thanks for letting us know.

                                Viewing 15 posts - 16 through 30 (of 30 total)
                                • You must be logged in to reply to this topic.